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 Support Request Form
Appendices 

 Examples of Display Types 
 Plan Views 
 3D Surface 
 Cross Sections
 Probes
 Hovmoller Display
 Imagery 
 Radar - Level II WSR-88D Data Displays 
 Soundings 
 Profiler Winds 
 Flow Displays 
 Observations 
 Miscellaneous Display Types 

 FAQ - Frequently Asked Questions 
 General FAQ
 Using McIDAS-V FAQ
 Data FAQ 
 Video Cards FAQ 
 Common Installation Errors FAQ 
 Common Run-Time Errors FAQ
 Reporting Problems FAQ 

 McIDAS-X Commands in McIDAS-V
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What is McIDAS-V?
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40 year history of
sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-
dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD
and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V
environment, and an integrated version of SSEC's HYDRA software package.

 
Image 1: The McIDAS-V Main Display Window

This McIDAS-V User's Guide is currently under construction. Once completed, it will describe using the features available in the McIDAS-V
application. For a brief description about getting started using McIDAS-V and making displays of common data available, refer to the Getting
Started section.

This Guide was originally developed at the Unidata Program Center by the developers of the Integrated Data Viewer (IDV). The first version of the
McIDAS-V User's Guide was created from the IDV User's Guide (September 2007) and has since been updated to reflect the changes that have
been made to McIDAS-V, IDV, and VisAD (see the Release Notes for details on recent changes).

Development of McIDAS-V is ongoing at the Space Science and Engineering Center (SSEC) at the University of Wisconsin-Madison. The
development is driven by the needs of the community of users. Suggestions, comments, and collaboration are welcomed and encouraged. See
Documentation and Support for more information. The goal is to provide new and innovative ways of displaying and analyzing Earth science data,
as well as provide common displays that many of its users have come to expect.

How can I get McIDAS-V?
See Downloading and Running McIDAS-V for information on how to download McIDAS-V, install McIDAS-V, and run McIDAS-V. For
additional information, refer to the latest McIDAS-V training materials.

http://www.ssec.wisc.edu/hydra/
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http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Starting__FILE
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Overview
Release Notes
System Requirements
Dowloading and Running McIDAS-V
Data Formats and Sources
Documentation and Support
License and Copyright
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Release Notes
The items below list the changes in McIDAS-V for the most recent released versions.

For a current list of known bugs and requested enhancements, please see the Open Inquiries Report from the McIDAS-V Inquiry System. To view
the items currently under development, see the list of Critical Bugs and Critical Development Items.

McIDAS-V 
Version 1.4

The items below reflect the changes since the 1.3 release.

Documentation Changes
McIDAS-V User's Guide

Display Changes
Add Unit to Color Scale in Display
Wavelength Readout for the MultiSpectral Display

Data Changes
MODIS Granule Aggregation

Other Changes
Scripting
Change to Save Data Window when Saving a Zipped Bundle
Format of RGB Composite Layer Controls
Logging Level
Formula Editor

Under Development
Suomi NPP Chooser

Documentation Changes

McIDAS-V User's Guide

Updated the McIDAS-V User's Guide to contain new features and more detailed content.

Display Changes

Add Unit to Color Scale in Display

Added the ability to add a unit to the color scale in the Main Display. A color scale can be added to the display through the Color Scale tab of the
Properties window for the layer. In this tab, there is now a Visible checkbox that, when selected, will display the unit of your data on the color
scale in the display.

Wavelength Readout for the MultiSpectral Display

Added a readout of wavelength when displaying multispectral data using the MultiSpectral display type. This wavelength readout will be at the
bottom of the Layer Controls tab alongside the Band dropdown menu. This helps to make this display type more user-friendly.

Data Changes

http://dcdbs.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=OpenInquiries
http://dcdbs.ssec.wisc.edu/inquiry-v/
http://dcdbs.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=CriticalBugs
http://dcdbs.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=CriticalDev
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat1_1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__doc1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat2_1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__unit1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__wavelength1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat3_1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__modis1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat4_1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#scripting1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#zipped1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#rgb1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#logging1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#formula1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat5_1.4b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__npp1.4b1
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MODIS Granule Aggregation

Generalized MODIS aggregation to work with half and quarter kilometer resolution data. Also, you can now aggregate mixed-length granules
together.

Other Changes

Scripting

Continued to add to the suite of fully supported Jython scripting tools introduced in McIDAS-V 1.2. The functions and methods in this suite can
be used to load and display data, manipulate the display, and save the images. This allows the user to automatically process data and generate
displays for web pages and other environments. This scripting can be done from the Jython shell within McIDAS-V, or from a Jython script that
can be invoked as a command line argument. Please see Scripting for the list of supported functions, an example script, and links to various Java
docs.

Since the release of McIDAS-V 1.3, there are new functions designed to work with ADDE data.  These functions are:

makeLocalADDEEntry - Creates a local ADDE entry in the server table.

getLocalADDEEntry - Gets the descriptor for a local ADDE Entry.

listADDEImages - Lists data from an ADDE image server.

listADDEImageTimes - Lists available dates and times of data from an image server.

There is also a new version of getADDEImage that gives different output than the previous version.

Change to Save Data Window when Saving a Zipped Bundle

Changed the Save Data window when saving a zipped bundle to make it easier to determine what data will get saved with your bundle. This is
now done through radio buttons.

Format of RGB Composite Layer Controls

Reformatted the Layer Controls for the RGB Composite display. There is now an Apply button that will apply any changes to the red, green or
blue minimum, maximum, or gamma values directly to the display without having to press Enter.  There is also now an Apply to All Gamma
Fields button that will apply a common gamma value to all colors.

Logging Level

Added the ability to set logging level in the Advanced tab of the User Preferences window. The logging level you select will determine how
much information gets written out to your mcidasv.log file in your McIDAS-V directory. For more information about each of the logging levels
and what they entail, please see the Log Level section of the Advanced Preferences page.

Formula Editor

Reworked the Formula Editor to make it more intuitive to users.  The Description field has moved out of the Advanced section of the
Formula Editor, and into the top main section.  The value in the Description field will be what is written out in the Field Selector as the name of
the formula. The Name field of the Formula Editor has changed its name to ID, and is used when setting Parameter Defaults.

Under Development

Suomi NPP Chooser

Added the ability to work with Suomi NPP data from NOAA CLASS that includes the data and geolocation within the same file. Non-
consecutive granules can now be displayed, and granules can now be aggregated regardless of granule size. VIIRS SVI data from CLASS can
now be displayed. Saving of both zipped and unzipped bundles containing NPP data is now supported.

There has been added functionality for working with VIIRS Cloud Mask products. If a GMODO-IICMO* product is loaded, there are various
quality flag products included with the data. McIDAS-V now has the ability to determine which quality flag products are included with the data
as well as what cloud mask fields can be produced from them. With cloud mask products, fields such as 'Cloud Phase', 'Volcanic Ash', 'Dust' and
'Fire' can be displayed.

There has been added functionality for working with VIIRS EDR (Environmental Data Records) products. These products include fields such as

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Scripting__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__loglevel
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cloud heights, pressures, and temperatures, sea surface temperatures, and snow cover.

This is currently located in the Under Development list of choosers in the Data Sources tab of the Data Explorer and is available for user
feedback through the McIDAS-V Support Forums. As the IDPS (Interface Data Processing Segment) begins to distribute new types of NPP data,
we test it in McIDAS-V and make any necessary changes to be able to get the data to display.

McIDAS-V 
Version 1.3

The items below reflect the changes since the 1.2 release.

Documentation Changes
McIDAS-V User's Guide

Display Changes
Latitude/Longitude Labeling
Contour Labeling Frequency
Consecutive Profiles of Sounding Data

Other Changes
Scripting
New Mask Formulas
New Grid Trajectory Formulas
Local ADDE Image Servers
Latest netCDF-Java Version

Under Development
Suomi NPP Chooser
Polar Orbit Track Chooser

Documentation Changes

McIDAS-V User's Guide

Updated the McIDAS-V User's Guide to contain new features and more detailed content.

Display Changes

Latitude/Longitude Labeling

Added the ability to add latitude and longitude labels to the display in two ways. You can add them as a component of the wireframe
box through the View->Show Display Scales menu item. These labels can be configured further through the View->Properties menu item using
the new Horizontal Scale tab. This tab allows you to control label and tick mark intervals. You can also add latitude and longitude labels as a
component of the map controls. This can be done in the Layer Controls tab of the Data Explorer for the Default Background Map. Here, there is
a Lat/Lon tab, which gives you the ability to display and configure latitude and longitude labeling in the Main Display.

Contour Labeling Frequency

Added the ability to change contour labeling frequency for contour displays. This is a new option in the Contour Properties Editor, where a
Frequency slider allows you to change the number of contour labels visible in the display.

Consecutive Profiles of Sounding Data

Added the ability to display consecutive profiles of sounding data. This works with both point observation data and model-derived sounding
displays. Once you create your display, there is a new option in the Sounding Chart tab, called Consecutive Profiles. Choosing this option will

http://dcdbs.ssec.wisc.edu/mcidasv/forums/
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat1_1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__doc1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat2_1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__lalo1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__contourlabels1.3b
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__sounding1.3b
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat4_1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#scripting1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#mask1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#grid1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#servers1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#netcdf-java
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat5_1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__npp1.3b1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__polar1.3b1
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display the sounding for the current time in your loop, as well as the sounding for the next time in your loop. The current sounding will display
as dashed Temperature and Dewpoint Temperature profiles, and the next sounding in the time series will display as solid lines for the
Temperature and Dewpoint Temperature profiles. This feature makes it easy to see how the vertical profile is expected to change in the future
with model data, and will show how the sounding actually did change through time when working with point observation data.

Other Changes

Scripting

Continued to add to the suite of fully supported Jython scripting tools introduced in McIDAS-V 1.2. The functions and methods in this suite can
be used to load and display data, manipulate the display, and save the images. This allows the user to automatically process data and generate
displays for web pages and other environments. This scripting can be done from the Jython shell within McIDAS-V, or from a Jython script that
can be invoked as a command line argument. Please see Scripting for the list of supported functions, an example script, and links to various Java
docs.

New Mask Formulas

Added two new mask formulas (Mask Function and Mask Within Range) to the list of native formulas in McIDAS-V. These formulas are
intended to operate on imagery data, and are listed under the Imagery field of the formulas. The Mask Function formula allows you to easily
display data that is above, below, or equal to a certain value. The Mask Within Range formula allows you to specify a specific range of data
values to display.

New Grid Trajectory Formulas

Added two new trajectory formulas (Grid 2D Trajectory and Grid 3D Trajectory) to the list of native grid formulas in McIDAS-V. These
formulas are used to create trajectories utilizing u- and v-wind components (and a vertical component for the 3D formula) as well as a scalar
parameter to color the trajectories by. As an alternative to the formulas, you can also create trajectories using the new derived fields for 'Grid 3D
Trajectory' and 'Grid 2D Trajectory'. The trajectories will originate from your selected region (the Trajectory Initial Area), and be drawn out
through the times of your data to where the u-, v- and vertical components take them.

Local ADDE Image Servers

Updated all local ADDE image servers, except for MODIS, to the versions included in McIDAS-X 2013.1. The most significant enhancements
were updates to the Meteosat server (to include calibration updates, support Meteosat-10 data, and support MSG compressed and rapid scan
data) and the NOAA/Metop AVHRR Level 1b server (to support Metop-B data and pre-KLM series NOAA POES data).

Latest netCDF-Java Version

A new version of the netCDF-Java library (4.3.16) is included in this release. This version of netCDF-Java includes major changes to the way
GRIB 1 and 2 files are handled. See the netCDF-Java GRIB documentation for a more details on these changes.

One major outcome of this change is that GRIB variable names will now be generated in a very general way. This means that bundles that were
generated with a previous version of McIDAS-V might break. In order to aid users in the transition between netCDF-Java 4.2 and 4.3, the
netCDF-Java library has provided a mapping of old variable names and new variable names for the datasets served on the Unidata THREDDS
Data Server (TDS), and this mapping is being used 'under the hood' in McIDAS-V to minimize the impact of these changes on users.

For users reading GRIB files from other locations (local files or other remote servers), McIDAS-V now allows users to make custom variable
name mappings. New variable mappings should be placed in the McIDAS-V/varrenamer.xml file. The structure of this file is quite simple:
<varrenamers>

  <varrenamer
    old="oldNameHere"
    new="newNameHere" />

  <varrenamer
    old="anotherOldNameHere"
    new="anotherNewNameHere" />

</varrenamers>

Changes to the way GRIB files are served via the Unidata TDS server have also been made. The impact of this change is that the dataset URLs
that point to GRIB resources will change, which will break bundles that point to the old Unidata TDS (motherlode.ucar.edu).

Again, in order to aid users in this transition, the netCDF-Java library has provided a mapping between the old and new dataset URL paths for all

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Scripting__FILE
http://www.unidata.ucar.edu/software/netcdf-java/formats/GribFiles.html
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datasets served through the Unidata TDS. As with the variable name changes, the URL mapping for datasets on the Unidata TDS is being used
'under the hood' in McIDAS-V to minimize the impact on users.

The latest version of TDS (4.3), where URL related impacts will be seen, is now running on the main Unidata TDS (thredds.ucar.edu). Starting
with version 1.3, McIDAS-V will redirect all requests to the old Unidata TDS (motherlode.ucar.edu) to the new Unidata TDS (thredds.ucar.edu)
automatically and update the appropriate data URLs.

As TDS servers in the community begin to upgrade to TDS 4.3, users will likely need to use custom URL mappings. New URL mappings
should be placed in the McIDAS-V/urlmaps.xml file.

Again, the format of this file is quite simple:
<urlmaps>

  <urlmap
    type="opendap"
    old="oldthreddsserver1.edu/"
    new="newthreddsserver1.edu/" />

  <urlmap
    type="opendap"
    old="threddsserver2.edu/thredds/dodsC/old/path/"
    new="threddsserver2.edu/thredds/dodcC/new/path/" />

</urlmaps>

In the first example, a new THREDDS server has replaced an old server - all requests going to oldthreddsserver1.edu will be directed to
newthreddsserver1.edu. The second example is where the URL path to a particular dataset has changed, either because the product has been
replaced (for example, the RUC to the RAP transition) or the maintainer of the TDS server has changed the way data are cataloged. Note in both
cases the type of URL is an opendap URL. In the future, this mechanism will be used to redirect other types of data requests.

Under Development

Suomi NPP Chooser

Added the ability to work with Suomi NPP data from NOAA CLASS that includes the data and geolocation within the same file. You can now
display non-consecutive granules. You can also now aggregate granules together regardless of granule size. VIIRS SVI data from CLASS can
now be displayed. Saving of both zipped and unzipped bundles containing NPP data is now supported.

There has been added functionality for working with VIIRS Cloud Mask products as well. If you load in a GMODO-IICMO* product, there are
various quality flag products included with the data. McIDAS-V now has the ability to determine which quality flag products are included
with the data as well as what cloud mask fields can be produced from them. Therefore, if you load in a GMODO-IICMO* file, you will see
fields such as 'Cloud Phase', 'Volcanic Ash', 'Dust', 'Fire', etc.

This is currently located in the Under Development list of choosers in the Data Sources tab of the Data Explorer and is available for user
feedback through the McIDAS-V Support Forums. As the IDPS (Interface Data Processing Segment) begins to distribute new types of NPP data,
we test it in McIDAS-V and make any necessary changes to be able to get the data to display.

Polar Orbit Track Chooser

Reworked the Polar Orbit Track chooser to enable easier access to local files. This is currently located in the Under Development list of choosers
in the Data Sources tab of the Data Explorer and is available for user feedback through the McIDAS-V Support Forums.

McIDAS-V 
Version 1.2

The items below reflect the changes since the 1.01 release.

Documentation Changes
McIDAS-V User's Guide

Display Changes
Layer Visibility Animations
Hovmoller Display

http://dcdbs.ssec.wisc.edu/mcidasv/forums/
http://dcdbs.ssec.wisc.edu/mcidasv/forums/
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat1_1.2
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http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__faq1_cat2_1.2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__layervisibility1.2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__hovmoller1.2
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Add Logos
Wind Barbs

Data Changes
Multispectral GEOCAT Data
Level 2 Calipso/CloudSat Data

Other Changes
Scripting
Compute Statistics Option for HYDRA Scatter Analysis Displays
Rotation Option
Image Handling
SEVIRI RGB Satellite Formulas
New Java Version

Under Development
Suomi NPP Chooser

Documentation Changes

McIDAS-V User's Guide

Updated the McIDAS-V User's Guide to contain new features and more detailed content.

Display Changes

Layer Visibility Animations

Added the ability to add a Layer Visibility Animations button to the Main Toolbar in McIDAS-V. This can be done through the Toolbar Options
tab of the User Preferences window. This allows you to animate through layers of data that do not have times associated with them without
having to go through the menus.

Hovmoller Display

Added the Hovmoller Display to the Displays panel of the Field Selector. Your display can be Time-Longitude or Time-Latitude, with either a
color shaded or contour display. The display will be plotted in the Layer Controls tab of the Data Explorer, where you can change the color
table, the time label format, and the order with respect to time of the display. This display can be used with both 2D and 3D model data, but not
with 2D derived fields.

Add Logos

Added the ability to add logos to displays. This option can be found in the View->Properties menu item of the Main Display window. In the
Main tab of the Properties dialog, there is a Logo panel. Here, you can select which image to add as the logo, select its location, and its size. You
must also select the 'Show Logo' checkbox at the top of the tab for the logo to be visible. This will add a logo to the Main Display window.
Certain types of displays are displayed in the Layer Controls tab of the Data Explorer. For these displays, an option to add a logo can be found in
the item's Properties window, accessed through the Edit->Properties menu item in the Layer Controls tab.

Wind Barbs

Changed the way that wind barbs are plotted when the wind is between 0 and 2.5kts. Previously, these winds were regarded as calm and denoted
by an open circle. Now, they are plotted as a staff with no flags.

Data Changes

Multispectral GEOCAT Data

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ReleaseNotes__logo1.2
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Added a new class to support multispectral GEOCAT data. This data can now be loaded in through the Satellite->HYDRA chooser.

Level 2 Calipso/CloudSat Data

Added support for Level 2 Calipso/CloudSat types of data. This data can now be loaded in though the Satellite->HYDRA chooser.

Other Changes

Scripting

Added a first release of a suite of fully supported Jython scripting tools. The functions and methods in this suite can be used to load and display
data, manipulate the display, and save the images. This allows the user to automatically process data and generate displays for web pages and
other environments. This scripting can be done from the Jython shell within McIDAS-V, or from a Jython script that can be invoked as a
command line argument. Please see Scripting for the list of supported functions, an example script, and links to various Java docs.

Compute Statistics Option for HYDRA Scatter Analysis Displays

Added a new feature to HYDRA Scatter Analysis displays to output statistical information pertinent to the data. After creating a Scatter Analysis
display, a new button has been added to the Layer Controls tab of the Data Explorer, called 'compute statistics'. When this button is clicked, a
Scatter Statistics window will open, listing statistical information corresponding to the data on the X and Y axes of the scatter plot. There is
statistical information for the display as a whole, and also for different areas you subset with the box/curve options. This information includes,
but is not limited to: maximum, minimum, number of points, mean, median, variance, standard deviation, and correlation. This statistical data
can be written out to a *.csv file by using the Save As CSV button.

Rotation Option

Added the ability to rotate displays clockwise and counterclockwise. You can do this by right clicking on the Auto-rotate icon in the Viewpoint
Toolbar of the Main Display window. Here, you will see different rotation options.

Image Handling

Changed the way McIDAS-V handles images. In the past, all images used Red, Green, Blue, and alpha as RealTypes in the data and they would
then map to RGB or RGBA. This meant that a change to the color map of one image would affect all others. Now, we are using unique
RealTypes (xxx_N) for each image, where N is a unique number for each image.

SEVIRI RGB Satellite Formulas

Added new a new group of formulas has been added as a plugin to McIDAS-V. This group of formulas is titled SEVIRI RGB. These are RGB
satellite formulas that are designed to work with satellite data from MSG's SEVIRI instrument, but they will work with any satellite data as long
as the necessary bands are included with the data. After adding your satellite data, select one of these formulas and click Create Display. This
will open a Field Selector window with recommended bands to select. The data from these bands will be utilized by McIDAS-V to produce the
final image.

New Java Version

Updated the Java version in McIDAS-V from 1.6.0_17 to 1.6.0_31.

Under Development

Suomi NPP Chooser

Changed the name of the Imagery - NPP chooser to Imagery - Suomi NPP, for use with local data from Suomi NPP (National Polar-orbiting
Partnership). This is currently located in the Under Development list of choosers in the Data Sources tab of the Data Explorer and is available for
user feedback through the McIDAS-V Support Forums. As the IDPS (Interface Data Processing Segment) begins to distribute new types of NPP
data, we test it in McIDAS-V and make any necessary changes to be able to get the data to display. Since the last release, granules that include
terrain-corrected geolocation now work. Also, time and date information will now be listed at the bottom of the Main Display window for
displayed granules. When multiple granules are aggregated together, the time/date information for the first granule will be listed. Simulated
GRAVITE data produced before the release of McIDAS-V 1.01 will no longer work, now that real data is being received.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Scripting__FILE
http://dcdbs.ssec.wisc.edu/mcidasv/forums/
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McIDAS-V 
Version 1.01

The items below reflect changes since the 1.0 release.

Documentation Changes
McIDAS-V User's Guide

Display Changes
Contour Labels
Grid Smoothing
Polar Satellite Data

Other Changes
BUFR Files
Jython Version

Under Development
NPP Chooser
Polar Orbit Track Chooser

Documentation Changes

McIDAS-V User's Guide

Updated the McIDAS-V User's Guide to contain new features and more detailed content.

Display Changes

Contour Labels

Added a new option to allow the user to change the font, font size, and alignment of contour labels. This is in the Contour Properties Editor,
which can be accessed through the Layer Controls tab of the Data Explorer and selecting Change next to 'Contour'.

Grid Smoothing

Added the ability to revert back to the default smoothing (none) after smoothing has been applied without having to reload the data. Also, users
can no longer smooth grids over topographic fields, and in this situation smoothing must be done via the McIDAS-V Jython formulas.

Polar Satellite Data

Added the ability to display loops of polar satellite data with different navigations.

Other Changes

BUFR Files

Added the ability to read BUFR data (*.bfr files) as a netCDF point data type.

Jython Version

Updated the Jython version in McIDAS-V from 2.2.1 to 2.5.2.

Under Development
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NPP Chooser

Added a new chooser, named Imagery - NPP, for use with local data from NPP (NPOESS Preparatory Project). This is currently located in the
Under Development list of choosers in the Data Sources tab of the Data Explorer and is available for user feedback through the McIDAS-V
Support Forums.

Polar Orbit Track Chooser

Added a new chooser, named Imagery - Polar Orbit Track, for use with local or remote orbital track data in TLE format. This is currently
located in the Under Development list of choosers in the Data Sources tab of the Data Explorer and is available for user feedback through the
McIDAS-V Support Forums.

McIDAS-V 
Version 1.0

Documentation Changes
Updated Content

Display Changes
New Image Rendering Option
Grid Smoothing

Data Changes
New Grid Diagnostics

Other Changes
New Directory Structure
New Satellite Image Chooser
New ADDE Data Manager

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

Display Changes

New Image Rendering Option

Added new "Enable access to image data by reference" option in Advanced tab of User Preferences to reduce likelihood of jagged edges at limb
and gaps at dateline.

Grid Smoothing

New grid diagnostics are available in this release. The following have been added:

PVOR(S,V) - Potential Vorticity
QVCL(THTA,V) - Q-Vectors in a layer
SAVG, SAVS - Average over a grid
SM5S, SM9S, SM5V, SM9V, GWFS, GWFV - grid smoothers (5-point, 9-point, Gaussian)
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You can use the Grid->Define a grid diagnostic formula to use these functions.

Data Changes

New Grid Diagnostics

Selected grid displays (contours, flow vectors, wind barbs) now have an option to perform smoothing functions on the grid. The GEMPAK 5-
point (SM5S), 9-point (SM9S) and Gaussian Weighted Function (GWFS) smoothing functions have been implemented in McIDAS-V.

Other Changes

New Directory Structure

Renamed the .mcidasv directory to McIDAS-V to make user files more easily accessible.

New Satellite Image Chooser

Redesigned the Satellite Imagery Chooser to include new options, such as an optional preview image in the Region tab of the Field Selector.

Users are encouraged to use this new chooser. Please notify us (via the McIDAS-V Support Forums or McIDAS Help Desk) if you feel there is
something in the previous chooser that should be implemented in the new chooser. The previous chooser is available through the Legacy
Choosers tree.

New ADDE Data Manager

Redesigned the ADDE Data Manager to be more intuitive and include separate local and remote managers.

http://dcdbs.ssec.wisc.edu/mcidasv/forums/
http://www.ssec.wisc.edu/mcidas/support/user_services.html
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System Requirements
McIDAS-V should run on any platform that fully supports Java and Java 3D. It has been tested on Linux, Mac OS X, and Windows. AIX and
IRIX support the requirements in certain configurations, but have not been tested.

To run McIDAS-V, a system will need to have a minimum of a 500 MHz processor and 512 MB of RAM free. However, if you are purchasing a
new system, it is recommended that an Intel system running McIDAS-V have at least a 2 GHz processor and 4 GB memory (RAM). Please note
that Java on 32 bit operating systems can only utilize 1536 MB, while 64 bit operating systems can utilize all of the available memory. Performance
will be better with faster processors and more memory. We have seen the best results with NVIDIA hardware and drivers.

Detailed requirements for the following are listed below:

 Operating Systems
Graphics Cards and Drivers
Java Versions
System Memory and Processor Speed
Internet Connection for Downloading McIDAS-V and Accessing Data

Operating Systems

The chart below lists the software versions, by vendor, that McIDAS-V is known to run on, and that McIDAS User Services tests:

OS Known to Work Tested at SSEC (1)

Linux Red Hat Linux 4.0+ Red Hat Enterprise Linux WS 5.7 (32 bit)
Red Hat Enterprise Linux WS 6.1 (64 bit)

Mac OS X(2) Mac OS X 10.6+
Mac OS X 10.6
Mac OS X 10.7
Mac OS X 10.8

Windows Windows XP, Vista, 7
Windows XP with Service Pack 3
Windows Vista with Service Pack 2 
Windows 7 Enterprise

Notes: 
(1)The local ADDE servers are distributed as binaries compiled only on these Operating System versions. If you are running versions
other than those listed, the local ADDE servers may not work and give you an error message that the "Local Server is not running". 
(2)Due to changes in the requirements of the netCDF package, McIDAS-V requires Java 1.6. Some Mac OS X systems do not support
Java 1.6 and thus are unable to run McIDAS-V. These include:
- All with PPC processors
- Intel Core Solo and Core Duo running OS X 10.5 or earlier

Graphics Cards and Drivers

McIDAS-V works on systems with graphics cards that support OpenGL (all systems) and Direct-X (version 8.0+, Windows only). On Linux, the
driver must support GLX, an X windows system extension to OpenGL programs. McIDAS-V also works on systems with stereo graphics cards. We
have seen the best results with NVIDIA hardware and drivers, and with the display configuration set to a high screen resolution and the maximum
number of colors.

McIDAS-V utilizes the latest developments in graphics cards, drivers and Java3D. If you encounter any problems with system instability (such as
using all of the memory or CPU on your machine, or frequent software crashes) or unusual data displays with "torn" or "gray" images, you should
make sure you have the latest driver for your system. Even if the system is brand new, the driver may not be the most recent version available.

Please Note: We have received reports of McIDAS-V failing to start (i.e., the windows never appear) on some systems using
integrated graphics chipsets, including:

Intel GMA 4500MHD
Intel GM965
ATI Radeon X300 family (including X550, X1050 and R300)

To determine the brand and driver information of your graphics card, follow the guides for each platform below:

Windows
Windows7/Vista: From the Start menu, open the Control Panel (click Start->Settings->Control Panel if you have the Classic Start

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Systems__os
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menu). Open the Device Manager. Under the Display adaptors tree, you will see your graphics card listed. You can double click on
the graphics card for more information.
XP: From the Start menu, right-click on My Computer, and select Properties. From here, navigate to the Hardware tab. Open the
Device Manager, and look under the Display adaptors tree to see your graphics card. You can double-click on the graphics card for
more information.

Linux
Open a command terminal and type the following command "lspci -v". The graphics card information will be listed under "VGA
compatible controller".

Mac OS X
10.6: Open the Apple menu and select "About This Mac". Click on the "More Info..." button to open up the System Profiler. Click on
"Graphics/Displays" under the Hardware list on the left hand side.
10.7/10.8: Open the Apple menu and select "About This Mac". Click on the "More Info..." button to open the About This Mac window.
The graphics card will list next to Graphics.

Once you have determined your graphics card brand and driver information, check the manufacturers web page for information on their updated
versions. Here are links to some of the most common graphic card Original Equipment Manufacturers (OEM):

NVIDIA
Desktop - http://www.nvidia.com/Download/index.aspx?lang=en-us
Laptop - http://www.nvidia.com/object/notebook_drivers.html

ATI - http://support.amd.com/us/gpudownload/Pages/index.aspx

Intel - http://downloadcenter.intel.com/

Java Versions

McIDAS-V runs on any platform that supports:

Java version 1.6+ (non-beta versions only) AND
Java 3D version 1.3.1+

McIDAS-V is packaged with the following versions included:

 Versions Included with McIDAS-V
JRE (Java Runtime Environment) Java3D JOGL (Java OpenGL)

Linux(1) 1.6.0 1.5.2 n/a
Mac OS X included with Mac OS X(2) 1.5.2 1.1.1
Windows(3) 1.6.0 1.5.2 n/a
other unix none none n/a

The necessary versions of the JRE, Java3D and JOGL are included with the Linux, Mac OS X, and Windows installers. On other platforms, you
will need to install Java and Java3D before installing McIDAS-V. If other platforms fully support Java version 1.6+ and Java 3D version 1.3.1+
(e.g. AIX, IRIX), they should also work, but have not been tested.

Notes: 
(1)The version of the Mesa library that comes with Red Hat Linux may be incompatible with Java 3D packaged with McIDAS-V. If
you experience X server crashes when exiting McIDAS-V, you will need to build and install Mesa from source available at
http://www.mesa3d.org. 
(2)To find and/or update your default Java version, follow these steps:

1. Open the "Java Preferences" application located in /Applications/Utilities
2. Look for "Java SE 6" in the "Java Applications" section
3. The version at the top of the "Java Applications" list is the version being used by McIDAS-V. If "Java SE 6" is not at the top of

the list, click and drag it to the top of the list (using the 64-bit option, if available). If "Java SE 6" is not in the "Java
Applications" list, you may need to manually run the Software Update feature in the Apple Menu.

(3)You must have DirectX version 8.0+ installed on your Windows system if you use the DirectX rendering mode of Java 3D (the
default is to use OpenGL).

System Memory and Processor Speed

http://www.nvidia.com/Download/index.aspx?lang=en-us
http://www.nvidia.com/object/notebook_drivers.html
http://support.amd.com/us/gpudownload/Pages/index.aspx
http://downloadcenter.intel.com/
http://www.mesa3d.org/
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McIDAS-V can be demanding of hardware speed and memory depending on the size of the datasets you wish to work with. It is recommended that
the system have a minimum of 512 MB of RAM free for McIDAS-V use. Performance is significantly better with 1 GB RAM or more. Please note
that 32 bit Java Runtime Environments (JRE) can utilize a maximum of 1536 MB RAM, while 64 bit JREs can utilize all of the RAM available to
the operating system (64 bit OS required).

The recommended processor speed will vary by platform. You can run on a system as slow as 500 MHz or even less, but response will be
correspondingly reduced. In general, the faster the processor, and the more memory your system has, the better the performance will be.

For reasonable performance, it is recommended that an Intel system running McIDAS-V have at least a 2 GHz processor and 4 GB memory
(RAM). Performance will be even better with faster processors and more memory.

Internet Connection for Downloading McIDAS-V and Accessing Data

You will need about 200 MB disk space for the installer file, which will uncompress into twice that size. You will have to download the installer
file in order to begin installing McIDAS-V.

McIDAS-V is designed to access data on remote servers on the Internet, as well as from local files. Downloading data from remote servers benefits
from a fast connection to the Internet, since many data fields are large.
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Downloading and Running McIDAS-V
This page contains information on:

Downloading McIDAS-V
Installing McIDAS-V
Running McIDAS-V
Setting Memory Usage
Downloading McIDAS-V Source Code

If you have any trouble downloading and installing McIDAS-V, first check the FAQ, then please report your problem as described in McIDAS-V
Support.

For more information on downloading and using McIDAS-V, please see the Installation and Introduction tutorial on the McIDAS-V Documentation
Page. Also, see this page for additional tutorials and instructional videos on more advanced subjects.

Downloading McIDAS-V
Check that your system meets the System Requirements for McIDAS-V and download the appropriate package for the following operating systems:

Linux - 32 bit
Linux - 64 bit
Mac OS X - Intel
Windows

This file is just the installer and can be placed anywhere on your machine. When you run the installer in the next step, you can then indicate where
you want McIDAS-V to be installed.

Installing McIDAS-V
Start the installer by following the instructions appropriate for your operating system:

Linux    open a terminal window and run sh ./<installer>.sh

Mac OS X    mount the .dmg and double-click the installer

Windows    double-click the downloaded .exe file

All other UNIX    open a terminal window and run sh ./<installer>.sh

A GUI will walk you through the installation steps and allow you to create a program group and/or desktop icon. When McIDAS-V is installed, a
McIDAS-V-System directory will be created in your installation directory. This directory contains system files necessary to run McIDAS-V and
users should not save files to the McIDAS-V-System directory.

Note: Windows users should not install McIDAS-V in the /Program Files directory as this can lead to permissions problems.

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If you do
not see your error listed, please send a support request to McIDAS-V Support.

Running McIDAS-V
On Mac OS X:

Double-click on the McIDAS-V shortcut icon that was created in /Applications.

On Windows:

Double-click on the McIDAS-V shortcut icon that was created on the Desktop.

On all other platforms:

At the UNIX prompt from the directory where McIDAS-V was installed, run the command: McIDAS-V-System/runMcV.

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If you do
not see your error listed, send a support request to McIDAS-V Support or use the Support Request Form in the Help menu of McIDAS-V.

Note: When McIDAS-V is first run, a /McIDAS-V directory will be created in the user path. This directory contains information about user-
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specified settings as well as XML files for color tables, projections, etc. that are used by McIDAS-V. Users can write files to this directory.

McIDAS-X users who install McIDAS-V and want to run their McIDAS-X commands in the McIDAS-V environment via the Bridge must also be
running McIDAS-X on the same computer. Sites that have joined the McIDAS Users' Group and purchased McIDAS-X support can download the
current version of McIDAS-X from the McIDAS-X Downloads page.

Setting Memory Usage
By default, McIDAS-V uses 80% of the available memory on your machine. The maximum amount of memory is determined by the operating
system. To manually change the amount of memory used by McIDAS-V, edit the Maximum Heap Size in the Advanced tab of the Preferences by
selecting Edit->Preferences... from the main menu. The new amount of memory will be saved and used in subsequent sessions. For 32 bit
operating systems, it is recommended to set this to no more than 1250 MB. The maximum value for 32 bit operating systems is 1536 MB, while 64
bit operating systems can use all of the RAM available. To change the amount of memory used to a percentage, select the percentage option in the
Advanced tab of the User Preferences by selecting Edit->Preferences... from the Main Display window.

Downloading McIDAS-V Source Code
The source code for McIDAS-V is available for download. For instructions on building McIDAS-V from source, see the Building McIDAS-V from
Source document.
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Data Formats and Sources
McIDAS-V can read a variety of data formats either from local files or remote data servers (e.g., HTTP, TDS, ADDE). This page contains
information about some data sources that work with McIDAS-V.

To connect McIDAS-V to data sources, see Data Sources.

Supported Data Types and Formats
Remote Data Servers
netCDF files
ASCII Text Point Data

Supported Data Types and Formats
Data Type Description Supported Formats Access Method

Gridded
Numerical weather prediction models,
climate analysis, gridded oceanographic
datasets, NCEP/NCAR Reanalysis

- netCDF - local files, HTTP, TDS servers
- GRIB (versions 1&2) - local files, TDS servers
- Vis5D - local files, HTTP
- GEMPAK - local files, TDS servers

Satellite
Imagery

Geostationary and polar orbiter satellite
imagery, derived satellite products

- ADDE - ADDE servers

- McIDAS AREA - local files, local & remote ADDE
servers

- AIRS - local files
- GINI - local files, TDS servers
- AMSR-E Level 1b - local ADDE
- EUMETCast LRIT - local ADDE
- Meteosat OpenMTP - local ADDE
- Meteosat Second Generation (MSG) Level 1b - local ADDE
- Metop AVHRR Level 1b - local ADDE
- MODIS L1b MOD02 (MODIS Level 1b) - local ADDE
- MODIS L2 MOD04 (Level 2 Aerosol) - local ADDE
- MODIS L2 MOD06 (Level 2 Cloud Top
Properties) - local ADDE

- MODIS L2 MOD07 (Level 2 Atmospheric
Profile) - local ADDE

- MODIS L2 MOD28 (Level 2 Sea Surface
Temperature Products) - local ADDE

- MODIS L2 MOD35 (Level 2 Cloud Mask) - local ADDE
- MODIS L2 MODR (Level 2 Corrected
Reflectance) - local ADDE

- MSG HRIT FD and HRV - local ADDE
- MTSAT HRIT - local ADDE
- NOAA AVHRR Level 1b - local ADDE
- SSMI (TeraScan netCDF) - local ADDE
- TRMM (TeraScan netCDF) - local ADDE

Radar Radar images

- Level II
- local files or TDS
(bzip2 compressed or
uncompressed)

- Level III - ADDE servers, local files or TDS
- Universal Format (UF) - local files
- DORADE - local files

Point
Observational

Surface observations (METAR and
SYNOP), earthquake observations

- ADDE - ADDE servers
- netCDF (Unidata, AWIPS/MADIS formats) - local files
- Text (ASCII, CSV), Excel spreadsheet - local files

Aircraft observations - netCDF (RAF convention) - local files
- Text (ASCII, CSV) - local files
- ADDE - ADDE servers
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Global balloon soundings - netCDF (Unidata, AWIPS/MADIS formats) - local files

- CMA text format - local files

Profiler NOAA Profiler Network winds - ADDE - ADDE servers

GIS Data typically used in Geographic
Information Systems (GIS)

- ESRI Shapefile - local files, HTTP
- USGS DEM - local files

QuickTime QuickTime movies (without extensions) - QuickTime - local files, HTTP

Remote Data Servers
Extensive meteorological and oceanographic data is available from remote data servers for use in research and education. Some of these data have
restrictions on their use, see Using Data Acquired via Unidata for that information.
Abstract Data Distribution Environment (ADDE)

Most of the data choosers in McIDAS-V use ADDE as the access method (satellite imagery, Level III radar, surface, profiler and RAOB). The
ADDE choosers are pre-configured with a list of available servers. SSEC and the Unidata community each maintain a set of cooperating ADDE
servers which serve up real-time and archived atmospheric datasets for use in McIDAS-V. You can use any of these to access the near-realtime
data. For more information on accessing data on ADDE servers, see the Data Sources section.

SSEC image data sets include:

rets1.ssec.wisc.edu
CIMSSP1 - GOES East and West Cloud mask, imager CTP and ECA, and sounder products.

rets2.ssec.wisc.edu
CIMSSP2 - GOES NH and SH wildfire products and GOES sounder products.

rets3.ssec.wisc.edu
CIMSSP3 - GOES East and West products (CAPE, LI, TPW, Eff Cld, Ctop Pr).

Additional image data sets:

adde.ucar.edu*
CIMSS - Products derived from one or more channels, made by CIMSS, SSEC.
GINICOMP - GINIEAST AND GINIWEST composites.
GINIEAST - GOES East images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 1.
GINIWEST - GOES West images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 2.
NEXRCOMP - Composites of NEXRAD imagery (1km, 6km, 10 km radar coded message, 1-hour precip total, storm total precip).
RTIMAGES - GOES East and West images in native view, not remapped. Also some global Mollweide images, and an Antarctic
composite.
TOPO - Plots land elevations with different projections using the color scales relevant to the chosen descriptor. The image will remap.

goessouth.unidata.ucar.edu
SOUTH - GOES South (GOES-12) imager and sounder coverage of South America.

satepsanone.nesdis.noaa.gov
PUB - FY2C, METEOSAT-9 (6-hourly) and MTSAT imagery. GOES-East and West imagery and products.

You can configure defaults for particular images by creating a custom defaults file. For more information, see Configuring Image Defaults.

*Additional alternate servers include: idd.unl.edu, stratus.al.noaa.gov, twister.millersville.edu, weather2.admin.niu.edu, and
weather3.admin.niu.edu. These alternate servers have most or all of the datasets listed under adde.ucar.edu.
THREDDS Data Server (TDS)/OPeNDAP

McIDAS-V can access gridded data (netCDF/GRIB/GEMPAK) and NEXRAD radar data stored on a THREDDS Data Server (TDS) through the
OPeNDAP (formerly called DODS) protocol. See Choosing Cataloged Data for more information.
HTTP

Many of the data sources listed in the table above can read files directly from web servers (e.g. Apache) through the HTTP protocol. In most cases,
the server must support the HTTP 1.1 protocol and be configured to set the "Content-Length" and "Accept-Ranges: bytes" headers. See the
Choosing a URL for more information.

netCDF files
The Network Common Data Form (netCDF) provides a common data access method for Unidata applications. This format can be used to store a
variety of data types that encompass single-point observations, time series, regular grids, and satellite and radar images. The mere use of netCDF by
itself is not sufficient to make data "self-describing" and meaningful to McIDAS-V.

Generally, McIDAS-V requires that datasets in netCDF format use metadata conventions to be able to fully understand and geolocate the dataset.
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These conventions provide documented "best practices". Using conventions with netCDF ensures your data is complete and self-describing, and can
be used by others. We recommend you use CF, COARDS, or NUWG conventions for netCDF data files for McIDAS-V, and be sure to follow the
best practices noted above.

ASCII Text Point Data
McIDAS-V can read point data and trajectories (aircraft tracks) from comma-separated value (CSV) text files. See the documentation on the Text
(ASCII) Point Data Format.
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Documentation and Support
Where to find Help and Support for McIDAS-V
If you are having problems installing or using McIDAS-V, or want to know how to perform a particular task, you have several resources to assist
you.

McIDAS-V Documentation
Other Sources of Help

McIDAS-V Documentation
The first source of support is this McIDAS-V User's Guide. It contains complete instructions for downloading, installing, running, and using the
McIDAS-V reference application and all its features. It also has a Frequently Asked Questions (FAQ) section with answers to many of the most
commonly asked questions. The User's Guide can be accessed from the McIDAS-V Help->User's Guide menu or online at
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/current/.

Additional documentation is available on the McIDAS-V homepage (http://www.ssec.wisc.edu/mcidas/software/v/), including McIDAS-V training
materials (tutorials and data used in training sessions) and McIDAS-V source code.

Other Sources of Help
If you have questions or encounter problems that the McIDAS-V documentation (described above) doesn't provide sufficient help, there are two
additional sources of help. They are the McIDAS-V Support Forums and the McIDAS Help Desk.

The McIDAS-V Support Forums contain subject-based forums, each with topics and posts relating to the forum's subject. Only registered users can
post on the forums. However, anyone can view the forums and their contents (i.e., visit as an unregistered "Guest").

The McIDAS Help Desk is staffed during business hours with user-support personnel. As noted in the MUG Policy Document, the help desk is
supported by the fees paid by the McIDAS Users' Group (MUG) and thus provides advanced-level support for MUG members. For McIDAS-V all
users (whether or not a MUG member) are welcome to contact the help desk to report software bugs or suggest improvements (enhancements).

When reporting a bug, first check for related error messages in the Message Console, and include the appropriate error messages in your email
message. Also include as much information as you can about how you were running McIDAS-V and what happened, including:

the version of McIDAS-V that you are using (use the Help->About McIDAS-V menu)
your operating system and version level
any messages on the console (to see the console, use the Help->Show Console menu)
exact data source and parameter choice
types of display being made and in use
the sequence of McIDAS-V actions and choices that caused the problem
a bundle file that recreates the problem if the data sources are network accessible (optional, but desirable)

Send this information to the McIDAS Help Desk using one of the three methods below.

1. Fill out the support form available from the Help->Support Request Form menu. Please include as much information as possible about the
problem. (This is the preferred method.)

2. Fill out the contact form available on the McIDAS Website. Please include as much information as possible about the problem.
3. You may contact McIDAS User Services or the McIDAS Help Desk by postal mail at the following address:

McIDAS User Services 
Space Science and Engineering Center 

University of Wisconsin-Madison 
1225 West Dayton Street 

Madison, WI 53706
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License and Copyright
McIDAS-V
Version 1.5beta1

Copyright© 2007-2013
Space Science and Engineering Center (SSEC)
University of Wisconsin - Madison
1225 W. Dayton Street, Madison, WI 53706, USA
http://www.ssec.wisc.edu/mcidas

All Rights Reserved

McIDAS-V is built on Unidata's IDV and SSEC's VisAD libraries, and
some McIDAS-V source code is based on IDV and VisAD source code.

McIDAS-V is free software; you can redistribute it and/or modify
it under the terms of the GNU Lesser Public License as published by
the Free Software Foundation; either version 3 of the License, or
(at your option) any later version.

McIDAS-V is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser Public License for more details.

You should have received a copy of the GNU Lesser Public License
along with this program. If not, see http://www.gnu.org/licenses.

Other Licenses
McIDAS-V includes software developed by:

The University Corporation for Atmospheric Research/Unidata (IDV) (http://www.unidata.ucar.edu/software/idv/)
The University of Wisconsin-Madison (VisAD) (http://www.ssec.wisc.edu/~billh/visad.html)
The Australian Bureau of Meteorology (AIFS) (http://ssu1.bom.gov.au/pub/ims/aifs.html)
The Apache Software Foundation (http://www.apache.org/)
The Jython project (http://www.jython.org)
The JDOM project (http://www.jdom.org)
The ImageJ project (http://rsb.info.nih.gov/ij/)
The JJ2000 project (http://jpeg2000.epfl.ch/)
The JFreeChart project (http://www.jfree.org/jfreechart/)
The JCommon project (http://www.jfree.org/jcommon/)
The L2FProd.com Common Components 6.9.1 (http://common.L2FProd.com)
The jnumeric package (http://jnumerical.sourceforge.net/)
JAMA: The Java Matrix Package (http://math.nist.gov/javanumerics/jama/)
JTEM: Java tools for experimental mathematics (http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods/index.html)
FamFamFam Silk icons (http://www.famfamfam.com/lab/icons/silk/)
Tango icons (http://tango.freedesktop.org/Tango_Icon_Library)

Please read the different LICENSE files present in the root directory of the McIDAS-V distribution for restrictions on those packages.

http://www.ssec.wisc.edu/mcidas
http://www.gnu.org/licenses
http://www.unidata.ucar.edu/software/idv/
http://www.ssec.wisc.edu/~billh/visad.html
http://ssu1.bom.gov.au/pub/ims/aifs.html
http://www.apache.org/
http://www.jython.org/
http://www.jdom.org/
http://rsb.info.nih.gov/ij/
http://jpeg2000.epfl.ch/
http://www.jfree.org/jfreechart/
http://www.jfree.org/jcommon/
http://common.l2fprod.com/
http://jnumerical.sourceforge.net/
http://math.nist.gov/javanumerics/jama/
http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods/index.html
http://www.famfamfam.com/lab/icons/silk/
http://tango.freedesktop.org/Tango_Icon_Library
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Getting Started
This section describes how to quickly get started using McIDAS-V and making displays of common data.

McIDAS-V Main Windows
There are two main windows in the McIDAS-V application, the Data Explorer window and the Main Display window. Other windows may appear
when needed.

Data Explorer
The Data Explorer window is central to McIDAS-V. It is used to choose data sources and parameters to display, the types of displays to make, and
times of data to display. More information can be found in the Data Explorer section of the McIDAS-V User's Guide.

Image 1: Data Explorer Window

Main Display window
The Main Display window includes the McIDAS-V display panels, Legend, Time Animation Controls, viewpoint controls for 3D displays, icons
for zooming, panning, and rotating, menus of projections, the main McIDAS-V toolbar, and the main menu bar. More information can be found in
Main Display window section of the McIDAS-V User's Guide.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataExplorer__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Legend__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__viewpoint
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_MainToolBar__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Menus__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ui__FILE
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Image 2: Main Display Window

Common Usage Scenario
To create displays with McIDAS-V, the common usage scenario is:

Choosing sources of data
Selecting parameters and times and creating a display
Controlling the display
Removing the displays

Getting Started Sections

Displaying Satellite Imagery
Displaying Hyperspectral Satellite Imagery Using HYDRA
Displaying Level II Radar Imagery
Displaying Level III Radar Imagery
Displaying Surface and Upper Air Point Data
Displaying RAOB Sounding Data
Displaying Profiler Data
Displaying Gridded Data
Displaying Fronts
Displaying Local Files
Displaying Files From a URL
Using the McIDAS-X Bridge
Using the Globe Display

Accessing Additional Tutorials

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__remove
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hydra__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelIII__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Fronts__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalFiles__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UrlFiles__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Bridge__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Globe__FILE
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For more help with getting started with McIDAS-V, please see the Installation and Introduction tutorial on the McIDAS-V Documentation
webpage.

http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Satellite Imagery
This section describes how to make displays using geostationary and polar orbiting satellite imagery.

Image 1: Satellite Image in the Main Display Window

The steps include:

Choosing Geostationary Satellite Imagery from a Remote Server
Creating the Display
Displaying a Single Polar Orbiting Satellite Image from a Remote Server
Creating a Loop of Polar Orbiting Satellite Images from a Remote Server
Accessing Additional Tutorials

Choosing Satellite Imagery from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Satellite->Imagery from the list of available choosers.
For more information about the imagery chooser, see Choosing Satellite Imagery.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__chooser
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__id
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__polar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__loop
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageChooser__FILE
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Image 2: Data Sources Tab of the Data Explorer

1. Choose the ADDE Server: satepsanone.nesdis.noaa.gov and the Dataset: PUB.

McIDAS-V comes pre-configured with a list of ADDE servers and datasets, or you can enter your own. See Available data for a
description of these pre-defined data sets.

2. Press Connect to query the server for available image types.

3. Select the Image Type to use (in the example below, GEFDSK01V for GOES-East full disk band 1 visible images).

4. Choose the image time(s) you want. Either choose a set of relative times as shown in the example below (5 most recent), or a set of absolute
times as shown in step 5.

5. A set of absolute times (e.g., 09:15:00 UTC, 17:45:00 UTC).

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSources__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 33 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Ctrl+click or Shift+click.

6. Select the Navigation type (either Default or Lat/Lon). Choose Lat/Lon if you are using Level 1B or POES ADDE servers.
7. If you do not want to create a preview image in the Field Selector tab of the Data Explorer, uncheck 'Create preview image' box.
8. When done, load the selected image data with the Add Source button.

Creating the Display
The image data source that you selected will be shown in the Field Selector tab. The available display types are listed in the Displays panel, the
times are listed in the Times tab, the preview image or map is displayed in the Region tab, and the geographical selection parameters are listed in
the Advanced tab.

Image 3: Field Selector Tab of the Data Explorer

1. Select the calibration that you wish to display in the Fields panel. In this example, Brightness is selected.
2. "Image Display" should be selected for you in the Displays panel. "Image Display" displays your data as an image and is the display type

used for satellite and Level III radar images in almost all cases.
3. Click the Region tab to view the Preview Image. Use the mouse to Shift+left click and drag to select the geographical boundaries of your

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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image.

4. Click  to display the image(s) in the Main Display window. To control time animation use the Time Animation Widget.

If you want to create another type of satellite display over your current display, click "Image Contours" in the Displays panel to contour your data.
To change your contour colors, right click on the color bar in the Legend, and choose one of the color tables shown in the list.

Image 4: Satellite Image with Contours in the Main Display Window

Due to the variability in brightness values in satellite images, some changes may need to be made to the contours to produce a quality image. To
reduce the number of contours in the image, the contour interval can be increased by clicking the  button next to Contour in the Layer
Controls tab of the Data Explorer, and entering a higher value for the Contour Interval. To decrease the rigidness of the contours, select a new
Smoothing method in the Layer Controls tab and enter a higher smoothing factor.

Displaying a Single Polar Orbiting Satellite Image from a Remote Server
Return to the Satellite Imagery chooser in the Data Sources tab of the Data Explorer. Selecting polar orbiting satellite data is similar to the method
to select geostationary data.

1. Choose the ADDE Server: stratus.al.noaa.gov and the Dataset: RTIMAGES and press Connect to query the server for available image
types.

2. Select the Image Type to use (in the example below, ANTARCTIC - Antarctic Thermal IR Composite).

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animation
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Legend__FILE
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3. Choose to display the most recent image, and click .
4. In the Fields panel, select the calibration that you wish to view.
5. When done, load the selected image data with the  button.
6. The polar orbiting satellite image will be displayed on top of the existing geostationary satellite image.

Creating a Loop of Polar Orbiting Satellite Images from a Remote Server
When creating loops of polar orbiting satellite images, it is recommended that the Auto-set Projection option be turned off, and a global projection
be used in the map display to ensure all images can be viewed. For this example, turn the Auto-set Projection option off by going to the Main
Display window and selecting Projections->Auto-set Projection. Under the same menu, change your projection to Projections->Predefined-
>World. These options can also be used for displaying single images of polar orbiting satellite data. If you have access to an ADDE server with
Aqua or Terra granules, you can use the following steps to display the data:

1. Return to the Data Sources tab of the Data Explorer.
2. Select a different Image Type to use (in the example below, Aqua 500 meter resolution Calibrated Radiances).

3. Choose a set of either the 10 most recent relative times, or a set of 10 absolute times.
4. When done, load the selected images into the Field Selector with the  button.
5. In the Fields panel, select the calibration that you wish to view.
6. In the Advanced tab, change the Coordinate Type to Image Coordinates. There is currently no method of determining the latitude and

longitude boundaries of multiple polar orbiting images. Using the Image Coordinates option ensures the images will be displayed.

7. When done, load the selected images with the  button.

Accessing Additional Tutorials
For more help with displaying satellite data, please see the Satellite Imagery tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__autosetpro
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Hyperspectral Satellite Imagery Using HYDRA
This section describes how to create multispectral displays using HYDRA. The set of steps include:

Creating the Multispectral Display
Using the Multispectral Display
Accessing Additional Tutorials

Creating the Multispectral Display
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Satellite->HYDRA from the list of available choosers.
For more information about the HYDRA chooser, see Choosing Hyperspectral Data.

Image 1: Data Sources Tab of the Data Explorer

The HYDRA chooser is fairly similar to the File Chooser. As a demonstration, download the IASI image from January 15, 2007 located at:
ftp://ftp.ssec.wisc.edu/pub/mug/mcidas-v/training/data/IASI_xxx_1C_M02_20070115_1140.nc. Navigate to the directory the file is in and press 

.

In the Field Selector tab of the Data Explorer, select Imagery->Multispectral Display, and click the  button.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hydra__chooser
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hydra__multi
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hydra__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_HydraChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_IASI_xxx_1C_M02_20070115_1140.nc_FILE
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Image 2: Field Selector Tab of the Data Explorer

There are four aspects to the multispectral display. The first is the image in the Main Display window. The image will be over Northern Africa and
the Mediterranean Sea. The second aspect is the Spectra. The Spectra is displayed in the Layer Controls tab under "MultiSpectral". The spectra
displayed by default is the 919.50 cm-1 spectral region (10.8 µm). The final two aspects are the two spectrum probes. In the Main Display window,
there are two colored square boxes that represent the main probe (magenta) and the reference probe (light blue). These two probes are listed under
"Readout" under "No Display" in the Layer Controls tab of the Data Explorer. Left click and drag either probe to view the spectra measured in
various pixels around the image, or use one as a reference spectrum.

Using the Multispectral Display

Change the wavenumber being displayed to 852.25 cm-1 by entering in the value into the Wavenumber: box in the Multispectral Display and
hitting Enter. Move the magenta and light blue spectra probes to the approximate locations in the image below to locate an inversion at the location
of the red box over Albania.
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Image 3: HYDRA Data Displayed in the Main Display Window

Once the two probes are in the approximate locations, the MultiSpectral window should look similar to the image below.

Image 4: HYDRA Data Displayed in the MultiSpectral Window

Zoom in over the 852.25 cm-1 region using the Ctrl+left click+drag combination to create a box of the region to zoom in on. If you miss the region,
or want to return to the full spectra, use Shift+left click. The inversion should become clear as you zoom in, as shown in the image below.
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Image 5: HYDRA Data Displayed in the MultiSpectral Window

Accessing Additional Tutorials
For more help with displaying hyperspectral satellite imagery using HYDRA data, please see the Hyperspectral Data tutorial on the McIDAS-V
Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Level II Radar Imagery
This section describes how to make displays using NWS WSR-88D Level II data. The steps include:

Accessing WSR-88D Level II Radar Data
Choosing Level II Radar Data
Making Level II Radar Displays
Creating 2D Displays of Individual Sweeps
Creating 3D Displays of Individual Sweeps
Displaying Pseudo-RHI Displays in 2D and 3D
Displaying All Sweeps in 3D
Radar Isosurfaces in 3D
Choosing Local Level II Radar Data
Accessing Additional Tutorials

Accessing WSR-88D Level II Radar Data
The Level II data is supplied as volume-scan files, each file having all data from WSR-88D radar for all sweeps for one "time". Archived Level II
data is available from the National Climatic Data Center (NCDC) (data from NCDC must be un-tarred).

The files should be stored on your local file system with each station's files in a directory whose name is the 4-character ID (e.g., KTLX for
Oklahoma City). In many cases, the data files do not have any location information in them and McIDAS-V uses the directory name as a first guess
at the station location.

Choosing Level II Radar Data
In the Data Sources tab of the Data Explorer, select Radar->Level II->Remote to view the Level II radar chooser. The Radar->Level II->Local
chooser allows you to choose Level II data from your file system. For more information about the Level II radar chooser, see Choosing NEXRAD
Level II Radar Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__access
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__chooser
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__displays1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__2displays
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__3ddisplays
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__rhi
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__allsweeps
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__isosurface
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__local
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__more
http://www.ncdc.noaa.gov/oa/ncdc.html
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Level2Chooser__FILE
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Image 1: Data Sources Tab of the Data Explorer

Select a station and a relative or absolute set of times. When done, click the  button.

Making Level II Radar Displays
The data source is shown in the Field Selector tab of the Data Explorer. Level II data has three moments or data types: Reflectivity,
RadialVelocity, and SpectrumWidth. McIDAS-V has several display types for Level II data, and any of the moments can be shown with any of the
displays. Selecting "Reflectivity" in the Fields panel will show the list of available displays in the Displays panel.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Image 2: Field Selector Tab of the Data Explorer

Creating 2D Displays of Individual Sweeps

Image 3: Level II 2D Radar Displayed in the Main Display Window

Select the Radar Sweep View in 2D under Radar Displays in the Displays panel and click . Radar Sweep View in 2D plots the
data as a colored image on the base of the 3D display area.

The Radar Sweep Controls allow you to change which sweep elevation you want to use. You can add range rings with the Displays->Add Range
Rings menu item.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarSweepControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarGridControl__FILE
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Creating 3D Displays of Individual Sweeps

 
Image 4: Level II 3D Radar Displayed in the Main Display Window

Select the Radar Sweep View in 3D entry under Radar Displays in the Displays panel. The Radar Sweep View in 3D display plots the data as a
colored image, with the data plotted in 3D space at the elevation where the sweep occurred. You can rotate the display to see its 3D nature.

You can use this display to merge radar data displays with upper air data, such as McIDAS-V plots of NOAA Profiler data. Since the Earth is
projected onto a flat surface in this display, the sweep has a shape very close to a rotated parabola. The Elevation Angles menu in the Layer
Controls tab allows you to change which sweep elevation to display.

Displaying Pseudo-RHI Displays in 2D and 3D
Select RHI (Range-Height Indicator) under Radar Displays in the Displays panel and press Create Display. The RHI display plots the data as a
colored vertical cross section at the true elevations of the beams in 3D space (Image 5). This pseudo-RHI is constructed from several horizontal
sweeps of the radar. It may be necessary to rotate the display to see the RHI in 3D.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__FILE
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Image 5: Level II Pseudo-RHI Radar Displayed in the Main Display Window

 
Image 6: Level II Pseudo-RHI Radar Displayed in the Layer Controls Tab

The beam width is indicated by the vertical extent of each colored vertical stripe, corresponding to a bin beam bin sample. The position of the RHI
in azimuth can be adjusted by dragging the little box on the end of the selector line above the RHI.

A 2D plot of pseudo-RHI (Image 6), is shown in the Display tab of the Layer Controls tab. The RHI displays have an auto-rotate feature and a
Time Animation Widget.

Displaying All Sweeps in 3D

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarRhiDisplayControls__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Image 7: Level II Radar Volume Scan in the Main Display Window

Select Volume Scan (all sweeps) in the Displays panel in the Field Selector. Volume Scan (all sweeps) plots the data as 3D field of points colored
by value. Each point is a bin value; all sweeps and bins are shown.

Radar Isosurfaces in 3D
Select Radar Isosurface under Radar Displays in the Displays panel in the Field Selector tab. An isosurface is a 3D analog of a contour line
which shows the location of all data with a single data value. Interpolation is used between sweep altitudes in the isosurface plot of Level II data,
and all data in a volume scan is used.
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Image 8: Level II Radar Isosurface Displayed in the Main Display Window

Choosing Local Level II Radar Data
To select Level II data from the Radar Imagery->Level II->Local file chooser:

1. Navigate to the desired directory. This chooser works like the Files chooser.

2. Select one or more Level II data files. Use Ctrl+click or Shift+click to select multiple files. Each file represents a full volume scan at a
particular time.

3. Alternatively, use the Use Relative Times button to select the latest N files in the directory. You can optionally use the File Pattern field
to specify the pattern for files to look for.

4. Provide a radar station name. For some Level II data, McIDAS-V requires you to provide the radar location. McIDAS-V will try to guess
at the location based on the directory name but you can specify the location using the Radar Location menu.

When done, load the selected radar data with the  button. The local data source will be shown in the Field
Selector.

Accessing Additional Tutorials
For more help with displaying Level II radar imagery, please see the Level II Radar Imagery tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Level III Radar Imagery
This section describes how to make displays using NWS WSR-88D Level III data.

Image 1: Level III Radar Display

The steps include:

Choosing Radar Image Data from a Remote Server
Creating the Radar Display

Choosing Radar Image Data from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Radar->Level III from the list of available choosers.
For more information about the Level III radar chooser, see Choosing NEXRAD Level III Radar Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelIII__choosing
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelIII__display
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarChooser__FILE
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Image 2: Data Sources Tab of the Data Explorer

1. Choose an ADDE Server and a Dataset to use. For this example, try Server: adde.ucar.edu and Dataset: RTNEXRAD.

2. Press Connect to query the server for available radars types:

3. Select a radar product, such as Base Reflectivity Tilt 1, from the pull-down menu.

4. The map shows the available radar station locations and IDs. Select one by clicking on it.
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The Decluttter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not overlap each
other (checked). You will need to zoom in to see all the stations without overlaps.

5. You can choose a relative set of times steps (e.g., Last 5 times) or absolute times (see step 6):

6. You can choose a set of absolute times:

When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Control+click or Shift+click.

7. When done, load the selected radar data with the Add Source button.

Creating the Radar Display
The radar data source that you selected will be shown in the Field Selector tab of the Data Explorer.

Image 3: Field Selector Tab of the Data Explorer

Open up the Base Reflectivity tab under the Fields panel ( ) to select a data type. Select "Image display" in the Displays panel under Imagery,
and make the display by clicking the  button.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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You can add Range Rings with the Display->Add Range Rings menu item. To control the looping of the images in the Main Display window, use
the Time Animation Widget.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarGridControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animation
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Displaying Surface and Upper Air Point Data
This section describes how to make station model plots and contour displays using surface and upper air data. It also explains how to create and edit
station models.

Image 1: Station Model Plot in the Main Display Window

The steps include:

Selecting Surface Observations from a Remote Server
Creating the Plot Display
Creating the Contour Display
Accessing Additional Tutorials

Selecting Surface Observations from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Point Observations->Plot/Contour from the list of
available choosers. For more information about the Point Observations Plot/Contour chooser, see Choosing Point Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__selecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__plot
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__contour
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PointChooser__FILE
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Image 2: Data Sources Tab of the Data Explorer

In the Server: and Dataset: entry boxes, use the pulldown lists to select a local or remote server and a dataset with METAR data, such as
adde.ucar.edu and RTPTSRC. You can also type a different server name into the entry box. Click  to find data on the
remote server. In the Point Type: selection box choose "Real-Time SFC Hourly", or the equivalent depending on your data source. You can choose
either the latest N times using the Relative tab or select specific times using the Absolute tab. Click  when you have
made your selection. Only data from the current date will be retrieved from the server.

Creating the Plot Display
The surface observation data will be shown in the Field Selector tab of the Data Explorer.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Image 3: Field Selector Tab of the Data Explorer

Select "Point Data" in the Fields panel and "Point Data Plot" under Point Data in the Displays panel. Make the display by clicking on the Create
Display button at the bottom of the Field Selector tab.

To declutter the display, use the Point Data Plot Controls in the Layer Controls tab.

Upper air plots can be created the same way. In the Data Sources tab of the Data Explorer, select a Point Type: of "Real-Time Upper Air
(Mandatory)," change the Interval to "12 hourly," and add the source. In the Field Selector, select a level of 500mb in the Level panel and click 

 to plot your data in the Main Display window.

Creating the Contour Display
The Gridded Fields tree allows you to use the Barnes analysis to create gridded fields of specific point observation parameters.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PointDataPlotControl__FILE
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Image 4: Field Selector Tab of the Data Explorer

Select the SYNOPTIC (SFCHOURLY) dataset from the Data Sources panel of the Field Selector. In the Fields panel, open the Gridded Fields
tree by clicking on the tab icon ( ) and select the temperature (T) parameter. In the Displays panel, select Contour Plan View, and create the
display by clicking the  button at the bottom of the Field Selector tab. You can create or edit your own station models by using
the Station Model Editor. To access the editor, click on the double down arrow ( ) and select Edit under the Layout Model: section in the Layer
Controls tab or select Tools->Station Model Template from the Main Display window.

Upper air gridded fields can be created the same way. In the Field Selector, select the UPPERMAND dataset, open the Gridded Fields tab, select a
parameter and level, and create the display.

Accessing Additional Tutorials
For more help with displaying surface and upper air point data, please see the Point Observations tutorial on the McIDAS-V Documentation
webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__FILE
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying RAOB Sounding Data
This section describes how to make Skew-T plots from RAOB data.

Image 1: Skew-T Display in the Layer Controls Tab of the Data Explorer

The set of steps include:

Choosing RAOB Sounding Data from a Remote Server
Creating the Sounding Display
Accessing Additional Tutorials

Choosing RAOB Sounding Data from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Point Observations->Soundings->Remote. For more
information about the soundings chooser, see Choosing Upper Air Sounding Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__connecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__display
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RaobChooser__FILE
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Image 2: Data Sources Tab of the Data Explorer

For the Server and Dataset, select adde.ucar.edu and RTPTSRC and click Connect. You must select UPPERMAND for real-time upper air
mandatory data, and you have the option to also select UPPERSIG for real-time upper air significant data for the Soundings category. The stations
that match your conditions will be displayed in the map. Select the station(s) you want to use. You can select one or more stations by clicking on
them; hold down the Ctrl key to select more than one. When the Declutter checkbox is checked, only stations that do not overlap will be shown.
When in declutter mode you can zoom in (by dragging the left mouse) to see more stations. The icons below the map allow you to navigate the
map.

After you select your station(s), select the available time(s) you want to view in the Available box. The list of available soundings will be displayed
in the Selected box. When you have made your selection click the  button.

Creating the Sounding Display
The RAOB data will be shown in the Field Selector tab.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Image 3: Field Selector Tab of the Data Explorer

Select "RAOB data" in the Fields panel and "Skew-T" or one of the other sounding types in the Displays panel. All times will be loaded by
selecting the RAOB Data field. You can select individual times to display at once by selecting individual times under RAOB Data. Make the
sounding display by clicking on the  button. The sounding will be displayed in the Layer Controls tab. For more information
about the Skew-T and other aerological displays, see Sounding Display Controls.

Accessing Additional Tutorials
For more help with displaying RAOB sounding data, please see the Point Observations tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AerologicalSoundingControl__FILE
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Profiler Data
This section describes how to make plots from the NOAA National Profiler Network. The set of steps involve:

Connecting to the NOAA National Profiler Network
Making the Profiler Displays
Additional Profiler Displays
Accessing Additional Tutorials

Connecting to the NOAA National Profiler Network
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Point Observations->Wind Profiler. For more
information about the wind profiler chooser, see Choosing NOAA National Profiler Network Data.

Image 1: Data Sources Tab of the Data Explorer

In the Server: and Dataset: entry boxes, use the pull down list to select a remote server and dataset with Profiler data, such as adde.ucar.edu and
RTPTSRC. Connect to the server and select a profiler type such as "Real-Time Hourly Profiler data".

Select a station by clicking on it on the map. Select a group of stations by dragging the mouse cursor while holding down the Shift key to make a
rubber band box, or do Shift+click to select more than one station. The map shows Profiler station names. To see more stations check the Declutter
box off. When unchecked, the Declutter check box allows you to show all stations, and when checked, only a limited number of stations that do not
overlap each other will be seen. As you zoom in, more station will appear, and it may be necessary to zoom in to see all of the stations clearly
separated. The icons below the map allow you to navigate the map.

Once you have selected one or more stations, select a relative or absolute set of times. For absolute times, check individual times on or off with
Ctrl+click. Select multiple times with Shift+click.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__connecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__display
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__others
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerChooser__FILE
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In the Interval selection box you can choose from Hourly, 30 minute, 12 minute, or 6 minute intervals to determine what time step will be used for
your data. Once you have selected an interval, click the  button.

Making the Profiler Displays
A label similar to "Profiler Hourly - 6 stations" appears in the Data sources panel in the Field Selector tab.

Image 2: Field Selector Tab of the Data Explorer

The Profiler winds item in the Fields panel allows you to make any of the Profiler displays for all the stations selected. You can use the individual
station fields to make a display only for that station.

Select Profiler->Time/Height Display in the Displays panel to choose this type of display. Then make the display by clicking  at
the bottom of the Field Selector tab.

Similarly you can choose the Profiler Station Plot display (a mapped plan view of profiler winds at any single level above sea level), or the 3D
View display which shows winds at all levels and at all stations selected.

Additional Profiler Displays
For examples of the Profiler displays and how to control them, see Profiler Controls.

Accessing Additional Tutorials
For more help with displaying profiler data, please see the Point Observations tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_profiler__FILE
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Gridded Data
This section describes how to make displays using gridded data sets. The steps include:

Connecting to a Data Source on a Remote Server
Creating a Plot of 2D Data
Creating a Plot of 3D Data
Subsetting Times
Subsetting Spatially
Accessing Additional Tutorials

Connecting to a Data Source on a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Gridded Data->Remote from the list of available
choosers. For more information about the catalog chooser, see Choosing Gridded Data.

Image 1: Data Sources Tab of the Data Explorer

Choose one of the remote Catalogs: such as http://www.unidata.ucar.edu/georesources/threddsRtModels.xml for Unidata's catalog of near
real-time model output.

A tree view of the catalog will be displayed. Open one, such as the "NCEP Model Data -> Global Forecast System (GFS) -> GFS-CONUS 80km ->
files -> Latest NCEP GFS CONUS 80km", by using the tab icons ( ).

The list of this model's run times appears. Click on one time to select it, and then click the  button. You have selected
this model run's output to be accessible by McIDAS-V.

Creating a Plot of 2D Data

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__connecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__selecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__3dplot
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__subset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__spatialsubset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__more
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GridChooser__FILE
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The gridded data source that you selected will be shown in the Field Selector tab of the Data Explorer. The Field Selector tab contains folders of
data categorized as 2D and 3D fields. Click on the 2D grid tab ( ) to expand that category list. A list of all 2D grid parameters in the data source
appears. When one of the fields is selected, the list of applicable display types will be added to the Displays panel.

Image 2: Field Selector Tab of the Data Explorer

Create a Contour Plan View display of a parameter by selecting a field to display in the Fields panel and selecting Contour Plan View in the
Displays panel.  Click the Create Display button. The display will be created and shown in the Main Display window. The display's Legend should
also be shown on the right side of the Main Display window. You can open the Layer Controls for the item by right-clicking on the name in the
legend and selecting Control Window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Legend__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViewControl__FILE
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Image 3: Contour Plan View Display in the Main Display Window

Creating a Plot of 3D Data
In the Field Selector tab of the Data Explorer, click on the 3D grid tab to expand that category. A list of all 3D grid parameters appears. To make a
plot, first select a parameter name such as "Geopotential height @ Isobaric surface".

Display types suitable for this parameter are listed in then Displays panel. Select the Contour Plan View display, and click the Create Display
button.

The initial plot is at the highest level in the data grid, such as 100 millibars. To shift the level to other levels:

Left-click on the blue text in the Legend for your 3D layer.  This takes you to the Layer Controls tab of the Data Explorer.
In the Data Explorer, click on the Levels: box to bring up the drop-down list of native grid levels for the data.
Select the desired level from the list.

The data in the Main Display window will now be displayed at the new level you have selected.

To zoom, pan, or rotate this 3D display, see Zooming, Panning, and Rotating. To toggle on the time animation loop, use the Run/Stop icon in the
Time Animation Widget. To remove an existing display, use the File->Remove Display menu of the Layer Controls tab.

Subsetting Times
McIDAS-V automatically loads data for all times selected in the Layer Controls tab of the Data Explorer, and loads them as displays for an
animation loop. Creating several displays may take time. If you only need to see one data time, it is better to only create displays for that time, as
McIDAS-V will load in smaller loops of data faster than larger ones.

To make time selections that apply to all data in one data source, double click on the data source name in the Data Sources panel of the Field
Selector tab to bring up the Data Source Properties editor. Click on the Times tab to subset the times.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animation
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Image 4: Times Tab of the Subset Panel

Initially, all times are selected for display, indicated by the times in this window being grayed out and the Use Default checkbox being checked. To
limit the selection to fewer times than all times, first check off the Use Default checkbox, and then select the times you want by clicking on the
times (Note: You can select multiple times with the Shift and Ctrl keys). The selected times will be highlighted in blue, and these are the only times
that will appear in your loop of data in the Main Display window.

To make time selections for one field, use the Times tab in the lower right panel of the Field Selector tab after you select the field and before you
create the display. This will override the default times for the data source selected in the Field Selector tab of the Data Explorer.

Subsetting Spatially
You can also spatially subset the grid using the Spatial Subset tab of the Data Source Properties. This works similar to the times subsetting where
you can set the property for all fields in the Data Source or override the default for a particular field.

Accessing Additional Tutorials
For more help with displaying gridded data, please see the Gridded Data tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSource__spatialsubset
http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Displaying Fronts
This section describes how to make plots from the NOAA National Profiler Network.

In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Front Positions from the list of available choosers.
For more information about the fronts chooser, see Choosing Front Positions.

Image 1: Data Sources Tab of the Data Explorer

In the Server: and Dataset: entry boxes, use the pull down lists to select a remote server and dataset containing front data, such as adde.ucar.edu
and RTPTSRC, and connect to the server.

Select either analysis or forecast fronts and click the  button. The fronts will automatically plot in the Main Display
window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FrontChooser__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 65 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Displaying Local Files
This section describes how to make a display using files or a directory located on your local machine.

Image 1: Satellite Image in the Main Display Window

The set of steps include:

Loading Local Files
Loading Local Files from a Directory
Creating the Display

Loading Local Files
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select General->Files from the list of available choosers. For
more information about this chooser, see Choosing Data on Disk.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalFiles__files
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalFiles__directory
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalFiles__creating
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_choosers__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
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Image 2: Data Sources Tab of the Data Explorer

1. Navigate to the directory that contains the file(s) you are interested in. Use the Look In menu to select directories, or double-click on
directory names to open the directories and load individual files.

2. Select one or more files. Multiple files can be selected using Ctrl+click or Shift+click.
3. Optionally, specify the type of data the file contains by using the Data Type menu.
4. When done, load the selected file(s) by clicking the  button.

Loading Files from a Directory
Loading files from a directory is similar to loading files, however you are limited to one directory. Loading files from a directory also gives you the
options of polling files, as well as limiting files to a specific file pattern.
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Image 3: Data Sources Tab of the Data Explorer

1. Select the directory you want to poll on.
2. Type in a name for the dataset that you want to show in the Field Selector.
3. Optionally, specify the type of data the URL contains by using the Data Type menu.
4. Choose the number of files you want to to search for. You can select an absolute number of files that have been updated in a certain time

period.
5. When done, load the selected URL by clicking the  button.

Creating the Display
The local data files will be shown in the Field Selector tab of the Data Explorer.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Image 4: Field Selector Tab of the Data Explorer

The data source name listed in the Field Selector will be based upon whether you loaded files or a directory. If one file is loaded, the name of the
file is shown. Multiple files will be listed as "N files" where N is the number of files loaded. A directory will be shown as the directory name plus
the file pattern (if used), or ".*" if all files in the directory are loaded. Once you have selected a Field, Display, and Time(s), click the 

 button to display your data in the Main Display window.
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Displaying Files from a URL
This section describes how to make a display using files located at a specific URL.

Image 1: Satellite Display in the Main Display Window

The set of steps include:

Loading Files from a URL
Creating the Display

Loading Files from a URL
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select the General->URLs from the list of available
choosers. For more information about this chooser, see Choosing a URL.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UrlFiles__loading
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Image 2: Data Sources Tab of the Data Explorer

1. Select the Data Type of your data using the pull down menu.
2. Enter the URL into the field or choose a previously selected URL from the pull down menu.
3. Toggle the  button to expand the box to allow for the entry of multiple URLs, one per line.
4. Optionally, specify the type of data the URL contains by using the Data Source Type menu.
5. When done, load the selected URL by clicking the  button.

Creating the Display
The local image data source files will be shown in the Field Selector tab of the Data Explorer.
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Image 3: Field Selector Tab of the Data Explorer

Once you have selected a Field, Display, and Time(s), click the  button to display your data in the Main Display window.
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Using the McIDAS-X Bridge
This section describes how to create displays from a McIDAS-X bridge session. The McIDAS-X Bridge provides a way to load data from an active
McIDAS-X session into McIDAS-V. Note: The McIDAS-X bridge will only work if you have McIDAS-X, and are updated to at least version
2007a or later. If you do not, proceed to the next section.

The set of steps include:

Starting the McIDAS-X Bridge Listener
Creating a McIDAS-X Bridge Session
Creating a McIDAS-X Display in McIDAS-V
Accessing Additional Tutorials

Starting the McIDAS-X Bridge Listener
To start the McIDAS-X bridge listener, type MCLISTEN START in a running McIDAS-X session (version 2007a or later) on a remote or local
machine.

Creating a McIDAS-X Bridge Session
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select McIDAS-X Bridge from the list of available choosers.
For more information about the McIDAS-X Bridge chooser, see Creating a McIDAS-X Bridge Session.

Image 1: Data Sources Tab of the Data Explorer

If you are connecting to the listener on your local machine, connect to the defaults of localhost listening on port 8080. Otherwise, enter in a host
name and the corresponding port number and click the  button. If MCLISTEN START was not run on the local or
remote host, an error box will say that the "Connection to McIDAS-X Bridge Listener at localhost:8080 failed".

The data source is shown in the Field Selector tab of the Data Explorer. The Frame Sequence will be listed in the Fields panel. Click the ( ) tree
tab to the left of "Frame Sequence" to expand that list and list all available frames in the connected McIDAS-X session. You have the option to
select all available McIDAS-X frames, or one single frame. Select the "Frame Sequence", and create a "McIDAS-X Image Display" by clicking the 

 button.
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Image 2: Field Selector Tab of the Data Explorer

Creating a McIDAS-X Display in McIDAS-V
The McIDAS-X bridge session will be in the Layer Controls tab of the Data Explorer, mirroring the McIDAS-X frame(s) selected. You can enter
McIDAS-X commands in the "Command Line" text entry box at the bottom of the Layer Controls tab. This will run McIDAS-X commands, and
the McIDAS-V display in the Layer Controls tab will update to reflect the results. Although the bridge session resembles a normal McIDAS-X
session, interactive commands are not implemented, but recall commands do work.
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Image 3: McIDAS-X Bridge Controls

Create a loop of satellite images in the McIDAS-X bridge session without displaying a map. Import these McIDAS-X frames into the current
McIDAS-V 3D panel by selecting the Settings tab and checking the "Display data in main 3D panel" option. This will import all of the navigated
McIDAS-X frames into the 3D panel. It is recommended that you do not use maps from McIDAS-X when importing frames, as their quality
diminishes as you zoom in on the 3D display.

If at any time you receive an error message: Selected image(s) not available, it is due to the fact that McIDAS-V will only import navigated
frames. In cases where you have a combination of navigated and non-navigated frames, McIDAS-V will import the navigated frames into McIDAS-
V. Non-navigated frames will remain in your 2D display in the Layer Controls.
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Image 4: McIDAS-X Display in McIDAS-V

Accessing Additional Tutorials
For more help with using the McIDAS-X bridge, please see the McIDAS-X Bridge tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/documentation.html
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Using the Globe Display
This section describes how to make a globe display. The illustration below shows a McIDAS-V Globe Display of GFS numerical weather
prediction model output of mean sea level pressure (as color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet
streams.

 
Image 1: Globe Display

In the Globe Display display of McIDAS-V, the displays and maps are projected onto a spherical globe. The globe can be rotated by hand or
automatically, along with the usual zooming and time animation of displays on the globe.

To create a Globe View window, use the File->New Display Tab->Globe Display->One Panel menu. This section describes how to make plots of
global satellite imagery on the Globe display. The set of steps include:

Choosing Global Satellite Imagery
Displaying the Data
Using the Display

Choosing Global Satellite Imagery
After creating a globe display in McIDAS-V, open the Data Sources tab of the Data Explorer and select the Satellite->Imagery chooser.

Connect to one of the servers listed using the RTIMAGES dataset.
From the Image Data Type selector, choose the GE-IR - GOES-East Hemispheric IR Image Type.
Select the three most recent images.
Click the  button to load the data source.

Displaying the Data
Once the data source has been selected, you can create the display by doing the following in the Field Selector tab of the Data Explorer:

Select the "GE-IR - GOES-East Hemispheric IR" data source in the Data Sources panel.
Select the "10.7 um IR Surface/Cloud-top Temp->Brightness" field in the Fields panel.
Select "Image Display" in the Displays panel.
Click the  button to create the display.

Using the Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Globe__chooser
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You can move the display using the standard McIDAS-V zooming, panning and rotating functions. For this exercise try the following:

Use the Viewpoint toolbar or the View->Viewpoint menu to rotate to the West view.
Start the image animation using the Time Animation Widget.
Utilize the Main Display window's View->Viewpoint->Auto-Rotate View menu to rotate the globe. Check this on to rotate the globe along
the vertical axis.

Any suitable data with navigation information (latitude, longitude, and altitude) that McIDAS-V can handle can be plotted on the globe display.
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Data Explorer
The McIDAS-V Data Explorer window is composed of three tabs, Data Sources, Field Selector, and Layer Controls:

Data Sources
Field Selector
Layer Controls

Image 1: McIDAS-V Data Explorer Window
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Data Sources
McIDAS-V can use data from local files, remote data servers such as OPeNDAP or ADDE and even web servers. You can read further about
specific data formats and sources available.

Select the sources of data that you want to work with within McIDAS-V using the Data Sources tab of the Data Explorer. Once selected, the data
source will be shown in the Field Selector tab where you can select parameters, display times, the display type, and create the display.

McIDAS-V can work with any number of data sources at one time. Choosing a data source with McIDAS-V typically only reads the metadata (i.e.,
data about the data); no parameter data values are read until you request a display to be made.

To select the data that is to be used in McIDAS-V you use the Data Sources tab. You can bring this up by selecting the Data Sources tab of the
Data Explorer window, or by using the Display->Create Layer from Data Source... menu item in the Main Display window.

This section describes:

Choosing Satellite Imagery
Choosing Hyperspectral Data
Choosing NEXRAD Level II Radar Data
Choosing NEXRAD Level III Radar Data
Choosing Point Data
Choosing Upper Air Sounding Data
Choosing NOAA National Profiler Network Data
Choosing Gridded Data
Choosing Front Positions
Choosing Data on Disk
Choosing Cataloged Data
Choosing a URL
Choosing Flat File Data
Creating a McIDAS-X Bridge Session
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Choosing Satellite Imagery
The Satellite->Imagery chooser allows you to access satellite imagery on local or remote ADDE servers. For more information on how to use this
chooser, see Getting Started - Displaying Satellite Imagery.

Image 1: Satellite Imagery Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right-click in the entry box to manage
your ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server.

 - Connects and queries the server for available image types.

Image Type - Selects the image type.

Times: Relative - Allows you to select a group of up to the last 100 times.

Times: Absolute - Allows you to select one or more absolute times. When choosing absolute times for the first time, McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Navigation - Selects one of the available navigation types. Use Default for most images, and Lat/Lon if LALO navigation should be used.
Level 1b servers and POES servers often require Lat/Lon navigation to be used.

Preview - Displays a preview of the image in the Region tab of the Field Selector. If this box is unchecked, then only a map of the image
coverage area will be shown without any data.

 Help - Brings up this help page.

 Refresh - Updates the Imagery chooser with the most recent data.
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 Cancel - Cancels the query of data. The chooser will reset back to default.

 - Loads the selected data.
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Choosing Hyperspectral Data
The Satellite->HYDRA chooser allows you to select data from your local file system to be displayed using HYDRA. For more information on
using this chooser, see Getting Started - Displaying Hyperspectral Satellite Imagery Using HYDRA.

 
Image 1: HYDRA Chooser

Properties

Look In - Allows you to select folders to search for data files.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Displays your most recent loaded data sources.

File Name - Represents the full name of the file selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

 Help - Brings up this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the selected file(s).
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Choosing NEXRAD Level II Radar Data
The Radar->Level II->Remote chooser allows you to choose Level II radar data from a remote THREDDS server. For more information on how
to use this chooser, see Getting Started - Displaying Level II Radar Imagery.

Local Level II Radar Chooser
The Radar->Level II->Local chooser allows you to choose Level II radar data from your file system. The Level II data is supplied as volume-scan
files, each file having all data from one WSR-88D radar for all sweeps for one "time". Archived Level II radar files can be displayed through the
Radar->Level II->Local file chooser. The files should be stored on your file system with each station's files in a directory (folder) whose directory
name is the station 4-character ID (e.g., KTLX for Oklahoma City). In some cases, the data files do not have any location information in them, and
McIDAS-V uses the directory name as a first guess at the station location. Archived Level II data is available from the National Climatic Data
Center (NCDC).

 
Image 1: Level II Local Radar Chooser

Properties

Station - Selects the radar station for the data. By default, McIDAS-V will use the folder name to determine the radar location.

Look In - Allows you to select folders to search for data files.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Represents the file name. Select a file to populate the entry box to show the full name of the file selected.
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Files of Type - Represents the file type. This narrows down the files shown in a folder to a specific data type.

Times - Represents the times of the radar displays. These times can be individually set, or you can use a File Pattern to display the images in
specific intervals.

File Pattern - Specifies the pattern for files to look for if Times is set to "Use most recent N files".

 Help - Brings up this help page.

 Refresh - Updates the Level II radar chooser with the most recent data.

 - Loads the selected radar data.

Remote Level II Radar Chooser

 
Image 2: Level II Radar Remote Chooser

Properties

Catalog - Selects the catalog used to access the Level II radar data.

 - Connects to and queries the server for available radar types and stations.

Collections - Selects the collection to use.

Station - Displays the stations related to the selected catalog and selection. Select a station by clicking on the station displayed on the map.
The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not overlap each other
(checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to locate a station, or the
following buttons:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.
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 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Click to move the view left (map right).

 Move View Right - Click to move the view right (map left).

Times: Relative - Allows you to select a group of up to the last 100 times.

Times: Absolute - Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

 Help - Brings up this help page.

 Refresh - Updates the Level II radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.
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Choosing NEXRAD Level III Radar Data
The Radar->Level III chooser allows you to choose NEXRAD Level III radar data on remote ADDE servers. For more information on how to use
this chooser, see Getting Started - Displaying Level III Radar Imagery.

 
Image 1: Level III Radar Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage
your ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Servers - Lists the public datasets available on the server

 - Connects to and queries the server for available radar types and stations.

Product - Selects a radar product.

Station - Selects a station using the map. Once a station and a product have been selected, the ADDE server will be queried as to the
available times. The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not
overlap each other (checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to
locate a station, or the following buttons:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.
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 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Times: Relative - Allows you to select a group of up to the last 50 times.

Times: Absolute - Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

 Help - Brings up this help page.

 Refresh - Updates the Level III radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Timeline__FILE
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Choosing Point Data
The Point Observations->Plot/Contour chooser allows you to choose surface, upper air, and other types of point data (eg: aircraft data) to plot or
contour for the current date. For more information on how to use this chooser, see Getting Started - Displaying Surface and Upper Air Point Data.

 
Image 1: Point Data Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Represents the dataset being used. Enter in a dataset name or choose one from the pulldown menu.

 Public Servers - Lists the public datasets available on the server.

 - Connects to and queries the server for available times.

Point Type - Selects the Point Type to display.

Times: Relative - Allows you to select a group of up to the last 100 times, for the current date only.

Relative Time Increment - Sets a time increment to use with relative times. For example, using "3 most recent" times with a "3" hour
time increment would result in the most recent time, one from 3 hours ago and one from 6 hours ago.

Times: Absolute - Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Interval - Selects the time interval to use when displaying this data.

 Help - Brings up this help page.

 Refresh - Updates the Level III radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__FILE
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Choosing Upper Air Sounding Data
Upper air RAOB data can be displayed as soundings. You can access RAOB data as soundings either from remote ADDE servers (using the Point
Observations->Soundings->Remote chooser, pictured below) or from local files (using the Point Observations->Soundings->Local chooser).
The only difference between these two choosers is specifying the source of data. You either select an ADDE server and press Connect, or you can
select a file containing RAOB data. For more information on how to use these choosers, see Getting Started - Displaying RAOB Sounding Data.

Image 1: RAOB Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Servers - Lists the public datasets available on the server.

 - Connects to and queries the server for available times.

Station Map - Displays the stations on the map. Select a station using the map. Left clicking on a station will select it. For multiple
selections, Shift+drag will select all stations within a region. Ctrl+drag will add the stations in the selected region to the set of already
selected stations. Pressing the Ctrl+A key will select all stations. Right clicking in the map will bring up a menu that allows you to select all
stations and to clear the selection. Right clicking in the Stations panel gives you the option to select every station, or to un-select the stations

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ServerPreferences__FILE
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you have selected. The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not
overlap each other (checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to
locate a station, or the following buttons:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Available Times - Selects a single or set of dates and times to use. To select more than one time use Ctrl+click or Shift+click.

00 & 12Z only - Lists only the 00Z and 12Z soundings under Available Times.

Selected Soundings - Shows soundings available for the times selected at all locations selected in the Available Times.

 Help - Brings up this help page.

 Refresh - Updates the RAOB chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected RAOB data.
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Choosing NOAA National Profiler Network Data
The Point Observations->Wind Profiler chooser allows you to access NOAA National Profiler Network data on ADDE servers. For more
information on how to use this chooser, see Getting Started - Displaying Profiler Data.

 
Image 1: Wind Profiler Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage
your ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Servers - Lists the public datasets available on the server

 - Connects to and queries the server for available times.

Profiler Type - Selects a profiler type.

Station Map - Displays the stations on the map. Select a station using the map. Left clicking on a station will select it. For multiple
selections, Shift+drag will select all stations within a region. Ctrl+drag will add the stations in the selected region to the set of already
selected stations. Pressing the Ctrl+A key will select all stations. Right clicking in the map will bring up a menu that allows you to select all
stations and to clear the selection. Right clicking in the Stations panel gives you the option to select every station, or to un-select the stations
you have selected. The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not
overlap each other (checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to
locate a station, or the following buttons:

 Zoom In - Zooms in over the current map area.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__FILE
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 Zoom Out - Zooms out over the current map area.

 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Times: Relative - Allows you to select a group of up to the last 50 times.

Times: Absolute - Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Interval - Selects an interval to use for the data.

 Help - Brings up this help page.

 Refresh - Updates the National Profiler Network Data with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected profiler data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Timeline__FILE
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Choosing Gridded Data
The Gridded Data->Remote chooser shows THREDDS catalogs of gridded data holdings on remote data servers (typically TDS or OPeNDAP).
The pulldown menu has several catalog options. For more information on using this chooser to display grid data, see Getting Started - Displaying
Gridded Data.

Image 1: Remote Grid Chooser

Properties

Catalog - Represents the catalog you are getting your data from. Enter in a catalog URL (and hit Enter or click  Refresh ) or select a
catalog URL from the pull down menu. Use the  button to select a catalog on your local disk.

History - Switches back and forth between selected catalogs by using the  and  buttons.

Data Source Type - Represents the type of file. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by
the URL itself. This can be overridden by selecting the type of data the file contains from the pull down menu. For more information, see the
list of data formats and sources that are available.

Tree Structure - Contains individual model runs for each of the parent models. Open the tree structure by clicking on the ( ) tab icon.
Clicking on a data source will enable the  button.

Show Thumbnail Images - Shows thumbnails in the THREDDS catalog if available.

 Help - Brings up this help page.

 Refresh - Updates the catalog chooser with the most recent data.

 - Loads the selected data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__FILE
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The following image displays the Gridded Data->Local chooser:

Image 2: Local Grid Chooser

Properties

Data Type - Selects the data type of the data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the
filename itself. This can be overridden by selecting the type of data the file contains from the pull down menu. For more information, see the
list of available data source types.

Look In - Selects folders to search for data files via the pulldown menu, or you can double-click on folder names.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Represents the name of the file. Select a file to populate the entry box to show the full name of the file selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

Recent Files - Lists up to the twenty most recent files. Choose the number of files you want to search for by an absolute number, or by the

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSources__FILE
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files that have been updated in a certain number of minutes.

Refresh - Updates automatically the files and their associated displays. Change the number of minutes to control the update frequency.

File Pattern - Selects the file pattern for the files you want to poll on.

Verify - Verifies the files that will be scanned.

Include Hidden Files - Includes hidden files in the polling.

 Help - Brings up this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the file(s) selected. The data file(s) will appear in the Field Selector tab.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Choosing Front Positions
The Front Positions chooser allows you to access analysis or forecast fronts on ADDE servers. For more information on using this chooser, see
Getting Started - Displaying Fronts.

 
Image 1: Front Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage
your ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Servers - Lists the public datasets available on the server.

 - Connects to and queries the server for available times.

Latest - Selects an current analysis or forecast or fronts.

 Help - Brings up this help page.

 Refresh - Updates the Front Position chooser with the most recent data.

 Cancel - Cancels the query of data. The chooser will reset back to default.

 - Loads the selected front data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Fronts__FILE
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Choosing Data on Disk
The General->Files/Directories chooser allows you to select data or a directory from your file system. For more information on using this chooser,
see Getting Started - Displaying Local Files.

 
Image 1: File Chooser

Properties

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the filename
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

Look In - Selects the folder to search for data files.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Selects the file or files selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

Recent Files - Selects the number of files you want to search for by an absolute number, or by the files that have been updated in a certain

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalFiles__FILE
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number of minutes.

Refresh - Automatically updates the files and their displays. Change the number of minutes to control the update frequency.

File Pattern - Selects the pattern for the files you want to poll on.

Verify - Verifies the files that will be scanned.

Include Hidden Files - Includes hidden files in the polling.

 Help - Brings up this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the file(s) selected. The data file(s) will appear in the Field Selector tab.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FieldSelector__FILE
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Choosing Cataloged Data
The General->Catalogs chooser shows THREDDS catalogs of data holdings on remote data servers (typically TDS or OPeNDAP) and provides
access to remote Web Map Server (WMS) image servers. McIDAS-V provides a link to an initial default catalog, idvcatalog.xml, which should
appear in the Catalog menu. If not you can directly enter the URL of the catalog: http://www.unidata.ucar.edu/georesources/idvcatalog.xml.

This URL links to a catalog of real time model data, a collection of county level shapefiles for roads and hydrography features, and a collection of
useful Web Map Servers. For more information on using this chooser to display grid data, see Getting Started - Displaying Gridded Data.

Image 1: Catalog Chooser

Properties

Catalog - Selects the catalog for the data. Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog URL from the pull
down menu. Use the  button to select a catalog on your local disk.

History - Switches back and forth between selected catalogs with the  and  buttons.

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

Tree Structure - Lists all of the data. Open the tree structure by clicking on the ( ) tab icon. Clicking on a data source will enable the 
 button.

Show Thumbnail Images - Shows thumbnails in the THREDDS catalog if available.

 Help - Brings up this help page.

 Refresh - Updates the catalog chooser with the most recent data.

 - Loads the selected data.

The following image displays the WMS chooser:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__FILE
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Image 2: WMS Chooser

The tree view on the left shows the different image layers available. You can select one image or use Ctrl+click to select multiple images. The map
on the right plots a red box around the bounding area of the particular item selected.

Data files that are imported through the WMS Servers must contain gridded data. Also, the NetCDF-Java Common Data Model must be able to
identify the coordinate system used.

Properties

Merge Layers - Selects multiple data sources to be loaded and displayed at the same time. When unchecked, multiple data sources will be
loaded, but not displayed.

Image Bounds - Provides an overview of the bounding box area of a selected image. Use the following buttons to navigate around the map:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 101 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Choosing a URL
The General->URLs chooser allows you to specify the internet location (URL) of a data source. This URL may be a web page, a bundle or any
data file that McIDAS-V can process from a URL. For more information on using this chooser, see Getting Started - Displaying Files from a URL.

 
Image 1: URL Chooser

Properties

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

URL - Selects the URL location of the data. Enter in a URL or select one from the pull down menu. Change the radio button to single to enter
in one URL. Change it to Multiple to enter in multiple URL entries. Only URL's using http will load data.

 Help - Brings up this help page.

 - Loads the URL.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UrlFiles__FILE
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Choosing Flat File Data
The General->Flat files chooser allows generic flat (2-dimensional) data to be loaded. The user must supply information about the format of the
data by either specifying it directly or by loading a properly formatted header file. Flat files can be binary, ASCII values, or standard images (JPEG,
GIF, etc.), and may contain multiple bands. Navigation may be loaded via separate navigation files or by specifying a bounding box for the data.

Image 1: Flat File Chooser

Properties

Files - Selects the file. Enter in a file location or use the  button to browse your local disk.

Type - Selects the file type. McIDAS-V will attempt to determine the type of file you are loading. If it is an unknown format, Binary, ASCII
or Image data will be displayed.

Description - Displays a description of the data if available. If no description can be found, the file name is displayed.

Properties->Dimensions -

Elements - Lists the number of elements (columns) in the data.

Lines - Lists the number of lines (rows) in the data.

Bands - Lists the number of bands (layers) in the data.

Units - Lists the unit type of the data.
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Sampling - Lists the number of points to skip in each dimension when loading the data. This is useful with very large data files.

Properties->Navigation -

Files - Specifies navigation files containing grids of Lat/Lon points by specified by clicking on the  button.

Bounds - Specifies a navigation bounding box by entering Upper Left (UL) and Lower Right (LR) Lat/Lon pairs.

Scale - Specifies the scaling factor if the Lat/Lon navigation dimensions if different than the data.

East positive - Indicates that the data is East positive.

Properties->Format -

Binary - Represents fields necessary when loading Binary data. When loading binary files the Byte format, Interleave, and Endian-
ness must accurately describe the data. A byte Offset into the data can also be given.

ASCII - Specifies the Delimiter field when loading ASCII files.

Image - Represents that a raw image has been selected.

Missing value - Specifies missing values from the data.

 Help - Brings up this help page.

 - Loads the selected data.
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Creating a McIDAS-X Bridge Session
The McIDAS-X Bridge chooser allows you to create a McIDAS-X bridge session which provides a way to load data from an active McIDAS-X
session (version 2007a or later) into McIDAS-V. For more information on using this chooser, see Getting Started - Using the McIDAS-X Bridge.

 
Image 1: McIDAS-X Bridge Chooser

Properties

Host -Specifies the host address or leave as localhost if connecting to a McIDAS-X session on your local machine.

Port - Specifies a valid port number which corresponds to the McIDAS-X bridge listener.

 Help - Brings up this help page.

 - Loads the McIDAS-X bridge session.
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Field Selector
The Field Selector tab of the Data Explorer is used to list the loaded data sources, view their available fields, select a display type, subset (time and
space) the field and create displays.

 
Image 1: Field Selector Tab

The Field Selector consists of four main panels:

Data Sources
Fields
Displays
Data Subset
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Data Sources
The Data Sources panel lists the data sources currently loaded into McIDAS-V and provides access to both the user-made and native formulas. The
data sources listed are chosen as described in the Data Sources page. The selected item is the data source that will be displayed after you have
completed your work in this tab:

Image 1: Data Sources Panel

To set the defaults for a data source bring up the Properties dialog by right-clicking (or double-clicking) on the data source name in the Data
Sources panel of the Field Selector tab and select Properties:

Image 2: Data Sources Panel Properties

Properties

Remove This Data Source - Removes the data source from the McIDAS-V Session.

Reload Data - Reloads the data. This allows your data to be updated to a more recent time without having to go back to the Data Sources tab
to reload it.

Change Data - Opens a 'Change data for:' window. This window looks almost exactly like the Data Explorer and works the same. You can
select a new data source to load in, and this will replace the existing one.

Write Local Grid - Saves the data as a grid as a netCDF file (*.nc). This opens a window where you can select what Fields in the selected
data source you want to write to a grid.

Write Field Mask Plugin - Saves the data source as a Jar file (*.jar). This opens a 'Data Source Field Mask File' window, where you can
select what parameters to show, hide, or write to a plugin.

Save As Favorite - Saves the selected data source as off as a *.xidv bundle in your /User/McIDAS-V/datasources directory. You can load
this file in as a bundle, and the data source will be added.

Properties - This allows you to open the data source's Properties window.

The Properties Dialog is different for different types of data sources. Below is the dialog window for a gridded data source:
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Image 3: Properties Tab of the Data Sources Properties Window

Properties

Name - Represents the name of the field you are polling.

Automatically Reload - Reloads the data from the data source automatically when the Active checkbox is checked.

Check Every - Sets how often McIDAS-V will check to see if the data source has been updated.

Reload Displays - Reloads the display at the time you begin polling.

Time Binning
For point data you can define Time Binning settings (not shown) by selecting a Bin Size (e.g., 5 minutes, 1 hour) and a Round To value (e.g., On
the hour, 15 minutes after the hour). This will map all the observation times into the nearest bin. The smallest time is rounded with the Round To
value (e.g., if Round To was "10 after" and the smallest time was 10:23 then this time would be rounded to 10:20). This is the base time. Each
actual observation time is mapped into a set of bins of Bin Size starting at the base time.

Times
The Times tab allows you to select the times to use. Click off the Use Default checkbox and select individual times. You can right mouse click in
the list to show a menu that allows you to select different subsets (e.g., every 3rd time).

Image 4: Times Tab of the Data Sources Properties Window

Spatial Subsetting
For grids and other data source types, the data can be subsetted and decimated with the Spatial Subset tab. The X Stride, Y Stride and Level
Stride lists allow you to decimate a grid, selecting every Nth point. The Bounding Box allows you to define a spatial area to load. The default
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spatial domain of the data is shown by the blue outline box. To select an area, left click and drag on the map. Alternatively, you can enter in
Lat/Lon values in the fields to the left of the map and press Enter. Once a subset is selected it can be resized (grab on the little black selection
points) moved (grab somewhere near the box) and delete (press the Delete key).

Subsetting can be useful when you are displaying an image that has a high resolution or covers a large spatial area as a Contour Plan View or Color-
Filled Contour Plan View display. Instead of having McIDAS-V take the time to compute values between every point, you can set a stride where
only every Nth point will be taken into consideration. If you need a very detailed image, it is recommended that you do not change the stride away
from the default (none). However, if you are trying to get a general picture, the stride feature can be a time-saver.

Image 5: Spatial Subset Tab of the Data Sources Properties Window

A version of this spatial subsetting window is used in the Field Selector tab of the Data Explorer. Here, you explicitly enable these settings. The
decimation and spatial subset are shown in different tabs:

Image 6: Subset Panels in the Field Selector

Details
The Details tab shows further information about the data source, e.g.: any documentation associated with the data, what files or URLs are used, etc.

Metadata
For grid data sources the Metadata tab shows the NetCDF metadata information.

Objective Analysis
The Objective Analysis tab is available if you are working with Point Data.
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Image 7: Objective Analysis Tab of the Data Sources Properties Window

Properties

Make Grid Fields - Allows point data to be plotted in as a grid display. If you do not have this option checked, then the Gridded Fields and
Gridded Fields (with first guess) will not be available in the Fields panel of the Field Selector. Also, if this option is not selected, any other
items in this display will have no effect on the final display. This option is checked on by default.

Spacing - Determines the grid spacing method.

Automatic - Calculates grid spacing from observation density.

Degrees - Uses a specific lat/lon spacing fro the grid spacing.

# Points - Sets the number of grid points in the x and y direction.

Grid Size - Sets the X and Y spacing in spacing units. This is an option if Degrees or # Points is selected for Spacing.

Passes - Sets the number of passes for the Barnes analysis to do. Four passes are recommended for analyzing fields where derivative
estimates are important (Ref: Barnes 1994b), three passes recommended for all other fields (with gain set to 1.0) (Ref: Barnes 1994c "Two
pass Barnes Objective Analysis schemes now in use probably should be replaced by appropriately tuned 3pass or 4pass schemes"), and two
passes are only recommended for "quick look" type analyses.

Search Radius - Sets the search radius (in grid units) for the weighting of points in determining the value at a specific grid point. This should
be in the range 0.2 to 1.0. Data are fitted more closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger
values smooth more.

Gain - Represents the factor by which scaleLength is reduced for the second pass. This should be in the range 0.2 to 1.0. Data are fitted more
closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more. Suggested default: 1.0. Set
the gain for each pass after the first.

Formulas
You can create your own formulas using the McIDAS-V Formulas facility. The Formulas data source in the Field Selector is a special data source
and lists all of the available end user formulas. You can right-click on the data source to create new formulas and import and export formulas. The
formulas are listed in the Fields tree. Right-clicking on one of the formulas listed in the Fields tree allows you to edit, copy or evaluate the formula.

You can select a formula just like any other Field and create a display from it. However, the formula, when evaluated to create the display, usually
needs one or more other data fields to act on. In this case a special Field Selector window appears that allows the user to select the fields for the
formula. (Note: The Fields you select here can also be Formula Fields resulting in further Field selection).
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Fields
The Fields panel displays the list of data choices for the selected data source:

Image 1: Fields Panel in the Field Selector

Selecting a data source in the Data Sources panel will list the available fields in the Fields panel. This list is usually hierarchical showing different
categories of fields (e.g., 2D grids, 3D grids, image sequences, etc.). Note that you can search through these fields by clicking the  button above
the Fields panel. This allows you to type in your desired field without having to go through the entire list. To see the fields under a particular
category, click on the toggle icon ( ).

Selecting a field will show the list of display types available in the Displays panel and subsetting information (e.g., times, spatial subset). The fields
listed in the initial tree (in the above case, 3D and 2D) are all native to the data source. The fields listed under the Derived tree are produced from
formulas that are applied to the native fields.

Derived Parameters
McIDAS-V provides derived parameters; parameters not provided by the original source data, but made from the source data with computations by
McIDAS-V. This provides commonly used fields, such as dewpoint. While dewpoint is not included in the native fields of the data, it can be
derived from humidity and temperature, where are native fields.

Since few data sets use the same names for parameters, McIDAS-V keeps of a list of "aliases" or particular parameter names that match with
"canonical" names which are generally understood by all McIDAS-V users and which McIDAS-V uses for computations. You can add your special
parameter names to the list of aliases. Read the Parameter Alias Editor section for information on using that facility.

All needed source parameters for one derived parameter must come from one single data source (e.g. from one single netCDF file). McIDAS-V
attempts to find derived parameters that can be made from data in each data source in the Data Sources panel, but not from all possible
combination of data sources. If you had separate files of u and v wind components, for example, the parameter names or aliases will not create
derived wind vectors.
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Displays
The Displays panel lists the display types applicable to the selected field. The display type you select will be used to display your data in the Main
Display window or the Layer Controls tab of the Data Explorer. Note that the displays listed in this panel will be different depending on the type
of data you are loading in.

Image 1: Displays Panel in the Field Selector

Creating Displays
The Displays panel shows a hierarchical list of the available displays for a particular field. Click on the type of display you want from the choices
listed in the Displays panel. There are a variety of different display types that are unique to particular types of data. For more information, see the
Examples of Display Types pages.

You can select two or more displays (different display types) at one time. For an additional display, hold down the Control key and click on the
second display type desired.
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Data Subset
The Data Subset panel contains tabs for subsetting Times, Levels, Region, and Stride. These tabs may be different depending on what data you
are loading.

Optionally subset the times by clicking off the Use Default checkbox and selecting the times. You can select individual times to display with
Ctrl+click or Shift+click. Alternatively, you can subset the times by right clicking in the panel and selecting 'Select every N'th time'. This
automatically subsets the times by only selecting every N'th time. The Use Default checkbox will utilize every available time in the display:

Image 1: Times Tab of the Subset Panel in the Field Selector

For 3D grids, you can optionally subset the levels. This represents the level in the atmosphere that will be used to plot the data in the Main Display
window:

Image 2: Level of the Subset Panel in the Field Selector

For images, optionally subset the spatial area to be displayed. Use the Region tab to left-click and drag to select a geographical region to display. In
the Main Display window, the display will be centered around your box and no data will be plotted outside of it. Note that before subsetting a
region, you may have to uncheck the Use Default checkbox:

Image 3: Region of the Subset Panel in the Field Selector

Use the Advanced tab to further refine your data selection and refer back to the Region tab to view the image you've selected:
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Image 4: Advanced Tab of the Subset Panel in the Field Selector

Properties
The image properties in the Advanced tab allow you to override the default properties McIDAS-V uses to specify aspects of the image data. The
widgets show the defaults McIDAS-V will use. By changing any of the widgets you can override the default value.

Coordinate Type - Changes the coordinate type used to specify the data location.

Latitude/Longitude Coordinates - Specifies Latitude and Longitude values of the image to be used by the Location field. Note that
McIDAS-V cannot read latitude and longitude values for loops of polar data where the navigation changes. If you are displaying a loop
of polar data, you should use Image Coordinates to ensure the images will be displayed.

Image Coordinates - Specifies the line and element values of the image itself to be used by the Location field. The upper left point is
specified by (1,1) and each pixel in the image has its own, unique pair.

Area Coordinates - Specifies the area coordinate of the image to be used by the Location field. This is based off the size of the area
and referenced in terms of line/element. The upper left point is specified by (0,0) and each pixel has its own, unique pair.

Location - Specifies the placement point of the image at either the center or the upper left.

Lat/Lon - Specifies the location of the image with respect to latitude and longitude. Note that if you select Image or Area Coordinates in
the Coordinate Type field, these fields will be Line/Element.

Line/Element - Specifies the location of the image with respect to line and element.

 Center Display - Centers the image over the center, upper left, upper right, lower left, or lower right latitude and longitude coordinates of
the of the current main display.

Image Size - Changes the size of the image.

 Lock Image Size - Changes size automatically when changing magnification when unlocked.

 Full Resolution - Sets the image size to the full resolution size of the image.

Raw Size - Lists the full size of the image on the server.

Magnification - Changes the magnification of the image, or manually type the Line and Ele magnification in the Mag= fields.

Res - Lists the approximate resolution of the image, if displayed with the current Image Properties.

Approx. Area - Lists the center, upper left, upper right, lower left, and lower right coordinates of the selected image, if displayed with the
current Image Properties.

Use the Stride tab to change the number of points used to create the image. You can utilize fewer points along the X and Y-axes to display the data
faster, but with less precision. It is recommended to leave the X and Y values as their default (All points) unless you are trying to get a general
picture and nothing too specific.

Use the Settings tab to utilize any display settings you may have set.
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Subsetting
The Subsetting component of the Field Selector allows you to subset the data in both time and space (if possible). If there are times in the data
source you are viewing they will be shown in this area. Likewise, if it is possible to do spatial subsetting or decimation a Spatial Subset tab will be
shown.

Time and spatial subsetting defaults can be applied to the data source itself through the Data Source Properties dialog or the defaults can be
overwritten through the Field Selector tab.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSource__times


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 115 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Layer Controls
The Layer Controls tab of the Data Explorer is used to modify an existing display. The options to choose from in this tab will vary depending on
your data source and field selected.

Image 1: Layer Controls Tab

This section describes the specifics of the Layer Controls tab for different data sources and fields, including the following:

Gridded Data Displays
Satellite and Radar Displays
Profiler Controls
Probes
Mapping Controls
Observation and Location Controls
Miscellaneous Controls
Properties Dialog
Color Scale
Charts
Ensemble Grid Controls

There are some general features of the Layer Controls tab that are consistent with every display, which are described below.

Options
 - Provides a dropdown menu with options to move the Main Display window to the front displaying the selected tab, and allows you to access

the View and Projections menus of the Main Display window.

These options are found at the bottom left corner of the Layer Controls tab of the Data Explorer.

Image 2: Options in the Layer Controls Tab

Properties

 Undock Control Window - Undocks the selected controls from the Data Explorer. You can redock the Control Window by selecting
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View->Dock in Data Explorer.

 Show Display Control Properties - Opens a Properties window, where you can control basic settings, add a color scale to the Main
Display window, change the times being displayed, or change the spatial subset of the data.

 Remove Display Control - Removes the selected display from the Data Explorer and from the Main Display window.

 Drag and Drop to a Window Component - Allows you to move a layer from one panel/tab to another. This is done by selecting an item
you want to move from one panel/tab to another by clicking on the item. Once you have the item selected, click on the Drag and Drop to a
Window Component icon, and while holding down your left mouse button, drag the mouse to your desired panel/tab and release your mouse
click when over your desired panel/tab name, represented by the  symbol. This will bring your selected field to the desired panel/tab in
both the Layer Controls tab of the Data Explorer and in the Main Display window.

Menus
All parameters share a common set of File, Edit, View, and Help menu items, shown in the menu bar of the Layer Controls tab. Different controls
may also have custom items in these menus as well.

The File menu has these common choices:

Remove Display - Removes the display.

Save - Saves the state of the display.

Save Data in Cache - Saves the current data of the display in a Cache Data Source as a new field. You will be prompted for the name
of the field. You can use this in a variety of ways:

After calculating a complex formula, selecting operands for the formula, etc., to create the data in a display you can save the
formula and the data that was calculated. Then you can create new displays from that formula without having to reselect the
operands and recalculate the final data.

The Web Map Server (WMS) display allows for the capturing of the image and then making use of it in formulas and in other
displays. For example, the image can be draped over topography.

Export Displayed Data to NetCDF - Saves the data in the NetCDF (*.nc) format.

Save As Parameter Defaults - Saves the current display state for the parameter as the default for that parameter in the future. See the
Parameter Defaults Editor page for more information.

Save Display as Favorite - Saves the current display state (without the data) as a Favorite Display.

Save Display as Bundle - Saves the current application state as a bundle.

Reload Data - Reloads the data for this display.

The Edit menu has these common choices:

Color Table - Edits the color table, changes the range, chooses a new color table, etc. This works for displays that have a color table.

Change Parameter - Changes the parameter that is being displayed.

Change Display Unit - Changes the unit that is used in the display, e.g., changing temperature plots in Kelvin to Celsius.

Change Contours - Changes the different aspects of the contours in the image by opening the Contour Properties Editor.

Sharing - Turns on/off sharing and sets the "share group". When sharing is turned on, control operations will be shared between two or more
displays of the same type that are in the same share group. The share group can be an arbitrary name. For example, the location of a vertical
cross section, the color table, location of a probe point, etc., can all be shared.

Display Settings - Opens the Display Settings dialog, allowing for the selection of display properties to be applied to other display controls
and/or to be saved as preferences to be used in the creation of new display controls.

Properties - Opens the Properties dialog, allowing for the changing of customization of the display.

The View menu has these common choices:

Visible - Toggles visibility. When selected, the parameter will be displayed in the Main Display window.

Lock Visibility - Toggles the visibility lock (see cycling visibilities).
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Bring To Front - Selects which display is on top if one display is showing at the same level in 3D as another (e.g., satellite and radar images
in the same display).

Show View Window - Brings the Main Display window to the front.

Use Times in Animation - Loops the data when the layers have a time associated with them by adding the Time Animation Widget to the
Main Display window.

Display List - Displays the parameter information at the bottom of the Main Display window and allows for setting the color of the text.

Center on Display - Re-centers the display in the Main Display window without changing the zoom level if the display has been translated
from its original position.

Undock from Data Explorer - Unattaches the Layer Controls tab from the Data Explorer by making it its own window. This can be
brought back to the Data Explorer by selecting View->Dock.

Export to Component - Transfers the Layer Controls tab of the Data Explorer to the Main Display window as a separate tab. This can be
brought back to the Data Explorer by selecting View->Undock, and once it is undocked, View->Dock.

The Help menu has these common choices:

Details - Opens a window that shows detailed information about the display and any associated data.

User's Guide - Opens the User's Guide entry relevant for the particular display.
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Gridded Data Displays
Plan View Controls
Flow Display Controls
Value Plot Controls
Vertical Cross Section Controls
3D Surface Controls
Volume Rendering Controls
Point Volume Controls
Sounding Controls
Hovmoller Controls
Grid Trajectory Controls
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Plan View Controls
Overview
Plan views can be made in four types of displays: Contour Plan View, Color-Filled Contour Plan View, Color-Shaded Plan View, and Value Plots.
Contour Plan View and Color-Filled Contour Plan View have the same properties. For more information on the Value Plots display, see Value Plot
Controls.

Image 1: Contour Plan View Controls

Image 2: Color-Shaded Plan View Controls

Properties

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Contour Plan View and Color-Filled Contour Plan View display types.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc. This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display types.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit Enter to set your own value. Additionally, you can click on
the arrows to the right of the Levels box to switch levels, or click on the Cycle check box to animate vertically through all available levels.
This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display types.

Visible Range - Determines what parts of the data is actually shown. Click the  button to set the range of data shown. Once the
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checkbox is checked, the Visible Range will be applied to the data in the Main Display window. This is an option in the Color-Shaded Plan
View.

Texture Quality - Sets the quality of the displayed texture. A higher quality will take longer to render and user more memory. This is an
option for the Color-Shaded Plan View display type.

Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Plan View display type.

Mode - Sets the way the texture is displayed. You can select Solid, Mesh, or Points. This is useful for looking at the structure of the
underlying data. This is an option for the Color-Shaded Plan View display type.

Point Size - Sets the size of the points when the Points Mode is selected. This is an option for the Color-Shaded Plan View display type.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Levels - Represents the level where the data is displayed. This is an option for the Contour Plan View, Color-Filled Contour Plan View, and
the Color-Shaded Plan View display types.

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option
for the Contour Plan View and the Color-Filled Contour Plan View display types.

The View menu has this unique option:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified. This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan
View display types.
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Flow Display Controls
Overview
The Flow Plan View Controls are used to control plan (horizontal) displays (flow vectors, wind barbs, streamlines) of vector based data (e.g., wind
components). They are similar to the Plan View controls. For more information on what wind speeds correspond to each of the wind barbs in
McIDAS-V displays, please see the table in the FAQ.

The five types of Flow Displays are Vector Plan View, Streamline Plan View, Wind Barb Plan View, Vector Cross Section, and Wind Barb Cross
Section. When you are working with 3D data, you can select Vectors Over Topography, Wind Barbs Over Topography, and Streamlines Over
Topography. The Layer Controls listed below apply for all display types:

Image 1: Properties Dialog for the Flow Display Controls

Properties

Show - Switches between displaying Vectors or Wind Barbs and Streamlines.

Vector Size - Displays vectors in the Main Display window. Size changes the length of the vectors. The Size box is an editable box
where you can enter a new size and press Enter, or use the slider ( ) to change the value. When the Autosize checkbox is checked, the
size of the vectors will decrease proportionally as you zoom in or out of the image. When unchecked, the vectors will remain the same
size regardless of zoom level.

Streamline Density - Displays streamlines in the Main Display window. Density changes the density of the streamlines on the display.

Skip - Defines the number of grid points that are skipped to avoid cluttering. A skip interval of 0 mean show all vectors, 1 means skip every
other vector, 2 means show every third vector, etc. This is also an editable box, enter a new skip interval and press return.

Range - Lists the current range of data for sizing the vectors. Click on the Edit ( ) icon to change the range. This is an option with the
Vector Plan View and Streamline Plan View displays.

Color - Changes the color of the streamlines and the vectors in the display.

Line Width - Sets the line width in the display. Click on the  or put in a value and hit enter to change the value.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units. This is not an option for the * Over Topography display types.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit return to set your own value. Additionally, you can click on
the arrows to the right of the Levels box to switch levels, or click on the Cycle checkbox to animate vertically through all available levels.

Selector Position - Determines the vertical positioning of the Selector line with respect to other variables displayed in the Main Display
window. This is an option with the Vector Cross Section and Wind Barb Cross Section displays.
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Vertical Scale - Changes the vertical axis of the chart in the Display tab of the Layer Controls tab of the Data Explorer.

Autoscale - Scales the Y-Axis automatically to the data range along the selector line in the display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Levels - Represents the level where the data is displayed. This is an option for the Vector Plan View, Streamline Plan View, and Wind Barb
Plan View display types.

Color - Changes the color of the streamlines, vectors, or wind barbs in the display.

The View menu has this unique option:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified. This is an option for the Vector Plan View, Streamline Plan View, and Wind Barb Plan View display types.
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Value Plot Controls
Overview
The Value Plot controls are used to adjust the display of individual grid point values.

Image 1: 2D Value Plot Controls

Image 2: 3D Value Plot Controls

Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown.

Layout Model - Sets the layout of the displayed data. Click on the downward facing blue arrows  to change the layout model. Selecting
Edit will open the Station Model Editor which will allow you to create your own custom station model.

Scale - Sets the size of the displayed elements. Enter a value into the field and press Enter or click Apply to scale up or down.

Vertical Position - Sets the vertical position of the locations with respect to other variables being displayed in the Main Display window.
This can be changed by using the slider, or entering a value into the field and pressing Enter.

Skip - Sets the size of the station model being displayed in the Main Display window. This value can be changed by using the slider.

Levels - Lists the native grid levels. Select a level value to reset the display to that level. The level in use is shown in the data's native altitude
units. The Levels box is editable. Click in the box, enter a value and hit Enter to set your own value. Additionally, you can click on the
arrows to the right of the Levels box to switch levels, or click on the Cycle check box to animate vertically through all available levels. The
current level used to display the data in the Main Display window is listed next to Current level.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Levels - Represents the level where the data is displayed when you are utilizing a 3D field.

Selector Color - Changes the color of the selector point at the bottom left corner of the display when utilizing a 3D field.

The View menu has this unique option:
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Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.
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Vertical Cross Section Controls
Overview
The Vertical Cross Section Controls are used to adjust vertical cross section displays. Vertical cross sections can be made in three types of displays:
Contour, Color-Filled Contour, and Color-Shaded. The control window has two tabs: Display and Settings. You can change the endpoints of the
cross section by clicking and dragging the endpoints in the Main Display window.

The Display tab includes a duplicate of the display in the Main Display window:

Image 1: Display Tab of the Layer Controls Tab

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the cross section covers in the Main Display window. This can be changed by left-
clicking and dragging the end points of the cross section in the Main Display.

Location - Displays the location of the end points of the cross section. The endpoints of the cross section can be changed by entering in new
values and hitting Enter.

The Settings tab shows the settings for this display control:
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Image 2: Settings Tab of the Layer Controls Tab

Properties

Contour - Sets contour parameters. Click  next to Contour to open the Contour Properties Editor. This control can be accessed
with the Contour Cross Section and Color-Filled Contour Cross Section views.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of data displayed when using the Color-Shaded Cross Section display type.

Selector Position - Changes the position of the selector in the main display. You can change this by using the slider or by typing a value into
the field and hitting Enter.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Vertical Scale - Changes the vertical axis range of the cross section.

Autoscale - Scales the Y-Axis automatically to the data range along the selector line in the display.

Visible Range - Determines what parts of the data is actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the cross section. This is an option for the Color-Shaded Cross Section
display type.

Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Cross Section display type.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option
for the Contour Cross Section and Color-Filled Contour Cross Section display types.

The View menu has these unique options:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

Cross Section - Enables you to capture an image or movie of your display, or open a Properties window which allows you to modify many
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aesthetic aspects of the Main Display window.



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 128 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

3D Surface Controls
Overview
Isosurfaces can be made in two types of displays, regular isosurfaces, and isosurfaces colored by another parameter. An isosurface is a 3D surface
mapping the location of a single parameter value through a 3D field. Isosurfaces are a 3D analog of a single contour line in a 2D plot; the
intersection of an isosurface and any plane is a contour line of the same value in that plane.

Coloring an isosurface by another parameter can serve many purposes. One example use of this is creating a display for possible icing conditions in
the atmosphere that could be useful for pilots. To do this, you would select Temperature as your field, the "Isosurface colored by another
parameter" display type, and Relative Humidity in the Field Selector window that appears when you click Create Display. After the display is
created, you can set the isosurface value for Temperature to be 0 degrees Celsius in the Layer Controls tab of the Data Explorer. Now, in the Main
Display window, you have a surface of 0 degrees Celsius colored by Relative Humidity. Wherever you see high RH values means that there is a lot
of moisture in the atmosphere, and at the freezing temperatures, there could be icing conditions.

Image 1: Isosurface Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Isosurface Value - Sets the numerical value of your field that the display will draw the isosurface at. You can do this by clicking the 
button or entering a value in the field and hitting Enter.

Properties with *As Topography Displays

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Color-Filled Contour Plan View display type.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the Visible Range checkbox is checked, if not checked, the default range will be used. To change
these values, check the checkbox, and click  to bring up a Change Visible Range window, where you can enter your upper and
lower bound values.

Texture Quality - Sets the quality of the displayed texture of Image Control. A higher quality will take longer to render and more memory.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit Enter to set your own value. Additionally, you can click on
the arrows to the right of the Levels box to switch levels, or click on the Cycle checkbox to animate vertically through all available levels.
This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display types.

Vertical Range - Sets the vertical extent of the data with respect to the wireframe box of the Main Display window. Click the 
button to set the vertical range of the data. This works similarly to the Vertical Range in the Main Display window, which sets the height of
the wireframe box for other types of data. Changing these values can allow certain features to stand out more by showing higher peaks and
valleys based off of their data values.

Display -

Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a
single data grid cell with one color.
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Mode - Sets the way the texture of the data is displayed. You can select Solid, Mesh, or Points. This is useful for looking at the
structure of the underlying data.

Point Size - Sets the size of the points when the Mode Points is chosen.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Levels - Represents the level where the data is displayed. This is an option for the *As Topography display types.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified. This is an option for the *As Topography display types.
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Volume Rendering Controls
Overview
3D grids can be rendered as a volume display.

Image 1: Volume Rendering Controls Properties Dialog

You can use the transparency features of the color table to see through the display. This is done by right-clicking on the color bar, going down to
Transparency, and selecting a percentage.

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of data displayed. Clicking the  button will allow you to change the range from the default values
for the parameter. Clicking the checkbox next to Visible Range applies any modified range to the data being displayed in the Main Display
window.

Use 3D Texture - Uses 3D texture to display the image in the Main Display window. This incorporates a sense of transparency to the
display, making it easier to visualize features.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.
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Point Volume Controls
Overview
The Point Volume display shows the grid points in a volume of data as individual points in the display. The controls are used to change color tables,
the number of points to skip, and the point size.

Image 1: Point Volume Controls Properties Dialog

You can use the transparency features of the color table to see through the display. This is done by right-clicking on the color bar, going down to
Transparency, and selecting a percentage.

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of data displayed. Clicking the  button will allow you to change the range from the default values
for the parameter. Clicking the checkbox next to Visible Range applies any modified range to the data being displayed in the Main Display
window.

Skip - Determines how many points to skip in the display. This helps to mitigate cluttering.

Point Size - Sets the size of the data points in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.
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Sounding Controls
Overview
For 3D derived gridded data, one of the Fields you can select is Sounding Data (Temperature & dewpoint only or with true winds). In the Displays
panel of the Layer Controls tab, there is a category for soundings. The three sounding display options are Grid Skew-T, Grid Stuve Display, and
Grid Emagram Display. This display uses the model data to produce soundings, and their controls are similar to those for Point Data sounding
display controls. You can modify the location of the sounding in the Main Display window by dragging the selector point to a different position on
the map.

The example below is loaded from the 'Sounding Data (with true winds)' field. If you select 'Sounding Data (Temperature & dewpoint only)', then
wind data will not be included in the display. Therefore, there will be no barbs along the side of the sounding in the Sounding Chart tab, the
Hodograph tab will not be available, and there will be no wind information listed in the Table tab. For more information on what wind speeds
correspond to each of the wind barbs in McIDAS-V displays, please see the table in the FAQ.

The Sounding Chart tab includes an aerological diagram (e.g., skew-T, Stuve, Emagram):

Image 1: Sounding Display of Model Data

Properties

Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if you select more than one time to display in the Field Selector.

Dry Adiabats - Displays the dry adiabats on the Skew-T diagram.

Saturation Adiabats - Displays the saturation adiabats on the Skew-T diagram.

Mixing Ratio - Displays the mixing ratio lines on the Skew-T diagram.
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Parcel Path - Displays the path of a parcel of air lifted pseudo-adiabatically from the initial point to the top of the Skew-T diagram.

Virtual Temperature - Displays the virtual temperatures of the environmental profile and pseudo-adiabatically lifted air-parcel.

Grid Points - Plots grid points in the Main Display window. The grid point spacing will be related to the model resolution that you selected
in the Data Sources tab of the Data Explorer.

Parcel mode - Specifies how the initial conditions of the pseudo-adiabatically lifted air-parcel are determined from the environmental
sounding according to the mode indicated. This will affect how the LNB, LFC, LCL, CAPE, and CIN are calculated. The choices are:

Bottom of Sounding - Determines the initial conditions of the parcel from the temperature and dewpoint at the level of highest
pressure. The path will update whenever the profiles change.

Below Cursor - Determines the initial conditions of the parcel from the temperature and dewpoint profiles by computing the pressure-
weighted mean potential temperature and water vapor mixing-ratio of the atmosphere that lies below the cursor when the middle mouse
button is pressed. Thus, pressing the middle button at 950 hPa for a sounding that starts at 1000 hPa will effectively mix the lower 50
hPa of the atmosphere and lift the resulting parcel starting at 975 hPa. The path will update whenever the profiles change and as the
cursor is dragged.

At Cursor Pressure - Determines the initial pressure, in-situ temperature, and moisture content of the parcel from the temperature and
dewpoint profiles at the pressure of the cursor when the middle mouse button is pressed. The initial moisture content is determined
from the dewpoint profile at the initial pressure. The path will update whenever the profiles change and as the cursor is dragged.

At Cursor (Press, Temp) - The computed path of a lifted parcel is automatically updated when appropriate. The initial pressure and
in-situ temperature of the parcel equal the pressure and temperature values under the cursor when the middle mouse button is pressed.
The path will update whenever the profiles change and as the cursor is dragged.

Wind spacing - Allows the user to control which wind levels are shown in the display.

Consecutive Profiles - Allows you to plot both the current sounding, as well as the sounding of the next time step in one image. The
temperature and dewpoint temperature profiles of the current timestep will be dashed, and the profiles of the next timestep will be displayed
as solid lines. The current time's winds will be displayed directly to the right of the sounding, and the next timestep's winds will be shown to
the right of that. This makes it easy to see how a profile will change through time. This will reduce the number of time steps in your loop by
1. This option will not make any changes to the display if you only have one timestep displayed.

A label above the sounding's chart shows the model, date, and time of the data. You can modify the individual T and Td profiles on the skew T by
clicking and dragging the profile lines. You will see changes in the parameter table to the left of the Skew-T that reflect modifications made to the
sounding.

The Hodograph tab shows a 3D hodograph display. Note that this tab is only included with the display if you select a Field that includes wind data:
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Image 2: Hodograph Display of Model Data

Properties

Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if you select more than one time to display in the Field Selector.

The hodograph is enabled if the plotted data includes wind fields. It can be rotated into 3D by right-clicking and dragging. You can zoom in/out by
holding down Shift and right-clicking and dragging up/down or by using the scroll wheel on your mouse. To reset the hodograph, use Ctrl+R.

The Table tab shows a table of all available values in the sounding. You can invert the order of the table by double clicking on the name of a
column (ex. AirPressure).:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Image 3: Table Display of Model Data

Properties

Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if you select more than one time to display in the Field Selector.

Show U and V - Breaks the Speed and Direction categories up into the individual U (east-west) and V (north-south) components of the wind.
This option will only be available if you choose a sounding display with true winds.

Aerological Parameters
The table to the left of the sounding diagram contains aerological parameters determined from the atmospheric sounding displayed in the diagram.
The following abbreviations are used:

LCL: Lifting Condensation Level - The level at which a pseudo-adiabatically lifted air-parcel becomes saturated with water vapor.

LFC: Level of Free Convection - The level at which the virtual temperature of a pseudo-adiabatically lifted air-parcel changes from being
less than the environment's virtual temperature to being greater than the environment's virtual temperature.

LNB: Level of Neutral Buoyancy - The level above the LFC at which the virtual temperature of a pseudo-adiabatically lifted air-parcel
equals the environment's virtual temperature.

CAPE: Convective Available Potential Energy - The area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel
and the virtual temperature trace of the environment from the LFC to the LNB in which the parcel's virtual temperature is greater than the
environment's (positive CAPE connotes convective development).

CIN: Convective Inhibition - The negative of the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and
the virtual temperature trace of the environment from the parcel's initial conditions to the LFC in which the parcel's virtual temperature is less
than the environment's (negative CIN connotes initial positive work to lift the parcel).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The File menu has this unique option:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Export Sounding Table to File... - Exports the data in the Table tab. This can be saved in Comma-Separated Values (CSV) format (*.csv)
or in Excel format.

The Edit menu has these unique options:

Reset Probe Position - Moves the probe in the Main Display window back to its initial location before it was moved.

Reset Sounding - Reverts the sounding back to its initial configuration after any modifications have been made to it.

Selector Color - Changes the color of the shape representing the location of the sounding in the Main Display window.

The View menu has these unique options:

Sounding Chart - Allows you to capture an image or movie of the sounding and change many aesthetic preferences.

Hodograph - Allows you to capture an image or movie of the hodograph and change aesthetic preferences related to the Main Display
window.
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Hovmoller Controls
Overview
The Hovmoller display plots grid and gridded point data in a diagram with the Latitude/Longitude component on the X-axis, and the time
component on the Y-axis. This display option is found in the Displays menu of the Field Selector tab of the Data Explorer. You can display the
data as Time with respect to either Latitude or Longitude, and either as a Color Shaded or Contour display type.

 
Image 1: Hovmoller Display

Properties

Contour - Opens the Contour Properties Editor, which allows you to change the contour interval, style, and labeling of the contour lines. The
current contour interval for the display is listed next to Interval. This is an option for Contour displays.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Time - Sets the format used to label time along the Y-axis. See the Formats and Data Preferences page for information on how to format the
label. After you enter your desired values into this field, press Enter for it to be applied to the display.

Latest Time at Bottom - Displays the oldest time will be shown at the top of display, and the most recent time at the bottom when selected.
This is the default for the Hovmoller display. If you uncheck this box, the Y-axis will be inverted, showing the most recent time at the top,
and the oldest time at the bottom.

By default, if you select a Longitude display, the entire spatial domain will be utilized, and the longitude range will go from the western extent to
the eastern extent of your domain. The latitude will be averaged from the northern to southern boundaries of your domain. You can restrict the
latitude and longitude domain by selecting a region in the Region tab of the Field Selector tab of the Data Explorer. The Latitude displays work the
same way, by averaging the longitude across the entire domain unless you subset a region.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FormatPreferences__dateformat


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 138 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options unique to this display.

The Edit menu has this unique option:

Contour Line Color - Allows you to change the contour line color in the display. This option is an option for the Contour display types.

The View menu has this unique option:

Hovmoller View - Allows you to capture an image of the data and change many aesthetic aspects of the display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 139 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Grid Trajectory Controls
Overview
The Trajectory Colored By Parameter display type is capable of working with gridded data containing u and v-wind components, as well as a scalar
quantity to color them by. You can create both 2D and 3D trajectories dependent on what is contained in your data. To use this display type, you
can use the grid formulas Grid 2D Trajectory or Grid 3D Trajectory. These formulas will request for your scalar quantity, as well as individual u
and v-wind fields. An alternative to the formulas is utilizing the new derived 2D and 3D fields of your data, Grid 2D Trajectory and Grid 3D
Trajectory. When using these fields, all you need to specify is the scalar quantity, and McIDAS-V will pull out the relevant u and v-wind
components (as well as the vertical component when creating 3D Trajectories).

After clicking Create Display and choosing your field(s), you will arrive at the Layer Controls tab of the Data Explorer, where you will define the
properties of your trajectories.

Image 1: Grid Trajectories Layer Controls

Properties

Levels - Sets the vertical level where your trajectories will originate.

Trajectory Initial Area - Allows you to determine where your trajectories will originate from. While the trajectories originate at these
locations, they are not bounded by the Trajectory Initial Area. They can extend beyond these boundaries up to the geographical extent of
your data. You can draw multiple different Trajectory Initial Areas of the same type, but you cannot mix different types:

Points - Plots individual points on the Main Display where the trajectories will originate from.

ClosePolygon - Allows you to click and drag in the Main Display window to draw a shape around any desired area. The trajectories
will originate from everywhere inside of the shape. By default, they will be spaced apart at the resolution of the grid.

Rectangle - Allows you to click and drag in the Main Display window to draw a rectangle around any desired area. The trajectories
will originate from everywhere inside of the shape. By default, they will be spaced apart at the resolution of the grid.

Initial Area Skip Factor - Sets the skip factor of the trajectories. This is an option when using ClosePolygon and Rectangle Trajectory
Initial Areas. By default, this value is 1.0, meaning that the trajectories will be spaced by the model resolution. You can change this number
by typing a value into the field and pressing Enter, or by using the slider. Raising this value will result in fewer trajectories being drawn in
your display.

Backward trajectory - Creates backward trajectories instead of the default, which is forward trajectories.

 - Creates your trajectories utilizing the information provided in the Level, Trajectory Initial Area, and Initial Area
Skip Factor fields. These trajectories will be displayed in the Main Display window.

Remove existing glyphs and trajectories - Removes any trajectories and trajectory initial areas from the Main Display window.

Once you click  to create your trajectories, the options in the Layer Controls will expand to include more controls. This is
composed of two tabs: Layout, and Times.

The Layout tab allows you to set various aesthetic aspects of your display:
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Image 2: Grid Trajectories Layout Tab

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc. This option sets the color of the trajectories drawn in the Main Display window.

Visible Range - Determines what parts of the data is actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the Main Display window. The current visible range is listed next to
From:.

Line Width - Sets the thickness of the trajectory lines in the Main Display window.  You can change this value by typing a value into the
field and pressing Enter, or by using the slider. The default value here is 1.0.

The Times tab allows you to determine how many times are included with each trajectory.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/tools/ColorTableEditor.html
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Image 3: Grid Trajectories Times Tab

Properties

Times to Use - Sets if you are using Nominal Time or Track Times to display your data. You can use Show Every and Enabled to limit the
number of time steps in your loop. For example, if you are using 6-hourly data, you can use a Show Every value of 720 minutes, enable it,
and your time steps will be cut in half.

Nominal Time - Displays the entire length of all trajectories in one time step. This will not allow for a loop of data.

Track Times - Displays the parcel trajectories in a series of time steps, allowing you to easily see how the parcel moves through time
in a loop. This is the default option for Times to Use.

Time Mode - Allows you to control how much of each trajectory is shown at each time step. By default, the entire length of each trajectory is
shown, which can lead to a cluttered display if you are working with a lot of trajectories. An example use of this is when working with 6-
hourly data, and you set each trajectory to use 12-hours worth of data, meaning two time steps in each trajectory. To set Time Mode, click
the  button to get to the Time Settings window:

Image 4: Time Settings Window

This time setting is different than that used for the general Define Animation Times tab of the Time Animation Widget since it has no
influence on the number of time steps in the loop, but rather the amount of data shown at each time step. You can utilize various options for
Start Time and End Time to determine how much of each trajectory will be shown at each time step.

Start Time - Sets the first time used in the trajectory at each time step.

Use First Time from Data - Begins the trajectories with the first time of the data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animationset
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From Animation Time - Begins the trajectories at a time relative to the current animation time.

Relative to End Time - Begins the trajectories at a time relative to the end time of the trajectory. Note that you must use offset to
determine how far back from the end time you are starting.

Fixed - Sets the start/end time to be a fixed time. Note that this must be a time included with your data.

Offset - Sets the temporal offset (either positive or negative) from the value selected for Start Time and End Time. This option can be
used with any of the provided choices for Start Time and End Time. The default is 0m, which means that the actual starting and
ending times are what was selected.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options unique to this display.

The File menu has these unique options:

Export Drawing - Allows you to export your Trajectory Initial Area as a drawing file (*.xgrf). You can also select Load as map data,
which will add your shape to the Field Selector. You can then load in this shape again in subsequent sessions using Import Drawing.

Import Drawing - Allows you to import a drawing file (*.xgrf) which draws a Trajectory Initial Area. Once you import the drawing, you
can click  and trajectories will be drawn using this shape.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Satellite and Radar Displays
Image Controls
HYDRA Controls
WSR-88D Level III Controls
Level 2 Radar Layer Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImagePlanViewControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_hydra__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LevelIIIControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_page_level2radardisplaycontrols__FILE
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Image Controls
Overview
The Image Controls are used to adjust displays of satellite imagery. The control window generally consists of two tabs: Settings and Histogram.

The Settings tab allows you to customize many aspects of the appearance of your display. Note that the items in this control may be different
depending on which display type you select:

Image 1: Settings Tab of the Image Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right-click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Vertical Position - Changes the vertical position of the satellite display with respect to other variables being displayed in the Main Display
window. You can change this value by using the slider, or by entering a value into the field and pressing Enter.

Pixel Sampling - Changes the resolution of the image. A larger number makes a lower resolution display.

Texture Quality - Sets the quality of the displayed texture of Image Control. A higher quality will take longer to render and utilize more
memory. One example of when Texture Quality may be useful is after reprojecting a satellite image. Depending on the original and final
projections, you may see tears or jagged edges near the sides of the image. Changing the Texture Quality slider to a higher value will help to
mitigate those reprojection artifacts.

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Image Contours display type.

Smoothing - Smooths the contour lines in the Main Display window. There are seven types of smoothing: None, 5-point, 9-point, Gaussian,
Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all except the 5-point and 9-point
smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing
factor is the radius in grid spacing units. This is an option for the Image Contours display.

The Histogram tab allows you to visualize a histogram of your Satellite data:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE
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Image 2: Histogram tab of the Image Controls Properties Dialog

There are many ways that you can customize this histogram. If you right-click on the histogram and select Properties, you can get to a Plot
Properties dialog which allows you to change many aesthetic properties of the histogram. You can also modify the display in the Main Display
window through the Histogram tab. You can do this by left-clicking and dragging from left to right to zoom in over your desired range of data
values. Once you are done zooming in, the display in the Main Display window will modify to use a color bar range that matches the boundaries of
the zoom box you created in this tab. To return to the original data range, use the  button.

Image Display Over Topography
One of the display types in the Displays subset panel of the Field Selector is Image Display Over Topography. This display type differs from the
other Imagery display types because it allows you to create a 3D display of your satellite image. In order to utilize this display type, you must have
both the satellite data and a separate data source for topography. One example of a topographic data source is the 2D->Geopotential_height @
surface field of GFS CONUS model data.

To use this display type, select your satellite field, the Image Display Over Topography display type, and click Create Display. This will open a
Field Selector window, prompting for your topography field. Once you select your topography field and click OK, a 3D display of your satellite
image draped over topography will be displayed. You can rotate the image in the Main Display window using right-click and drag to visualize the
3D aspects of the display. You can also make the topographic features stand out more or less by using the Vertical Range item in the Viewpoint
Toolbar in the Main Display window. Lowering the Max value field of the Vertical Range window will make tall features (ex. mountains) appear
even taller.

The Layer Controls tab of the Data Explorer for this display type does not include a Histogram tab. The controls in this tab are Color Table,
Pixel Sampling, and Texture Quality, which are described in the Properties section above.

Note: In order to get this display type to show 3D topographic features, the entire domain of your satellite data must lie within the domain of your
topographic field. For example, if you are working with a full disk satellite image, but you only have topographic data over the United States, you
must subset a satellite region over the United States in the Region tab of the Field Selector before creating the display. If you do not do this, the
image will display entirely in the 2D and not show any topographic features.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Native Image Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__plotproperties
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__VerticalRange
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImagePlanViewControl__properties
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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HYDRA Layer Controls
MultiSpectral Display Controls
Linear Combination Controls
4 Channel Combination Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_MultispectralDisplayControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LinearCombinationControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ChannelCombinationControl__FILE
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MultiSpectral Display Controls
Overview
HYDRA MultiSpectral Display controls are used to create a multispectral display within McIDAS-V. There are two sets of controls, the
MultiSpectral Display and the MultiSpectral Probes. The Multispectral Display consists of three tabs: Display, Settings, and Histogram.

The Display tab shows the spectra.  This may differ if you are looking at Hyperspectral data or Multispectral data due to the number of bands
included with the data.  Hyperspectral data will have a spectra drawn as a line, while multispectral data will show a variety of points:

Image 1: Display Tab of the MultiSpectral Display Controls Window for Hyperspectral Data

Image 2: Display Tab of the MultiSpectral Display Controls Window for Multispectral Data

Properties

Wavenumber - Changes the wavelength/wavenumber displayed in the image by entering in a new value and hitting Enter.

Band - Changes the band number the green spectral line will be at, as well as the band that is used to display the data in the Main Display
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window.

Wavelength - Lists out the wavelength associated with your chosen Band.

Use the Shift+left click+drag combination to create a box of a region to zoom in on. To return to the full spectra, use Ctrl+left click. Middle-
clicking on a point in the spectra will change the wavelength/wavenumber of the image displayed. Right click+drag will translate the spectra left or
right. Left click+drag on the green wavelength/wavenumber selector bar will allow you to change the wavelength displayed in the image. As you
are dragging the selector bar, the wavelength/wavenumber will be displayed in the upper left corner of the spectra window for the current location
of the the bar.

The Settings tab shows the settings for this display control and the readout probes:

Image 3: Settings Tab of the MultiSpectral Display Controls Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Vertical Position - Sets the vertical position of the range rings with respect to other data being displayed. This can be changed by dragging
the slider or typing a value into the field and pressing Enter.

Readout Probes - Lists information on the probes located in the Main Display window. This section allows you to modify the probe
visibility and color.

 - Allows you to add a new probe to the MultiSpectral Display.

 - Allows you to remove the selected probe from the Readout Probes list as well as from the Main Display window.

The Histogram tab shows the histogram of the data for the image:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Image 4: Histogram Tab of the MultiSpectral Display Controls Window

Zoom in by left-clicking and dragging on the histogram, or enter in a set of minimum and maximum values.

Properties

Range - Allows you change the minimum and maximum values shown in the image in the Main Display window.

Reset - Resets histogram back to the default range.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Linear Combination Controls
Overview
The Linear Combinations controls are used to create and perform functions beyond the standard arithmetic functions in McIDAS-V. The Console
tab consists of two parts - The Spectra and the Console:

Image 1: Linear Combination Controls Window

The Console allows a user to define multiple spectra and perform more complex mathematical operations.

Command line functions

selector(wavenumber, color ) - Creates a spectra line with a optionally defined color and wavelength. If no wavenumber parameter is found,
a data-dependent default value will be used. If no color parameter is found, the color of the selector bar will default to green. The spectra line
can be dragged between wavelength/wavenumbers.

Examples:

a = selector()
[ Creates a green selector named "a" at a data-dependent wavenumber or
wavelength]

b = selector(1000) [ Creates a green selector named "b" at wavenumber 1000.0 ]

c = selector('cyan') [ Creates a cyan selector named "c" at a data-dependent wavenumber or
wavelength]

d = selector(919.5, 'red') [ Creates a red selector named "d" at wavenumber 919.5 ]
e = selector('40',
'orange')

[ Creates a orange selector named "e" at the wavenumber? associated with band
40 ]

f = selector('11') [ Creates a green selector named "f" at the wavenumber associated with band 11
]

combine(combination, name ) - Computes the mathematical operation corresponding to the expression entered. The results are available in
the Field Selector under the "MultiSpectral" tree in the Fields tab listed under the optional name. If no name was specified, the results will be
displayed using the expression that was computed. A combination is required for this function.
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Examples:
a = selector('2', 'red') [ Creates a red selector named "a" at the wavenumber associated with band 2]
b = selector('1',
'yellow') [ Creates a yellow selector named "b" at the wavenumber associated with band 1]

c = ((a-b)/(a+b)) [ Creates a variable c that corresponds to the expression ((a-b)/(a+b))]

combine(c, 'NDVI') [ Results of the "c" variable will appear in the Field Selector as the "NDVI" entry
]

combine((a-b)/(a+b)) [ Results of the expression in the combination field will appear in the Field
Selector ]

print( ) - Prints out information about the current wavelength/wavenumber of a selector, or its value.

Linear Combination Properties

Spectra Window - Use the Shift+left click+drag combination to create a box of a region to zoom in on. To re-set the zoom level and return
to the full spectra, use Ctrl+left click. Middle-clicking on a point in the spectra will change the wavenumber of the image displayed. Right
click+drag will move the spectra left or right. Left click+drag on the wavelength/wavenumber selector bar(s) will allow you to change the
wavelength
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4 Channel Combination Controls
Overview
The 4 Channel Combination controls are used to create a basic linear combination of spectral bands. There are two sets of controls. The top of the
controls shows the spectra, while the bottom half gives the linear combination option:

Image 1: Four Channel Combination Controls Window

Multispectral Display Properties

4 Channel Combination Equation - Changes the wavenumber displayed in the image by entering in a new value and hitting Enter or use
the pull down menus to select a band.

Compute New Field - Computes the expression. The resulting image will show up in the Field Selector under the "Multispectral" field in
the Fields tab.

Use the Shift+left click+drag combination to create a box of a region to zoom in on. To return to the full spectra, use Ctrl+left click. The Middle
click+drag probing feature will list the wavelength/wavenumber as well as the reflectance or Brightness Temperature at a point along the spectra.
Use the Left click+drag option to move the spectra selector bar(s) to a different value. The new value for where you moved the spectra bar to will
be updated in the field at the bottom of the window.

The 4 Channel Combination tool allows you to specify arithmetic expressions for four spectral bands. Use the pull down menus between variables
to select the appropriate arithmetic expressions for the equation. To apply a multiplier to any of the variables, change the value ahead of the
wavelength/band.
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WSR-88D Level III Controls
Overview
The controls for Level III Radar imagery are similar to the standard Image Controls and are used to adjust image displays of this Radar imagery.
The control window consists of two tabs: Settings and Histogram.

The Settings tab allows you to customize many aspects of the appearance of your display:

Image 1: Settings Tab of the WSR-88D Level III Controls Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Vertical Position - Changes the vertical position of the Radar display with respect to other variables being displayed in the Main Display
window. You can change this with the slider, or by entering a value in the box and pressing Enter.

Pixel Sampling - Changes the resolution of the image. A larger number makes a lower resolution display.

Texture Quality - Controls the texture quality of the display. A higher quality will provide more detail in the display, but it will take longer
to render and use more memory.

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Image Contours display type.

The Histogram tab allows you to visualize a histogram of your Radar data:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImagePlanViewControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 154 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Image 2: Histogram tab of the WSR-88D Level III Controls Window

There are many ways that you can customize this histogram. If you right-click on the histogram and select Properties, you can get to a Plot
Properties dialog which allows you to change many aesthetic properties of the histogram. You can also modify the display in the Main Display
window through the Histogram tab. You can do this by left-clicking and dragging from left to right to zoom in over your desired range of data
values. Once you are done zooming in, the display in the Main Display window will modify to use a color bar range that matches the boundaries of
the zoom box you created in this tab. To return to the original data range, use the  button.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Native Image Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__plotproperties
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Level 2 Radar Layer Controls
Radar Sweep View Controls
Radar RHI Display Controls
Radar Cross Section Controls
Radar CAPPI Display Controls
Radar Volume Scan Controls
Radar Isosurface Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarSweepControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarRhiDisplayControls__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarCrossSectionControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarCappiDisplayControls__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarVolumeControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarIsosurfaceControl__FILE
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Radar Sweep View Controls
Overview
The Radar Sweep Controls are used to control displays of single level sweeps of radar data, and their display appears in the Main Display window.
WSR-88D Level II radar data has three moments or display types: Reflectivity, RadialVelocity, and SpectrumWidth, indicated by the  icon in
the Field Selector. WSR-88D Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and
DifferentialPhase.

The controls are identical for 2D and 3D displays:

Image 1: Level II Radar Sweep Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of the data displayed. The numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where you can enter your upper and lower bound
values.

Texture Quality - Changes the texture quality of the display.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Elevation Angles - Determines which of several radar tilts, in degrees, is displayed. Click on the Cycle check box to animate vertically
through all available angles. The current elevation angle used to display the data in the Main Display window is listed after Current level.
The Cycle option works when the top level of the data type in the Fields section of the Field Selector is selected, which makes all angles
available in the display.

Display Mode - Sets the way the texture is displayed. You can select Solid, Mesh, or Points. This is useful for looking at the structure of the
underlying data.

Station - Shows the station Location ID, Latitude, Longitude, and Altitude.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Levels - Lists the different Elevation Angles for the chosen display. Changes to the Elevation Angle will be applied to the Radar display in
the Main Display window.

The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.
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Radar RHI Display Controls
Overview
The RHI (Range-Height Indicator) display appears in the Main Display window and as a 2D plot in the Layer Controls tab. WSR-88D Level II
Radar data has three moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector.
WSR-88D Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In
order for RHI to be listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen
in the Fields panel, not one of their individual elevation angles. The control window contains two tabs, Display and Settings.

The Display tab shows the RHI in 2D:

Image 1: Display Tab of the Radar RHI Display Controls

Properties

Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the covered by the radar in the Main Display window. This can be changed by left-
clicking and dragging the end points of the cross section in the Main Display.

Station - Shows the station Location ID, Latitude, Longitude, and Altitude.

The Settings tab shows settings to control the display:

Image 2: Settings Tab of the Radar RHI Display Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Selector Position - Changes the vertical position of the selector line in the Main Display window. You can change this value by using the
slider or by typing a value into the field and pressing Enter.

Vertical Scale - Changes the vertical axis range of the RHI line in the Display tab. To change this value, click  to open a Change
Vertical Axis Range window, where you can enter in new minimum and maximum values for the axis.

Autorotate RHI - Starts and stops autorotation of the RHI in the Main Display window. The 2D plot changes with the 3D RHI display when
autorotate is on. Start the rotating by clicking  and stop the rotation by clicking .

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options that are unique to this display.

The View menu has this unique option:

RHI - Offers options to capture an image or movie and to change many Display Window preferences.

The Edit menu has this unique option:

Selector Line Color - Selects the color of the selector line controlling the RHI azimuth in the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayWindowPreferences__FILE
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Radar Cross Section Controls
Overview
The radar vertical Cross Section Control is used to adjust vertical cross section displays of Level II Radar volume data. WSR-88D Level II Radar
data has three moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D
Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar
Cross Section to be listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen
in the Fields panel, not one of their individual elevation angles. The control window has two tabs, Display and Settings.

The Display tab includes a duplicate of the display in the Main Display window:

Image 1: Display Tab of the Radar Cross Section Controls

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Display - Use the left-mouse button to drag the colored squares on the positioning line in the Main Display window. This repositioning of the
end points allows you to reposition and extend or decrease the distance along the transect displayed by the radar cross section.

Location - Shows the location of the end points of the cross section.

The Settings tab shows the settings for this Layer Control:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 161 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Image 2: Settings Tab of the Radar Cross Section Controls

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Selector Position - Changes the vertical position of the selector line in the Main Display window. You can change this value by using the
slider or by typing a value into the field and pressing Enter.

Visible Range - Sets the range of the data displayed. The numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where you can enter upper and lower bound values.

Vertical Scale - Changes the vertical axis range of the 2D Cross Section in the Display tab. To change this value, click  to open a
Change Vertical Axis Range window, where you can enter in new minimum and maximum values for the axis.

Shade Colors - Blends the color between the radar data bins. The shaded display usually is not preferred for radar displays.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Cross Section - Offers options to capture an image or movie and to change many Display Window preferences.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayWindowPreferences__FILE
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Radar CAPPI Display Controls
Overview
The CAPPI (Constant Altitude Plan Position Indicator) Radar display appears in the Main Display window. WSR-88D Level II Radar data has
three moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual
Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for CAPPI to
be listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields
panel, not one of their individual elevation angles.

The CAPPI Radar displays data at a constant altitude around the Radar site:

Image 1: CAPPI Display in the Main Display Window

The Layer Controls tab of the Data Explorer allows for several ways to customize the image or loop displayed:

Image 2: CAPPI Layer Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where you can enter your upper and lower bound
values.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Texture Quality - Controls the texture quality of the display. A higher quality will provide more detail in the display, but it will take longer
to render and use more memory.

Smoothing - Smooths the Radar display in the Main Display window. There are seven types of smoothing: None, 5-point, 9-point, Gaussian,
Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all except the 5-point and 9-point
smoothers. The higher the value, the smoother the grid. For Cressman, Circular, and Rectangular aperture smoothing types, the smoothing
factor is the radius in grid spacing units.

Levels - Displays the native levels for the CAPPI Radar display. Use the dropdown menu to select one of the default levels to view, or type
your own value into the Levels box and hit Enter. Additionally, you can use the  button to switch between levels, or the check the Cycle
checkbox to animate vertically through all of the default levels in the Levels dropdown menu. The Current Level represents the pressure level
at which the data is being displayed in the Main Display window at that moment.

Display Mode - Sets the way the texture of the data is displayed. You can select Solid, Mesh, or Points. This is useful for looking at the
structure of the underlying data.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Radar Volume Scan Controls
Overview
The radar volume scan controls are used to show a radar volume as a series of nested cones. WSR-88D Level II Radar data has three moments or
data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual Pole radar includes
these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar Cross Section to be
listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields panel,
not one of their individual elevation angles.

Image 1: Radar Volume Scan Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
click the checkbox, and click  to bring up a Change Visible Range window, where you can enter your upper and lower bound
values.

Station - Lists the station location ID, latitude, longitude, and altitude.

Point Size - Changes the size of the points shown in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Radar Isosurface Controls
Overview
Displays of Level II isosurfaces are controlled by the Isosurface controls. The Radar Isosurface display type allows you to visualize radar data in the
3D, including all elevation angles, at specific data values. An example of when this display type can be useful is if you are looking for only very
high reflectivity values that may coincide with a hail spike. WSR-88D Level II Radar data has three moments or data types: Reflectivity, Radial
Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual Pole radar includes these three moments, as well as
DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar Isosurface to be listed as a valid Display Type in the
Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields panel, not one of their individual elevation
angles.

Image 1: Radar Isosurface Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Isosurface Value - Sets the isosurface value. Only radar data with this specific data value will be shown in the display. You can set this value
by using the  button or by entering a value in the text field and pressing Enter.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Profiler Controls
McIDAS-V Profiler displays show wind data from the NOAA National Profiler network. There are three different types of displays available:

Profiler Time/Height Controls
Profiler Station Plot Controls
Profiler 3D Multi-station Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerTimeHeightControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerStationPlotControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerMultiStationControl3D__FILE
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Profiler Time/Height Controls
Overview
The Profiler Time/Height display shows winds at all levels above one station, for one or more times. Winds are shown with the meteorological
wind barb symbol. The location of the barb on the plot shows the wind observation height above mean sea level, and the barb provides information
about the direction and speed of the wind. For more information on what wind speeds correspond to each of the wind barbs in McIDAS-V displays,
please see the table in the FAQ.

Image 1: Time/Height Display

The map position of the vertical profile is indicated by the "Lat: Long:" readout above the graph. The time and height values on the plot can be
sampled by dragging the middle mouse button over the plot.

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Windbarb size - Enlarges or reduces the size of the wind barbs.

Vertical interval - Changes the vertical separation between wind barbs in meters.

Stations - Switches between the station being displayed if more than one station was selected.

Latest data on left - Changes the order of times displayed. When checked, the most recent data time is on the left; and the oldest on the right.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataFaq__windbarb
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Profiler View - Allows the user to change many aspects of the display shown in both the Main Display window, and in the Layer Controls
tab of the Data Explorer.
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Profiler Station Plot Controls
Overview
The Profiler Station Plot display shows winds at one level above one or more stations on the Main Display window. Winds are shown with the wind
barb symbol. For more information on what wind speeds correspond to each of the wind barbs in McIDAS-V displays, please see the table in the
FAQ.

Image 1: Profiler 3D Multi-station Controls

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Windbarb size - Sets the size of the wind barbs displayed in the Main Display window.

Plan level - Changes the level above mean sea level, in meters, where the wind barbs are plotted.

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataFaq__windbarb
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Profiler 3D Multi-Station Controls
Overview
The Profiler 3D View shows winds at all levels above one or more stations in the Main Display window. Winds are shown with the wind barb
symbol. For more information on what wind speeds correspond to each of the wind barbs in McIDAS-V displays, please see the table in the FAQ.

Image 1: Profiler 3D Multi-station Controls

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Windbarb size - Sets the size of the wind barbs displayed in the Main Display window.

Vertical interval - Changes the vertical separation, in meters, between wind barbs.

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataFaq__windbarb
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Probes
Data Probe/Time Series
Time/Height Controls
Vertical Profile Controls
Data Transect Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProbeControl__FILE
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Data Probe/Time Series
Overview
The Data Probe/Time Series display shows a time series chart of one or more fields at a single location. It also shows a tabular readout of the value
at the current animation time step. Note that you must select two or more times in the Field Selector in order to get valid data to display in the
charts. In the image below we have a Probe Control showing three parameters: T, RH and windspeed. Their values at the current animation time
step are shown in the table and their time series are shown. Note, the T and RH fields are shown in one chart and the windspeed is shown in another
chart. You can have any number of fields and any number of charts. You can configure the layout of the charts, the chart properties and the line
properties for each parameter. See the Charts page for more information.

Image 1: Probe Control Window

A small colored square selector point in the Main Display window shows the location of the data probe. You can drag the data probe over the map
in the Main Display window by using left-click and drag. When displaying a 3D field, you can change the data probe vertically as well. As the
selector point is moved, the data in the charts will change to represent the data at the location of the probe.

The table shows the parameters with their values, the level at which the value is sampled, and the type of sampling. At the bottom of the window,
the location of the probe is shown in latitude, longitude, and altitude. When surface data is probed the height of the probe point does not matter.
You can move the probe by clicking and dragging it in the Main Display window, or by entering new values into the Lat, Lon, and Alt fields and
pressing Enter.

You can add new parameters a number of ways:

Right-click on the table and select Add Parameter...
Through the Edit->Add Parameter... menu item.
Through the View->Parameters->Add Parameter... menu item.

Parameter Properties
These parameter actions can be accessed by right-clicking on the parameter row in the table or through the View->Parameters menu.

Copy - Copies the selected parameter. This allows you view the same parameter value at different locations or with different sampling
methods.

Chart Properties - Allows you to change how the parameter is displayed in the chart. See the Chart Properties section of the Charts page for
more information.

Change Unit... - Changes the display unit for the selected parameter.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__FILE
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Set Sound... - Defines a sound type and range for the parameter. As the probe is moved around or the time animation is run a sound is
applied based on the value.

Remove - Removes the selected parameter.

Probing on Point Data
When probing on point data, the control will find the closest observation to the probe position and use that data to sample on.

Chart Options

Location - Sets the location of the probe. Enter a latitude, longitude or altitude in the location fields on the bottom right side of the Layer
Controls and press Enter.

Levels - Shows the height of the sample point. Click in the level value box, and you can reset the level for that parameter to other altitude
values (in the native data set) with a selector list of levels that pops up. The level "Probe's" is whatever level the probe happens to be at,
which may not be a native level of the data. Note that once you set the level to a level not at the probe point, the probe point no longer shows
where the sample is from. The probe does have the same latitude and longitude as the data shown, but not the altitude.

Sampling - Shows which interpolation is used. Probe values can be interpolated from neighboring grid values, since the probe position
almost never coincides exactly with the location of a data point. "Weighed average" uses interpolation of nearby data points; "Nearest
neighbor" gives the exact value of the datum in the grid cell where the probe is located. Click in the sampling column box, and you can set
the sampling method for that parameter.

Menu Options
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to the Data Probe/Time Series display. These menus are found at the top of the Layer
Controls tab of the Data Explorer.

The File Menu has these unique options -

Export Current Time as CSV... - Exports the current time step's data or all times as a comma separated file (CSV) by selecting the File-
>Save menu.

Export All Times as CSV - Exports all times as a comma separated file (CSV).

The Edit Menu has these unique options -

Change Display Format - Changes how the data is displayed in the table. This template is HTML with macros that get replaced with the
display value, unit, raw value and raw data unit.

Probe Color - Changes the color of the probe in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of your loaded Data
Sources.

The View Menu has these unique options -

Parameters

Show Parameter Table - Displays the parameter table below the chart.

Show Readout in Legend - Displays the readout of the chart in the Legend in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of your loaded Data
Sources.

Parameter - Allows you to copy the chart, open the Chart Properties dialog window, change the unit of the selected parameter, set a
sound, or remove the parameter.

Chart

Show Thumbnail in Legend - Displays a thumbnail version of the image in the Legend in the Main Display window.

Show Sunrise/Sunset Times - Displays sunrise/sunset times in the chart if applicable.

Layout - Gives you the option to open the Edit Chart Layout window as well as the option to format the chart in several ways.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Chart - Allows for zooming, saving the chart, and the option to open the Data Probe Properties window.

Probe

Position - Controls how you can reposition the probe by preventing movement in the direction of certain axes. There is also an option
to reset the probe back to its initial position.

Color - Changes the color of the probe in the Main Display window.

Size - Increases or decreases the size of the probe in the Main Display window.

Probe Shape - Changes the shape of the probe displayed in the Main Display window.
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Time/Height Controls
Overview
A Time/Height Display is a display of samples of a 3D parameter along a vertical profile line from top to bottom of the available data, with time as
the independent coordinate (X-axis). You can choose both a Contour or Color Shaded Time/Height Display.

Image 1: Time/Height Display and Controls Window

Properties

Position - Displays the map position of the vertical profile by the "Lat: Lon:" readout below the graph. Enter a value in the Lat and/or Lon
fields and press Enter to set the value. The map position of the profile is shown in the Main Display window by a colored vertical line. There
is a Selector Point on top of the vertical line which can be moved by dragging the Selector Point with the left mouse button.

Contour - Represents the current contour interval. Click  to open the Contour Properties Editor to set contour information. The
current contour interval used to display the data in the Main Display window is displayed after 'Interval'.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Latest Data on Left - Reorders the X-axis of the display to show the latest data on the left when checked, and on the right when unchecked.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Change Parameter... - Opens a Field Selector window, which allows for the selection of a different parameter from your loaded Data
Sources.

Change Display Unit... - Opens a Change Unit window, which allows for the changing of the unit of the displayed parameter.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE
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Change Contours... - Opens the Contour Properties Editor, to change how the contours appear in the Main Display window.

The View menu has these unique options:

Time/Height Display - Allows the user to change many aspects of the display shown in both the Main Display window, and in the Layer
Controls tab of the Data Explorer.

Probe - Allows the user to change many display preferences of the probe, see the View->Probe menu option on the Charts page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE
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Vertical Profile Controls
Overview
The Vertical Profile Display Control shows a plot of any number of field values versus altitude. See the Charts page for more information about
customizing the chart. In order to use the Vertical Profile display, you must be working with 3D data.

Image 1: Vertical Profile Controls Display Window

Properties

Position - Displays the map position of the vertical profile is indicated by the "Lat: Lon:" readout below the graph. Enter in a value in the Lat
and/or Lon fields and press Enter to set the value to move the location of the probe.

The map position of the profile is shown in the Main Display window by a colored vertical line. There is a Selector Point on top of the
vertical line. You can move the vertical profile line by dragging the Selector Point with the left mouse button.

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Selector Color - Changes the color of the shape representing the location of the probe in the Main Display window.

Add Parameter... - Opens a Field Selector window with the option to add another parameter to the display from one of your loaded Data
Sources.

The View menu has these unique options:

Parameters - Provides access to the Chart Line Properties window for each parameter, change the unit of the displayed parameters, and the
option to add or remove parameters.

Chart - Allows you to change the chart layout, zoom in/out of the chart, save the chart, and access the Vertical Profile Properties window.

Probe - Allows you to change many display preferences of the probe. See the View->Probe menu option on the Charts page for more
information.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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10/3/13 12:29 PMMcIDAS-V User's Guide

Page 178 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 179 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Data Transect Controls
Overview
The Data Transect controls are used to adjust data transect displays. The control window includes a display of the profile of the data along the
transect. The vertical axis is the parameter value and the horizontal axis is the distance along the transect line. In the Main Display window, a
transect selector allows you to position the location of the transect by dragging the selector points along the line. The control window consists of
two tabs, Display and Settings.

The Display tab shows the the profile of the data along the transect:

Image 1: Display Tab of the Data Transect Window

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the cross section covers in the Main Display window. This can be changed by left-
clicking and dragging the end points of the data transect line in the Main Display window.

Location - Shows the starting and ending points of the data transect line. You can change the endpoints of the data transect by entering in
new values and hitting Enter.

The Settings tab contains widgets for changing properties of that display:

Image 2: Settings Tab of the Data Transect Window

Properties

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Selector Position - Changes the vertical position of the data transect line with respect to other variables being displayed in the Main Display
window. This value can be changed with the slider or by typing a value into the field and pressing Enter.

Vertical Scale - Modifies the vertical axis range. The Use Predefined option allows you to select a variety of predefined minimum and
maximum vertical values for your chosen parameter. When the Auto-scale? checkbox is checked, the data transect will scale the Y-axis of
the transect to the sampled data range.

Line Width - Changes the width of the data transect line. Use the slider to change this value

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The Edit menu has these unique options:

Selector Color - Changes the color of the shape representing the location of the probe in the Main Display window.

Change Parameter... - Opens a Field Selector window, which allows you to change the parameter you are displaying to a parameter from
one of the added Data Sources.

Change Display Unit... - Opens a Change Unit window, which allows you to change the unit of the parameter you are displaying.

The View menu has these unique options:

Use Data Projection - Allows the user to change many aspects of the display shown in both the Main Display window, and in the Layer
Controls tab of the Data Explorer.

Data Transect - Uses the standard Data Transect to display the Data Transect in the Layer Controls tab of the Data Explorer.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Mapping Controls
Map Controls
Topography Controls
Shapefile Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_MapDisplayControl__FILE
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Map Controls
Overview
Maps in McIDAS-V are shown using the Map Display Controls. There are two ways these controls are used: for the default background maps and
for a user created map display. The control window is composed of two tabs, Maps and Lat/Lon.

The Maps tab lists the set of available maps. You have the ability to select which maps are displayed, as well as how they are displayed:

Image 1: Maps Tab of the Map Controls Window

Properties

 Apply changes to all visible maps - Applies any changes to only the one map you modify. When clicked, this icon changes to , where
any change made to one map will be applied to all of the currently visible maps.

Maps - Lists the set of currently loaded maps. The maps displayed in the Main Display window are are checked.

 - Sets the thickness of the map line.

 - Sets the style of the map line.

 - Sets the color of the map line.

Fast Rendering - Save rendering time by not checking for projection seam crossings. Some maps display better when fast rendering is turned
on, others display better when it's turned off. If a map displays poorly (e.g., has missing line segments), try switching its fast rendering
settings to see if it fixes the problem. See the Fast Rendering section of the User's Guide for more information on this feature.

 Move the map up/down - Shifts the map up and down in the list.

 Remove the map - Removes the selected map from the list.

 Load this map as a data source - Places the selected map in the Field Selector tab of the Data Explorer, where you can display the map
with the Map Display or with the Omni Control display. This feature allows for adding multiple maps to one tab in the Main Display
window. Adding a map as a data source also allows you to utilize the Maps->3D Map formula to draw a map over a topography field.

Position - Sets the vertical position of the maps and latitude/longitude lines and labels. This option is available through both the Maps and
Lat/Lon tabs.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__mapfast
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The Lat/Lon tab allows the user to set the visibility of and control the latitude/longitude lines and labels:

Image 2: Lat/Lon Tab of the Map Controls Window

Properties

Lines

 Apply changes to all lat/lon lines - When this is selected, any change made made to either the latitude or longitude lines will apply
to both, making the latitude and longitude lines identical. Click the link icon to make the lines unlinked ( ), so that a change made to
one line will not be applied to the other.

Interval - Sets the spacing between the lines, in degrees. For fewer lines, set this value higher, and for more lines, set this value lower.

Relative to - Sets a value, in degrees, that one of the lines will be drawn at. From this line, other lines will be drawn in both directions
of the Relative to line at an increment specified in the Interval field.

Width - Sets the width of the lines.

Style - Sets the style of the lines. This can be a solid line, dashes, points, or dashes and points.

Color - Sets the color of the lines.

Fast Render - Turns on and off Fast Rendering for lines.

Labels

 Apply changes to all lat/lon labels - When this is selected, any change made made to either the latitude or longitude labels will
apply to both, making the latitude and longitude labels identical (with the exception of At Longitudes/Latitudes, which are never
linked). Click the link icon to make the labels unlinked ( ), so that a change made to one label will not be applied to the other.

Interval - Sets the spacing between the labels, in degrees. For fewer labels, set this value higher, and for more labels, set this value
lower.

Relative to - Sets a value, in degrees, that one of the labels will be drawn at. From this label, other labels will be drawn in both
directions of the Relative to label at an increment specified in the Interval field.

At Longitudes - Sets the longitude line(s) to draw the latitude labels at. You can specify more than one value by separating them with
a semicolon (;).

At Latitudes - Sets the latitude line(s) to draw the longitude labels at. You can specify more than one value by separating them with a
semicolon (;).

Color - Sets the color of the labels.

Alignment - Sets the alignment point of the location of the labels with respect to the actual location of the point. This can be useful to
position the label at a location where it is not interfering with a latitude or longitude line. These Alignment options are given in
geographical coordinates (ex. NE = northeast, etc).

Font - Sets the font, style, and size of the labels.
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Format - Sets the format of the labels. You can select a variety of decimal, or DMS (Degrees, Minutes, Seconds) formats.

0-360 - Uses 0 to 360 degrees to label longitudes when selected, instead of the standard -180 to 180.

Example - Set both the Latitude and Longitude Line Interval to 15 degrees and Relative to to 0 degrees. This will draw latitude and
longitude lines at 0 degrees Latitude and Longitude, and draw another line at 15 degrees either direction (..., -30, -15, 0, 15, 30, ...). Set the
both the Latitude and Longitude Labels Interval to 20 degrees and Relative to to 0 degrees. This will draw labels at 0 degrees and draw
another label at 15 degrees in either direction (..., -40, -20, 0, 20, 40, ...).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has this unique option:

Default Maps - The Save as the Default Map Set menu item will save the maps you have selected and reopen them next time you open
McIDAS-V. This menu item creates a maps.xml file in your McIDAS-V directory that includes the name of the map, its category, and other
display settings. The Remove Local Map Defaults menu item will undo any saved changes by the user, and will revert back to the initial
default map display of McIDAS-V. This removes the maps.xml file in your McIDAS-V directory. Note that this option will take a restart of
McIDAS-V for the changes to take effect.

The Edit menu has these unique options:

Add Your Own Map... - Opens an Add a map window, where you can enter a URL of a map or select a shapefile you have locally. Here,
you can name the map, choose the category it will list under, and select the style, color, and width of the map lines.

Add System Map... - Allows you to select a list of different system maps to add to the list of maps in the Maps tab.

The View menu has this unique option:

Maps - Allows you to select which maps are checked in the Maps tab, and thus what maps are displayed in the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Topography Controls
Overview
The Topography controls allow you to display topography datasets. These controls are available through the 3D Surface->Topography display type.
An example of a field that can utilize this display type is the 2D 'Geopotential Height @ Surface' field in model data. The first image shows the
control user interface which allows you to customize many options with this display.

Image 1: Topography Controls Properties Dialog

This is an example of how the display may appear in the Main Display window:

Image 2: Topography Displayed in the Main Display Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Shade Colors - Blends neighboring colors together to smooth the image.

Display Mode - Sets the way the texture of the data is displayed. You can select Solid, Mesh, or Points. This is useful for looking at the
structure of the underlying data.

Point Size - Changes the size of the points in the Main Display window when the Points Display Mode is chosen.
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Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Shapefile Controls
Overview
McIDAS-V supports the ability to load and display GIS shapefiles. You can select and load a shape file (i.e., a file that ends with .shp) from the
General->Files/Directories chooser in the Data Sources tab of the Data Explorer using the Shapefile Data Type. The zipped (.zip) version of
shapefiles can also be loaded.

Image 1: Display Tab of the Shapefile Display Properties Dialog

Properties

Vertical Position - Defines the vertical position of the data in the Main Display window. This can be changed by using the slider or typing a
value into the field.

Set Line Width - Changes the width of the lines in the display.

For shapefiles that also have a data base file (.dbf) you can control what shape segments are shown with the Filters tab.

Note: McIDAS-V supports a simple XML format for maps. The Shapefile Control can export the displayed shapes in this XML format the File-
>Save->Export Displayed Shapes... menu.

Image 2: Filters Tab of the Shapefile Display Properties Dialog

Properties

 - Applies one or more filters to the current shape file display.

Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Match all of the filters - Displays only data that corresponds with every filter entered.

Match any of the filters - Displays any data that matches up with one or more of the filters entered.

Property - Represents the variable or property that you want to filter.

Middle Dropdown Menu - Represents the mathematical symbol that determines your filter. This can be Greater Than, Less Than, Equal To,
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Not Equal To, etc.

Value - Represents the value that sets the filter.

When the shapefile has an associated data base file (.dbf) a tabular listing of the attributes is shown in the Table tab. Use the Select Fields to Show
button to select what fields to show. The table can be exported as a CSV file with the File->Save->Export Table... menu.

Image 3: Table Tab of the Shapefile Display Properties Dialog

Properties

 - Opens a box which allows you to add, remove, and organize the list of fields to show.

 - Opens a box which allows you to add, remove, and organize the list of unique fields to show.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Line Color -- Changes the color of the lines plotted in the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Observation and Location Controls
Point Data Plot Controls
Point Data List Controls
Gridded Point Data
Sounding Display Controls
Front Controls
Location Controls
WorldWind Controls
Track Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PointDataPlotControl__FILE
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Point Data Plot Controls
Overview
The Point Data Plot Control displays a set of observations using a station model. This control is accessed by selecting the Point Data field and the
Point Data Plot display. The control window consists of four tabs: Layout, Times, Plot, and Filters.

Layout
Times
Plot
Filters
Menus

The Layout tab allows you to control basics of the display:

Image 1: Layout Tab of the Point Data Plot Controls Dialog

Properties

Declutter - Displays only stations that do not overlap when selected. When unchecked, all of the stations will be shown, and the Density
slider will be grayed out. The small "lock" icon allows you to lock the stations that are currently being displayed and not have their display
changed when navigating in the Main Display window.

Density - Changes how dense the display of stations is in the Main Display window when the decluttering option is selected. This option will
not be available if the decluttering option is not selected, as all of the stations will then be displayed.

Layout Model - Sets the layout model that will be used to display the data. This can be one of the native layout models included with
McIDAS-V, or a user-made layout model. Click on the downward facing blue arrows  to change the layout model. Selecting Edit will open
the Station Model Editor which will allow you to create your own custom station model.

Scale - Sets the size of the layout model displayed in the Main Display window.

Line Width - Sets the thickness of the layout model displayed in the Main Display window.

Vertical Position - Sets the vertical positioning of the layout model with respect to other variables being displayed. The Altitude option will
set the vertical position of the layout models based off of the stations' altitudes (if this information is available through the data source). The
Fixed Position option will uniformly set a fixed vertical position for each layout model regardless of altitude. The value for a fixed position
can be set using the slider or entering a value into the field and pressing Enter.

The Times tab allows you to change the observation times that are shown in the display. By default, data for a single time corresponding to the
current animation time will be shown. Using this widget allows you to show data from multiple times at once:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PointDataPlotControl__layout
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Image 2: Times Tab of the Point Data Plot Controls Dialog

Clicking  opens a Time Settings window that allows you to select specific start and end times:

Image 3: Time Settings Dialog

Properties

Show - Displays the data on individual frames in the Main Display window with respect to the time of the data, or plots all of the data on
every frame regardless of the time of the data.

Range - Changes the initial and final date and time to display in your loop.

Declutter - Subsets the data that is being displayed by only showing every N minutes. This is generally not useful for observation data (e.g.,
station data). However, for observation data that contains many times (e.g., airplane track data), you can use this field to subset the times.
Selecting the enabled checkbox allows you to set a number of minutes.

Note: If you are displaying point data that has a large number of times, you will be prompted whether you want to view all of the times.

The Plot tab provides a time series chart and a data readout table of a selected station. To use this, left-click on a station in the main display.
Double-click or right-click and select Add To Chart on a table row to add it to the time series chart. See the Charts page for more information about
customizing the chart:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__FILE
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Image 4: Plot Tab of the Point Data Plot Controls Dialog

Properties

Station - Shows the station for which the data is being displayed. This can be changed by left-clicking on a different layout model in the
Main Display window.

Field - Lists the different fields available from your data source that you can select from to display in the plot.

Value - Lists the numerical value of the Field at the time selected.

The Filters tab allows you to set individual or multiple filters to specify which data are shown in the Main Display window:

Image 5: Filters Tab of the Point Data Plot Controls Dialog

Properties

 - Applies any set filters to the data displayed in the Main Display window.
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Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Match all of the filters - Displays only station models that correspond with every chosen filter.

Match any of the filters - Displays any station models that correspond with one or more of the chosen filters.

Property - Represents the variable or property that you want to filter.

Middle Dropdown Menu - Represents the mathematical symbol that determines your filter. This can be greater than, less than, equal to, not
equal to, etc.

Value - Specifies the numerical value that the mathematical symbol in the middle dropdown menu will utilize.

As an example, the above image shows two filter expressions, one that states the Temperature Property needs to be greater that 35 F and the other
states that the Wind Speed value needs to be greater than 15. The unit of [F] is entered for the Temperature Property. If you do not define a unit
after the value, then McIDAS-V will utilize the native unit for the Property. Match all of the filters is selected, meaning only station models where
the Temperature is greater than 35 degrees F and the wind speed is greater than 15 will be plotted in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has these unique options:

Save Chart Image... - Saves an image of the chart produced in the Plot tab.

Export to KMZ... - Exports the data in the (*.kmz) format.

Export Selected Observation... - Exports the data in the Comma-Separated Values (*.csv) format.

The Edit menu has this unique option:

Layout Model... - Opens the Station Model Editor which will allow you to create your own custom station model.

The View menu has these unique options:

Use Projection From Observations - Re-centers the display and resets the zoom level back to the display's initial settings without changing
any other preferences you have modified.

Chart - Allows you to display a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the
Plot Properties window.

Show Raw Data - Displays the data in its raw format in the Value menu of the Plot tab before any rounding/formatting is done to the data by
McIDAS-V.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Point Data List Controls
Overview
The Point Data List Control shows a set of observation data in a textual list format. This control is accessed by selecting the Point Data field and the
Point Data List display.

Image 1: Point Data List Window

Properties

 - Opens a Field Selector window that allows you to select what Fields are listed in the table.

Only Show Every - Allows you to set a time interval where data will be listed only once every N minutes. This feature can be used by
selecting the Only show every checkbox, typing a numerical value into the field, and pressing Enter.

Show Raw Data - Displays the data in its raw format in the chart before any rounding, formatting, or changing of the native units is done to
the data by McIDAS-V. This, for example, may break up the SPD field into individual U and V components.

The  button opens a Field Selector window that allows you to determine which fields are included in the table:

Image 2: Field Selector Window to Add or Remove Fields from the Point Data List Window

Properties

All Fields - Lists all of the fields that are included in your data source.

Current Fields - Lists the fields that are included in the chart.

 - Moves the selected Field from the All Fields menu to the Current Fields menu.

 - Moves the selected Field from the Current Fields menu to the All Fields menu.
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 - Shifts the selected Current Fields item up or down, changing its position in the chart.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The File menu has this unique option:

Save->Export Table to CSV... - Allows you to save the data in the Comma-Separated Values (*.csv) format.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Gridded Point Data
Overview
McIDAS-V can create gridded fields of numeric data using the Barnes Objective Analysis. You can control the parameters used to create the grid
from the Data Source Properties or using the Grid Parameters tab in the Data Subset panel of the Field Selector. Note that since this gridded
display will utilize point observation data, the display over areas with few observations (ex. open ocean) may not correctly represent the actual data
over that region. To get more exact gridded displays of point data, it is best to utilize the Region tab to subset an area of interest with a relatively
high density of point observations:

Image 1: Gridded Point Data in the Field Selector

The resulting grid can be displayed using any of the Gridded Data Displays.

Properties

Use Default - Uses the default, native values for the selected field.

Spacing - Determines the grid spacing method.

Automatic - Calculates grid spacing from the observation density.

Degrees - Uses a specific lat/lon spacing for the grid spacing.

# Points - Sets the number of grid points in the x and y direction.

Grid Size - Specifies the grid spacing if not using automatic calculation.

Passes - Sets the number of passes for the Barnes analysis to do. Four passes are recommended for analyzing fields where derivative
estimates are important (Ref: Barnes 1994b), three passes recommended for all other fields (with gain set to 1.0) (Ref: Barnes 1994c "Two
pass Barnes Objective Analysis schemes now in use probably should be replaced by appropriately tuned 3pass or 4pass schemes"), and two
passes are only recommended for "quick look" type analyses.

Search Radius - Sets the search radius (in grid units) for the weighting of points in determining the value at a specific grid point. This option
is available with the Degrees and # Points spacing options. This should be in the range 0.2 to 1.0. Data are fitted more closely with a gain of
0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more.

Gain - Represents the factor by which scaleLength is reduced for the second pass. This should be in the range 0.2 to 1.0. Data are fitted more
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closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more. Suggested default: 1.0. Set
the gain for each pass after the first.

First Guess Field - Uses a model grid as a first guess field for the analysis. Select the "Grid Parameters (with first guess)" field and you will
be prompted to select the gridded field to use for the first guess.

References -

Barnes, S.L., 1994a: Applications of the Barnes objective analysis scheme Part I: Effects of undersampling, wave position, and station
randomness. J. Atmos. Oceanic Technol. 11, 1433-1448.

Barnes, S.L., 1994b: Applications of the Barnes objective analysis scheme Part II: Improving derivative estimates. J. Atmos. Oceanic
Technol. 11, 1449-1458.

Barnes, S.L., 1994c: Applications of the Barnes objective analysis scheme Part III: Tuning for minimum error. J. Atmos. Oceanic
Technol. 11, 1459-1479.
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Sounding Display Controls
Overview
The meteorological sounding display is available for: RAOBs, numerical weather prediction model output, and from a local file that contains
aircraft track data. The dewpoint temperature is computed by internal code from temperature and relative humidity grids.

To load sounding data see Choosing RAOB Sounding Data and Displaying Gridded Data. The sounding display consists of a table of aerological
(thermodynamic) parameters and three tabs: Sounding Chart, Hodograph, and Table.

The Sounding Chart tab includes an aerological diagram (e.g., skew-T, Stuve, Emagram):

Image 1: Skew-T of Point Data

Properties

Station - Selects which station's sounding is being displayed when multiple stations are selected in the Main Display window.

 Time Animation Control - Controls the looping of displays through time. See Time Animation
Control for more information.

Dry Adiabats - Displays the dry adiabats on the Skew-T diagram.

Saturation Adiabats - Displays the saturation adiabats on the Skew-T diagram.

Mixing Ratio - Displays the mixing ratio lines on the Skew-T diagram.

Parcel Path - Displays the path of a parcel of air lifted pseudo-adiabatically from the initial point to the top of the Skew-T diagram.

Virtual Temperature - Displays the virtual temperatures of the environmental profile and pseudo-adiabatically lifted air-parcel.

Grid Points - Plots points in the Main Display window spatially separated by the resolution of your data. These grid points represent the

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sounding__connecting
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actual locations of where the data values in the sounding are retrieved. Your data probe may be between one of these grid points, but the
display in the sounding will be indicative of the nearest grid point to the location of the probe.

Parcel mode - Specifies how the initial conditions of the pseudo-adiabatically lifted air-parcel are determined from the environmental
sounding according to the mode indicated. This will affect how the LNB, LFC, LCL, CAPE, and CIN are calculated. The choices are:

Bottom of Sounding - Determines the initial conditions of the parcel from the temperature and dewpoint at the level of highest
pressure. The path will update whenever the profiles change.

Below Cursor - Determines the initial conditions of the parcel from the temperature and dewpoint profiles by computing the pressure-
weighted mean potential temperature and water vapor mixing-ratio of the atmosphere that lies below the cursor when the middle mouse
button is pressed. Thus, pressing the middle button at 950 hPa for a sounding that starts at 1000 hPa will effectively mix the lower 50
hPa of the atmosphere and lift the resulting parcel starting at 975 hPa. The path will update whenever the profiles change and as the
cursor is dragged.

At Cursor Pressure - Determines the initial pressure, in-situ temperature, and moisture content of the parcel from the temperature and
dewpoint profiles at the pressure of the cursor when the middle mouse button is pressed. The initial moisture content is determined
from the dewpoint profile at the initial pressure. The path will update whenever the profiles change and as the cursor is dragged.

At Cursor (Press, Temp) - The computed path of a lifted parcel is automatically updated when appropriate. The initial pressure and
in-situ temperature of the parcel equal the pressure and temperature values under the cursor when the middle mouse button is pressed.
The path will update whenever the profiles change and as the cursor is dragged.

Wind spacing - Allows the user to control which wind levels are shown in the display.

Consecutive Profiles - Allows you to plot both the current sounding, as well as the sounding of the next time step in one image. The
temperature and dewpoint temperature profiles of the current timestep will be dashed, and the profiles of the next timestep will be displayed
as solid lines. The current time's winds will be displayed directly to the right of the sounding, and the next timestep's winds will be shown to
the right of that. This makes it easy to see how a profile will change through time. This will reduce the number of time steps in your loop by
1. This option will not make any changes to the display if you only have one timestep displayed.

A label above the sounding's chart shows the station number, date, and time of the sounding. When displaying sounding plots made from gridded
model output, the position of the sounding is shown in the Main Display window by a solid-color selector point and vertical line. You can move this
model-output-based sounding position over the map by dragging the selector point with the left mouse button.

When displaying a sounding diagram made from gridded numerical weather model output, there is a pull-down selector menu of the model output
valid times in the upper right corner.

The animation control buttons are available in either case:

To increase precision using the sounding diagram, enlarge the window by dragging on the edges. You can zoom the sounding diagram by holding
down the Shift key and dragging the right button upwards; drag downwards to zoom out. Zooming can also be done by using the scroll wheel on the
mouse. You can pan the diagram by dragging the mouse pointer in any direction while holding down the right mouse button.

The temperature and dewpoint traces can be modified via the cursor. Press the left button on the first data-point to be modified and drag it
horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired
position and to pick-up the next data-point. Repeat until done and then release the mouse button.

The Hodograph tab shows a 3D hodograph display:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Image 2: Hodograph of Point Data

The hodograph is enabled if the plotted data includes wind fields. It can be rotated into 3D by clicking and dragging the right mouse button. You
can zoom in/out by holding down Shift and right-clicking and dragging up/down or by using the scroll wheel on the mouse. To reset the hodograph,
use Ctrl+R.

The Table tab shows a table of all values in the sounding:
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Image 3: Table of Point Data

Properties

Show U and V - Breaks the Speed and Direction categories up into the individual U and V components of the wind.

Aerological Parameters
The table to the left of the sounding diagram contains aerological parameters determined from the atmospheric sounding displayed in the diagram.
The following abbreviations are used:

LCL: Lifting Condensation Level - The level at which a pseudo-adiabatically lifted air-parcel becomes saturated with water vapor.

LFC: Level of Free Convection - The level at which the virtual temperature of a pseudo-adiabatically lifted air-parcel changes from being
less than the environment's virtual temperature to being greater than the environment's virtual temperature.

LNB: Level of Neutral Buoyancy - The level above the LFC at which the virtual temperature of a pseudo-adiabatically lifted air-parcel
equals the environment's virtual temperature.

CAPE: Convective Available Potential Energy - The area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel
and the virtual temperature trace of the environment from the LFC to the LNB in which the parcel's virtual temperature is greater than the
environment's (positive CAPE connotes convective development).

CIN: Convective Inhibition - The negative of the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and
the virtual temperature trace of the environment from the parcel's initial conditions to the LFC in which the parcel's virtual temperature is less
than the environment's (negative CIN connotes initial positive work to lift the parcel).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has this unique option:

Export Sounding Table to File... - Exports the data in the Table tab to an Excel file.

The Edit menu has these unique options:
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Reset Sounding - Reverts the sounding back to its initial configuration after any modifications have been made to it.

Selector Color - Changes the color of the shape representing the location of the sounding in the Main Display window.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

Sounding Chart - Allows you to capture an image or movie of the sounding and change many aesthetic preferences.

Hodograph - Allows you to capture an image or movie of the hodograph and change aesthetic preferences related to the Main Display
window.
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Front Controls
Overview
The Front Controls shows a list of the different weather features (high and low pressures, fronts, etc.) shown in the Main Display window in a
textual list format. This control becomes available once the Front Positions data source has been added:

Image 1: Front Display Controls Window

Properties

Name - Lists the different features that can be seen in the Main Display window.

Type - Lists a descriptor of the name.

Third Column - Lists the times that the feature is seen in the Main Display window.

Z Position - Changes the vertical position of the features with respect to other variables being displayed in the Main Display window. You
can change this with the slider, or by entering a value in the field and pressing Enter.

Double-clicking on an item in this window open the Properties Editor for that item. This window consists of two tabs: Properties and Points:

The Properties tab allows you to change general characteristics of the display. Note that the options that appear in this tab may differ depending on
what feature's properties you are viewing:

Image 2: Properties Tab of the Properties Window

Properties

Scale - Changes the thickness of the selected feature in the Main Display window.
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Name - Changes the name of the feature in the Fronts tab of the Front Display window.

Visible - Toggles the visibility of the feature in the Main Display window.

Times - Lists the relevant times for this feature. This cannot be changed through this window.

Distance - Represents the spatial extent of the feature.

 - Opens the Flythough feature which allows you to interactively explore the item.

The Points tab provides information about the location of the selected feature:

Image 3: Points Tab of the Properties Window

Properties

Latitude - Lists the Latitude of each displayed point of the feature.

Longitude - Lists the Longitude of each displayed point of the feature.

 - Exports the table listed in the Points tab to a Comma-Separated Values (CSV) file (*.csv).

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__flythrough
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Location Controls
Overview
McIDAS-V provides a collection of locations. These may be NEXRAD stations, states, counties, geographical features, countries, etc. The Location
Controls are used to display these locations. The list of locations is accessed through the Display->Plot Location Labels... menu item in the Main
Display window. You can also load in local files that use these location controls. The user interface consists of four tabs: Display, Locations, Data
Sets, and Filters.

Display
Locations
Data Sets
Filters
Menus

The Display tab allows the user to control how the display will appear in the Main Display window:

Image 1: Display Tab of the Location Controls Dialog

Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown, and the Density slider will be
grayed out. The small "lock" icon allows you to lock the stations that are currently being displayed and not have their display changed when
navigating in the Main Display window.

Density - Changes how dense the display of stations is when the Declutter checkbox is selected. When the Declutter checkbox is not
selected, the Density option will not be available, and all stations will be displayed.

Display - Displays locations as a fixed specification of a symbol and/or identifier, or as one of the available station models.

Use the options under the Predefined radio button to control what station information is displayed. Use the options in the Symbol menu to
control what marker symbol is displayed. Clicking an item will immediately change the display. Use the checkboxes to the right of Id and
Symbol to trigger their visibility in the Main Display window.

Layout Model - Sets the layout model that will be used to display the data. This can be one of the native layout models included with
McIDAS-V, or a user-made layout model. Click on the downward facing blue arrows  to change the layout model. Selecting Edit will open
the Station Model Editor which will allow you to create your own custom station model.

Vertical Position - Displays the locations at their altitude (if there is one) or specifically defines the vertical position. This can be changed by
using the slider or typing a value into the field and pressing Enter.

The Locations tab shows two sub-tabs, All Locations and Displayed Locations. Shown at the bottom are the details of a location:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__display
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__locations
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__datasets
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__filters
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__FILE
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Image 2: Locations Tab of the Location Controls Dialog

Properties

All Locations - Lists all of the locations relevant to the chosen parameter.

Displayed Locations - Lists only the locations that are currently visible in the Main Display window.

Listen for clicks - Updates the current location information to the station you click on in the Main Display window.

Center on selected - Centers the Main Display window over the location selected in this tab.

The Data Sets tab lists all of the location files that are being displayed. You can remove a data set by clicking on the data set and pressing Delete:

Image 3: Data Sets Tab of the Location Controls Dialog

The Filters tab allows you to filter what locations are being shown based on their internal attributes:
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Image 4: Filters Tab of the Location Controls Dialog

Properties

 - Applies any set of filters to the data displayed in the Main Display window.

Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Only show these - Displays only the data relevant to the filters, but it will not show all of the locations, utilizing the cluttering level from the
Display tab when creating the Display.

Always show these - Displays only the data relevant to the filters, but it will show all of the locations, regardless of the cluttering level from
the Display tab when creating the Display.

Match all of these filters - Displays only data that corresponds with every chosen filter.

Match any of these filters - Displays data that matches up with one or more of the chosen filters.

Property - Represents the variable or property that you want to filter.

Middle Dropdown Menu - Represents the mathematical symbol that determines your filter. This can be greater than, less than, equal to, not
equal to, etc.

Value - Specifies the numerical value that the mathematical symbol in the middle dropdown menu will utilize.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Add Locations - Allows you to add more locations. This includes states, countries, Radar sites, earthquakes, glaciers, etc. to the Main
Display window.

Color - Determines the color of the data being displayed in the Main Display window.

The View menu has these unique options:

Show Flythrough - Opens the Flythrough feature which allows you to interactively explore the display.

Use Projection From Locations - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you have modified.

Chart - Allows you to display a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the
Plot Properties window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__flythrough
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__chartlayout
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__plotproperties
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WorldWind Controls
Overview
The WorldWind controls are a special version of the Location Controls. They provide access to a large collection of locations from NASA's
WorldWind Viewer project.

As the display is panned or zoomed over more locations, different location sets are retrieved and displayed.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__FILE
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Track Controls
Overview
The track controls display trajectory data sets, e.g., aircraft track, ship, buoys, etc. This data can be loaded in the General->Files/Directories
chooser of the Data Sources tab of the Data Explorer, with the Data Type of Track files. You can display your data in the form of a chart, table,
track, or as a Point Data Plot drawn in the Main Display window. The items in the Layer Controls for a Point Data plot are the same as the controls
for displaying regular Point Data. If you are working with data for a lot of times, or have many parameters included with your data, you may
be prompted to subset the point data. This gives you the option of only including the necessary fields to cut down on memory usage and time to
display the data.

To draw a track in the Main Display window, select your field in the Fields panel, the Track Colored By Parameter display type, and hit Create
Display. These same controls are utilized for the Trajectory Colored By Parameter display type. The track controls consist of two tabs, Layout and
Times.

The Layout tab controls the appearance of the display:

Image 1: Layout Tab of the Track Controls Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Visible Range - Determines what parts of the data are actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the Main Display window. If the Visible Range checkbox is not
selected, the default range will be used.

Marker - Defines an end point symbol and text as well as its color with these fields when using Nominal Time in the Times to Use option of
the Times tab. If you select Track Times in the Times to Use option of the Times tab, then this point will represent the current location of the
track as you play through the loop of data in the Main Display window. By default, "Location" is selected as the default marker. Click the
checkbox to the left of the "Location" box to enable the marker. Click on "Location" to choose another marker from the list of layouts. Click
on the  Edit icon to edit a current layout, or to create a new one. Use the slider or enter in a value and hit enter in the Scale option to set the
scale of the marker.

Line Width - Allows you to set the width of the displayed trajectory line. You can change the line width by typing a value into the field and
pressing Enter, or by clicking  to use a slider.

The second tab controls the Times used for the display:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PointDataPlotControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Image 2: Times Tab of the Track Controls Dialog

Properties

Times to Use - Represents if you are using nominal times or the track times from the data. You can also choose to limit the times of data
shown by checking enabled. There are two Times to Use options:

Nominal Time - Displays the entire track of data in one time step, regardless of the number of observations along the track.

Track Times - Displays the track as a series of time steps, from start to finish.

Time Mode - Allows for the control of how much of the track is shown and from what time. Even though a track represents a set of
observation times, there is not time set defined for animating in the main display. Click  to show the Time Settings dialog. The time mode
allows for the control of how much of the track is shown at each time step of the loop:

Image 3: Time Settings Dialog

This dialog allows you to define the time range to show of the track. The image above defines that the end time is the current animation time,
and the start time is relative to the end time less 30 minutes. This means that the track or trajectory drawn in the Main Display window would
include the current animation time of the loop, as well as the any data from 30 minutes prior this time.

This time setting is different that that used for the Define Animation Times tab of the Time Animation Widget since it has no influence on
the number of time steps in the loop, but rather the amount of data shown at each time step. You can utilize the various options for Start
Time and End Time to determine how much of the track or trajectory will be shown in each time step.

Use First Time from Data - Begins plotting the track or trajectory of your data from the first time step of the data.

From Animation Time - Begins plotting the track or trajectory of your data from the current timestep of the animation in the Main
Display window.

Relative to End Time - Begins plotting the track or trajectory of your data from a time relative to the End Time selected for your data.
You must use an Offset with this to determine how far back (in terms of time) to be from the final time step. The Offset here should be
a negative value assuming your loop is progressing forwards through time.

Fixed (Start Time) - Begins plotting the track or trajectory of your data from a fixed time that will not change as your loop progresses.
This does not affect the End Time of your data.

Use Last Time from Data - Sets a time where your path or trajectory will end.

Relative to Start Time - Stops the plotting of the the track or trajectory at a time relative to the Start Time selected for your data. You
must use an Offset with this to determine how far in the future the End Time will be from the Start Time. The Offset here should be a
positive value assuming your loop is progressing forwards through time.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animationset
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Offset - Sets the temporal offset (either positive or negative) from the value selected for Start Time or End Time. This option can be
used with any of the provided choices for Start Time and End Time. The default is 0m, which means that the actual starting and
ending times are what was selected.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one item that is unique to this display.

The Edit menu has this unique option:

Change Parameter... - Changes the parameter that the track or trajectory is colored by.

The View menu has this unique option:

Show Flythrough - Opens the Flythrough feature which allows you to interactively explore the display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__flythrough
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Miscellaneous Controls
Scatter Analysis Controls
McIDAS-X Bridge Controls
Grid Table Controls
Omni Controls
Jython Controls

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ScatterAnalysisControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_BridgeControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GridTable__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_OmniControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_JythonControl__FILE
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Scatter Analysis Controls
Overview
The Scatter Analysis controls are used to create a scatter plot within McIDAS-V. The scatter controls show three different panels:

Image 1: HYDRA Scatter Analysis Display

The plot on the first panel on the left represents the first field selected in the Field Selector, the panel in the middle represents the second field
which is selected through the Field Selector window, and the panel on the right is the scatter analysis of the two fields. The first field selected is
represented on the X-axis (abscissa) and the second field selected represents the Y-axis (ordinate). The X-axis is selected in the Field Selector -
what you have selected in the lower right Channels tab will be used as the X-axis.

You can subset regions in any of the three panels, and the equivalent points will also be selected in the other two panels. For example, if you draw a
box in panel 1, the same box will be drawn in panel 2, and the points in these boxes will be colored the same in panel 3, the scatter analysis. To
draw a box, select a Box radio icon and a color, and use Shift+left-click and drag to select a region. You can also draw any enclosed shape by
selecting the Curve radio button and a color, and left-click and drag in any panel to select a region. You are allowed one box and one curve per
color in the scatter analysis (panel 3), and one box and one curve for the images (panels 1 and 2). To remove region that you have subsetted, simply
double click on the color of the region you wish to remove next to the Box/Curve radio buttons.

Right-click on the color bar below the images to open the Color Table Editor, change the range, select other color tables, etc.

To the right of the Box/Curve options, there is a  button. Clicking this button will Scatter Statistics window that will list
statistical information about the data as a whole, as well as the regions of the data that were subsetted with a box/curve. The values in the white
columns are computed for the image as a whole, and the values in the colored columns are computed for the area of the respective box/curve.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Image 2: HYDRA Scatter Statistics Window

Properties

Maximum - Lists the maximum numerical value of the field within the boundaries of the entire image or a subsetted region.

Minimum - Lists the minimum numerical value of the field within the boundaries of the entire image or a subsetted region.

Number of points - Lists the total number of points within the boundaries of the entire image or a subsetted region.

Mean - Lists the mean numerical value of the field within the boundaries of the entire image or a subsetted region.

Median - Lists the median numerical value of the field within the boundaries of the entire image or a subsetted region.

Variance - Lists the variance of the field within the boundaries of the entire image or a subsetted region.

Kurtosis - Lists the kurtosis value of the field within the boundaries of the entire image or a subsetted region.

Std Dev - Lists the standard deviation of the field within the boundaries of the entire image or a subsetted region.

Correlation - Lists the correlation between the numerical values of the two fields within the boundaries of the entire image or a subsetted
region.

Difference Maximum - Lists the maximum difference in the numerical values of the fields on a pixel-by-pixel basis.

Difference Minimum - Lists the minimum difference in the numerical values of the fields on a pixel-by-pixel basis.

Difference Mean - Lists the mean difference in the numerical values of the fields on a pixel-by-pixel basis.

Area [km^2] - Lists the area, in square kilometers, of the subsetted regions.

 - Saves this statistical data as a Comma-Separated Values (CSV) file (*.csv).

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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McIDAS-X Bridge Controls
Overview
The McIDAS-X Bridge Controls are used to create and import a McIDAS-X session into McIDAS-V. The control window has two tabs, Frames
and Settings.

The Frames tab includes a pseudo duplicate of the two main McIDAS-X windows:

Image 1: Frames Tab of the McIDAS-X Bridge Controls Dialog

The Settings tab shows the settings for this display control:
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Image 2: Settings Tab of the McIDAS-X Bridge Controls Dialog

Vertical cross sections can be made in three types of displays, with contour lines, color-filled contours, and as a color-shaded image.

Properties

Command Line - Reads McIDAS-X commands that can be entered through the "Command Line" text entry box at the bottom of the Layer
Controls tab. Interactive commands are not implemented. Recall commands (Shift+6 and Shift+7) do work in the bridge session.

Smooth images - Uses anti-aliasing to smooth images when re-sizing to fit the frame display.

Time Animation Controls - 

Controls looping of displays when more than one data time is loaded. See more in Time Animation Control.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open thee Color Table Editor, change the range, select other color
tables, etc.

Vertical Position - Displays the locations at their altitude (if there is one) or specifically defines the vertical position. This can be changed by
using the slider or typing a value into the field.

Pixel Sampling - Sets the resolution of the image. A larger number makes a lower resolution (coarser) display.

Texture Quality - Sets the quality of the displayed texture of Image Control. A higher quality will take longer to render and more memory.

Display data in the main 3D panel - Displays images, graphics, and/or annotation lines from navigated frames in the McIDAS-X Bridge
session the Main Display window. Non-navigated frames are not imported into McIDAS-V and will be skipped.

Use McIDAS-X frame order to override data time with frame number - Imports navigated data into McIDAS-V based upon their order
within the McIDAS-X frame order instead of by time.

Use McIDAS-X data projection - Uses the default projection for McIDAS-X when displaying navigated data in the Main Display window
in McIDAS-V.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Grid Table Controls
Overview
The Grid Table display in creates a table in the Layer Controls tab of the Data Explorer. This chart plots the numerical value of your selected field
at every latitude and longitude point. You can change the order of the items in this chart by Latitude, Longitude, or field values by clicking on the
title of the respective column in the table. This will change the order of the table to go from lower to higher values, or higher to lower values.

Image 1: Grid Table Display

Properties

 Time Animation Controls - Controls the looping of data through time. For more information, see
Time Animation.

Show native coordinates - Lists X/Y values instead of Latitude/Longitude values.

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Omni Controls
Overview
The Omni controls consist of a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to
create a display where you have complete control over which coordinates are the axes, how it is colored, and so on. Use of the VisAD Spread Sheet
is not described here. See the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

Image 1: Omni Controls Windows

Properties

Mappings - Brings up the VisAD Math Type and display mappings control box shown on the right in the image above.

Controls - Brings up the spreadsheet Controls box (not shown).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of your loaded Data
Sources.

http://www.ssec.wisc.edu/~curtis/ss.html
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Jython Controls
Overview
The Jython Controls allow for the development of custom layer controls written in Jython. The controls operate in two modes.

First is the "developer" mode. Here the developer can create a Jython Control; specify the name of the display, any data categories, and the probe
type; and write the Jython that creates a GUI and responds to data, animation time and probe position changes.

The default Jython code has examples of accessing data, etc.

The second mode is "user" mode. In developer mode you can write out an specification of the Jython Control to a plugin through the File->Save-
>Write to Plugin menu. This plugin, when loaded, will only show the user interface that is created by the developer-written Jython.
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Contour Properties Editor
The Contour Properties Editor is invoked from any contour display control with the Contour: Change button or through the Edit->Change
Contours... menu item in the Layer Controls tab of the Data Explorer. Use the items in this window to set contouring properties.

Image 1: Contour Properties Editor

Properties

Contour Interval - Sets the spacing (difference in value) between contours. There are four ways to specify the contour interval.

1. Specify a single value to denote a regular interval between contours.

2. Specify irregular contour intervals with a semi-colon separated list of values. For example:

5400;5460;5800. This would only show contours at 5400, 5460, and 5800.

3. Specify different contour intervals for different ranges in the following format:

cint1/min1/max1;cint2/min2/max2;...;cintn/minn/maxn

For example, with geopotential heights: 30/0/4200;60/4200/8600;120/8600/24000 would draw contours at 30gpm between 0 and
4200, 60gpm between 4200 and 8600, and 120gpm between 8600 and 24000

4. Specify one individual contour by setting the interval, min, and max as the same value. For example:

5400/5400/5400. This would only show the 5400 line.

Base Contour - Sets the value on which all contours are based. All contours will be integer multiples of the contour interval from the base
value. For example, with a base value of 0 and a contour interval of 3 contours would be created at ..-6, -3, 0, 3, 6... A base of 1 with that
interval would create contours at ..-5, -2, 1, 4, 7... The base value does not have to be the lowest contour level on a plot, or inside the range of
values plotted; it is only a computational reference point. The base contour value is also used for controlling which lines are dashed.

Minimum Value - Sets the limit below which no contour lines are drawn. The minimum value may be larger than the base value, so that the
base value may never appear on a plot.

Maximum Value - Sets the upper limit above which no contour lines are drawn. The minimum and maximum values do not need to match
contour line values; they are only limits.

Line Width - Sets the line width (in pixels) of the contour lines and labels.

Dash - Dashes contour values less than the base value. If the base is set higher than maximum value, then all lines are dashed. Use the
pulldown menu to select the dash pattern to use.

Labels - Displays contour labels on the image.

Font - Sets the font style of the contour labels.

Size - Sets the font size of the contour labels.
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Align - Sets the way contour labels will be written on the contours. Along Contours means the labels will be written along contours,
and while they will not be written upside down, there is a chance they will be written at an angle depending on the layout of the
contours. Horizontal means the contour labels will be written on the contour, but it will be written in the horizontal and not on an
angle.

Frequency - Sets the frequency of labels along the contour lines. There will be more labels displayed as the slider is moved from left to right.
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Properties Dialog
The Properties dialog is accessed by right clicking on a layer in the Legend of the Main Display window, and selecting Edit->Properties menu
item. This dialog can also be accessed in the Layer Controls tab of the Data Explorer, by clicking the  button at the bottom of the tab. The
Properties dialog consists of a Settings tab, and possibly others depending on item being displayed:

 
Image 1: Layer Control Properties Dialog

Properties

Display Category - Organizes the Legend by moving items from one Legend category to another. The  button shows a list of all of
the current display categories and allows you to easily set this field.

Legend Label - Represents the label used in the Legend of this display control. It can contain arbitrary text as well as a set of macros. The
macros can be added to the label with the  button:

Display Name - Represents name of the display.

Field Short Name - Shows the short name of the parameter being displayed.

Field Long Name - Shows the long name of the parameter being displayed.

Data Source Name - Shows the name of the data source that produced the parameter being displayed.

Time Stamp - Shows the time of the data that is currently being displayed using the default time format preference. You can also use a
macro of the form %time:<time pattern>% to set a specific time format other than the default. <time pattern> follows the same rules
defined in the User Preferences' Formats & Data tab. For example, %time:HHz EEE dd MMM yyyy% would show something like
12GMT Fri 16 Feb 2007.

... And other values depending on the display.

Extra Legend Labels - Acts like the Legend Label field (e.g., with macros).

Layer Label - Acts like the Legend Label field to define the text label that is shown in the display list. The colored rectangle to the right of
the layer label changes the color. Left-click and use the pull down menu to specify a color or create a custom color.

Id - Defines an ID for this display. The ID is used for accessing particular displays from the McIDAS-V Scripting Language.

There may be a variety of checkboxes:

Lock Visibility Toggle - Locks/unlocks visibility toggling.

Use Fast Rendering - Uses fast rendering to display data layers (images, contours, etc.); see Performance Tuning for more
information. A separate fast rendering option for map layers is available in the Map Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FormatPreferences__dateformat
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Remove on Remove All - Removes the layer when the Remove all Layers or Remove all Layers and Data buttons are pressed. When
this option is not selected, the layer will remain after removing all layers and data sources.

Show Note Text - Adds a text field to the bottom of the Layer Controls tab of the Data Explorer for the item. This allows you to enter
notes/text that can be saved in bundles.

Show in Layer List - Allows for the toggling of the visibility of the label in the view window. Note that you must enable showing the
list of display labels that are toggled on using the View->Properties dialog of the view window, or by setting the global property for
all display through the User Preferences dialog.

Include Times In Animation - Includes the item in the time animation.

Include in cursor readout - Includes probe readout values for the parameter at the bottom of the Main Display window when you
probe the data.

There may be other tabs shown, depending on the display. For example, the Color Scale tab allows for the configuration of where the color scale
bar is shown. The Spatial Subset tab allows for defining further spatial subsetting of the data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayWindowPreferences__showlayerlist
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Color Scale
For those controls that include color tables, the color scale can be displayed in the Main Display window. Use the the Edit->Properties->Color
Scale menu in the Layer Controls tab of the Data Explorer to configure the visibility, positioning, and labeling of the color scale.

 
Image 1: Color Scale Properties Dialog

Properties

Visible - Determines if the color scale will be shown in the Main Display window. The scale is visible when the box is checked.

Display Unit - Adds a unit to the color scale, as long as the color scale is set as visible.

Position - Represents the location of the color scale in the display.

Labels - Determines if labels will be plotted along with the color scale. When the Visible option is checked, labels will be displayed.

Font - Represents the font, style, and size of the font plotted in the color scale's labels.

Color - Represents the color that the labels will be plotted in for the color scale.
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Charts
Overview
There are many different sources of data that can make use of the charting facility in McIDAS-V. It is possible to use the charting facility to display
your data by selecting Data Probe/Time Series in the Displays menu in the Field Selector tab of the Data Explorer. The chart will be plotted in the
Layer Controls tab, while a square representing the location of the probe will be shown in the Main Display window. The location of the probe can
be changed by left-clicking on the probe and dragging it.

There are four levels of configuration available to the user, as well as several unique menu options for this display.

Chart Line Properties
Plot Properties
Chart Properties
Chart Layout
Menu Options

Chart Line Properties
At the lowest level, you can set the properties of how each parameter or field is shown. This is done through the Chart Line Properties dialog, which
is opened by right-clicking on the parameter below the chart and selecting Chart Properties.

Image 1: Chart Line Properties Dialog

Full Plot - Toggles the visibility of the data displayed on the chart on or off.

Axis - Toggles the visibility of the axis on or off.

Legend Label - Changes the name of the selected parameter, both in the parameters list, and on any axes labels. This can be changed by
typing in the field.

Chart Name - Select a chart name from the pull down menu, or create a new by entering a new name in the field. The display will
automatically create a new chart with the new name.

Axis Side - Specifies what side of the chart the axis and axis label is shown.

Range - Fixes the axis range to remain constant as the chart values change.

 - Allows you to specify the initial range values for the selected parameter.

Includes Zero - Includes zero on the axis range.

Type - Specifies the display of the data in the chart. It can be displayed as Lines, Lines and Shapes, Shapes, Area, Area and Shapes, or a Bar
Chart.

Shape - Specifies the shape to be displayed when Shapes is included in the Type.

Line - Specifies the line stroke and width to be displayed.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__chartlines
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Color - Specifies the color of the data being displayed.

Vertical Position - Defines where in the chart special shapes are shown (e.g., wind barbs, cloud coverage, text).

Plot Properties
For each individual plot, there are a number of settings that can be changed through the Plot Properties dialog. This is also accessed through the
View->Chart->Chart:->Properties... menu item.

Image 2: Data Probe Properties Dialog

Name - Sets the name of the chart.

Color - Sets the background and chart colors.

Domain Lines - Changes the domain lines properties including the stroke, width, and color. The visibility of the domain lines can also be
toggled on and off with the Visible checkbox.

Legend Label - Changes the Legend Label along the Domain Lines.

Range Lines - Changes the range lines properties including the stroke, width, and color. The visibility of the range lines can also be toggled
on and off with the Visible checkbox.

Legend Label - Changes the Legend Label along the Range Lines.

Title - Sets the visibility of the Name on the chart.

Date Format - Sets the format of the date/time labeling on the chart along the axis representing time.

When right-clicking on a chart, you can also zoom in and out and save the chart as an image. There are also a number of key and mouse bindings on
the chart:

Ctrl+R: Reset any zooming.
Up/Down/Left/Right Arrows: Pan p
Left mouse drag - zoom

Chart Properties
There are several chart properties that can be changed through the Chart Properties dialog box. This is accessed by right clicking on the chart and
selecting "Properties." The Chart Properties dialog box consists of three tabs: Title, Plot, and Other. The Plot tab includes three tabs within itself:
Domain Axis, Range Axis, and Appearance.

The Title tab deals with the chart's title and its attributes.
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Image 3: Title Tab of the Chart Properties Dialog

Show Title - Displays the title on the chart in the Layer Controls tab of the Data Explorer.

Text - Lists the current title for the chart. This can be changed by typing in the field.

Font - Changes the font style and size of the title.

Color - Changes the color of the title.

The Domain Axis tab allows for customization of the Domain Axis.

Image 4: Domain Axis Tab in the Plot Tab of the Chart Properties Dialog

Label - Sets the label for the Domain Axis.
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Font - Sets the font style and size of the title.

Paint - Sets the color of the title.

Show tick labels - Displays labels below the tick marks on the Domain Axis.

Tick label font - Sets the font size and style of the tick labels.

Show tick marks - Displays tick marks, which extend just beyond the boundaries of the chart on the Domain Axis.

The Range Axis tab allows for customization of the Range Axis.

Image 5: Range Axis Tab in the Plot Tab of the Chart Properties Dialog

Label - Sets the label for the Range Axis.

Font - Sets the font style and size of the label.

Paint - Sets the color of the label.

Show tick labels - Displays labels next to the tick marks on the Range Axis.

Tick label font - Sets the font size and style of the tick labels.

Show tick marks - Displays tick marks, which extend just beyond the boundaries of the chart on the Range Axis.

Auto-adjust range - Computes the minimum and maximum values of the Range Axis automatically when checked. When unchecked, you
can enter in a minimum and maximum value to set the range. This option exists under the Range tab of the Other tab.

The Appearance tab has several options to change the appearance of the plot.



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 229 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Image 6: Appearance Tab in the Plot Tab of the Chart Properties Dialog

Outline stroke - Sets the chart outline stroke style.

Outline paint - Sets the color of the chart outline.

Background paint - Sets the color of the chart plot background.

Orientation - Sets the orientation of the chart.

The Other tab deals with general chart properties.

Image 7: Other Tab of the Chart Properties Dialog

Draw anti-aliased - Draws the chart using anti-aliased techniques to reduce distortion.
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Background paint - Sets the chart background color.

Series - Series and Series Outline options are not implemented at this time.

Chart Layout
When you have multiple charts, you can define different layouts for them using the View->Chart->Layout menu item. There are a number of pre-
defined layouts: Grid, Vertical, Horizontal, 2 Column, 3 Column, Tabs. The Grid Layout allows for much flexibility in how the charts are organized
and laid out. The View->Chart->Layout->Change Grid Layout menu item brings up the Grid Layout Editor:

Image 8: Edit Chart Layout Window

You can add/remove rows and columns with the  buttons. You can then drag the graphical representations of the charts to place them in the
grid. A chart can also span multiple rows or columns. This is done by grabbing the black square on one side of the chart image and dragging it to
change the row or column.

Menu Options
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to the Data Probe/Time Series display.

The File menu has these unique options

Export Current Time as CSV... - Exports the current time step's data or all times as a comma separated file (CSV) by selecting the File-
>Save menu.

Export All Times as CSV - Exports all times as a comma separated file (CSV).

The Edit menu has these unique options:

Change Display Format - Changes how the data is displayed in the table. This template is HTML with macros that get replaced with the
display value, unit, raw value and raw data unit.

Probe Color - Changes the color of the probe in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of your loaded Data
Sources.

The View menu has these unique options:

Parameters
Show Parameter Table - Displays the parameter table below the chart.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 231 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Show Readout in Legend - Displays a readout of the data in the Legend in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display.

Parameter - Allows you to copy the chart, open the Chart Properties dialog window, change the unit of the selected parameter, set a
sound, or remove the parameter.

Chart
Show Thumbnail in Legend - Displays a thumbnail version of the image in the Legend in the Main Display window.

Show Sunrise/Sunset Times - Displays sunrise/sunset times in the chart if applicable.

Layout - Opens the Edit Chart Layout window as well as the option to format the chart in several ways.

Chart - Allows for zooming, saving the chart, and the option to open the Data Probe Properties window.

Probe
Position - Controls how you can reposition the probe by preventing movement in the direction of certain axes. There is also an option
to reset the probe back to its initial position.

Color - Changes the color of the probe in the Main Display window.

Size - Increases or decreases the size of the probe in the Main Display window.

Probe Shape - Changes the shape of the probe displayed in the Main Display window.
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Ensemble Grid Controls
Overview
The Ensemble Grid feature in McIDAS-V allows you to create a plot of possible forecast scenarios from model data. This plot is produced by
adding a perturbation to the initial model solution, and by adding perturbations to every subsequent perturbation. Thus, each perturbation away
from the unperturbed initial model output theoretically diverges further from the initial model solution. These perturbations can be the result of
slightly different initial conditions or different physics utilized by the model. Ensemble Grid displays are a valuable tool for medium range weather
forecasting.

The Ensemble Grid controls are accessed through the Data Explorer window by selecting an ensemble run in the Data Sources tab, and then
defining the parameter to display and the output format in the Field Selector. You can also utilize McIDAS-V's ensemble formulas to display this
data.

Image 1: Ensemble Grid Data in the Field Selector Tab of the Data Explorer

By default, McIDAS-V displays all ensemble members. This can be changed in the Field Selector by selecting the Ensemble tab. You can select a
range of ensemble members with the Shift key, or individual ensemble members with the Ctrl key. The times used to display the data can be
changed in the Times tab. When displaying a 3D grid parameter, use the Level tab to select which level(s) to display. You can select a specific
region to plot the data with the Region tab, or select how many data points to plot with the Stride tab. Press  to plot the data in
the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GridFormulas__ensemble
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Image 2: Ensemble Grid Data Displayed in the Main Display Window

There are a variety of ways to customize the display once it has been plotted. These options can be found in the Layer Controls tab of the Data
Explorer.

Image 3: Ensemble Grid Controls

Properties

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ContourDialog__FILE
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Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Levels - Shows the current level being displayed. The dropdown menu lists the native grid levels. Click on one level value to reset the plan to
that level. The plan level in use is shown in the data's native altitude units. The Levels box is editable. Click in the box, enter a value and hit
Enter to set your own value. Additionally, you can click on the arrows to the right of the Levels box to switch levels, or click on the Cycle
checkbox to animate vertically through all available levels.

Ensembles - Displays the data colored with respect to the value of the plotted parameter when the Color by Member checkbox is checked.
When this box is unchecked, the individual perturbations for each time will be colored the same color, regardless of the value of the
parameter being displayed.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options that are unique to this display.

The Edit menu has this unique option:

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window.

The View menu has this unique option:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Main Display Window
The Main Display window within McIDAS-V contains:

A 3D view of the displays.
A Legend panel that shows information about the current displays.
A main menu bar and main toolbar that allow you to control the application.
A subsidiary view menu bar that is relevant to the 3D display.
Time animation display and control widgets.
Navigation toolbars.

This section describes:

Menu Bar
Main Toolbar
Drag and Drop Tabs
Display Menus
Properties Dialog
Visibility Animation
Time Animation
Legend
Modify the Color Bar Interactively
Status Bar
Zooming, Panning and Rotating
Transect Views

 
Image 1: McIDAS-V Main Display Window
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Menu Bar
The main menu bar shown at the top of the Main Display window has several different menus associated with it.

File Menu
Edit Menu
Display Menu
Tools Menu
History Menu
Bundles Menu
Window Menu
Help Menu

File Menu

New Display Window - Opens a new display window which can be a map or globe display with one to four panels. Other speciality displays
are also available.

New Display Tab - Adds a new display tab to your currently open display window. This tab can be a map or globe display with one to four
panels. Other speciality displays are also available.

Open File... - Opens an Open File window, that allows you to load a bundle into your session. There are four options you can use when
loading in a bundle:

Create new window(s) - Displays the bundle's data in a separate Main Display window without changing anything with your
previously existing Main Display window.

Merge with active tab(s) - Adds the a display of the bundle's data to your currently active tab in the Main Display window. This will
not remove any previously existing displays in the tab.

Add new tab(s) to current window - Adds tabs to your previously existing Main Display window to display the bundle's data. This
will not remove any previously existing displays in other tabs.

Replace session - Removes any previously existing displays, data, and tab/panel configuration to load the bundle in from scratch.

Save Favorite - Allows you to easily create a set of favorite bundles and readily access them through the Bundles menu. A favorite bundle
can also be used as the Default Bundle.

Save Bundle - Allows you to save the current application state as a bundle.

Default Layout - Allows you to manage the default layout of McIDAS-V. The default layout saves the window placement and the number of
tabs and panels.

Save - Saves the current layout as the default layout. This creates a layout.mcv file in your McIDAS-V directory.

Remove - Removes the currently saved default layout.

Note: Saving the default layout does not affect the maps displayed in each panel or the data loaded at the beginning of each McIDAS-V
session. Map defaults can be set in the Layer Controls tab of the Data Explorer in the Map Controls. To change map defaults, use the
File->Default Maps->Save as the Default Map Set menu item. Change the default projection in the Display Window tab of the User
Preferences window, or automatically load a Favorite bundle by selecting a default bundle in the Defaults panel of the Advanced tab
of the User Preferences window.

Exit - Exits McIDAS-V.

Edit Menu

Remove - Lets you choose to remove all layers, all data, or all layers and data from the main display.

All Layers and Data Sources - Removes all layers and loaded data sources.

All Layers - Remove all layers. This will remove any displays or items listed in the Legend of the Main Display window, but no data
will be removed.

All Data Sources - Removes all loaded data sources without removing any layers. This will retain the displays.

Preferences... - Opens the User Preferences window, allowing you to edit settings for McIDAS-V.

Display Menu
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The display menu contains facilities to create new displays.

Create Layer from Data Source... - Takes you to the Data Sources tab of the Data Explorer.

Layer Controls... - Takes you to the Layer Controls tab of the Data Explorer.

Add Range Rings - Creates a Range Ring display, with the initial position centered in the current projection.

Add Range and Bearing - Adds a Range and Bearing display to show the distance, azimuth, and back azimuth of a great circle line
connecting two positions on the Earth's surface. The initial position is near the center of the current entire map area. If you are zoomed in, the
range and bearing line may be off screen.

Draw Transect... - Opens the Transect Drawing Control window that allows you to view, create and modify transects for the Transect View.

Drawing Freely... - Opens the Drawing Control window which allows you to draw polygons, lines, shapes, and annotate McIDAS-V
displays.

Add Location Indicator - Creates a location indicator cross-hair on the display. See the Location Indicator Controls page for more
information.

Plot Location Labels - Lists a variety of point location plots that can be created: NEXRAD sites, state names, state locations, etc. This will
create a Location Control with the chosen location information.

Add Background Image - Adds a background image to the display that can be changed using the Web Map Server(WMS)/Background
Image Controls.

Reset Map Layer to Defaults - Resets the map layer to default, or redisplays the map if it has been deleted.

Tools Menu
This menu allows you to configure and edit different McIDAS-V resources.

Manage ADDE Datasets - Opens the ADDE Data Manager, which allows you to create and edit remote and local datasets.

Text Data - Allows you to to access local text products or ATCF storm data.

Weather Text Products (from server) - Shows the Weather Text Products window.

Weather Text Products (from NWX files) - Opens a window where you can load in GEMPAK tables.

ATCF Tropical Storm Data - Adds ATCF Storm Data as a data source in the Field Selector tab of the Data Explorer.

Color Tables - Opens the Color Table Editor, which allows you to view, create, and modify color tables.

Station Model Template - Opens the Station Model Editor, which allows you to view, create, and modify station models for plotting point
data.

Parameters - Contains items related to parameters in McIDAS-V. Parameters are used to determine how field names from different data
sources are read and interpreted into McIDAS-V.

Aliases - Opens the Parameter Alias Editor, which allows you to define aliases for parameters in data sets that McIDAS-V does not
know about.

Defaults - Opens the Parameter Defaults Editor, which allows you to define the default display conventions (e.g., color tables, ranges,
etc.) for parameters.

Groups - Opens the Parameter Groups Editor, which allows you to define the groups of parameters for use in derived data formulas.

Projections Manager - Contains items related to projections.

Edit Map Projections - Opens the Projection Manager, which allows you to choose, edit, and save map projections for use in
McIDAS-V.

Restore Saved View - Restores the previously saved view. This will list out various previously saved views and allow you to delete
previously saved views as well.

Delete Saved Views - Deletes a previously saved view.

Save Current View - Saves the current view. This does not include any layers that are loaded in, only the zoom level, projection, and
location. When you save a current view, you can apply a name to the viewpoint. This name will be used to list out the viewpoint under
the Projections menu of the Main Display as well as under Restore Saved View. Any saved viewpoints will be saved in the
viewpoints.xml file stored in the McIDAS-V directory.

Formulas - Contains items related to end user formulas.
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Create Formula - Opens the Formula Editor to allow you to create a new formula.

Edit Formulas - Gives a list of all current formulas to edit. Selecting a formula will open the Formula Editor with that formula entered
into the fields.

Jython Library - Opens the Jython libraries window.

Jython Shell - Opens the Jython Shell window.

Import - Imports a formula from a file.

Export - Exports a formula to a file. This opens an Export Formulas window that lists out all of the native formulas in McIDAS-V,
as well as any formulas you may have created yourself. The format of the file containing the formula is *.xml.

Plugins

Create... - Opens the Plugin Creator window, which allows you to create plugins.

Manage... - Opens the Plugin Manager window, which allows you to manage McIDAS-V plugins.

History Menu
This menu lists the recently accessed data sources and layers and allows you to easily load them. This includes data sources from your current
McIDAS-V session, and from previous sessions.

Bundles Menu
This menu lets you manage and load your favorite bundles.

Manage... - Brings up the Local Favorites Bundles Manager.

Favorite Bundles - Brings up the folders and list of bundles saved as favorites. Note that this menu item is only available if you have a
favorite bundle saved.

Window Menu
This menu lets you bring up the Data Explorer window and go back and forth between tabs.

Show Data Explorer - Brings the Data Explorer to the front.

Next Display - Brings the next display tab/window to the front. Note that this menu item is only available if you have more than one tab or
window open.

Previous Display - Brings the previous display tab/window to the front. Note that this menu item is only available if you have more than one
tab or window open.

Select Display... - Opens a Select Display window, which allows you to select which tab/panel you want to view. Note that this menu item is
only available if you have more than one tab or window open.

Help Menu
This menu allows you to view this User's Guide, show error messages, etc.

User's Guide - Opens the McIDAS-V User's Guide.

Getting Started - Opens to the Getting Started section of the McIDAS-V User's Guide.

Show Help Tips - Shows the McIDAS-V Help Tips window.

Show Console - Opens a Console window which has the error messages and other text output from McIDAS-V.

Show Support Request Form - Opens a Request McIDAS-V Support window that allows you to post support requests to the McIDAS Help
Desk.

Visit Online Forums - Brings up the McIDAS-V Support Forums in your default browser.

Check for new version - Checks to see if your current version of McIDAS-V is up to date.

Check for new notice - Checks to see if a new notice about McIDAS-V is available.

Release Notes - Displays the Release Notes for this version of McIDAS-V.

About McIDAS-V - Gives information about your version of McIDAS-V.
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Main Toolbar
Below the main menus you will find the main toolbar of the Main Display window.

 
Image 1: Main Toolbar (Default)

Many of the more commonly used features of McIDAS-V can be accessed here. Hold your mouse over a toolbar button to get a popup tip on what
that button does. The main toolbar is user configurable. Right-click on the toolbar to change the icon sizes and select "Customize..." to open the
User Preferences' Toolbar Options tab where you can add, remove, and change the position of the buttons in the toolbar.

You can also undock the main toolbar from the Main Display window by left-clicking and dragging the textured area on the left side of the toolbar.
This will place the main toolbar in its own window. To dock the toolbar back into the Main Display window, click the 'x' in the toolbar's window.
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Drag and Drop Tabs
McIDAS-V has drag and drop tabs which allow you to organize multiple tabs and windows.

 
Image 1: Drag and Drop Tabs in the Main Display Window

Drag and drop tabs allow you to separate tabs into individual windows, combine windows into tabs, as well as reorganize the layout of tabs in a
window. Drag tabs into separate windows by using the left-click and drag option to drag the tab outside of the Main Display window. When the last
tab in a window is moved into another window, the window will disappear. When tabs are rearranged or added from a different window, green
arrows will point to the location the new tab will be placed.

Rename the tab by double clicking on it. Close a tab by clicking on the  on the right side of the tab. Closing a tab will remove all layers associated
with the display, but will not remove the data sources.



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 242 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Display Menus
The View and Projections menus are associated with the 3D display and are located in the Main Display window.

View Menu
Projections Menu

View Menu
The View menu lists the displays shown in this window, allows you to change the point of view, capture images and movies, and make some other
changes to the overall display.

Displays - Controls many basic aspects of the Main Display window.

Hide/Embed Legend - Removes the Legend and docks the Legend back to the Main Display window.

Float/Embed Legend - Floats the Legend in a separate window and docks the Legend back to the Main Display window.

Remove All Displays - Removes the displays shown in this view. While the display is removed from the Main Display window, the
data is still in the Field Selector tab of the Data Explorer.

Visibility Animation - Cycles through the visibility of each layer, showing one at a time. Click the checkbox on to start animation and
check it off to stop. You can increase or decrease the speed with the provided Faster and Slower choices.

Capture - Captures the current view as an image, sends it to a printer, or captures a movie. See the Image and Movie Capture page for more
information about available image and movie types.

Show - Allows you to turn on or off different flags relating to the display.

Wireframe Box - Displays the white wireframe box around the area of interest in the display. This wireframe box is useful for
navigating in the 3D.

"Please Wait Message" - Shows the please wait message on the bottom left of the Main Display window when McIDAS-V is loading
data.

Display List - Lists the names of products you are displaying at the bottom of the Main Display window.

Clip View At Box - Shows only the background map and data in the area inside of the Wireframe Box.

Cursor Readout - Displays the Latitude, Longitude, and Altitude at the location of the mouse over the Main Display window without
having to probe the data with the middle mouse button.

Display Scales - Adds a scale to the edge of the Wireframe Box.

Times In View - Lists the time and time step at the bottom of the Main Display window for each image.

Overview Map - Adds an overview map to the Legend, showing the area where you are viewing in the Main Display window.

Earth Navigation Panel - Adds an Earth Navigation panel to the bottom of the Main Display window. You can use the arrows to
navigate through space, or enter in an address in the Go To Address field.

Logo - Shows/hides a logo that was added through the Properties dialog.

Viewpoint - Allows you to change your point of view.

Top View through West - Sets the point of view to one of the orthogonal directions.

Perspective View - Provides an alternate 3D view of the display. The default is a parallel projection.

Viewpoint Dialog - Shows a dialog box for you to enter the azimuth and tilt of a desired point of view. Azimuth is from North,
clockwise to 360 degrees. Tilt is degrees down from overhead, vertical.

Vertical Range - Shows a dialog box to set the vertical scaling between the top and bottom of the wire frame box. The scale is linear.
You can specify the units for the max and min values. Units must be convertible with meters (e.g., km, ft, fathoms, etc).

Auto-Rotate View - Turns on/off an automatic rotation of the display.

Color - Changes the background and foreground colors of the display (not the map lines) to the selected colors. When setting your own
colors you can also save off the chosen color pair as a named predefined color pair which will appear in the list.

Full Screen - Shows the current view in full screen mode.

Animation Timeline - Shows the Animation Timeline

Flythrough - Allows the user view the data in the Main Display window from the perspective of an airplane dashboard. The gauges on the
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dashboard will represent the probed values of the data on the map at the location of the airplane. This is an IDV tool, and more information
about this feature can be found in the IDV User's Guide.

Properties - Opens the Properties dialog for the view. Allows you to set aspect ratio, vertical scale, flags, color, etc.

Projections Menu
The Projections menu lets you change the map projection in the 3 dimensional display.

Predefined - Contains the list of pre-defined projections you can choose from, including both system-supplied and your own projections.

From Displays - Lists the native data projections of any data added to the tab.

Viewpoints - Allows you to define, select, or delete saved viewpoints.

History - Lists the projections that have been used in this tab. This allows you to easily revert back to a previously-used projection.

New/Edit - Opens the Projection Manager dialog to view, create and edit projections.

Use Displayed Area - Maintains your current projection and viewpoint, but wraps a wireframe box around the region you are zoomed in
over.

Go to Address - Changes the projection to a given address, zip code, city, etc.

Image 1: Go To Address Dialog

The formats include:
12345 oak street, my town, my state
my town, my state
80303 (zip code)
latitude longitude
"ip" for the location of this computer

Auto-set Projection - Toggles the behavior of automatically setting the projection to the projection of the most recent display that has been
added. When checked on, the map projection will be automatically switched to match the native projection of the newest data source added.
When checked off, the current map projection will remain for any additional data source added to the display. This may be desirable when
you have set up a view of a particular area and want to retain it when displaying new data.

Share Views - Controls whether Sharing is turned on or off for this view. If sharing is turned on then the view point and projection changes
are shared with any other views that also have sharing turned on. This is used if you have multiple panels in the same tab.

Set Share Group - Enables you to select different share groups for multiple panels. Note that the Share Views option must be checked on for
this to work.
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Properties Dialog
Accessed through the View->Properties menu item in the Main Display window, this Properties dialog allows you to control many aesthetic
aspects of the display. The Properties dialog window is composed of five tabs: Main, Aspect Ratio, Lighting, Vertical Scale, and Horizontal
Scale. If you are working with a globe display, there is no Horizontal Scale tab, but there is an additional tab for Globe Background.

Main
Aspect Ratio
Lighting
Vertical Scale
Horizontal Scale
Globe Background

The Main tab of the Properties dialog allows you to change several general settings pertaining to the display. Many of the items in this tab can also
be found in the Display Window tab of the User Preferences window.

Image 1: Main Tab of the Properties Dialog

Properties

Name - Sets the name of the panel. This name will be centered between the Projections menu and the Time Animation Widget.

Show Wireframe Box - Toggles the visibility of a 3D wireframe box around the data. This box helps provide orientation in 3D views.

Show Times In View - Turns on the label shown inside the Main Display window that shows the current animation time and step in the loop.

Show Logo - Adds a logo to the Main Display window. The logo is set at the bottom of this dialog.

Show Cursor Readout - Displays a label of latitude, longitude, and altitude at the cursor position over the display, shown in the lower border
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of the Main Display window without having to probe the data.

Show Display Scales - Adds a vertical scale, as well as latitude and longitude values to the wireframe box in the Main Display window.

Perspective View - Provides an alternate 3D view of the display. This sets the 'set parallel/perspective projection' option in the Viewpoint
Toolbar of the Main Display window.

Show Earth Navigation Panel - Shows an Earth Navigation panel at the bottom of the Main Display window.

Share Views - Controls whether sharing is turned on or off for the display. If sharing is turned on, then the viewpoint and projection changes
are shared with any other displays that also have have sharing turned on.

Show "Please Wait" Message - Displays a "Please Wait" message in the bottom toolbar of the Main Display window when McIDAS-V is in
the middle of a process.

Clip View At Box - Allows the user to omit from view all display elements outside of the wireframe box. This is helpful to remove map lines
outside the area of data.

Show Display List - Shows a listing of the names and times of the displays in the Main Display window.

Auto-set Projection - Changes the projection to match the native projection of the newest data source added. When checked off, the current
map projection will remain unchanged for any additional data source added to the display. This may be desirable when you have set up a
view of a particular area and want to retain it when displaying new data.

Auto-rotate - Turns on/off an automatic rotation of the display.

Show Overview Map - Adds an overview map to the Legend, showing the area where you are viewing in the Main Display window.

Show Globe Background - Turns on/off the globe background. Turning it on makes a globe background by filling a solid color on the
surface of the globe; off removes the background by making it 100% transparent. This option is present only with Globe Displays.

Colors - Changes the background and foreground colors of the display (not the map lines) to the selected colors.

Display List - Controls how the list of the layers you are displaying at the bottom of the Main Display window will be written. You can
modify the font, style, size, and color.

Full Screen Dimensions -

Width - Sets the width of the display when in full screen mode. Set this value to 0 or leave blank for the standard full screen display.

Height - Sets the height of the display when in full screen mode. Set this value to 0 or leave it blank for the standard full screen
display.

Logo -

Screen Position - Selects the location of the logo in the Main Display window. The options are Lower Left, Upper Left, Upper Right,
Lower Right, and Center.

Offset - Adds an offset of the logo from the screen position selected. This is in the format of (X,Y).

Scale - Scales the size of the logo in the Main Display window. Use the slider to change this value. A value of 1.0 uses the full size for
the image, values below 1.0 make the image smaller, and values greater than 1.0 make the image larger.

The Aspect Ratio tab of the Properties dialog allows you to change the aspect ratio of the display with respect to the X, Y, and Z directions. You
can change the individual X, Y, and Z values by using the slider. Any changes will be made to the display once you hit Apply or OK. The Display
Matrix Settings panel will actively update as you change the X, Y, and Z values, and as you rotate or zoom in/out of the Main Display window.
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Image 2: Aspect Ratio Tab of the Properties Dialog

Properties

 - Resets the X, Y, and Z values back to the last values applied to the image. If you have not yet hit Apply, then the values will
return to default.

X - Stretches the display along the X-axis. The higher the value, the more stretched in the east-west direction the display will be. The default
value for this is 1.0.

Y- Stretches the display along the Y-axis. The higher the value, the more stretched in the north-south direction the display will be. The
default value for this is 1.0.

Z - Stretches the display along the Z-axis. The higher the value, the more stretched in the vertical the display will be. The default value for
this is 0.4.

Display Matrix Settings - Displays information pertaining to the rotation, translation, and scale of the X, Y, and Z axes. This also displays
numerical values pertaining to boundaries of the Main Display window and also the wireframe box. These values actively change as you
apply changes to the X, Y, and Z sliders, and as you rotate or zoom in/out of the Main Display window.

The Lighting tab of the Properties dialog allows you to add the effect of light shining on your display from different angles along the X, Y, and Z
axes. The default values are listed in the image below.
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Image 3: Lighting Tab of the Properties Dialog

Properties

Left Column - Denotes the direction that the light will be shining from. You can uncheck the checkboxes in order to not add lighting for
specific directions.

Slider - Controls the intensity of the light. When the slider is on the far left, there is no light, and the brightness increases as you move the
slider to the right.

Direction - Represents the direction that the light will be coming from. The first box is from the X direction, with positive values aiming the
light right along the X-axis. The second box is from the Y direction, with positive values aiming up along the Y-axis. The third box is from
the Z direction, with positive values aiming up along the Z-axis.

 - When this is button is seen, all of the components in this tab are controlled individually. This means that a change to one item (ex.
Over), will not effect any of the other items in this tab. When you click this button, the image will change to . When this image is seen, the
components are linked together. Therefore, any change to the visibility checkboxes or the slider for brightness will be shared between all
components of this tab.

The Vertical Range tab of the Properties dialog allows you to change the vertical scale used for the Z-axis of the display in the Main Display
window.

Image 4: Vertical Range Tab of the Properties Dialog

Properties

Min value - Sets the minimum vertical value to use for the Z-axis in the Main Display window. The default value for this is 0.

Max value - Sets the maximum vertical value to use for the Z-axis in the Main Display window. The default value for this is 16,000.
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Units - Sets the units used for the vertical scale in the Main Display window. The default value for this is 'm' for meters.

Visible - Sets the vertical scale labels along the wireframe box as visible.

The Horizontal Scale tab of the Properties dialog allows you to set the visibility and properties of the latitude/longitude labels along the outside of
the wireframe box.

Image 5: Horizontal Scale Tab of the Properties Dialog

Properties

Label - Sets the label along the latitude/longitude axes. The default values are "Latitude" and "Longitude".

Base - Sets the lowest numerical value of latitude/longitude that will be plotted.

Major Increment - Sets the spacing in degrees of the labels along the latitude/longitude axes. There are also large tick marks drawn along
the wireframe box at this increment.

Minor Division - Sets the number of minor divisions, denoted by small tick marks, between the Major Increment tick marks. The default
value for both Latitude and Longitude is 1, meaning that there is one division between major increment tick marks, so there will be no small
tick marks between them. A value of 2 will place one small tick mark between the major increment tick marks, a value of 3 will place two
small tick marks between the major increment tick marks, etc..

Visible - Sets the latitude/longitude labels along the wireframe box as visible.

Format - Sets the format of the latitude/longitude Major Increment labels. You can change the structure of the labeling to show degrees out
to various decimal values, latitude/longitude labels in DMS (Degrees, Minutes, Seconds) format, and include a label for hemisphere (N, S, E,
W) by choosing a Format value with an H at the end.

0-360 Longitude - Uses a 0-360 degree range for the labeling of the Longitude's Major Increment. The default is to have this checkbox
turned off, which uses a -180-180 degree range.

Font - Sets the Font, Style, and Size of both the Major Increment labels for latitude and longitude, as well as the Labels.

The Globe Background tab of the Properties dialog allows you to set the color and the vertical positioning of the globe background. Note that you
must have the Show Globe Background option in the Main tab of the Properties dialog selected to use the globe background. This tab is only
available if you are using a Globe Display.
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Image 6: Globe Background Tab of the Properties Dialog

Properties

Color - Sets the color of the globe background.

Level - Sets the vertical positioning of the globe background. The default value here is -0.01 so it is just below the surface of the earth,
making map lines visible. You can change this value by using the slider or by entering a value into the field and pressing Enter.
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Visibility Animation
In the Legend of the Main Display window, the Layer Visibility checkbox to the left of each layer's label can be used to toggle the visibility of that
layer. This checkbox can also be selected in the item's Layer Controls tab by selecting View->Visible. Visibility animation cycles through the
visibility of each layer, showing them one at a time. This is not a time animation loop; it loops through the visibility of the layers present in the
Main Display window.

The padlock icon  on the right side of each layer in the Legend is used to block the effects of the visibility animation described above. When
locked ( ), the visibility of the layer is not affected by the animation.

Visibility Animation can be invoked via the Layer Visibility Animations button. You can add this button to your main toolbar in the Toolbar
Options tab of the User Preferences window.

Image 1: Animate Visibility Window

Properties

 - Begins layer visibility animation. Click this button again to stop the animation.

 - Makes the layer visibility animation loop slower.

 - Makes the layer visibility animation loop faster.

Dwell (s) - Corresponds to the dwell rate of the layer visibility animation, or how long (in seconds) each layer is displayed before cycling to
the next layer.

You can also access this tool in the Main Display window through the View->Displays->Visibility Animation menu item. In this menu, you can
turn visibility animation on/off, and change the speed of the animation.

As an alternative to the Layer Visibility Animations tool, the function keys F1, F2, F3* can be used to cycle visibility as follows:

The F1 key cycles visibility through all non-locked layers, looping through each layer one at a time.

The F2 turns on all non-locked layers.

The F3 turns off all non-locked layers.

*On a Mac laptop, you may need to press the "Fn" key along with the particular function key.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Legend__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ToolbarPreferences__FILE
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Time Animation
Time Animation Widget
Time Animation Properties Dialog
Define Animation Times Tab

Time Animation Widget
Each McIDAS-V display area has a set of time animation controls above the Main Display window.

Image 1: Time Animation Widget

The Time Animation Widget controls looping of displays through time. A series of small green boxes is displayed representing each frame of the
animation. The box corresponding to the current time is colored blue. Click on a box to select a different time. Right-click on a box to disable that
frame in the animation. Disabled boxes will be colored red. You can also Ctrl+left click on a box to turn on/off all of the frames to the left of the
box you clicked on, and Shift+left click to turn on/off all of the frames to the right of the box you clicked on.

The time of the data is displayed in the labeled pull-down list and in the entries of the pull down list on the left. Holding the mouse over the time
will show information about how many frames are in the loop, and what the starting and ending times are. The toolbar of button icons, on the right,
control time animation. The Time Animation Widget buttons do the following:

 Beginning - Shows the first frame, and stop looping if looping is on.

 Back One - Steps back one frame.

 Play/Stop - Toggles looping on or off.

 Forward One - Steps forward one frame.

 End - Shows the last frame, and stop looping if looping is on.

 Properties - Shows the Time Animation Properties dialog box.

Time Animation Properties Dialog
Click on the  in the animation controls to see the Time Animation Properties Dialog box. This dialog has two tabs: Settings and Define
Animation Times.

The Settings tab allows you to define how looping will work for your display:

Image 2: Settings Tab of the Time Animation Properties Dialog

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animation
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animationprop
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animationset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__animationprop
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By pressing  or , you will set the properties in the Animation Widget. If you have the Save As Default checkbox checked, then
the properties will be saved and used every time a new Animation Widget is created. For example, you may find that you are always setting the
dwell rate to a particular value. You can save that state as the default state for all Animation Widgets that are subsequently created, both in the
current run of McIDAS-V and in future runs.

Properties

Dwell - Controls how fast the animation occurs. Click on the slider icon:  to change the values or type a value into the field and press
Enter. Values are seconds/frame.

Forward - Controls speed of looping forward.

Reverse - Controls speed of looping backwards.

First - Chooses how long first frame is seen.

Last - Chooses how long last frame is seen.

Direction - Controls which direction the loop goes when you press play.

Forward - Loops forward in time

Backward - Loops backward in time

Rocking - Alternates looping between forward and backward directions.

Share Times - Shares the time animation in a display with the animation in other displays with the Share Times button. See the Sharing
page for more information.

None - Does not share any times with any other displays.

Absolute - Shares absolute times with other displays.

Relative - Shares relative times with other displays.

Group - Allows you to share certain time animations, while not sharing with others. You can set up to four different share groups.

Skip Steps - Works the same as in the Main Display window, you can right click on a square to make that time step not visible in a loop. The
Boxes visible checkbox enables the time animation boxes to be visible in the Main Display window.

Reset To - Determines which time step will be displayed when the time set changes.

Start Time - Returns to the first time step when the time set has changed.

No Change - Remains at the time step you were at when the time set has changed.

End Time - Displays the final time of the loop when the time set has changed.

Define Animation Times Tab
The Define Animation Times tab allows you to define a custom animation time set:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Sharing__FILE
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Image 3: Define Animation Times Tab of the Time Animation Properties Dialog

By default, the times used in the animation time set are all of the times from the data that is being displayed. However, you can define your own
time set by selecting the Define your own list of times button.

You define how to determine the start time, end time and a time interval. The time interval is used to create the set of time steps (inclusive) between
the start and end times. The start time and end time modes are determined one of four ways:

Use Minimum/Maximum Time from Data - Sets the beginning/end of the loop to be the minimum/maximum times included with your
data.

Current Time (Now) - Sets the animation time set to use the current clock time. This is useful for animation of real time data. If you select
this option you can then define how often the animation set is updated with the Refresh Rate field. The Round To field allows you to
specify a rounding factor.

Fixed - Allows to you to specify a fixed date/time to start/end the loop.

Relative to End/Start time - Allows you to specify the beginning/end of your loop at a time relative to the end/beginning time. For example,
you could set the end time to be the Current Time, and set the start time to be relative to the end time minus 1 hour (using the start time offset
field). This would have a loop of data over the last hour, with a time step as defined in the interval field. Note: You cannot have start and end
times both be relative to one another.

Once you select the start and end time modes you can define an offset which is added (or subtracted) to the base time. To change the offset select
the  button. When you do this the Offset dialog will be shown:

Image 4: Set Round To Value Dialog

This allows you to define a time offset by entering years, days, hours and minutes. Note that this Offset dialog will also include a +/- option when
selected from Start Time or End Time.

The  button gives you another way to adjust the items in the Define Animation Times tab. The two options from this button are
Uniform Across Data Range and Real Time.
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Uniform Across Data range - Opens a Uniform Data Range window, which allows you to control the Interval.

Image 4: Uniform Data Range Window

Real Time - Opens a Real Time window, which allows you to control the length of the loop, the length of each time step, and how often the
data is updated.

Image 5: Real Time Window
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Legend
The Legend in the Main Display window lists the set of Layer Controls within that view. The Legend can be floated from the Main Display
window. This is done with the  Float Window button (the  Embed Window button will move the Legend back into the Main Display
window).

 
Image 1: Side Legend in the Main Display Window

The Legend shows each layer under the Layer Category of that display. For example, the Legend in the above image shows the categories "Maps",
"Radar Displays", and "Plan Views". The Layer Category may be changed. This is useful for grouping and controlling the visibility of a group of
layers.

The Legend Label shows the parameter or Field name, the display type, and sometimes other information such as the level of a plan view or value
of an isosurface. The label may be changed using items under the Edit->Properties menu item. Clicking on the blue, highlighted part of the label
will bring up the Layer Controls tab of the Data Explorer. Right-clicking will allow you to open the Layer Controls tab for that parameter, or
access the menu options in the Layer Controls tab.

Each layer category within the Legend can be toggled to show or hide the layers under that category with the Toggle Category button. The
visibility of the layers under a category (e.g., Radar Displays, Plan Views, etc.) can be changed with the Category Visibility checkbox. The
visibility of an individual layer can be changed with the Layer Visibility checkbox.

The  Remove button quickly removes a layer. The  Visibility Toggle Lock "locks" the current visibility of the layer and does not change it
while cycling visibilities.

Detailed information about a layer may also be shown in the Legend. For example, for those layers that use a color table, the color bar will also be
shown in the Legend. Moving the mouse over the color bar shows intermediate values. Right-click on the color bar to open the Color Table Editor,
change the range, select other color tables, etc. You can also modify the color bar interactively for each display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayVisibility__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE
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Modify the Color Bar Interactively
Click the color bar in the Legend to interactively modify the color bar. Holding the cursor over the color bar shows the interactive color bar editor
instructions.

 
Image 1: Interactive Color Bar Editor

These controls are activated once the color bar is clicked on in the Legend.

Right-clicking on the color bar will open a drop-down menu with an option to open the Color Table Editor, change the range of the color,
change the color bar to a different saved color bar, etc.

Ctrl+R will revert the color bar back to its initial range after modifications have been made to it.

The Right arrow shifts the range of the color bar up, raising both the upper and lower bounds.

The Left arrow shifts the range of the color bar down, lowering both the upper and lower bounds.

The Up arrow expands the range of the color bar by lowering the lower bound and raising the upper bound.

The Down arrow shrinks the range of the color bar by raising the lower bound and lowering the upper bound.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 257 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Status Bar
At the bottom of the Main Display window is a status bar. This bar is useful for seeing how much memory has been used, the current time, what
McIDAS-V is doing, as well as the value of the parameter probed in the Main Display window. You can change the panel on the left back and forth
between displaying time or memory by left-clicking on the time or memory that is currently being displayed.

Time

Image 1: Time Readout

The time displayed in the left panel of the status bar is not the time associated with the data you have loaded into McIDAS-V, but rather the current
time in GMT.

Memory

Image 2: Memory Readout

The memory displayed in the left panel of the status bar is in the format of (Currently used memory)/(Max used memory thus far in the
session)/(Max memory available for McIDAS-V to use) in MB. You can change the amount of memory allocated by McIDAS-V at startup in the
Advanced tab of the User Preferences window. When McIDAS-V has used up the majority of its available memory, the memory panel of the status
bar will turn pink and then red. This will cause McIDAS-V to slow down, and may eventually prevent new data sources from being loaded. You
can mitigate this problem by right-clicking on the memory and selecting: . This will clear out some memory so you can still
work efficiently in your current session.

Messages

Image 3: Messages Readout

To the right of the Time/Memory readout panel is a Messages readout panel that tells you what McIDAS-V is doing. If no data is being loaded or
no data sources are being loaded into McIDAS-V, this panel will be reserved for displaying the Latitude, Longitude, and Altitude information at the
location of your cursor over the Main Display window. In the example above, a Grids data source is being loaded from an OPeNDAP server. If you
are loading data into McIDAS-V as a loop, the middle message panel will list the data source name and also indicate how much data has loaded. To
the right of this message is a loading panel. When data is loading into McIDAS-V, you will see this blue bar move from side to side. When
McIDAS-V is completing various processes, different messages may be overlaid on top of this loading bar, including "Reading Data" and "Creating
Layers".

Probe Readout

Image 4: Probe Value Readout

As a default in the Navigation Controls tab of the User Preferences window, holding down the middle mouse button over your display will probe
the data and give a numerical readout of your displayed parameter(s). The probe value(s) will be listed at the bottom of the Probe Readout panel.
This panel also lists the location of your mouse when you probe the data with respect to Latitude and Longitude. As a default, this panel will list
your data source and the display type. You can change how your data source will be labeled in this panel by right-clicking on the item in the
Legend, and going to Edit->Properties.... In the Settings tab of this Properties dialog, you can change the Legend Label to say anything, including
adding macros to further customize the readout in this panel.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__FILE
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Zooming, Panning and Rotating
There are several methods to zoom, pan, and rotate in McIDAS-V. You can use the mouse, the arrow keys, a rubber band box, or the Zoom/Pan
Toolbar. To reset to the initial base viewpoint use the key combination Ctrl+R.

Note: You need to click in the Main Display window when using key combinations.

Note: If you are using an Apple Mac with a single button mouse, see Apple Mac One Button Mouse Controls.

Zooming Panning Rotating
Mouse

Shift-Left Mouse Drag: Select a region by
pressing the Shift key and dragging the left
mouse button (MB1). 
Shift-Right Mouse Drag: Hold Shift key and
drag the right mouse button (MB3). Moving up
zooms in, moving down zooms out.

Ctrl-Right Mouse Drag: Hold Control key and
drag right mouse to pan.

Right Mouse Drag: Drag right mouse to rotate.
This works for a globe display.

Scroll Wheel
Scroll Wheel-Up: Zoom out. 
Scroll Wheel-Down: Zoom in.

 Ctrl-Scroll Wheel-Up/Down: Rotate
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: Rotate
forward/backward clockwise.

Arrow keys
Shift-Up Arrow: Zoom in. 
Shift-Down Arrow: Zoom out.

Ctrl-Up arrow: Pan down. 
Ctrl-Down arrow: Pan up. 
Ctrl-Right arrow: Pan left. 
Ctrl-Left arrow: Pan right.

Left/Right Arrow: Rotate around vertical axis. 
Up/Down Arrow: Rotate around horizontal
axis. 
Shift-Left/Right Arrow: Rotate
clockwise/counter clockwise.

The default mouse and keyboard controls can be customized using the User Preferences window's Navigation Controls tab by selecting Edit-
>Preferences from the main menu.

Apple Mac One Button Mouse Controls
Mouse controls are a bit more challenging if you are running McIDAS-V on a Mac with a single mouse button. The typical left mouse button
(MB1) functions are done with a click of the button. Right mouse options (MB3) are simulated using the Option key with a mouse click. Use the
following:

Option + click to rotate
Shift + Option + click to zoom

There is no replacement for the mouse panning actions on the Mac. Use the keyboard arrow functions or the Viewpoint toolbar instead.

The Viewpoint Toolbar
The Viewpoint Toolbar allows you to quickly switch between different viewpoints, change the perspective of the display, and add rotation.

 Rotate to top viewpoint - Rotates the display to a view from the top, looking down along the z-axis.

 Rotate to bottom viewpoint - Rotates the display to a view from the bottom, looking up along the z-axis.

 Rotate to north viewpoint - Rotates the display to a view from the north, looking down along the y-axis.

 Rotate to east viewpoint - Rotates the display to a view form the east, looking left along the x-axis.

 Rotate to south viewpoint - Rotates the display to a view from the south, looking up along the y-axis.

 Rotate to west viewpoint - Rotates the display to a view from the west, looking right along the x-axis.

 Set parallel/perspective projection - Maintains the selected viewpoint, and adds the more of a perspective of working in a 3D space.

 Rotate to a user specified view - Opens a Viewpoint Settings window, where you can enter numerical values for Azimuth from North
and Tilt down from top. This allows you to set a viewpoint without having to navigate through the display to get to it.

 Set the vertical range - Opens a Vertical Range window, which allows you to set the vertical scale (height) of the wireframe box in the
Main Display window, as well as the units to utilize. This feature is useful when working with a 3D display to either make features stand out
more or less.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Navigation__mac
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 Auto-rotate - Rotates the display. Right click on this icon to select which direction to rotate the display and to set a speed for the rotation.

The Zoom/Pan Toolbar
The Zoom/Pan Toolbar assists in navigating the 3D space.

 Zoom in - Zooms in on the display, towards the center of the Main Display window.

 Zoom out - Zooms out of the display, away from the center of the Main Display window.

 Rest display projection - Undoes any zoom, translation and rotation done to the display.

 Translate left - Shifts the display to the left.

 Translate right - Shifts the display to the right.

 Translate up - Shifts the display up.

 Translate down - Shifts the display down.

The Undo/Redo Toolbar
The Viewpoint Undo/Redo buttons allow you to undo/redo any zoom/pan/rotation/projection change made to the display. Note that you can hold
down Shift and click these buttons to go forward/back 10 changes at once.

 Undo the viewpoint/projection change - Undoes the last change to zoom level, pan, rotation, or change in projection made to the
display.

 Redo the viewpoint/projection change - Redoes the last event that was undone with the Undo the viewpoint/projection change button.
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Transect Views
The Transect View is a 2-Dimensional display that shows data along a transect line. This type of view can be created through the File->New
Display Tab(Window)->Transect Display menu item in the Main Display window.

 
Image 1: Transect View of Wind Speed

The left vertical axis shows altitude in meters, the right axis shows pressure levels. The bottom horizontal axis shows distance along the transect.
The top horizontal axis shows the latitude and longitude locations of the end points of the transect line drawn in the map display. You can zoom and
pan in this display with the normal key and mouse combinations. The transect display will also be duplicated in the Layer Controls tab of the Data
Explorer.

To work with a transect display, you must have two tabs/windows open. One of these tabs/windows must have the transect display, and the other
must have a standard map display. To control the location of the transect, in the transect display tab, select Transects->Edit. This creates a
Transect Drawing Control in the map display. Using the Create a transect Mode, click and drag in the map display to draw the transect. The
transect drawn in the transect display will be representative of the most recent transect line you have drawn. You can also select any of the pre-
defined or user created transects from the Transects menu of the transect display.

In the Transects tab of the Properties dialog for the Transect View (from View->Properties menu item in the transect display window/tab) you
can define a maximum distance to show. Normally, data that lies with the bounding lines that are orthogonal to the transect line is shown in this
display. The max distance gives a display radius. Data that lies past this max distance is not displayed.
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Display Controls
This section contains information about the different display controls that you can utilize in McIDAS-V. All of these display controls can be found
in the menus of the Main Display window.

Range Ring Controls
Range and Bearing Controls
Transect Drawing Controls
Drawing Controls
Location Indicator Controls
Web Map Server(WMS)/Background Image Controls
Quicktime Movie Controls
Image and Movie Capture Controls
Timeline Controls
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Range Ring Controls
Overview
The range rings control displays a set of concentric circles labeled by distance from the central point, with radial lines, useful for judging distance
and angle from a geographic location. You display range rings from the Main Display window with the Display->Add Range Rings menu item.
Range rings are often used with radar imagery, but they can be used with any data. The control window is composed of two tabs: Location and
Settings.

The Location tab allows you to specify the location to center the range rings:

Image 1: Location Tab of the Range Rings Properties Dialog

Properties

Location - Displays range rings centered at the location chosen in the drop-down menu.

Center - Centers the rings at the entered lat/lon values. Note: West longitudes are negative.

Position at click - Centers range rings where you left-click in the Main Display window.

Vertical Position - Sets the vertical position of the range rings with respect to other data being displayed. This can be changed by dragging
the slider or typing in a value and pressing Enter.

The Settings tab allows you to control how the range rings are displayed:

Image 2: Settings Tab of the Range Rings Properties Dialog

The range rings are oriented with local north-south on the displayed map projection. In some cases, the eastward radial line may not be horizontal.
The range rings will appear centered on the map projection. You can move the range rings by resetting the latitude-longitude or the station.
McIDAS-V can display multiple range rings at once and at any location.

Properties

Visible - Toggles the visibility of the range rings, labels, and radials on and off with the Visible checkboxes. To toggle the entire range ring
display at once, use View->Visible checkbox menu item.

Spacing - Sets the ring spacing, label spacing, and the azimuth interval of the radials using the control window. The values appear in the text
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fields under Spacing. You can give new values two ways: enter a new value in the text field and press Enter, or click on the pull-down arrow
on the right side of the text field to see a list of common values.

Max. Radius - Sets the maximum radius of the range rings from the center location.

Unit - Determines the unit that is used for the numerical values in the Spacing and Max. Radius fields.

Color - Sets the color of the range rings, radials, and labels.

Line Width - Sets the width of the range rings, radials, and labels.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Set Locations - Allows the user to select a specific location, radar site, earthquake location, etc. to center the range rings about.
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Range and Bearing Controls
Overview
The Range and Bearing Controls show the distance, azimuth, and back azimuth of a great circle line connecting two positions on the Earth's
surface. This feature can be found in the Main Display window in the Display->Add Range and Bearing menu item.

Image 1: Range and Bearing Properties Dialog

When the range and bearing controls are first created, a range and bearing line is added to the Main Display window. The distance, azimuth, and
back azimuth values are shown on the Legend and at the top of the Range and Bearing control window. The latitude/longitude position values of the
endpoints are shown in the control window. Computations are based on the WGS-84 reference ellipsoid, using computation code from the U.S.
National Geodetic Survey. You can reposition the endpoints by left-clicking and dragging them in the Main Display window, entering new values
into the Latitude/Longitude boxes in the control window and pressing Enter or clicking , or selecting a location in the dropdown menu to the
right of the Latitude and Longitude fields.

Note The line shown on the display is not the great circle path connecting the end points. The values are computed for a great circle path on the
ellipsoidal Earth, using the numerical latitude and longitude values, not the line on the display. The line shown in the display is a straight line on
whatever map projection you happen to have; usually it will not coincide with the great circle line.

Note If you change the map projection, an existing range and bearing map line will stay at the same location in the display, hence the end points on
the map are in new locations. The distance, azimuth, etc. values in the control window reflect the latitude-longitude positions in the control window
and hence do not match the display picture until an end point is moved by hand.

Properties

End Points - Represents the latitude and longitude values of either end point of a line. Click in the text window of "From:" or "To:" as to
which values you want to save. Clicking  or pressing Enter will move the endpoint of the line to the new position, and show the new
distance and azimuth values. You can also select locations from the dropdown menus. By default, this dropdown menu lists out states. You
can change this through the Edit->Set Locations menu item, where you can change the items in this list to be cities, radar sites, etc.

Vertical Position - Changes the vertical position of the data transect line with respect to other variables being displayed in the Main Display
window. This can be changed by using the slider or typing a value into the field and pressing Enter.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple options that are unique to this display.

The Edit menu has these unique options:

Set Locations - Changes the items in the "--Select a location--" dropdown menus to be a specific location, radar site, earthquake location, etc.

Selector Color - Changes the color of the endpoints and line of the range and bearing in the Main Display window.
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Transect Drawing Controls
Overview
The transect drawing controls are a version of the Drawing Controls that allows you to view, create, and modify the transect lines that are used in
the Transect Views. This option can be found in the Main Display window under the Display->Draw Transect menu item or through the
Transects menu in the Transect View.

This display control is a representation of the set of transects that are defined by the transect resource. Not only does it have its own state (that can
be saved in a bundle, for example), but it also writes out any transects you may create or change into your local McIDAS-V state directory in a
transects.xml file. This transects.xml file (if one is created) is carried over from session to session. Therefore, if you draw transects in one session
and save the transects (via the File->Save or Automatically update transects items), the same transects will appear in subsequent sessions when
you open the Transect Drawing Control widget.

In this control, there is only one shape that you can draw, a Transect Line. This control also shows a non-editable Transect Shape which displays the
full transect line used by any Transect Views, called the "Active Transects". There are also a set of transect lines that are non-editable that are from
the system transects property. For an active transect, if the Transect View that it represents has a max distance set then the transect will show this
max distance as a rectangular box.

The Transect Drawing Control window consists of three tabs: Controls, Style, and Shapes.

Controls
Style
Shapes
Menus

The Controls tab allows for the user to draw features in the Main Display window:

Image 1: Controls Tab of the Transect Drawing Control Properties Dialog

Properties

Mode -

 Create a transect - Creates a transect in the Main Display window by left-clicking and dragging.

 Select - Allows you to select one or more transect drawings. To select multiples press the control key. The selected transects will be
shown with small magenta rectangles. Once selected you can bring up the transect's property editor by pressing Ctrl+P. You can also
delete the selected objects by pressing Ctrl+X. You can select all of the objects by pressing Ctrl+A.

 Move or stretch graphic - Allows you to reposition a transect without stretching (changing the distance between the endpoints) it.

 Stretch Graphic - Allows you to move one of the endpoints of a transect. The other endpoint will remain in its fixed location.

Enabled - Allows you to utilize the different mode options. If you are done creating/modifying transect lines, you can unselect this
option to allow you to work in the Main Display window without creating/modifying any existing transect lines.

Z Position - Allows you to define the Z-position of the transect line. This is the vertical positioning of the transect line in the Main Display
window.

Automatically update transects - Makes your most recently drawn transect line the active transect, and it will control the display if you are

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TransectViewManager__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TransectDrawingControl__controls
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TransectDrawingControl__style
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TransectDrawingControl__shapes
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TransectDrawingControl__menus


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 266 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

working with a Transect Display. This will also write out all transects (active and inactive) to a transects.xml file stored in your McIDAS-V
directory.

Show transects - Toggles the visibility of all transect lines drawn in the display, other than the active transect, which is controlled by the
Show active transects item.

Show active transects - Toggles the visibility of the active transects. Active transects are transects that are currently being utilized to create a
display in a Transect Display. Active transects are drawn in the color green in the Main Display window.

The Style tab controls the appearance of the transect lines in the Main Display window:

Image 2: Style Tab of the Transect Drawing Control Properties Dialog

Properties
These menu options apply to the shapes listed in the Controls tab. Once modifications have been made in this tab, they will be applied to the next
transect you draw in the Main Display window, without changing any transects already created. Note that Font and Justification are not valid
options for this control, since there is no text component in the Controls tab.

Color - Sets the color of the transect in the display.

Line Width - Sets the thickness of the transect drawn in the display.

The Shapes tab lists all of the graphical elements:

Image 3: Shapes Tab of the Transect Drawing Control Properties Dialog

Properties

Name - Lists the names of the transects.

Type - Lists the type of shape in the display. This will always be listed as 'Transect' because that is the only shape you can create from the
Controls tab
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Coordinates - Lists the coordinates used to display the transect line.

Double-clicking on an element in the Shapes tab will show its properties editor, which consists of two tabs: Properties and Points.

The Properties tab gives general information about each transect:

Image 4: Properties Tab of the Properties Dialog

Properties

Line Width - Sets the thickness of the transect line.

Name - Sets the name of the transect. This is the name that will be listed in the Name column of the Shapes tab of the Drawing Control
window. Setting names of items can make it easier to keep multiple shapes organized, as opposed to the default of "Transect 1", "Transect 2",
etc.

Visible - Toggles the visibility of the transect line in the Main Display window. If this item is unchecked, it will not be visible in the Main
Display, but the shape itself will not be deleted. Any transects that aren't visible will have '(hidden)' listed next to their names in the Shapes
tab of the Transect Drawing Control window.

Color - Sets the color of the transect line in the display.

Distance - Lists the geographical distance the transect covers in the Main Display window. This cannot be changed here, and is listed for
informative purposes only.

Start Label - Sets the label at the beginning of your transect line in the Main Display window. The default value here is B, for Beginning.

End Label - Sets the label at the end of your transect line in the Main Display window. The default value here is E, for Ending.

The Points tab gives general information about each shape:
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Image 5: Points Tab of the Properties Dialog

You can modify a latitude/longitude value here by double-clicking in one of the cells for latitude or longitude, entering a new value, clicking in
another cell, and clicking Apply or OK. The new latitude/longitude values will be applied to the endpoints of your transect line in the Main Display
window.

Properties

Latitude/Longitude - Lists the latitude/longitude values of the starting and ending points of the transect line.

 - Allows you to save the list of points as a Comma-Separated Values (CSV) file (*.csv).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has these unique options:

Save Transects - Allows you to save your transect display. This will save information about your transect lines currently displayed in the
Main Display window to a transects.xml file stored in your McIDAS-V directory. This file contains information about transect line beginning
and end points, color, and starting/ending labels.

This transects.xml file is important when working with a Transect Display, as these are the transect lines that are listed out under the
Transects menu item in the Main Display window. This makes it easy to switch between different transect lines for your transect display
without having to re-draw lines.

Save - Allows you to save the transect display as a bundle or a favorite.

The Edit menu has these unique options:

Remove All - Removes all transects from the Main Display window without removing any other items. Note, if you have the Automatically
update transects option turned on, this will delete all transects from your transects.xml file.

Apply Color to Selected - Changes the color of the selected transect drawn in the Main Display window. After an item is drawn, if you want
to change its color in the Main Display, you can make the item active with the Select mode, change the Color in the Style tab of the Drawing
Control window, and use the Apply Color to Selected menu item to change the color of the item to the new color you selected.

Apply Z Position to Selected - Applies a modified Z-position (height) to the selected transect drawn in the Main Display window. After an
item is drawn, if you want to change its vertical positioning in the Main Display, you can make the item active with the Select mode, move
the Z-Position slier in the Controls tab of the Drawing Controls to your new desired position, and use the Apply Z Position to Selected
menu item to move the item to the new Z-position.
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Drawing Controls
Overview
The drawing controls consists of a drawing editor that supports polygons, lines, shapes and text. This tool allows you to create and move graphics in
the Main Display window. Drawing and selecting in 3D can be difficult and sometimes it is best to be in the main overhead view. This feature can
be found in the Main Display window in the Display->Draw Freely menu item.

Controls
Style
Shapes
Properties
Menus

The Drawing Control window consists of three tabs: Controls, Style, and Shapes.

The Controls tab is used to draw features in the Main Display window:

Image 1: Controls Tab of the Drawing Control Dialog

Properties

Mode - There are three editing modes; Select, Move and Reshape:

 Select - Selects one or more drawing objects. To select multiples press the Control key. The selected objects will be shown with
small magenta rectangles. Once selected, you can bring up the object's property editor by pressing Ctrl+P. You can also delete the
selected objects by pressing Ctrl+X. All of the objects can be selected by pressing Ctrl+A.

 Move - Activates and moves the active object (the object with pink squares at its corners/along the line). Do this by left-clicking
and dragging the object.

 Reshape - Stretches an object drawn in the Main Display. To use this, left-click and drag on a pink square of an active object. As
you move this point, other points in the object will move as well to keep the object smooth.

Enabled - Turns on/off the ability to use the modes. This makes it easy to modify other objects that may be in the Main Display
window without moving the position of your shapes.

Shapes - Sets the shapes to be drawn in the Main Display window. Utilize the Style tab of the Drawing Control to specify line/text color,
thickness, size, and other items pertinent to the shape. To use this feature, select the shape you wish to use, and left-click and drag in the Main
Display to draw the shape. See the Properties Editor of the shapes for further customization after an item has been drawn:

 Create a polygon - Creates a smooth polygon.

 Create a rectangle - Creates a rectangle.

 Create a diamond - Creates a diamond.

 Create an arrow - Creates an arrow that can face in any direction.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__controls
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__style
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__shapes
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__properties
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__style
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__properties


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 270 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

 Create a horizontal arrow - Creates an arrow in the horizontal direction.

 Create a vertical arrow - Creates an arrow in the vertical direction.

 Create text - Opens a Text entry window, where you can type in text or HTML. Click OK when done, and the text will appear in
the Main Display window.

 Create waypoint - Opens a Text entry window, where you can type in text or HTML. Click OK when done, and the text will
appear in the Main Display window along with a marker to represent the exact location where you clicked in the Main Display
window.

 Create image - Places a saved image or an image from an HTML address on the Main Display window. Select an image file from
the file chooser or enter a URL. When using this shape, you can use the Full Lat/Lon option next to Coordinates. This controls how
the corners of the image are positioned. If you are adding a large image and you want to display the full image right away without
having to stretch it, check this option. Otherwise, your image will be compressed in the horizontal.

 Create quicktime movie - Places a movie on the Main Display window. Select the movie from the file chooser or enter a URL.
This can only work with certain types of Quicktime (*.mov) files.

 Create a symbol - Places a cross (+) symbol on the display. This symbol can be changed in the Properties Editor of the shape. You
can get to this through the Shapes tab of the Drawing Control and double-clicking on the item. Use the Symbol button to change the
symbol to a variety of meteorological symbols including various types of weather conditions, clouds, and turbulence.

 Create high pressure symbol - Adds a high pressure symbol to the Main Display window with a user-specified pressure.

 Create low pressure symbol - Adds a low pressure symbol to the Main Display window with a user-specified pressure.

 Create a cold front - Adds a cold front to the display.

 Create a warm front - Adds a warm front to the display.

 Create an occluded front - Adds an occluded front to the display.

 Create a stationary front - Adds a stationary front to the display.

 Create a trough - Adds a trough to the display.

Filled - Fills in the outline of a shape. This can be used with the Polygon, Front, and Rectangle shapes.

Straight - Creates straight lines when drawing freely. This can be used with the Polygon and Front shapes.

While the icon buttons only allow you to draw 5 different front types, there are 20+ front types to choose from in the Properties dialog
for the shape.

Coordinates - Draws in four different coordinate systems. This affects how the Points tab of the Properties Editor for the item will be
formatted. Ex: If you select X/Y, your points will list out in columns with values of X and Y, and if you choose Lat/Lon, your points will list
out in columns with values of Latitude and Longitude:

X/Y/Z - Draws in the 3D box coordinate space. Re-projections will not affect the shape.

X/Y - Draws in the 3D box coordinate space, fixing the Z position. Re-projections will not affect the shape.

Lat/Lon/Alt - Defines the points of the shapes by Latitude/Longitude/Altitude. When you reproject the display the shape will also be
reprojected.

Lat/Lon - Defines the points of shapes by Latitude/Longitude, but the Z position is fixed using the Z Position slider. When you
reproject the display the shape will also be reprojected.

Z Position - Changes the vertical position of the features with respect to other variables being displayed in the Main Display window. You
can change this with the slider, or by entering a value in the text field and pressing Enter.

Time - Determines the visibility of your drawing items as you progress through time steps in a loop.

Draw In Current Time - Draws the features only on the time step you are looking at. As you step through the animation, the features
will not be visible in any subsequent time steps.

Show All - Displays all of the features drawn at any time step, regardless of if Draw In Current Time was selected.

A graphic can be shown at more than one time using the Properties Editor. Select the object and press Ctrl+P to bring up the Properties

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DrawingControl__properties


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 271 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Editor. Select the times to be displayed in in the Times list (Shift+click or Ctrl+click to select multiples) and press Apply or Ok.

The Style tab controls the style that the drawings take in the Main Display window:

Image 2: Style Tab of the Drawing Control Dialog

Properties
These menu options apply to the shapes listed in the Controls tab, excluding the High/Low pressures/fronts. Once modifications have been made in
this tab, they will be applied to the next shape you make in the Main Display window, without changing any shapes already created.

Color - Sets the color of the shape/text in the display.

Line Width - Sets the thickness of the shapes in the display. This Line Width control sets the thickness of arrows, polygons, rectangles, and
diamonds. This does not control the line width of fronts. The default value is 1.0.

Font - Sets the font of the text in the display.

Size - Sets the size of the text in the display.

Justification - Sets the placement of the shape with respect to the latitude/longitude location where you clicked in the Main Display window
to draw the shape. The first dropdown controls the left/right justification, and the second dropdown controls the top/bottom justification. Ex.:
To center an item directly where you click in the Main Display window, choose Center, Center.

Front Scale - Sets the scale of the fronts. A larger value will make the front thicker, and you may see fewer details about the front (ex. Fewer
blue triangles along a cold front). This works similarly to Line Width, but for fronts instead of shapes. The default value is 1.0.

The Shapes tab lists all of the graphical elements:

Image 3: Shapes Tab of the Drawing Control Dialog
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Properties
This tab lists out the different shapes drawn in the Main Display window from the Controls tab, as well as other information about them.

Name - Lists the names of the shapes currently drawn in the Main Display.

Type - Lists the type of shape in the display (ex. Front, Low, High, Shape, Smooth Polygon).

Coordinates - Lists the Coordinates selected in the Controls tab.

Specifics - Lists specifics about some of the items, including pressure, area, and distance values.

Double-clicking on an element in the Shapes tab will open its Properties Editor, which consists of two tabs: Properties and Points.

The Properties tab gives general information about each shape:

Image 4: Properties Tab of the Properties Dialog

This tab allows you to control many aspects of the individual shapes. After making any modifications to this window, click Apply or OK, and the
changes will be applied to the shape in the Main Display window. Note: The different types of shapes will have different menu options.

Properties

Line Width - Sets the thickness of the shapes being displayed.

Name - Sets the name of the shape. This is the name that will be listed in the Name column of the Shapes tab of the Drawing Control
window. Setting names of items can make it easier to keep multiple shapes organized, as opposed to the default of "Glyph1", "Glyph 2", etc.

Visible - Determines if the shape will be visible in the display. If this item is unchecked, it will not be visible in the Main Display, but the
shape itself will not be deleted. Any shapes that aren't visible will have '(hidden)' listed next to their names in the Shapes tab of the Drawing
Control window.

Color - Sets the color of the shape in the display.

Distance - Lists the distance the object covers in the Main Display window. This cannot be changed here, and is listed for informative
purposes only. The Distance will also be listed out in the fourth column of the Shapes tab of the Drawing Control window.

Area - Represents the area of a shape being displayed in the Main Display window. This cannot be changed here, and is listed for informative
purposes only. The Area will also be listed out in the fourth column of the Shapes tab of the Drawing Control window.

Pressure - Sets the pressure when your shape is a high or low pressure.

Front Type - Changes the type of front displayed for the selected element. There are a variety of fronts available from this control that are
not available in the Controls tab of the Drawing Control window.

Flip the front orientation - Changes the display to represent the front traveling in the opposite direction (i.e., what side the cold front the
blue triangles are drawn on).

Scale - Changes the size of the item (ex. front) without changing its spatial extent.

Text - Allows you to view the current text of the item and change it. You can also change the Font, Size, and Alignment with respect to the
lat/lon where you clicked to create the text.
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Marker - Allows you to add a marker for the originating point of a text display.

BG Color - Allows you to set a background color for text.

Times - Determines what times the shape will appear when you are displaying a loop of data. You can specify which times the item will be
visible by selecting individual times with Control/Shift+click. This menu item will only be used if you have a loop of data displayed.

 - Opens the Flythrough feature which allows you to interactively explore the feature.

The Points tab gives general information about each shape:

Image 5: Points Tab of the Properties Dialog

This tab lists out location coordinates of your shape. The points listed can be seen in the Main Display window, and are represented by the pink
squares along the boundaries of the shape. These values can be changed by double clicking on a coordinate, and typing in a new value. Once you
click on a different coordinate, and then press Apply or OK, the change will be made in the Main Display window.

Properties

Latitude/Longitude - Lists the latitude/longitude values at a variety of points in the shape. If your properties are for a rectangle, the points
listed will be the four corner points. If your properties are for a line (including a front), you will see several latitude/longitude points along the
length of the line.

 - Saves the list of points as a Comma-Separated Values (CSV) file (*.csv) or as an Excel file. This file can subsequently be
loaded in through the General->Files/Directories chooser of the Data Sources tab of the Data Explorer and the points can be used to create
a Point Data display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has these unique options:

Export Drawing - Exports all drawings created from the Drawing Control in the IDV Drawing files (*.xgrf) format. This file can later be
loaded into McIDAS-V in two ways. First, you can load the file through the General->Files/Directories chooser of the Data Sources tab of
the Data Explorer with the Drawing Files Data Type. This will display your saved drawings in the Main Display window with controls
similar to the Shapes tab of the original Drawing Control window. Secondly, you can import this file through the File->Import Drawing
menu item of the Drawing Controls window.

When exporting your drawing, there is a checkbox in the Save window called Load as map data. If you select this option, when your data is
saved, a new layer will also be added to the Field Selector tab of the Data Explorer. This layer will be the drawing you saved loaded in as a
map layer. This enables you to do a variety of things. First, you can create a simple Map Display of your data with the Map Display display
type in the Field Selector. Secondly, if you load in a topography field (ex. GFS Global 'Geopotential_height @ surface' data), you can create
a 3D map over topography using the Maps->3D Map native formula. For the MapData field, select your exported drawing, and for
Topography, select your topography field. You must make sure that your topography field is large enough to cover the entire domain of your
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map layer (your drawing).

Import Drawing - Imports files in the IDV Drawing files (*.xgrf) format. These files contain previously drawn shapes created from the
Drawing Controls.

The Edit menu has these unique options:

Remove All - Removes any drawings from the Main Display window without removing any other items. While all drawings will be
removed, the Drawing Control will remain open.

Apply Color to Selected - Changes the color of the selected item drawn in the Main Display window. After an item is drawn, if you want to
change its color in the Main Display, you can make the item active with the Select mode, change the Color in the Style tab of the Drawing
Control window, and use the Apply Color to Selected menu item to change the color of the item to the new color you selected.

Apply Z Position to Selected - Applies a modified Z-position (height) to the selected item drawn in the Main Display window. After an item
is drawn, if you want to change its vertical positioning in the Main Display, you can make the item active with the Select mode, move the Z-
Position slier in the Controls tab of the Drawing Controls to your new desired position, and use the Apply Z Position to Selected menu item
to move the item to the new Z-position.
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Location Indicator Controls
Overview
The location indicator controls display a configurable axis in the Main Display window and (optionally) a bearing point. This option can be found
in the Main Display window under the Display->Add Location Indicator menu item. The Location Indicator window consists of three tabs:
Location, Settings, and Orient.

Location
Settings
Orient
Menus

The Location tab displays and allows you to modify the position of the origin and the bearing point:

Image 1: Location Tab of the Location Indicator Dialog

Properties

Origin - Represents the latitude, longitude, and altitude of the origin point in the Main Display window.

Point - Represents the latitude, longitude, and altitude to set the location of the bearing point in the Main Display window.

Bearing - Lists the bearing point degree.

X Tick - Sets the location of the X tick mark in the Main Display window.

Y Tick - Sets the location of the Y tick mark in the Main Display window.

Z Tick - Sets the location of the Z tick mark in the Main Display window.

The center point of the Location Indicator can be moved by left-clicking and dragging on the lines produced in the Main Display window. You can
also move the center point of the Location Indicator with a series of Ctrl+Alt key combinations.

Ctrl+Alt+o - Moves the center point of the Location Indicator to the origin (center in the x, y, and z-axes) of the display.

Ctrl+Alt+l - Moves the center point of the Location Indicator to the left side of the display (in the x-axis), maintaining the previously
existing top/bottom and up/down positions.

Ctrl+Alt+r - Moves the center point of the Location Indicator to the right side of the display (in the x-axis), maintaining the previously
existing top/bottom and up/down positions.

Ctrl+Alt+t - Moves the center point of the Location Indicator to the top of the display (in the y-axis), maintaining the previously existing
left/right and up/down positions.
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Ctrl+Alt+b - Moves the center point of the Location Indicator to the bottom of the display (in the y-axis), maintaining the previously existing
left/right and up/down positions.

Ctrl+Alt+u - Moves the center point of the Location Indicator vertically (in the z-axis) to the top of the display, maintaining the previously
existing left/right and top/bottom positions.

Ctrl+Alt+d - Moves the center point of the Location Indicator vertically (in the z-axis) to the bottom of the display, maintaining the
previously existing left/right and top/bottom positions.

The Settings tab allows for the configuration of display settings:

Image 2: Settings Tab of the Location Indicator Dialog

Properties

Move - Constrains along which axis the center point of the Location Indicator can be moved.

Keep in Box - Constrains the movement to be within the main 3D bounding box.

Enabled - Enables the option to drag points.

Clip - Clips the Location Indicator as well as the display in the Main Display window in relation to the center point of the Location Indicator.

Visibility - Turns on/off the visibility of the X, Y, and Z axes in the Main Display window.

Labels - Turns on/off the visibility of the X, Y, and Z labels in the Main Display window.

Solid - Shades in the plane of any of the axes selected. You can select a color and a transparency for this plane.

Bearing Lines - Shows or hides the bearing lines. These are dashed lines from the respective axis to the bearing point.

Bearing Point - Turns on/off the display of the bearing point.

Axis size - Expands/contracts the length of the origin axis.

Line Width - Sets the line width of the Location Indicator lines.

Color - Sets the color of the Location Indicator lines.

The Orient tab allows for the orienting the display based on the location. To change the origin, click and drag in the main display. To show and/or
change the bearing point, do a Control+drag in the Main Display window. The x/y/z locations of the bearing point are shown on the origin axis as
tick marks and, optionally, as longitude/latitude/altitude readouts:
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Image 3: Orient Tab of the Location Indicator Dialog

Properties

Center At Origin - Centers the display at the origin of the Location Indicator.

Center At Point - Centers the display at the center of the image, not taking into account the location of the center point of the Location
Indicator.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

Selector Color - Changes the color of the Location Indicator display in the Main Display window.

The View menu has these unique options:

Set origin to address - Changes the location of the origin to a given address, zip code, city, etc. See the Go to Address section of the Display
Menus page for more information.

Set point to address - Changes the location of the point to a given address, zip code, city, etc. See the Go to Address section of the Display
Menus page for more information.
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Web Map Server(WMS)/Background Image Controls
Overview
The WMS Controls display imagery from WMS servers. A set of predefined links to WMS servers for topographic, shaded relief and aerial imagery
is also provided with the Background Image control.

To use the pre-defined background images, in the Main Display window, select the Display->Add Background Image menu item. To choose
imagery from web map servers, bring up the Catalog Chooser in the Data Explorer and enter the URL that points to the Capabilities document of
the desired WMS. We also provide links to a set of useful WMSs from the idvcatalog. If it is not in the Catalog pull down menu, enter the
following url:

http://www.unidata.ucar.edu/georesources/idvcatalog.xml

From this catalog open the Web Map Servers tab and select the WMS you would like to access.

The WMS Controls makes a request to the Web Map Server for an image that covers the area currently being displayed in the Main Display
window. Due to the time it takes to access remote servers, the WMS Control does not request new images while the user pans and zooms.

Image 1: WMS Control Dialog

Properties

Layer - Selects which background image to add to the Main Display. Listed below are the different Layers included with McIDAS-V.

Blue Marble (BBM) - Static
Blue Marble (BBM) - Dynamic
Bathymetry/Topography - Static
World Topography - Static
World Day - Static
Lights - Static
USGS Topography - Static
Topography/Political - Static
Biosphere - Static
Land/Sea Mask - Static
Land Mask - Static
Sea Mask - Static
Global Topography - Dynamic
Topographic Map
Digital Ortho-Quad
Shaded Relief
Urban Area
Solid Blue
Solid Light Blue
Solid White
Solid Green
Solid Gray

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CatalogChooser__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 279 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Image Buttons -

Reload the image - Reloads the image from the server at the current screen location.

Reproject to image - Sets the projection in the display to the current image bounds.

Auto-Reload - Fetches a new image every time the Main Display window is panned or zoomed. There is a slight delay so that
successive zooms do not cause successive image requests.

Resolution - Allows you to change the resolution of the image. A lower resolution image will have a smaller image file size and quicker
requests from the server.

Vertical Position - Sets the vertical position of the image. You can adjust this value by dragging the slider or by typing a value into the field
and pressing Enter.

Transparency - Adjusts the overall transparency of the image. Note: Some Web Map Servers provide images that contain transparent
sections. Currently, McIDAS-V does not support the display of transparent sections.

Dimension Scale - Allows you to fetch a larger image than the default one. By default, the bounds of the image that is retrieved from the
server is the size of the display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has this unique option:

Save As Image XML/KML File... - Saves the most recently displayed image as an Image XML file (*.ximg) or as a Google Earth File
(*.kml, *.kmz). The Image XML format references the image as well as the geolocation boundaries.

The View menu has these unique options:

Reproject Image - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.

Go to Address - Changes the projection to a given address, zip code, city, etc. See the Go to Address section of the Display Menus page for
more information.

Use Native Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.
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QuickTime Movie Controls
Overview
McIDAS-V can display QuickTime movies. You can pause, single step and play a movie. This option can be found in the Main Display window
under the View->Capture->Movie menu.

Image 1: Movie Display Window

Properties

 Play - Starts the QuickTime movie.

 Pause - Pauses the QuickTime movie.

 Step Backward - Moves backwards a single step in the movie.

 Step Forward - Moves forwards a single step in the movie.

 Media Properties - Opens the QuickTime media properties. Right-click to change the rate of the movie.

The media properties is composed of three tabs, General, Video, and Plug-in Settings.

The General tab has general information about the QuickTime movie:
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Image 2: General Tab of the Media Properties Window

Properties

Media Location - Represents the location of the movie file on your computer.

Content Type - Represents the content type of your movie file.

Duration - Displays the length of the movie.

Position - Displays how far you are into the movie.

Bit Rate - Represents the number of bits that are conveyed or processed per unit time.

Frame Rate - Represents the speed at which the movie is playing.

The Video tab lists the specific video information:

Image 3: Video Tab of the Media Properties Window

Properties

Track # - Represents the order of videos when multiple videos have been added.

Encoding - Represents the image type of the frames in the movie.

Size - Displays the size of the frames in terms of pixels.

Frame Rate - Represents the speed at which the movie is playing.

The Plug-in Settings tab has access to the PlugIn Viewer details:
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Image 4: Plug-in Settings Tab of the Media Properties Dialog

Properties

PlugIn Viewer - Opens a PlugIn Viewer window, where you can choose a Parser for QuickTime file format, or a JPEG Renderer.

Menus
All of the menu items seen utilizing the movie display are standard options that can be found in the Menus section of the Layer Controls page.
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Image and Movie Capture Controls
You can capture the Main Display window as an image, a QuickTime movie or an animated GIF.

Saving Images
Printing Current View
Saving QuickTime Movies
Creating a Movie
Playing QuickTime Movies

Saving Images
You can save a display as an image by selecting the View->Capture->Image... menu item in the Main Display window. A file dialog will open
where you can enter a file name for the image file. McIDAS-V supports JPEG, PNG, GIF, PDF, PS, and SVG formats. From this File Dialog you
can also specify the image quality (only used for JPEGs) and what to capture. You can also select whether or not the background is transparent.

Note: When capturing an image, the Main Display window cannot be obscured.

McIDAS-V can also write out an image and the corresponding Google Earth KML or KMZ file. For this to be correct, the projection must be a
Lat/Lon geographic projection (i.e., rectilinear) and in an overhead view. Some of the default projections that are Lat/Lon include World, Africa,
Asia, Australia, and the individual state projections (US->States->...). You can also create your own Lat/Lon projection using the Projection
Manager. The simplest way to get a correct projection is to select the Projections->Use Displayed Area menu item in the Main Display window. If
you specify a .kml file, McIDAS-V will generate an image with the same file prefix and the kml file that refers to the image. If you specify a .kmz
file (which is a zip format) it will contain the image and the kml file.

Printing Current View
You can send any display to a printer. Select the View->Capture->Print... menu item in the Main Display window. A Print dialog will popup
where you can configure and print an image.

Saving QuickTime Movies
You can save any sequence of displays as a movie. Select the View->Capture->Movie... menu item in the Main Display window to open the
Movie Capture window:

Image 1: Movie Capture Window

Properties
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Note: More information about these controls is found in the Creating a Movie section below.

Capture -

 - Captures one image to create a movie.

 - Captures a loop of images at the specified dwell rate through the Time Animation Controls.

Reset to start time - Resets the loop to the initial timestep before recording the video.

 - Creates a new frame in the movie every given number of seconds.

What to capture -

View - Captures only what is in the view screen of the Main Display window.

View & Legend - Captures both the view and the Legend.

Full Window - Captures the entire Main Display window, including the toolbars.

Full Screen - Captures everything visible on the monitor.

Beep - Produces a beeping noise at the beginning of each frame captured in the movie.

Background Transparent - Captures the movie with the background image transparent.

Image Files -

Image Quality - Sets the quality of the images. Lower quality images will utilize less memory, but will not look as good.

Save Files To - Allows you to individually save each image in your movie. To use this option, click the checkbox for Save Files To
and specify a directory.

Filename Template - Sets the naming structure for the images. This option is only available if you are saving the individual images in
your movie with the Save Files To option. There are several ways you can customize the output, described in the section below.

Frames -

# frames - Displays the number of frames in the movie.

 - Opens a Movie Preview window, where you can see individual slides before saving the movie.

 - Deletes every frame saved in the movie.

 - Saves the movie to the specified location using the chosen format type.

Creating a Movie
To make a movie, there are three steps: capturing the frames, previewing the frames, and creating the movie. McIDAS-V supports QuickTime
movies, animated GIF and AVI files, Google Earth KMZ and AniS or FlAniS HTML file formats.

To capture frames, in the Capture section of the Movie Capture window, do the following:

Capture one image - Makes a single frame of the McIDAS-V display. Progressively change the display and capture one frame at a
time to create a movie.

Capture animation - Captures all frames in a display time sequence that you control with the usual Time Animation Controls. Check
Reset to start time to ensure you capture the entire animation sequence. The QuickTime animation capture starts on the first frame
visible in McIDAS-V and goes to the end. This tool can be used to capture part of a loop.

Capture automatically - Takes snapshots of the frames in McIDAS-V display while you make changes, such as changing the view
point, zooming, rotating, etc. Click the button again to stop the snapshot. You can change the sampling rate of the snapshots with the
Rate field.

You can combine these three different methods of capture. The list of frames is additive.

You can Preview the movie by pressing the  button. This opens a Movie Preview window, where you can see the individual
slides before saving the movie. The Movie Preview window also allows you to remove individual frames from the movie before saving it
with the  button.

If you want to save the individual intermediate files that are used to create the movie, check the Save Files To box and specify a directory
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and file name format. Otherwise, the intermediate files will be saved in a temporary directory and will be removed. You can use the following
templates to customize the name of the output file:

%count% - Represents the image counter.

%count:decimal format% - Allows you to format the count using the same rules defined in the lat/lon format section of the User
Preferences window's Formats & Data tab. You can also specify a Java DecimalFormat, e.g., %count:000% outputs three-digit counts
with leading zeros (001, 002, etc.).

%time% - Represents the animation time in the default format.

%time:time format% - Begins with "time:" and contains a time format string using the the same date formatting rules described in the
User Preferences window's Formats & Data tab.

When done capturing the frames, select the  button to specify the name and format of the movie you want to save.

Playing QuickTime Movies
McIDAS-V supports displaying certain types of QuickTime movies (including the ones McIDAS-V generates). These movies can be loaded in the
General->Files/Directories Chooser in the Data Sources tab of the Data Explorer.
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Timeline Controls
McIDAS-V makes use of a timeline widget in a variety of areas. The timeline allows you to see the temporal distribution of a set of times and easily
select them. There can also be a date selection mechanism (see below) that allows you to select based on a range, interval, etc.

 
Image 1: Absolute Times Chooser

Date Selection
The date selection settings can be accessed by right-clicking in the timeline to show a popup menu. The menu allows you explicitly define these
settings through a Properties dialog or set them directly with sub-menu choices. The date selection settings are listed below.

Properties - Opens a Date Selection window, where you can set a starting and ending time, as well as an interval, max number of images,
and a skip factor.

Set Visible Range - Stretches out the timeline seen in the Absolute tab to cover the selected time range.

Set Date Selection - Selects all of the times in the time range selected.

Use Visible Range - Selects all of the times currently visible in the Absolute tab.

Start/End date - Defines the range to look within.

Interval - Allows you to select dates every N time units.

Skip Factor - Skips every N'th time that would be selected.

Count - Specifies a max number of times that will be selected. Only the most recent N times will be selected.

Sunrise/Sunset - Shades the background of the times in yellow when the sun is up, and in white when the sun is down.

Before/After Range - Displays as the little gray triangles in the timeline. By default, the ranges that we use are one half the size of the
interval. However, you can set the range both before and after the interval tick. So for example, if you want to just consider times within 15
minutes before the interval but nothing after the interval set the Before Range to be 15 minutes and the After Range to be 0 minutes.

The View Managers use the timeline to show the animation time set and the times of the different displays. Here, the timeline is used for
informational purposes and is not used to select times. This can be shown through the View->Animation Timeline menu. The gray timeline
represents non-visible displays. Double clicking in a timeline sets the animation step to that time.
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Image 2: Animation Timeline Window

Timeline Navigation
The timeline supports a variety of navigation mechanisms:
Event Action
Left Mouse Drag Change visible range or date selection range.
Left/Right Arrow Change visible range. 

Use Ctrl+Key to change date selection. 
Use Shift+Key to use larger increment.

Up/Down Arrow Zoom in/out visible range. 
Use Ctrl+Key to change date selection. 
Use Shift+Key to use larger increment.

Mouse Click; Control-
Click; Shift-Click

Select individual times, multiple times or a range of times

Shift-Drag When not showing the date selection mechanism you can choose a range of times with shift-drag
Right Mouse Click This brings up a popup menu that allows you to show the properties dialog, go to particular current date ranges, set the

interval, range, skip factor and count of the date selection.
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Tools
User Preferences
Remote Data Manager
Local Data Manager
Weather Text Product Controls
Storm Track Controls
Color Table Editor
Station Model Editor
Parameter Alias Editor
Parameter Defaults Editor
Parameter Groups Editor
Projection Manager
Data Analysis
Display Settings
Plugin Creator
Plugin Manager
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User Preferences
Preferences are used to save standard settings of McIDAS-V, such as the map projection to show when McIDAS-V starts. The Preferences Dialog
is opened in the Main Display window through the Edit menu with Edit->Preferences.

Click on Cancel if you wish to exit preferences setting, Ok to accept the changed preferences and close this window, and Apply to accept the
preferences and keep this window open.

Note: Some of these preferences only take effect the next time you run McIDAS-V or when you create a new view window. The preferences also
may be overwritten when you use bundles.

The follow sections describe the different user preference options for McIDAS-V:

General Preferences
Display Window Preferences
Toolbar Options Preferences
Data Sources Preferences
ADDE Servers Preferences
Available Display Preferences
Navigation Controls Preferences
Formats and Data Preferences
Advanced Preferences

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Menus__edit
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Bundles__FILE
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General Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The General tab allows the user to
configure many of the general settings within McIDAS-V. The image below represents the default settings for the General tab.

Image 1: General Preferences (Default)

General

Show Help Tips on start - Displays the help tip window on start up.

Show Data Explorer on start - Opens the Data Explorer window when McIDAS-V starts.

Check for new version and notice on start - Checks at startup to see if your current version of McIDAS-V is up to date and checks for
important notices from SSEC.

Include prereleases in version check - Checks at startup to see if there is an updated prerelease version ready for download.

Confirm before exiting - Asks the user to confirm before the exiting McIDAS-V.

Automatically save default layout at exit - Stores the position of the Data Explorer for the next session.

Save visibility of Data Explorer - Stores the visibility of the Data Explorer for the next session.

Confirm removal of all data sources - Asks the user to confirm before removing all data sources.

Confirm removal of all layers - Asks the user to confirm before removing all layers.

Confirm removal of all layers and data sources - Asks the user to confirm before removing all layers and data sources.

When Opening a Bundle

How to open bundle - Determines how the bundle will open. The dropdown list contains four options for opening bundles: Create new
window(s), Merge with active tab(s), Add new tab(s) to current window, and Replace session.

Prompt when opening bundles - Opens a window asking how to open the bundle, allowing you to choose each time you open a bundle.
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Prompt for location for zipped data - Allows you to specify a directory to place zipped data files, or choose to create a temporary directory.

Layer Controls

Show windows when they are created - Specifies that when a display is created its control window is automatically shown.

Use fast rendering - Uses fast rendering to display data layers (images, contours, etc.); see Performance Tuning for more information. A
separate fast rendering option for map layers is available in the Map Controls.

Auto-select data when loading a template - Displays can be saved as a template without data. When it is created, should McIDAS-V
attempt to automatically select the appropriate data fields.

When Layer Control Window is Closed

Remove the layer(s) - Specifies that when a display's window is closed then the layer itself is removed.

Remove standalone layers - Removes the layer when the window is closed for a standalone layer (i.e., one that does not have a display
component in the Main Display window).

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__FILE
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Display Window Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Display Window tab allows the
user to set preferences related to the Main Display window. The image below represents the default settings for the Display Window tab.

 
Image 1: Display Window Preferences (Default)

Navigation Toolbars

Show Earth Navigation Panel - Shows an Earth Navigation panel at the bottom of the Main Display window.

Show Viewpoint Toolbar - Enables the Viewpoint toolbar.

Show Zoom/Pan Toolbar - Enables the Zoom/Pan toolbar.

Show Undo/Redo Toolbar - Enables the Undo/Redo toolbar.

Legends

Show Side Legend - Lists the loaded layers into the Legend of the Main Display window. Note that you must create a new tab/window for a
change to this preference to take effect.

Show Bottom Legend - Lists the loaded layers in a Legend at the bottom of the Main Display window. Note that you must create a new
tab/window for a change to this preference to take effect.

Panel Configuration

Show Globe Background - Displays a solid globe background.

Show Wireframe Box - Toggles the visibility of a 3D wireframe box around the data. This box helps provide orientation in 3D views.

Show Cursor Readout - Displays a label of latitude, longitude, and altitude at the cursor position over the display, shown in the lower border
of the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__earthnav
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Clip View At Box - Allows the user to omit from view all display elements outside the wireframe box. This is helpful to remove map lines
outside the area of data.

Show Layer List in Panel - Shows/hides the Layer Label at the bottom of the display in the Main Display window.

Show Times In Panel - Turns on the label shown inside the Main Display window that shows the current animation time.

Show Map Display Scales - Shows a vertical scale in the map displays.

Show Transect Display Scales - Shows a vertical scale for transect displays.

Show "Please Wait" Message - Displays the "Please Wait" message in the bottom toolbar of the Main Display window when McIDAS-V is
in the middle of a process.

Reset Projection With New Data - Causes each new display made in McIDAS-V to snap the whole Main Display window to the native
projection of the data. This can be undesirable if you are overlaying several kinds of data, some of which have differing projections.
However, it works well if you are working with data based on the same projection. Another option related to this is Auto-Set Projection.

Color Scheme

Globe Background - Sets the color of the globe's background.

Background - Sets the color of the background behind the image being displayed.

Foreground - Sets the color of the wireframe box in the foreground.

Selected Panel - Sets the color in the frame around the selected panel/tab. This is the panel/tab that changes will be made to if you have
multiple tabs open.

Note: The color of the maps is controlled by the individual map control. The selected panel color changes the color used to highlight the
current panel.

Layer List Properties

Font - Sets the style of the text at the bottom of the Main Display window listing the layers. Using the dropdown lists, the user can define the
font, style, and size of text.

Color - Sets the color of the text at the bottom of the Main Display window.

Default Projection

Default Projection - Sets the default map projection. This is the map projection that will be used in the Main Display window when
McIDAS-V is started.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PropertiesDialog__layerlabel
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__autosetpro
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_MapDisplayControl__FILE
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Toolbar Options Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Toolbar Options tab allows the
user to define what actions/icons are displayed in the toolbar. The list on the left shows all of the available actions. The list on the right shows the
actions that make up the toolbar. The image below represents the default settings for the Toolbar Options tab.

 
Image 1: Toolbar Options Preferences (Default)

Properties

 - Adds selected item on left column to the right column, bringing this item to the toolbar. You can also add
an item by hitting the Right arrow.

 - Takes selected from right column to the left column, removing this item from the toolbar. You can also
remove an item by hitting the Left arrow or Delete.

 - Adds a space between the icons on your toolbar.

 - Undoes any user changes to the Toolbar Options tab, returning the Actions and Toolbar columns to the
the way they were at the start of the session.

 - Brings up the Plugin Creator window with the selected action included under the Resources tab.

 - Brings up the Export to Menu window where the user can enter in a Menu Name and select which menu to
add the action under.

 - Moves the selected action in the toolbar column up in the list, changing the location of the action in the toolbar.

 - Moves the selected action in the toolbar column down in the list, changing the location of the action in the toolbar.
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Data Sources Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Data Sources tab allows the
user to define what types of data choosers to use. This is a way to simplify the Data Explorer window by only showing the choosers that you want
to use. Note that you must restart McIDAS-V for any changes made in this tab to take effect. The image below represents the default settings for the
Toolbar Options tab.

 
Image 1: Data Sources Preferences (Default)

Properties

Use all data sources - Utilizes all data sources.

Use selected data sources - Utilizes only selected data sources.

 - Selects all data sources.

 - Unselects all data sources.
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ADDE Servers Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The window is also accessible by
clicking the Manage servers button ( ) next to the server name of the applicable choosers in the Data Sources tab of the Data Explorer. The
ADDE Servers tab allows the user to add and manage a list of active ADDE servers separated by data type. The selected ADDE entries will be
included in the list of servers in the Data Sources tab of the Data Explorer. Limiting the number of servers in the Data Sources tab will make it
easier to find the desired sources of data.

The list of ADDE Servers is hierarchial, meaning that you can turn off all servers, specific groupings of servers (ex. Point), or individual servers
within a group (ex. adde.ucar.edu/RTPTSRC can be turned off under POINT, but the rest can remain selected).

The image below represents the default settings for the for the ADDE Servers tab. All of the ADDE entries are checked on except for 'NAV' and
'UNKNOWN'.

 
Image 1: ADDE Servers Preferences (Default)

Properties

Use all ADDE entries - Selects all of the ADDE entries. With this option selected, it is possible to use every type of ADDE data in McIDAS-
V.

Use selected ADDE entries - Uses only selected ADDE entries. This option allows you to individually select which types of ADDE servers
are available to be used.

 - Selects all of the ADDE entries. With this option selected, it is possible to use every type of ADDE data in
McIDAS-V.

 - Unselects all of the ADDE entries.

 - Opens the ADDE Data Manager where a remote server or a local server can be added.

 - Opens the ADDE Data Manager where a remote server or a local server can be added.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__FILE
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Available Displays Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Available Displays tab allows
the user to specify what types of displays to use. The chosen displays can possibly be included in the Displays list in the Field Selector if the field
you are displaying incudes the display type in its properties. Choosing what displays you want to appear in the Field Selector will limit the number
of displays in the list, making it easier to create your desired image.

The list of display types is hierarchial, meaning that you can turn off all displays, specific groupings of displays (ex. Plan Views), or individual
display types within a group (ex. Color-Shaded Plan View can be turned off under Plan Views, but the rest can remain selected).

The image below represents the default settings for the Available Displays tab. Every display is selected on by default.

 
Image 1: Available Displays Preferences (Default)

Properties

Use all displays - Selects all of the displays. With this option selected, it is possible for every display type in McIDAS-V to be used to create
a display.

Use selected displays - Uses only selected displays. This option allows you to individually select which display types are available to be
used. The display types you leave checked can be used by McIDAS-V to create displays.

 - Selects all of the displays. With this option selected, it is possible for every display type in McIDAS-V to be used to create a
display.

 - Unselects all of the displays. With none of the display types selected, you will not be able to create any displays in McIDAS-V.
However, this can be a useful starting point if you only want to utilize specific displays, as it allows you to individually select on a few
display types without having to unselect the rest of them.
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Navigation Controls Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Navigation Controls tab allows
the user to change how McIDAS-V interprets mouse and keyboard events for navigating in 3D space. The user can choose to use the navigation
defaults for the IDV, VisAD, Google Earth, or create their custom navigation settings. The below images represent the default Custom settings for
the mouse and keyboard in the Navigation Controls tab.

 
Image 1: Mouse Navigation Controls (Default)
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Image 2: Keyboard Navigation Controls (Default)

Properties

Function - This is how McIDAS-V interprets mouse and keyboard events for navigating in 3D space. The functions for each key
combination can be changed in the dropdown boxes in the Mouse tab, and are listed in the Function column of the Keyboard tab. The
available functions are listed below.

None - Will not perform any tasks when the key combination on the mouse or keyboard is performed.

Rotate - Rotates the display. While most useful in the globe projection, it can be used at any time. If Rotate is followed by X, Y, or Z,
that is the axis the display will rotate about. If there are no letters proceeding rotate, then the user can rotate the image about any axis.
Negative and positive denote the direction that the image will rotate.

Zoom - Zooms in to magnify a specific portion of the display, or zooms out to get a broader view. On the scroll wheel, Down Zoom In
means if you scroll down, the image will be magnified at the center of the display, while scrolling up will zoom out. The opposite is
true for Down Zoom Out.

Translate - Shifts the entire image in any direction with respect to the stationary background.

Selection - Moves selector points in displays when no keys are pressed or when Ctrl is pressed. Creates a rubber band zoom box when
pressing the Shift key or Ctrl+Shift.

Cursor/Data Readout - Probes the data. Information of latitude/longitude and other variables plotted on the map will be displayed at
the location your cursor is centered over the image.

Key Combination - Mouse and keyboard key combinations can be defined to perform the above functions in McIDAS-V. The available keys
are listed below.

None - With None selected, it is not necessary to hold down a key while pressing your defined key or mouse click for a given function.

Control - The Control key must be held down while pressing your defined key or mouse click for a given function.

Shift - The Shift key must be held down while pressing your defined key or mouse click for a given function.

Ctrl+Shift - The Control and Shift keys must be held down while pressing your defined key or mouse click for a given function.

Left (MB1) - The left mouse button must be held down while pressing your defined key for a given function.
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Middle (MB2) - The middle mouse button must be held down while pressing your defined key for a given function.

Right (MB3) - The right mouse button must be held down while pressing your defined key for a given function.

Scroll Wheel - The scroll wheel must be scrolled down or up while pressing your defined key for a given function.

Key - The keyboard key must be held down while pressing your defined key for a given function.
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Formats and Data Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Formats & Data tab allows the
user to define data formats and defaults to be used when displaying data. The below image represents the default values for the Formats & Data
tab.

 
Image 1: Formats and Data Preferences (Default)

Formats

Date Format - Sets the format used when McIDAS-V displays dates. The date format string uses the following symbols. Note, these symbols
can be repeated to give different results.

For example:

"MMMM" gives full month name "MMM" gives short month name "MM" gives 2 digit month
number "M" gives 1 or 2 digit month number

Symbol Description Presentation Example
G Era designator Text AD
y Year Number 1996; 96
M Month in year Text and Number July; Jul; 07
w Week in year Number 27
W Week in month Number 2
D Day in year Number 189
d Day in month Number 10
F Day of week in month Number 2
E Day in week Text Tuesday; Tue
a Am/pm marker Text PM
H Hour in day (0-23) Number 0
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h Hour in am/pm (1-12) Number 12

K Hour in am/pm (0-11) Number 0
k Hour in day (1-24) Text 24
m Minute in hour Number 30
s Second in minute Number 55
S Millisecond Number 978

z Time zone Text and Number
Pacific
Standard
Time; PST;
GMT-08:00

Z RFC 822 Time zone Number -0800
' Escape for text Delimiter
'' Single quite Literal

Note: The "yyyy" year symbol can also be written as "yy" for recent data. However, it cannot be written as "y".

Ex: The day 215 in the year 2009 would be written as "09215" yyDDD and not "9215" yDDD.

Time Zone - Sets the time zone used by McIDAS-V. McIDAS-V will utilize this time zone for labeling the times of data that you bring in, as
well as for listing the time in the status bar in the Main Display window. This field defaults to GMT. Note that you must restart McIDAS-V
for a change in this field to take effect.

Lat/Lon Format - Represents the format used when McIDAS-V displays latitudes and longitudes. The following symbols are valid in the
decimal formatting.

0 Digit
# Digit, zero shows as absent
. Decimal separator or monetary decimal separator
- Minus sign
, Grouping separator

E Separates mantissa and exponent in scientific notation.

; Subpattern boundary Separates positive and negative
subpatterns

The table below shows a list of example formats and the resulting display in the latitude and longitude values.

Format Example
##0 -95
##0.0 -94.6
##0.0# -94.56
##0.0## -94.563
0.0 -094.6
0.00 -094.56
0.###E0 1.04E2
000.#E0 104.6E0

Probe Format - Represents the HTML template that is used to display data readouts in the data probe display. This HTML template can
contain macros that are replaced with the probed values. Macros are:

%value% Formatted value
%unit% Display unit
%rawvalue% Unformatted value
%rawunit% Original unit

Distance Unit - Represents the default unit that is used when displaying distances (e.g., in the Range and Bearing Control). Note that you
must restart McIDAS-V for this change to take effect.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StatusBar__FILE
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Data

Sampling Mode - Represents the sampling method used by data probes in McIDAS-V. Choose between a weighted average sampling or
nearest neighbor.

Pressure to Height - Represents the type of algorithm McIDAS-V uses for converting from pressure coordinates to height. See the FAQ for
more information on this option.

Cache Data in Memory - Attempts to cache data that McIDAS-V loads into memory for quicker data access. For more information, see Data
Caching.

Disk Cache Size - Represents the maximum amount of disk space used when caching data. McIDAS-V will cache some datasets to disk to
eliminate network latency.

Max Image Size - Represents the maximum image size (in pixels) that is to be displayed. When this preference is set, the image display will
adjust the Pixel Sampling to reduce the image to less than the preferred value. This allows for the initial display of large images without
causing memory issues. A value of -1 in this field imposes no limit on the maximum image size.

Grid Threshold - Sets the size limit for holding grids in memory. Grids larger than this size will be cached to disk instead of held in memory
during the McIDAS-V session. This allows loading large grids and long loops of grids without a major performance hit.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataFaq__pressure_to_height
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Advanced Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Advanced tab allows for
changing options that require a restart in order for them to take effect. To configure the settings before running McIDAS-V, execute the runMcV-
config command from the directory where McIDAS-V was installed (normally McIDAS-V-System) or by selecting Configure McIDAS-V in the
Windows Start menu. The below image represents the default settings for the Advanced tab.

Image 1: Advanced Preferences (Default)

Startup Options

Memory - Sets the Java heap size, which is the amount of memory allocated by McIDAS-V at startup. Use the first bubble to choose a
percentage of available memory, or use the second bubble to enter a specific value. The new amount of memory will be saved and used in
subsequent sessions. For more information, see the Setting Memory Usage section in Downloading and Running McIDAS-V.

Specify default bundle - Loads the selected bundle at startup by setting the "-bundle" command line flag. Select a default bundle in the tree
below the checkbox, which shows the bundles in the Bundles->Favorite Bundles menu. Note that when a favorite bundle is created,
McIDAS-V will have to be restarted before the bundle will list in the Advanced tab.

Load default layout - Restores the previously-saved window configuration upon startup. Uncheck to use the initial window layout of one
Main Display window with one panel. For more information, see the Menu Bar's Default Layout section.

Enable 3D controls - Controls the value of the "idv.3d" IDV property and gives the ability to view and navigate in 3D space with the 3D
controls in the Main Display window's Viewpoint Toolbar. Uncheck to override the default 3D behavior of McIDAS-V and to switch to a 2D
view with the Viewpoint Toolbar removed.

Enable JOGL (Mac OS X only) -Sets the "j3d.rend" property to "jogl", which sets Java3D to use JOGL (Java OpenGL) as the graphics
rendering backend. Disabling will omit the "j3d.rend" property, causing Java3D to use its default OpenGL backend.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Starting__memory
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Enable Direct3D (Windows only) - Sets the "j3d.rend" property to "d3d", which sets Java3D to use Direct 3D as the graphics rendering
backend. Disabling will omit the "j3d.rend" property, causing Java3D to use its default OpenGL backend.

Enable access to geometry by reference - Sets the "visad.java3d.geometryByRef" property to true and enables the visualization of larger
datasets because of the more efficient use of memory. Unchecking this option can help to remove random/extraneous map lines that
sometimes appear in displays of image data. This is a problem that may occur more frequently on systems with ATI graphics cards.

Enable access to image data by reference - Sets the "visad.java3d.imageByRef" property to true and improves the rendering of satellite
imagery in the satellite's native projection, removing the jagged edges at the limb and/or gaps at the dateline that sometimes appear in
displays of image data. It is recommended that this option be checked.

Enable Non-Power of Two (NPOT) textures - Sets the "visad.java3d.textureNpot" property to true and enables the visualization of larger
datasets because of the more efficient use of memory. Unchecking this option may be necessary on machines with graphics cards that do not
support NPOT.

Log Level - Sets the amount of logging information that will go to the mcidasv.log file in the /McIDAS-V/ directory. The options for this
menu item are TRACE, DEBUG, INFO, WARN, ERROR and OFF. TRACE puts the most logging information into the log file and the
subsequent options put less information into the log file until OFF doesn't put anything in the log file. The default logging level is INFO. The
log file will include lines for the chosen logging level, as well as any lesser logging levels. For example, INFO will include INFO, WARN
and ERROR lines in the log file. Listed below is a description of what will be put in the log file for each of the settings:

TRACE - Outputs all logging information.

DEBUG - Outputs information about choosers, the start and exit of the session, error messages and stack traces.

INFO - Outputs information about the start and exit of the session, error messages and stack traces.

WARN - Outputs error messages and stack traces.

ERROR - Outputs error messages.

OFF - Outputs no information.

Enable concurrent mark-sweep garbage collector - Passes "-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -
XX:MaxPermSize=128m" to the McIDAS-V JVM (Java Virtual Machine) and uses shorter garbage collection pauses by performing most
garbage collection activity while the McIDAS-V threads are running. Unchecking this option uses the JVM defaults, which vary by
Operating System.

Java Threads
If running McIDAS-V on a multi-core machine, McIDAS-V can be configured to render individual time steps in parallel when working with a loop
of data. McIDAS-V can also do remote data reads in parallel. This typically results in a 50% reduction in overall data reading and rendering time.
For more information, see Parallel Rendering and Data Reading.

Rendering - Sets the number of Java threads to use for rendering. This number defaults to the number of processors on the machine.

Reading - Sets the number of Java threads to use for reading. This number is dependent on the configuration of the server machine. This
defaults to 4. This is used when reading individual time steps of data from remote ADDE and OpenDAP servers.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__parallelrender
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Remote ADDE Data Manager
The Local and Remote ADDE Data Managers are accessible in the Main Display window through the Tools->Manage ADDE Datasets menu
item. Click the Remote Data tab to manage access to data on other workstations, or the Local Data tab to manage access to data on your
workstation. Continue below for more information about the Remote ADDE Data Manager, or go to the Local ADDE Data Manager page for more
information.

Viewing the Existing Remote Datasets
Adding a New Remote Dataset
Editing an Existing Remote Dataset
Removing an Existing Remote Dataset
Importing MCTABLE...
Menus

Viewing the Existing Remote Datasets

Image 1: Remote ADDE Data Manager

The Remote ADDE Data Manager lets you add, delete or edit access to remote datasets that are available through the Satellite->Imagery chooser.
You can also import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data Manager.

The columns in the table are defined below.

Valid - An empty column (no icon) means that the entry passed a verification check (the specified dataset and data type exists on the server)
when it was added. A sad-face icon ( ) indicates that the entry failed the verification check and thus will not work if you attempt to access
data from the dataset. Once a MCTABLE is imported, this column will change to saying 'Checking...' while the datasets are being verified. If
the dataset is valid, this column will be empty, or a sad-face icon will appear if there is a problem verifying the dataset.

Source - Indicates the source of the entry. System entries ( ) are ones supplied in the McIDAS-V package and thus are not editable. User
entries ( ) are ones that were added by the user and thus are editable. MCTABLE entries ( ) are ones that were added by importing
MCTABLE.TXT file and are also editable.

Dataset - Lists the server IP address and dataset name for the entry. When you access the dataset (by pressing the Connect button in the Data
Explorer), an ADDE request is sent to the server, which then returns the requested data.

Accounting - Indicates whether the entry includes accounting information (username and project number) for the server. These are the values
specified in the Username and Project # fields in the Define New Remote Dataset window that appears when the Add New Dataset button
is clicked. If accounting information was not specified, then the Accounting field entry says "public dataset".

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__view_remote
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__add_new_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__edit_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__remove_selection
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__import_mctable
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageChooser__FILE
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Data Types - Indicates the values that were selected in the Dataset Types section in the Define New Remote Dataset window that appears
when the Add New Dataset button is clicked.

At the bottom of this window, there is a status message that lets you know if local servers are running and does not affect remote servers. For more
information this, please see Local ADDE Data Manager.

The four buttons at the bottom of the window are described in the corresponding section below.

 - Opens the Define New Remote Dataset window.

 - Opens an Edit Remote Dataset window.

 - Removes the selected dataset.

 - Opens an Open window that allows you to import a MCTABLE file.

 - Closes the ADDE Data Manger window and saves any changes.

Adding a New Remote Dataset
The window below appears if you click the Add New Dataset button or select the File->New Remote Dataset menu in the ADDE Data Manager
window.

Image 2:Add Remote Dataset Window

The Add Remote Dataset window lets you add access to remote datasets so they are available through the Data Explorer.

The fields and buttons are defined below.

Server - Represents the IP address of the server workstation.

Dataset - Represents the ADDE dataset name. In McIDAS-X, this is often called the ADDE group name.

Specify accounting information - Enables text entry into thte fields if the server uses ADDE accounting to require the user to enter a
username and project number to access the dataset. If the dataset is a public dataset, meaning that the server allows users to access the dataset
without specifying a username and project number, then leave this box unchecked. If you are unsure whether it's a public dataset or one that
requires a username and project number, click the Verify Server button and the Status field will say "Incorrect accounting information", and
the Username and Project # fields will be highlighted in pink if a username and project number are required.

Username and Project # - Sets the username and project number required to be granted access to a dataset on a server that uses ADDE
accounting to limit access to specific users. The valid usernames and project numbers for each server are assigned and maintained by the
server administrator.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__status
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__add_new_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__edit_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__remove_selection
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__import_mctable
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataExplorer__FILE
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Dataset Types - Sets each of the types of data in the dataset. To find which types are available, click the Verify Server button and it will
check the box of each available type.

Status - Indicates the status and provides instructions.

 - Contacts the server and verifies that the valid dataset exists. Then, if everything is passes the verification tests, the
new entry is added to the Remote ADDE Data Manager containing the information specified in this window. If the dataset is not valid, the
Status will read "Dataset does not appear to be valid", and the Dataset field will be highlighted in pink. If there are problems connecting to
the server listed, then the Status will read "Could not connect to the given server", and the Server field will be highlighted in pink.

 - Contacts the server and verifies that the valid dataset exists. Then, if everything is passes the verification tests, it adds a
new entry to the Remote ADDE Data Manager containing the information specified in this window. If the dataset is not valid, the Status will
read "Dataset does not appear to be valid", and the Dataset field will be highlighted in pink. If there are problems connecting to the server
listed, then the Status will read "Could not connect to the given server", and the Server field will be highlighted in pink.

 - Adds a new entry to the Remote ADDE Data Manager containing the information specified in this window. This option
does not do any verification testing, so it's possible to add an incorrect dataset name, username, project number,etc.

 - Closes the window and discards any information that was entered.

Editing an Existing Remote Dataset
If you highlight an editable entry in the ADDE Data Manager window and then click the Edit Dataset button, the window and fields are the same
as above, except that the window title is Edit Remote Dataset and the bottom buttons say Verify and Save Changes, Verify Changes, and Save
Changes (rather than Verify and Add Server, Verify Server, and Add Server).

Image 3: Edit Remote Dataset Window

Note that you cannot edit any of the remote datasets that come with McIDAS-V.

Removing an Existing Remote Dataset
If you highlight an editable entry in the ADDE Data Manager window and then click the Remove Selection button, it immediately removes the
entry from the table. There is no recovery option, so if you accidentally remove an entry you need, you will have to remake the entry using the Add
New Dataset button. Note that you cannot remove any of the native remote datasets that come with McIDAS-V.

Importing MCTABLE...
The window below appears if you click the IMPORT MCTABLE... button in the Remote ADDE Data Manager window.
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Image 4: Import MCTABLE Window

This window lets you import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data Manager. For example,
McIDAS-X users may have added access to many servers via the DATALOC command. Those entries are stored in the MCTABLE.TXT file,
which can be imported to McIDAS-V.

The fields and buttons are defined below.

Look In - Selects the location of where to look for your MCTABLE.TXT file.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

Use ADDE Accounting? - Enables you to enter a Username and Project Number if the servers in the MCTABLE.TXT file you are importing
use ADDE accounting. If you use different usernames and/or project numbers on some servers, you can edit them (via the Edit Dataset
button in the Remote ADDE Data Manager window) after you import the file.

File Name - Selects the file that you are importing as your MCTABLE.

Files of Type - Narrows down the files shown in a folder to a specific data type.

 - Imports the selected file so that its entries are added to the Remote Data tab of the ADDE Data Manager.

 - Closes the window and discards any information that was entered.

Menus
A couple of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to this tool.

The File menu has these unique options:

New Remote Dataset - Opens a Add Remote Dataset window that prompts for information about the dataset.

New Local Dataset - Opens an Add Local Dataset window that prompts for information about the dataset.

Import MCTABLE... - Opens an Open window that allows you to import MCTABLE ADDE entries into the ADDE Data Manager.

Import from URL... - Opens an Import from URL window that allows you to specify a URL for a MCTABLE along with accounting
information.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__add_new_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__add_new_entry
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Close - Closes the ADDE Data Manager window.

The Edit menu has these unique options:

Edit Entry... - Opens the Edit Remote Dataset window, where you can edit the information about your local dataset. This window is the
same as the Add Remote Dataset window.

Remove Selection - Removes the selected dataset from the list of local datasets. Note that you cannot remove the native datasets that come
with McIDAS-V.

The Local Servers menu has these unique options:

Start Local Servers - Starts a new local server if your current one has stopped working.

Stop Local Servers - Stops the currently running local server.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__edit_dataset
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Local ADDE Data Manager
The Local and Remote ADDE Data Managers are accessible in the Main Display window through the Tools->Manage ADDE Datasets menu
item. Select the Local Data tab to manage access to image data on your workstation, or the Remote Data tab to manage access to data on other
workstations. Continue below for more information about the Local ADDE Data Manager, or go to the Remote ADDE Data Manager page for more
information.

Viewing the Existing Local Datasets
Adding a New Local Dataset
Editing an Existing Local Dataset
Menus

Viewing the Existing Local Datasets

Image 1: Local ADDE Data Manager

The Local ADDE Data Manager lets you add, delete or edit local image datasets that are available through the Satellite->Imagery chooser when
you select <LOCAL-DATA> in the Server field. Other types of data (e.g., grib or point) in local files can be accessed directly through other
choosers (e.g., the General->Files/Directories chooser).

The columns in the table and buttons are defined below.

Dataset - Sets the dataset name for the local server entry. The dataset name is limited to eight characters or less.

Image Type - Sets the image type name for the new local server entry. This will appear under the Image Type pull down menu in the
Satellite Imagery chooser.

Format - Sets the format of the image files. The following formats are supported in McIDAS-V:
AMSR-E L 1b
GINI
LRIT GOES-9
LRIT GOES-10
LRIT GOES-11
LRIT GOES-12
LRIT MET-5
LRIT MET-7
LRIT MTSAT-1R
McIDAS AREA
McIDAS MD

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__image1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__add_new_entry
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__edit_entry
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
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Meteosat OpenMTP
Metop AVHRR L 1b
MODIS L1b MOD02 (MODIS Level 1b)
MODIS L2 MOD04 (MODIS Level 2 Aerosol)
MODIS L2 MOD06 (MODIS Level 2 Cloud Top Properties)
MODIS L2 MOD07 (MODIS Level 2 Atmospheric Profile)
MODIS L2 MOD28 (MODIS Level 2 Sea Surface Temperature)

Note: When loading this data, you must use line/element for the Location, and use the raw size of the image, or a magnification
with the lock icon unlocked)

MODIS L2 MOD35 (MODIS Level 2 Cloud Mask)
MODIS L3 MODR (MODIS Level 2 Corrected Reflectance)
MSG HRIT FD and HRV

Note: McIDAS-V reads the uncompressed segmented MSG Level 1.5 files transmitted by EUMETSAT. The prologue files
(*PRO*) must be in the same directory as the segmented data files or the images will not display.

MTSAT HRIT
NOAA AVHRR L 1b
SSMI (TeraScan netCDF)
TRMM (TeraScan netCDF)

Directory - Represents the location of the local files using the pop up navigation box. At this time, only a directory can be selected. An
option to add files by file mask will be added in the future.

 - Opens the Add Local Dataset window, allowing you to create a new local dataset.

 - Opens the Edit Local Dataset window, allowing you to edit the dataset that is currently selected in the Local Data tab.

 - Removes the currently selected local dataset.

 - Closes the ADDE Data Manager window and saves any changes.

At the bottom of this window, there is a status message that lets you know if local servers are running. The Server Manager will attempt to connect
to ports 8112 to 8122. When port 8112 cannot be connected to, port 8113 will be attempted, and then 8114 and so on. After these ports have been
stopped or cannot be connected to, the status message will say "Local servers have been stopped". When this status message is showing, you cannot
connect to any local servers. To help avoid connection problems, your firewall software must allow connections to port 8112.

Adding a New Local Dataset
To add a new local dataset entry, select File->New Local Dataset from the ADDE Data Manager menu, or click .

Image 2: Add Local Dataset Window

The Add Local Dataset window lets you add access to local image datasets so they are available through the Satellite->Imagery chooser. The fields
and buttons are defined below.

Dataset - Represents the dataset name for the local server entry. The dataset name is limited to eight characters or less.

Image Type - Represents the image type name for the new local server entry. This will appear under the Image Type pull down menu in the
Satellite->Imagery chooser. The image type name is limited to twelve characters or less.

Format - Represents format of the image files. See the above list for data formats that are supported as local datasets in McIDAS-V.

Directory - Represents the location of your files.

 - Adds the new entry to the Local ADDE Data Manager containing the information specified in this window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__add_new_entry
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__edit_entry
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__format
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 - Closes the window and discards any information that was entered.

Editing an Existing Local Dataset
To edit an existing entry, double click on the entry, select Edit->Edit Entry..., or click  to bring up the Edit Local Dataset window.
Make the needed changes and click  (or click  to discard any changes and close the window).

Image 3:Edit Local Dataset Window

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to this tool.

The File menu has these unique options:

New Remote Dataset - Opens a Define New Remote Dataset window that prompts for information about the dataset.

New Local Dataset - Opens an Add Local Dataset window that prompts for information about the dataset.

Import MCTABLE... - Opens an Open window that allows you to import MCTABLE ADDE entries into the ADDE Data Manager.

Import from URL... - Opens an Import from URL window that allows you to specify a URL for a MCTABLE along with accounting
information.

Close - Closes the ADDE Data Manager window.

The Edit menu has these unique options:

Edit Entry... - Opens the Edit Local Dataset window, where you can edit the information about your local dataset. This window is the same
as the Add Local Dataset window.

Remove Selection - Removes the selected dataset from the list of local datasets.

The Local Servers menu has these unique options:

Start Local Servers - Starts a new local server if your current one has stopped working.

Stop Local Servers - Stops the currently running local server.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RemoteDataManager__add_new_dataset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocalDataManager__add_new_entry
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Weather Text Product Controls
Overview
The Weather Text Product Control is used to display weather text products (forecasts, warnings, watches, etc.) produced by the National Weather
Service and other international meteorological agencies. The Weather Text Product Display is accessed through the Main Display window via
Tools->Text Data->Weather Text Products(from server). The user interface consists of three tabs, Products, Display, and Locations.

The Products tab selects and displays the text products. When a product is selected, the available stations are plotted in the Main Display window.
One or more stations can be selected by clicking on the station in the Main Display window (or Ctrl+click for multiple stations). When a station is
selected, the text product for that station is displayed in the Weather Text Product Display:

Image 1: Weather Text Product Display in the Text View

Find - Searches for specified items in the text.

 Find Next - Finds the next occurrence of the searched for item in the text.

 Find Previous - Finds the previous occurrence of the searched for item in the text.

 Highlight All - Highlights all occurrences of your searched for item in the text. When all items are highlighted in the text, this button will
change from white to yellow.

Match Case - Finds only items in the text that match the case of the entry in the Find field.

By default, the text product is displayed as raw text. Click on the HTML tab at the bottom of the display window to view the product in HTML.



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 316 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Image 2: Weather Text Product Display in the HTML View

Show Glossary - Toggles a glossary which will highlight certain terms in the text. When the links are clicked, a dialog will pop up with an
explanation of the term.

By default, the most recent text product is displayed. Previous versions of the products can be displayed by selecting a time range from the Time
Covered drop-down list. Use the Time Animation Widget to loop through multiple products. The time animation will be synced with any other data
in the Main Display window.

The Display tab controls the display of the station locations in the Main Display window:

Image 3: Display Tab of the Weather Text Product Display Window

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE
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Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown. The  icon allows you to lock the
stations that are currently being displayed and not have their display changed when navigating.

Density - Changes how dense the display of stations is when decluttering. More stations will appear in the Main Display window with a
higher Density value. This option is only available if you have the Declutter checkbox selected.

Display - Displays locations as a fixed specification of a symbol and/or an identifier or as one of the available station models.

Use the options under the Predefined radio button to control what station information is displayed. Use the options in the Symbol panel to
control what marker symbol is displayed. Clicking an item will immediately change the display. Use the Visible checkboxes to trigger the
visibility of the ID or Symbol in the Main Display window. Color sets the color of the Symbol and ID in the Main Display window.

When you select the Layout Model radio button the station model facility is used to display the location. You open the Station Model Editor
by clicking the  Edit icon.

Vertical Position - Displays the locations at their altitude (if there is one) or specifically defines the vertical position for all stations. This can
be changed by using the slider or entering a value into the field.

The Locations tab lists information about the selected location and shows lists of all the locations and the locations currently visible in the Main
Display window:

Image 4: Displayed Locations Tab in the Locations Tab of the Weather Text Product Display Window

Properties

All Locations - Lists all of the locations relevant to the chosen parameter.

Displayed Locations - Lists only the locations that are currently visible in the Main Display window.

Listen for clicks - Updates the current location information to the station you select in the Main Display window.

Center on selected - Centers the Main Display window over the location selected in this tab. This only works if Listen for clicks is selected.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Add Locations - Adds the locations of a variety of features, including city labels, states, oceans, earthquakes, etc. to the display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__FILE
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Color - Changes the color of the location labels in the Main Display window.

The View menu has these unique options:

Show Flythrough - Opens the Flythrough feature which allows you to interactively explore the display.

Use Projection From Locations - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you have modified.

Chart - Allows you to display a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the
Plot Properties window.

Show Raw Data - Displays the data in its raw format in the chart before any rounding/formatting is done to the data by McIDAS-V.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__flythrough
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__chartlayout
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Chart__plotproperties
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Storm Track Controls
Overview
The Storm Track Control displays tropical storm observation and model output tracks. Currently the McIDAS-V supports both the Automated
Tropical Cyclone Forecasting System (ATCF) data as well as data from the Shanghai Typhoon Institute.

To load in ATCF data select the Tools->Text Data->ATCF Tropical Storm Data menu item in the Main Display window. This creates a data
source with a predefined path to the National Hurricane Center ftp site. Then, create the Storm Track display.

The display control shows the set of available storms on the left panel organized by year and basin, e.g., Atlantic (AL), Eastern Pacific (EP) and
Central Pacific (CP).

Year Display
At the top of the list is an option (Yearly Tracks) which allows the user to display the observed tracks for all the storms in a given year. You can
load and/or unload any number of years worth of observed tracks. The color swatch changes the color of the tracks for a given year. The Time
Mode menu allows one to change the animation mode, e.g., use the year or use the storm start time.

Image 1: Storm Track Window

Storm Display
To show the observation and all of the model results for a single storm select the storm in the list and press the  button. You can
load any number of storms but they are shown in different panels. You can use the View->Storm Tracks menu to list out all of the loaded storms,
remove them all, etc. Once a storm is loaded it can be removed with the  icon shown in the upper right.

Once a storm is loaded the first thing you should do is to specify which "Techs" (or models) to use by bringing up the control's Properties dialog
Edit->Properties menu. Use Ctrl+A to select all items in the tab, the left/right arrows to remove/add an item from/to the Use column, or Delete to
remove an item from the Use Column.

http://www.nrlmry.navy.mil/atcf_web/index1.html
http://www.sti.org.cn/
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Image 2: Techs to Use Tab of the Storm Track Properties Window

Properties

 - Adds the selected item from the Don't Use column to the Use column, adding the Tech to the Tracks tab of the Storm Track
window.

 - Removes the selected item from the Use column and adds the item to the Don't Use column, removing the Tech from the
Tracks tab of the Storm Track window.

Save as preference - Saves the setup of the Don't Use and Use columns for future displays.

The Storm display panel consists of three tabs: Tracks, Table and Storm Chart.

Tracks
The Tracks tab controls the display and animation of the tracks.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StormTrackControl__tracks
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StormTrackControl__table
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StormTrackControl__chart
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Image 3: Tracks Tab of the Storm Track Window

Properties

Points - Specifies which station model to use for both the Observation as well as the Forecast tracks.

Animation - Specifies the station model to use for the Observation track that moves along with the time animation.

Animation Mode - Determines whether to animate the tracks or show all of the tracks.

Color By - Specifies whether the track is shown with a fixed color or using a color table. The color table used is a single one for the entire
display control and is set through the main Edit menu.

Show - Specifies what is to be shown. One can toggle on/off the visibility of the Observation track, all of the forecast tracks, or individual
forecast tracks.

Table
The Table tab shows a tabular listing of all of the observational track data and individual forecast model runs. On the left is a tree view organized
by the Tech and model run time. Selecting one of the model runs will display the data in the table. The main File->Save->Export to Spreadsheet
menu allows you to export the track data to an Excel spreadsheet. In the File Dialog are options to select what is to be saved.
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Image 4: Table Tab of the Storm Track Window

Properties

 - Opens a Flythrough window that allows you to interactively explore the display in the Main Display window.

Storm Chart
The Storm Chart tab shows time series charts of selected tracks. Under the main Edit menu you can any number of new forecast time or forecast
hour charts. The forecast time chart is based around the model run time of the selected forecasts. The forecast hour charts selects data across the
different model run times, e.g., you can show the 12 hour forecast from each model run.

To do the charting of the storm track, one or more Techs need to be selected. Once selected the Forecast Hour/Forecast Time list is populated. One
or more times can be selected (Ctrl+click). Each Parameter that is selected will result in a new chart shown on the right.
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Image 5: Storm Chart Tab of the Storm Track Window

Properties

Techs - Selects the source of the data for the charts in the Storm Track window. This is either observation or model data.

Forecast Time - Allows you to select which forecast model runs to display in the charts.

Storm Category - Shows the ATCF storm category.

0 DB Disturbance

1 TD Tropical
Depression

2 TS Tropical Storm

3 TY Typhoon

4 ST Super Typhoon

5 TC Tropical Cyclone

6 HU Hurricane

Min Pressure - Plots the pressure level at the time of the observation/forecast.

Max Windspeed - Plots the wind speed at the time of the observation/forecast.

Use Difference - Plots the difference between the forecasted value and the observed value for the chosen parameter(s).
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 - Removes the Storm Chart tab from the Storm Track window.

Menus
Many of these menu items seen utilizing this tool are standard options that can be found in the Menus section of the Layer Controls page. However,
there are some options that are unique to this display.

The File menu has these unique items:

Save->Export to Data File - Saves the file as a Microsoft Excel (.xls) file.

Save->Export to Google Earth - Saves the file as a Google Earth (.kml) file.

Close Window - Closes the Storm Track window.

The Edit menu has these unique items:

Edit Mode - Allows you to change the track of the storm in the Main Display window by clicking and dragging on the track, and allows you
to edit values in the table.

Add Forecast Time Chart - Adds a new tab to the Storm Track window that is the same as the Storm Chart tab. Here, you can enter a new
forecast time and create new charts.

Add Forecast Hour Chart - Adds a new tab to the Storm Track window that is the same as the Storm Chart tab. Here, you can enter a new
forecast hour and create new charts.

The View menu has these unique items:

Storm Tracks - Allows you to select an archived or current storm to display.

Use Projection From Tracks - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you may have modified.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Color Table Editor
Introduction
Starting the Color Table Editor
Using the Color Legend
Painting and Editing Colors
Using Breakpoints
Saving, Importing, and Exporting
Using the Color Chooser
Menus

Introduction
The Color Table Editor supports editing existing color tables and creating new ones. A color table is an ordered collection of colors that is used to
color a display according to a range of data values.

Image 1: The Color Table Editor

Starting the Color Table Editor
The Color Table Editor can be used stand-alone by selecting the Tools->Color Tables menu item in the Main Display window. It can also be used
or in conjunction with a particular layer by right-clicking on the layer's color bar in the Legend and selecting Edit Color Table, or through the
layer's Edit menu (Edit->Color Table->Edit Color Table). You can also click on the button that represents the name of the color bar in the Layer
Controls tab and select Edit Color Table.

The Color Table Editor starts with a color table loaded in it. If you are working with a data display and you open the Color Table Editor through the
Layer Controls tab of the Data Explorer, the color table in the editor is the same as in the display. If you want to use or edit a different color table,
use the Color Tables menu to select from the categorized list of color tables:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__intro
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__starting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__legend
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__painting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__breakpoints
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__saveCT
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__chooser
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Legend__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__edit
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Image 2: The Color Tables Menu

Color tables are grouped into categories. Click on a color table to bring it into the Color Table Editor. To change to the newly selected color table
for a display on the Main Display window, click OK or Apply at the bottom of the Color Table Editor. Apply will save changes to the color table,
while keeping the Color Table Editor open, and OK will save any changes to the color table and close the Color Table Editor. Also, when editing a
color table that is currently being used to display a layer in the Main Display window, there is an Auto update checkbox on the bottom right of the
Color Table Editor. When this box is checked, any changes made to the color table will be applied directly to the display in the Main Display
window. If you are making several changes to the color bar at once, and you have a lot of data displayed in the Main Display, it is recommended
that you do not have this option turned on, as it will use up more memory. Once done making changes to the color bar, click Apply or OK to apply
your changes to the displayed data.

Using the Color Legend

Image 3: The Color Legend

Properties

Color table - Lists the name of the color table currently being displayed in the Color Table Editor.

Category - Lists out the category that the color table currently being displayed in the Color Table Editor is under. The category is utilized to
help organize the color bars in the Color Tables menu of the Color Table Editor. In the example above, the color table for Temperature can
be found under the Color Tables->System menu item. You can enter your own values into this text field to organize your color bars in your
desired fashion. If you wish to use multiple levels of menus, you can use the ">" symbol between different menu levels. For example, if you
have a variety of color bars to be utilized in different weather conditions, and you are making a color bar for CAPE, you can specify a
Category of "Weather > Severe". If you give your color bar a name of CAPE, once your color bar is saved, it can be found under the Color
Tables->Weather->Severe Weather->Cape menu item of the Color Table Editor.

History - Allows you to step forward and backward through changes you have made. Using Shift+click on these buttons will step
forward/back 10 changes.

 - Sets the minimum and maximum data values on the color bar, with minimum being the breakpoint at the left end of the color
bar, and maximum being the breakpoint on the right end of the color bar. You can change these values by typing values into the fields and
pressing Enter or by clicking .

Colors - Shows the number of colors currently in the color bar. This is how many segments your color bar is broken up into. You can
decrease or decrease the number of colors by clicking on the  buttons above the left and right ends of the color bar. You can add/remove
10 colors at once by using Shift+click on these buttons. New colors are added or removed at each end of the legend with the same color as the
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end color. The minimum number of colors required in the color bar is five, and there is no upper limit. The more colors you have in your
color bar, the smoother the transition of colors between break points will be if interpolating colors.

Color Bar - Displays the current color bar that you are working with. Any changes that you make in the Color Table Editor window will be
applied to this color bar.

Paint Mode - Determines how the colors will be applied to the color bar. These controls are described in the section below.

Painting and Editing Colors
You can "paint" in the color table by left-clicking and dragging the mouse within it. When your mouse is over the color table the cursor will change
to a paintbrush and a gray line is drawn to indicate the position of the cursor.

The type of painting is specified by the Paint Mode buttons.

Fill - Fills the color table with the currently selected color in the color chooser when the mouse is clicked and dragged on the color table.
With this Paint Mode, the color you selected will be drawn in solidly over the distance you click and drag on the color table. There will be no
interpolation.

Interpolate - Applies a linear interpolation with the currently selected color in the color chooser when the mouse is clicked and dragged in
the color table. Over the distance you click and drag on the color table, the color will gradually transition from one end to the other.

Brightness - Applies the given brightness value (in the pull-down list) when the mouse is clicked and dragged on the color table. A higher
value will make the colors appear lighter, and a lower value will make the colors appear darker.

Transparency - Applies the given transparency value (in the pull-down list) when the mouse is clicked and dragged on the color table. The
transparency value is important because it will be utilized in the Main Display when you have a field using this color table. A transparency
value of 0 will make it so you cannot see any features through a layer utilizing this color bar. A transparency value of 100 will make it so you
do not see the layer utilizing this color bar. Transparency can be used so you can visualize multiple items in one display without worrying
about the items overlapping each other.

Color Space - Allows you to add select color space that will be applied to the color bar. This helps to determine the color mixing when using
the Interpolate Paint Mode.

Using Breakpoints
The editor uses "breakpoints" indicated along the top of the color legend with triangles and the numerical value. By default, the beginning and
ending of the color bar will each be a breakpoint. You can add additional breakpoints to the color bar by right-clicking on the color bar and
selecting Add Breakpoint, or by double-clicking on or above the color bar where you want a breakpoint.

Clicking on a breakpoint makes it active. The active breakpoint will have bold text for the label, and the colored triangle below it will have an
outline of yellow. There is only one active breakpoint at a time. Breakpoints are used for a number of things: showing the data and transparency
values at a point along the color table and changing the colors (fill, interpolation or transparency).

The values on the breakpoints are determined by the position of the breakpoint along the legend, proportional to the min and max of the Range.
Changing the minimum and maximum of the Range changes the breakpoint values.

You can move the active breakpoint (assuming it isn't locked) in several ways:

Left-click and drag it with the mouse pointer
Move in small increments with the right or left arrow keys (If there is no response, first left-click on the breakpoint to make it active)
Right-click on the breakpoint and use the menu item Change Breakpoint. Enter a new value into this field and click OK

If you have the Actively set color checkbox selected, when you change the color in the color chooser that color will be applied to the color slot
under the selected breakpoint automatically.

You can also change colors and manipulate breakpoints by right-clicking on a breakpoint:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ColorTableEditor__add
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Image 4: Add a Breakpoint

The choices are:

Remove Breakpoint - Removes the active breakpoint.

Lock/Unlock Breakpoint - Locks or unlocks the active breakpoint. When locked, it cannot be moved.

Change Breakpoint - Sets the breakpoint to a new value.

Add Breakpoint - Adds a new breakpoint to the color bar.

Here - Adds a new breakpoint where you clicked on the color bar.

At Data Point - Opens a Breakpoint Value window, which allows you to enter a specific numerical value to place your breakpoint.

At Beginning - Adds a new breakpoint on the far left end of the color table.

At End - Adds a new breakpoint on the far right end of the color table.

Edit Colors - Allows you to change the colors between the breakpoints.

Interpolate - Interpolates colors on both sides, to the left or right, of the selected breakpoint up to the next breakpoint. Transparency
and brightness values will not be interpolated between the colors.

Fill - Fills a single, solid color on both sides, to the left, or to the right of the selected breakpoint up to the next breakpoint.

Transparency - Sets the transparency value on both sides, to the left, or to the right of the selected breakpoint up to the next
breakpoint. The current transparency value of the breakpoint will be listed next to Transparency. You can also select to interpolate
transparency to the left, right, or on both sides of the breakpoint. For example, if your selected breakpoint has a transparency value of
100, and the next breakpoint on the right has a transparency value of 50, interpolating transparency to the right of this breakpoint will
cause the transparency values between the two breakpoints to gradually shift from 100 to 50 (more to less transparent).

Brightness - Sets the brightness value on both sides, to the left, or to the right of the selected breakpoint up to the next breakpoint. The
current brightness value of the breakpoint will be listed next to Brightness. You can also select to interpolate brightness to the left,
right, or on both sides of the breakpoint. For example, if your selected breakpoint has a brightness value of 100, and the next breakpoint
has a brightness value of 50, interpolating brightness to the right of this breakpoint will cause the brightness values between the two
breakpoints to gradually shift from 100 to 50 (more to less bright).

Replicate Color Table - Replicates the current color table x number of times over the current color table. The overall range will not change.

Invert Color Table - Reverses the order of the color table. The range will not change, but the colors will be reversed.

Saving, Importing, and Exporting
You can modify an existing color table, or edit an existing color table and save it with a new name to make a new color table. Any new or modified
color table can be saved for future use. To save a new or modified color table simply select the the File->Save. To save a modified color table as a
new color table, select File->Save As and enter the new name in the dialog box that appears. This new color table will now be permanently saved in
your local collection of color tables. You can control where your color bar will be saved by selecting a Category in the upper right of the Color
Table Editor.

To save a color table as a file which can be shared with others in McIDAS-V, select the File->Export menu item. A file dialog will appear that will
allow you to save the color table as an XML-format file. We suggest you use a file extension of .xml.

To use a color table as a file which has been supplied to you by another McIDAS-V user, select the File->Import menu item. A file dialog will
appear that will allow you to find the color table as an XML-format file. The following types of color tables can be imported:

McIDAS-V (IDV) color tables (*.xml)
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GEMPAK color tables (*.tbl)
3-column RGB color table (*.ascii)
McIDAS-X color tables (*.ET)

Another way that you can save all of your color tables at once is to save them as a plugin. This can be done through the Plugin Manager, by
including your colortables.xml file that is inside of your /User/McIDAS-V directory. You can then pass this on to any McIDAS-V user, and they
can install this plugin and obtain all of your color bars without having to individually transfer them.
3-column RGB color table

The definitions of the 3-column RGB color table are divided over a range of values. Each line represents one of the equal sized blocks on the color
bar, and the bar is saved in the *.ascii format. Ascii files are text files with three space-separated columns consisting of the RGB component counts.
An example is shown below:

180 0 10 140 0 50 140 0 140 80 0 180 0 120 60 0 140 80

In the example above, there are six lines (definitions) that would be divided into the color table. The color table would be broken into six even
segments, with the first line applying to the first segment, the second to the second segment, etc. Your file may be any number of lines long. The
values in these columns must be between 0 and 255.

Using the Color Chooser

 
Image 5: The HSB Tab of the Color Chooser

The Color Chooser, in the lower half of the Color Table Editor window, allows you to select any possible color. The chooser contains two tabs,
HSB (Hue, Saturation, Brightness) and RGB (Red, Green, Blue). In most cases, the HSB tab provides better control and better depiction of color
changes because of its hue, saturation, and brightness controls. Thus, it is recommended that you use the HSB tab (rather than the RGB tab) unless
you have specific red, green, and blue values to set.

The HSB Tab

The HSB tab allows you to control color by hue, saturation, and brightness, thereby making any color. With the HSB tab open, click on one of the
radio buttons marked H, S, or B for the corresponding control for hue, saturation, or brightness. All controls in the HSB tab also show the RGB
values for any color selected, in case you need to know the RGB values for another use.

Hue is the term indicating a pure color selection from the spectrum. Saturation is an indication of how much white is added to the hue. 100%
saturation is pure hue with no white. Brightness is an indication of how much black is added to the hue. 100% brightness has no black and
maximum brilliancy, but can be any saturation from the hue to pure white. 0% brightness is solid black. Some colors are not found in the spectrum,
and are a mixture of a hue and black and/or white. You only need to use one of the controls for H, S, or B to make any color.

With the Hue (H) radio button selected, the slider bar chooses the pure hue. Once you have chosen a hue, clicking or dragging the mouse on the
color display chooses degrees of saturation and brightness for that hue.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Plugins__FILE
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Image 6: The HSB Hue Tab, Set on Green With High S and High B

Saturation (S) has a slider bar with the full range of saturation. The bottom is always solid black. A saturation value of 100 is the pure hue, and
more black is mixed in with the hue until it is solid black at a value of 0. The saturation value can be controlled by the slider to the right of the color
square, or by entering a value into the field to the right of S and pressing Enter. After selecting a saturation level, you can click and drag in the
colored square to get your desired color.

 
Image 7: The HSB Saturation Tab, Set on the Same Green

Brightness (B) has a slider bar with the full range of brightness. The bottom is always solid white. A brightness value of 100 is the pure hue, and
more white is mixed in with the hue until it is solid white at a value of 0. The brightness value can be controlled by the slider to the right of the
color square, or by entering a value into the field to the right of B and pressing Enter. After selecting a brightness level, you can click and drag in
the colored square to get your desired color.

 
Image 8: The HSB Brightness Tab, Set on the Same Green

All controls in the HSB tab show the RGB values for any color selected, in case you need to know the RGB values for another use.

The RGB Tab

The RGB tab allows you to control color by specifying individual Red, Green, and Blue components.
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Image 9: The RGB Tab, Set on the Same Green

The individual R, G, and B components are numerically scaled between 0 and 255, ranging from black to the true color. Each color can be modified
by using the slider, typing a value into the field and pressing Enter, or by using the up and down arrows to the right of the value.

As you make modifications to the RGB components, the current color will be displayed above the HSB and RGB tabs next to the Actively set
color checkbox. If you have the Actively set color checkbox selected, any changes you make in this tab will be applied directly to the color bar as
you make the changes.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.

The File menu has these unique options:

New - Begins a new color table from scratch.

Save - Saves changes to a color table. This will overwrite the current color bar that you are editing.

Save As... - Saves a color table and allows you to name it. This allows you to save your updated color bar with a new name and keep your
original color bar as well.

Remove - Removes an existing color table. Note that you cannot remove any system color bars (color bars that are included with McIDAS-
V). If you have a system color bar open, this Remove option will be grayed out and not usable. You can only remove color bars you have
created yourself.

Import... - Imports a color table in the IDV (*.xml), GEMPAK (*.tbl), 3-column RGB (*.ascii), and McIDAS-X (*.et) color table formats.

Export... - Exports a color table in the IDV (*.xml) and GEMPAK (*.tbl) color table formats.

Close - Closes the Color Table Editor.

The Color Tables menu has these unique options:

Satellite/AWIPS/Radar/System/Miscellaneous - Contains pre-existing color tables as well as color tables that you have saved that you can
edit.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Station Model Editor
The Station Model Editor composes the model and style used to plot data on a map from observations at discrete points (e.g., weather observations).
This tool is used to edit existing models or to create new models. The Layout Model Editor is opened with the Tools->Station Model Template
menu item in the Main Display window.

Creating a Station Model
Editing a Station Model
Properties Dialog - Display Tab
Properties Dialog - Color By Tab
Properties Dialog - Scale Size Tab
Properties Dialog - Rotate Tab
Menus

 
Image 1: Layout Model Editor

Creating a Station Model
You can create your own station model from scratch by utilizing the File->New menu option, or you can select an existing station model with the
Layout Models menu. The display includes a horizontal and vertical line, which acts as a reference point for the location of your station model with
respect to the physical location of the observation (at the origin). The different shapes and features that you can add to the station model are in the
left panel. They can be added to the station model by left-clicking the item and then clicking where you want to place it. Once in the Layout Model,
individual components can be moved by left-clicking and dragging them. When you place an item into the station model, the Properties dialog for
the component will open. You can also double click on an item to bring up its Properties dialog.

Each component of the station model can be resized by dragging the black squares along the outside of the item. You can select multiple items to
align at once by holding down Shift and clicking on the items you wish to move. Each item in the station model also includes a red "Alignment
Point', which acts to locate the individual components of the model with respect to the center point of the observation. The location of the
Alignment Point to the item can be changed via the Alignment Point option in the menu when you right click on the item.

When you hold your mouse over a component of the station model, the name of the item will be listed in the bottom bar of the Layout Model
Editor. This can be useful if you have multiple Value fields for text (temperature, dew point, etc.).

To save a station model you have composed, use the File->Save or File->Save As... menu items. When you save a station model, any point data
displays that are using it will be updated. To remove a model, use the File->Remove menu item. You cannot remove a model supplied with
McIDAS-V, but you can remove local models.

Editing a Station Model

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__create
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__edit
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__image2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__image3
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__image5
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__image6
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__menus
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__image2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__popup
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There are many options that you can control for each individual component of the station model. This menu is seen by right-clicking on an item.

Image 2: Editing a Station Model Menu

Set Color - Sets the color of the selected item.

To Front - Moves the selected item in front of others that may overlap it.

To Back - Moves the selected item behind others that may overlap it.

Delete - Removes the selected item from the station model display. You can also use the Delete key to remove an item.

Hide - Grays out the component in the station model, still leaving the object in the model, but not displaying it in the Main Display window.

Alignment Point - Sets the location of the Alignment Point with respect to the item. For example, NW would place the Alignment Point to
the northwest (upper left) of the item. This is not an option when working with windbarbs or vectors

Center - Centers the display in both the horizontal and vertical, just in the horizontal, or just in the vertical.

Properties... - Opens the Properties Dialog described below. You can also get to the Properties Dialog by double-clicking on a component of
the station model.

The Properties window consists of four tabs: Display, Color By, Scale Size, and Rotate.

Properties Dialog - Display Tab
The Display tab allows you to assign which observation variable is associated with that item. Numerical values should appear in a "Value" item,
text in a "Text" item, etc. Note that the items in this tab may differ depending on what item's properties you are displaying.

Image 3: Display Tab of the Properties Dialog

Properties

Parameter - Represents what parameter the station model item is displaying. This can be a single parameter, such as pressure, or it can be an
equation. This is possible because the parameter identifiers in the station model can hold embedded Jython code, and any parameter that
begins with "=" is treated as a Jython expression. For example, you can type "=T-Td" for dew point depression. You can also format this as
"='Td:'+str(T-Td)". If you want to format the result of the calculation using the format specifier from the properties dialog, then enter
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"='Td:'+format(T-Td).

Unit - Determines the unit that the parameter will use in its display.

Format - Represents how the numerical value will be displayed. This can affect rounding. An example of how each format will appear is
written in the 'ex:' next to the Format field.

Font - Sets the font of the item's text when displayed in the Main Display window.

Size - Sets the size of the item's text when displayed in the Main Display window.

Shown - Determines if the item will be shown as part of the station model.

Foreground Color - Represents the color of the text/symbol.

Background Color - Sets a background color for the text/symbol if desired. A  through this field is representative of a transparent
background.

Scale Size By - Scales the size of the item with respect to other items in the station model. The default value for this field is 1, meaning that
all parameters in the station model are scaled the same.

Properties Dialog - Color By Tab
The Color By tab consists of two tabs within itself: Map Value Into Color Table, and Color From Parameter. This tab allows you to determine
how you want to color your station model.

The Map Value Into Color Table tab allows you to color the parameter based off of its numerical value in relation to the set data range and color
table for the parameter.

 
Image 4: Map Value Into Color Table Tab of the Color By Tab

Properties

Map Value of - Sets the parameter used for coloring the displayed item. The  to the right of this field allows you to select a currently loaded
field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field. This represents the end points for the color table.

Unit - Sets the unit of the parameter listed in the Map Value of field.

Color Table - Sets the color table of the parameter to be one of the already existing tables.

For example, in the above image the Temperature parameter has been specified with data range -90 to 45 Celsius. For each display, McIDAS-V will
find the Temperature value (e.g., 15 Celsius), convert it to the specified unit (if necessary), find where it lays within the range, and use the
corresponding color from the color table to display the data in the Main Display window.

The Color From Parameter tab allows you to specify parameter, a set of (regular expression) patterns, and a corresponding color. If the text value
of the parameter matches one of the patterns then the given color is used to color the shape.
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Image 5: Color From Parameter Tab of the Color By Tab

Properties

Get Color From - Selects a parameter or set of patterns that correspond to a color. The  to the right of this field allows you to select a
currently loaded field or an alias.

Parameter Value - Represents a numerical, fixed value that will be colored by the color selected for each value. Clicking  will
change any set color back to transparent. Pressing the  button will give you two more Parameter Value fields once all other fields
are filled.

Properties Dialog - Scale Size Tab
The Scale Size tab allows you to specify a parameter to scale the shape by. For each point display, McIDAS-V will find the value of the parameter,
determine where that value lies within the data range, and find the corresponding scaling from the scale factor range.

 
Image 6: Scale Size Tab of the Properties Dialog

Properties

Scale By Parameter - Sets the parameter used to scale the data in the Main Display window. The  to the right of this field allows you to
select a currently loaded field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field of the Color By tab.
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Unit - Sets the unit of the parameter listed in the Scale By Parameter field.

Scale By Factor - Sets the range for which the scaling factor will be applied to the data.

Properties Dialog - Rotate Tab
The Rotate About Axis tab works like the scale and color by facilities. Note that the rotation is about the Z axis in X/Y/Z space. It is not a rotation
in Lat/Lon space. All three tabs in the Rotate tab have the same fields.

Image 7: Rotate About Tabs of the Rotate Tab

Properties

Rotate By Parameter - Sets the parameter used to rotate the data in the Main Display window. The  to the right of this field allows you to
select a currently loaded field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field of the Color By tab.

Unit - Sets the unit of the parameter listed in the Scale By Parameter field.

Degrees - Sets the range of degrees for which the data will rote about each respective axis.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.

The File menu has these unique options:

New - Opens a New Layout Model window that prompts for the name of the station model you are going to create.

Save - Saves the station model so that it can be used in McIDAS-V.

Save As... - Saves the station model so that it can be used in McIDAS-V.

Rename... - Opens a Rename Layout Model window that prompts for you to change the station model's name.

Remove - Removes the station model that you are viewing.

Import... - Allows you to import a station model as an IDV station model file (*.ism).

Export... - Allows you to export a station model as an IDV station model file (*.ism).

Close... - Closes the Layout Model Editor.

The Edit menu has these unique options:

Symbols - Lists the different symbols that you have in your station model. Clicking on the symbol will bring up the Properties Dialog
window for that symbol, allowing you to make several modifications to it.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Set properties on selected - Opens a Properties Dialog window for the symbol you have selected in the Layout Model Editor. This allows
you to change the range, set the unit, and set a color table for the symbol.

Cut - Removes the selected symbol from the station model.

Copy - Copies the selected symbol from the station model.

Paste - Pastes a symbol into the station model.

Select All - Selects each individual symbol in the station model so that you can perform a cut/copy/paste to all of the symbols at once.

To Front - Moves the selected item to the front of others that may overlap it.

To Back - Moves the selected item to the back of others that may overlap it.

The View menu has these unique options:

Show Alignment Points - Displays a red square representing where the symbol will be centered.

Zoom in - Zooms in on the station model.

Zoom out - Zooms out on the station model.

Zoom rest - Reverts back to original zoom level.

Grid - Adds horizontal/vertical grids to the station model. Increase makes the grid size larger (fewer grids), and Decrease makes the grid size
smaller (more grids).

Black background - Makes the background in the Layout Model Editor black, with white grids and gray axes lines.

White Background - Makes the background in the Layout Model Editor white, with gray grids and black axes lines. This is the default for
the Layout Model Editor

The Layout Models menu has these unique options:

Location - Changes the station model to display the name of the locations of the station models in the Main Display window.

Label - Changes the station model to be a label when displayed in the Main Display window.

Selected - Removes any symbols in the station model, leaving just the Alignment Point.

Observations/Tracks/Grids/etc. - Allows you change the station model to be one of the saved symbols/parameters.
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Parameter Alias Editor
The Parameter Alias Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Aliases menu and allows for
the association between "canonical" parameter names used by McIDAS-V for physical quantities, such as TEMP for temperature, and parameter
names used in particular data sets for the same quantity, such as for example "jan_mean_temp."

Image 1: Alias Editor

Different data sets often have different names for the same physical quantity, such as the quantities for temperature or easterly wind speed
component. You can make McIDAS-V recognize any particular data name as representing a standard quantity. The Alias Editor associates any
particular variable name that may appear in a data set (right column) with a canonical or McIDAS-V name or alias (left column).

The Alias Editor has a number of tabs that display the user editable aliases and the non-editable system aliases. You can right-click on a row in the
System Alias tab to copy that row to the User aliases tab. You can edit a user's entry by right-clicking on the table row.

When you attempt to create a new alias, a Data Alias dialog is shown where you can edit the name, label (descriptive text) and the aliases:

Image 2: Data Alias Properties Dialog

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Menus__tools
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Menus
The File menu has these unique items:

New Alias - Opens a Data Alias dialog, where you can create a name, label, and the aliases.

Export to Plugin - Opens the Plugin Creator window with all of your aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with your selected aliases loaded in.

Close - Closes the Data Alias dialog window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 340 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Parameter Defaults Editor
The Parameter Defaults Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Defaults and allows for
the specification of default color tables, ranges, units, and contouring values for different parameters:

 
Image 1: Parameter Defaults Editor

Properties

Parameter - Represents the name of the parameter. The double down arrows allow you to change the parameter to one of a loaded data
source, or a predefined alias. The parameter name is included with data that is loaded into McIDAS-V.

Color Table - Sets the color table to be used to display the parameter.

Range - Sets the range that the color bar will cover, from low to high.

Contours - Sets the spacing (difference in value) between contours.

Display Unit - Sets the unit used to display the parameter.

This feature lets you preset conventional color and contouring choices, and lets you override system defaults.

There are three sets of defaults: User defaults, Application defaults, and System defaults. While the items in the Application defaults and System
defaults tabs cannot be modified within the tab, you can create a duplicate of the same parameter in the User defaults tab. If the same parameter is
defined as a User default and an Application/System default, the User default will be used first. If you wish to modify an existing default, you can
right-click on the item and select Copy Row to Users Defaults. When you do this the Parameter Defaults window allows you to select what
properties you want to modify and define:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Menus__tools
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Image 2: Parameter Defaults Properties

In the example above, any time a parameter named "rh" is used to define a field, the data will display with the Relative Humidity color bar, a range
of 0-100, units of "%", and contour values as specified in the window. If you wish to define an individual item, such as Range, make sure the
Defined checkbox is selected. If it is not checked, then any values stored in this window will not be saved as a default. From the User defaults tab,
you can also right-click on a row to add a new row, edit the settings for the row, delete the row, or export an individual row as a plugin.

The parameter names are given in regular expression syntax to help match with actual data names. Plain text is matched exactly. The string dot star,
".*", means "any text here." The ^ means "begin with the following text exactly".

Properties

Parameter - Represents the name of the parameter. The double down arrows allow you to change the parameter to one of a loaded data
source, or a predefined alias.

Color Table - Sets the color table to use to display your parameter. You can change this by clicking the Change button, and selecting a pre-
defined color bar.

Range - Sets the range that the color bar will cover, from low to high.

Unit - Sets the unit used to display the parameter.

Contour Interval - Sets the spacing (difference in value) between contours. There are four ways to specify the contour interval.

1. Specify a single value to denote a regular interval between contours.

2. Specify irregular contour intervals with a semi-colon separated list of values. For example:

5400;5460;5800. This would only show contours at 5400, 5460, and 5800.

3. Specify different contour intervals for different ranges in the following format:

cint1/min1/max1;cint2/min2/max2;...;cintn/minn/maxn

For example, with geopotential heights: 30/0/4200;60/4200/8600;120/8600/24000 would draw contours at 30gpm between 0 and
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4200, 60gpm between 4200 and 8600, and 120gpm between 8600 and 24000

4. Specify one individual contour by setting the interval, min, and max as the same value. For example:

5400/5400/5400. This would only show the 5400 line.

Base Contour - Sets the value on which all contours are based. All contours will be integer multiples of the contour interval from the base
value. For example, with a base value of 0 and a contour interval of 3 contours would be created at ... -6, -3, 0, 3, 6... A base of 1 with that
interval would create contours at ... -5, -2, 1, 4, 7... The base value does not have to be the lowest contour level on a plot, or inside the range
of values plotted; it is only a computational reference point. The base contour value is also used for controlling which lines are dashed.

Minimum Value - Sets the limit below which no contour lines are shown. The minimum value may be larger than the base value, so that the
base value may never appear on a plot.

Maximum Value - Sets the upper limit above which no contour lines are shown. The minimum and maximum values do not need to match
contour line values; they are only limits.

Line Width - Sets the line width (in pixels) of the contour lines and labels.

Dash - Dashes contour values less than the base value. If the base is set higher than maximum value, then all lines are dashed. Use the
pulldown menu to select the dash pattern to use.

Labels - Displays contour labels on the image.

Labels: Font - Sets the font style of the contour labels.

Labels: Size - Sets the font size of the contour labels.

Labels: Align - Sets the way contour labels will be written on the contours. Along Contours means the labels will be written along contours,
and while they will not be written upside down, there is a chance they will be written at an angle depending on the layout of the contours.
Horizontal means the contour labels will be written on the contour, but it will be written in the horizontal and not on an angle.

Frequency - Sets the frequency of labels along the contour lines. There will be more labels displayed as the slider is moved from left to right.

Menus
The File menu has these unique items:

New Row - Opens a Parameter Defaults window, which allows you to select what properties you want to define.

Open - Allows you to open an eXtensible Markup Language (XML) file (*.xml).

Import - Allows you to import an eXtensible Markup Language (XML) file (*.xml).

Export to File - Allows you to save your Parameter as an eXtensible Markup Language (XML) file (*.xml).

Export to Plugin - Opens the Plugin Creator window with all of your aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with your selected aliases loaded in.

Close - Closes the Parameter Defaults Editor window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ParameterDefaultsEditor__image2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE
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Parameter Groups Editor
The Parameter Groups Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Groups and allows for
the specification of "parameter groups", named groups of parameter names.

 
Image 1: Parameter Groups Editor

Properties

Parameter Group - Lists the names of the parameters that are being grouped together in the terms that will be used to list them in McIDAS-
V.

Description - Represents the user-made description used to represent the parameter group names.

Params - Represents the way that McIDAS-V stores the names of the parameters. This is necessary so McIDAS-V can look up the selected
parameters.

There are two sets of defaults: user defaults in the tab User Groups, and system groups supplied with McIDAS-V in the System Groups tab. Look
at the system defaults for examples.

The system settings cannot be edited by the user, but right clicking a row allows you to copy a group to the "user defined" table. When you do this
the Parameter Groups Properties window allows you to define the sets of parameters that fall under this group.

 
Image 2: Parameter Groups Properties

Properties

Name - Represents the group name for the selected parameters.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Menus__tools


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 344 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Description - Represents the user-made description used to represent the parameter group names.

Parameters - Represents the way that McIDAS-V stores the names of the parameters. This is necessary so McIDAS-V can look up the
selected parameters.

Menus
The File menu has these unique items:

New Row - Opens a Parameter Group window, which allows you to define the sets of parameters that fall under the group.

Open - Allows you to open an eXtensible Markup Language (XML) file (*.xml).

Import - Allows you to import an eXtensible Markup Language (XML) file (*.xml).

Export to File - Allows you to save your Parameter as an eXtensible Markup Language (XML) file (*.xml).

Export to Plugin - Opens the Plugin Creator window with all of your aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with your selected aliases loaded in.

Close - Closes the Parameter Defaults Editor window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ParameterGroupsEditor__image2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE
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Projection Manager
The Projection Manager allows you to choose, edit, and save map projections for use in McIDAS-V.

A projection is a way of mapping the surface of the Earth (a curved 2D surface) onto a flat 2D surface (a plane). A projection transforms a point on
the earth (specified by latitude, longitude) to a point on the projection plane.

In the Projection Manager, both the projection and the area of the Earth can be specified. For example, you can make a Lambert Conformal map of
North America, and a Lambert Conformal map of Sedgwick County, Kansas. Same projection, different areas.

McIDAS-V provides several basic types of projections: Lat/Lon, Lambert conformal conic, Transverse mercator, Stereographic, Mercator,
Albers Equal Area, Lambert Azimuth Equal Area, Orthographic, VerticalPerspectiveView. Each of these can be parameterized (e.g., tangent
point, origin longitude) to create a specific projection area of that type. When you define a projection and area, you specify the type of projection
and its parameters.

Projection Manager Window
You can bring up the Projection Manager with the Projections-> New/Edit... menu item in the Main Display window, or through the Tools-
>Projections->Edit Map Projections menu option in the Main Display window. Projections supplied with McIDAS-V are shown in the list. There
may be additional projections you have created and named. In the figure, the US->CONUS projection is highlighted, and displayed on the left.

 
Image 1: Projection Manager

Properties

 - Opens a Define/Edit Projection window, where you can edit the map boundaries, type, and name of the existing map.

 - Opens a Define/Edit Projection window, where you start from scratch by naming the map, setting the boundaries, and selecting
the map type.

 - Allows you to export a map and save it to a file.

 - Deletes the selected map and removes it from the list.

Name - Lists the names of the user-saved and default maps.

Type - Lists the type of projection that is used to display the map.

Parameters - Lists the lat/lon origin of the display, as well as the parallels.

Default Zoom - Represents the zoom level and size of the map.

 - Changes the map projected in the Main Display window to the selected map

 - Changes the map projected in the Main Display window to the selected map and closes the Projection Manager.

 - Opens the McIDAS-V User's Guide to this page.
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 - Closes the Projection Manager window without making any changes to the Main Display window.

McIDAS-V starts with a default projection. Use the Default pulldown menu to select the projection that will be shown each time your McIDAS-V
starts. (The default projection may not be used if you are starting McIDAS-V with a Bundle of configuration information).

Define/Edit Projection Window
This allows you to define new projections and to modify existing ones. Remember that a projection not only consists of the mathematical
projection, but also the area of the Earth that is seen.

Here is how to create a new or revised projection:

1. Choose  or  from Projection Manager window. You can also double click on an existing projection in the Projection
Manager to open the Define/Edit Projection window.

2. Enter a new or revised name if necessary. See the Properties section below for more information about naming and creating hierarchies.
3. Choose a Projection Type from the pull-down menu.
4. Fill in the projection parameters.
5. Set the map area shown with this projection by zooming and panning the view on the left. To zoom, click and drag the left mouse button. Use

the other buttons in the window to zoom in/out and translate the display.
6. Resize the map boundaries by clicking and dragging on the black boxes at the borders of the image. Pressing Delete or Ctrl+D will delete the

box, and pressing Ctrl+R will resize the boundaries of the map to the current geographical boundaries of the map in the Define/Edit
Projection window.

 
Image 2: Define/Edit Projection Dialog

Note that some fields in this window may be different depending on the map type you select. There are no Projection Parameters when using a
Lat/Lon map type. In the example shown, a Lambert conformal conic projection is being defined with the projection parameters as shown in the
figure.

Properties

 /  Projection - Edits an existing/Creates a new map area.

 - Turns on/off maps in the map area while defining a new projection.

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Bundles__FILE
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 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Name - Represents the name of the map. Enter in a new or revised name if necessary (projection names are unique). Use ">" between names
to create a category hierarchy.

Type - Represents the projection type. Each projection type will have their own specific parameters to define.

Projection Parameters - Determines the positioning of the boundaries of the map. These parameters will differ depending on the map type
that you select.

False easting - Moves the map boundaries east and west. A negative value in this field moves the boundaries of the map east, and a
positive value moves the map's boundaries west.

False northing - Moves the map boundaries north and south. A negative value in this field moves the boundaries north, and a positive
value moves the map's boundaries south.

Origin lat - Represents the center of the map's boundaries with respect to latitude.

Origin lon - Represents the center of the map's boundaries with respect to longitude.

Height - Sets the zoom level of the display in the Define/Edit Projection window. The larger the value, the more zoomed in you will
be. This is an option with the Lambert conformal conic map type.

Scale - Sets the scale of the map with respect to size. The larger the scale, the larger the map will appear. This is an option with the
Transverse mercator map type.

Tangent lon - Sets the tangent longitude for the map. This is an option with the Transverse mercator map type.

 - Changes the map in the Projection Manager to match the map in the Define/Edit Projection window.

 - Displays what the projection looks like.

 - Exits the Define/Edit Projection window.
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Data Analysis
Formulas
Derived Data
Native Formulas

Description of Formulas - Maps
Description of Formulas - Grids
Description of Formulas - Miscellaneous
Description of Formulas - Image Filters (Beta)
Description of Formulas - Export
Description of Formulas - Imagery

Jython Methods
Jython Shell
Jython Library
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Formulas
McIDAS-V provides techniques to make computations with data sources and to display the results. The simplest technique is using McIDAS-V
formulas, which are one-line mathematical expressions. The steps for computing and displaying the output of a McIDAS-V formula are:

Defining a McIDAS-V formula by name, description, and mathematical formula.
Saving the formula.
Selecting the display type.
Selecting which data to use in the formula.

You can make formulas more powerful by writing methods (subroutines) in the Jython computer language, which is described in Jython Methods.

Once you define a McIDAS-V formula, it is saved and will appear in future sessions of McIDAS-V.

To create a formula, select the Tools->Formulas->Create Formula menu item in the Main Display window. This opens the Formula Editor dialog
window used to define a formula:

Image 1: Formula Editor Dialog

Properties

Description - Represents the name of the formula that will be written in the Field Selector tab of the Data Explorer.

ID - Sets the ID of the formula that is used in the Parameter Defaults. This allows for settings such as color tables to be automatically
assigned to the display when the formula is evaluated. For example, if T is entered as the ID, the displays created by this formula would use
the Temperature color table.

Formula - Represents the formula that will be evaluated.

The formula itself can use common mathematical operators much as +, -, * for multiply, / for divide, and ** for power. Other Jython operations
such as sqrt(a), max(b), pow(a,b), and sin(c) are available. The Jython Methods section of the User's Guide explains how to write complete multi-
line functions or Jython methods that you can call in one-line formulas.

The variable names in the formula definition, such as "NIR" in the figure above, are operands and do not need to exactly match any particular
parameter name in any data source; the association is made later, in the parameter selection step.

Do not use spaces in formula variable names, such as "wind speed." The formula is an expression in the Jython language. Each variable name must
start with a letter.

It is best to use variable names that suggest the parameter data they represent, so that later you can easily remember what the variables mean. Use
names like Temp500m, RelHum_surf, absvort, sst_jan, density, or whatever makes sense to you. If you use a variable names like V1 and V2, then

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Jython__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ParameterDefaultsEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Jython__FILE
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later when the formula requests which real parameter name goes with which variable name you may be puzzled which is which.

Variable names can have extra "syntactic sugar" attached to them that McIDAS-V uses for a variety of purposes. The "sugar" consists of a set of
name/value pairs contained in brackets ("[...]") after the variable name.

For example, normally variables are used to select and define data choices. You can also have variables that are simple text input from a user. For
example, evaluating the following expression:

someProcedure(someValue[isuser=true])

will result in a dialog box being shown to allow for the user to enter a text value (e.g., a number) for the variable someValue.

You can provide default values with:

someProcedure(someValue[isuser=true,default=some default])

You can specify the types of data that can be selected for a variable with the categories name. e.g.:

someProcedure(someDataValue[categories=param:ALTITUDE])

If you want multiple data categories, separate them with a ";":

someProcedure(someDataValue[categories=param:ALTITUDE;param:elevation])

If you only want to select 3D grids do:

someProcedure(someDataValue[categories=GRID-3D-*])

If you only want to select 3D or 2D grids do:

someProcedure(someDataValue[categories=GRID-3D-*;GRID-2D-*"])

You can also specify a regular expression pattern that is used to pre-select the first data choice whose description matches the pattern.

someProcedure(someValue[pattern=some_pattern])

In the advanced section you can enter a description of the formula, its group or category, and you can define what types of displays are applicable
for the given formula (the default is to be able to use all displays).

The group is used to display the formula in the Field Selector window and can be any alphanumeric text including spaces, numbers, and
punctuation characters. Hyphens ("-") define sub-categories.

To save the formula, click on . A new entry appears in the selector panel. By right clicking on the formula entry in the Field
Selector window you can edit the formula. If you edit a native formula and save it, the original formula will still be listed, but the modified formula
will also be listed. To remove a formula, click on  in the pull down menu. You can also right click on a formula and select
Remove Formula.

For information about the Derived tab, see Derived Data.

Different data sources and automatic navigation
McIDAS-V hides much of the computational complexity. You can write a simple formula such as (CT*1.8 + 32.0) - dewptF, and McIDAS-V will
automatically apply the calculation to every element in large 3D grids referred to as CT and dewptF. No loops over grid points are needed; and you
don't need to know anything about how the grid is defined, mapped on the Earth, or the data format. You can even use different sources for the
individual parameters. For example, CT can come from a NAM model output grid and dewptF from your own local weather model. The two grids
don't need to have the same grid point locations nor the same areal coverage. The results are computed in the area of overlap on the grid points
locations of the first grid. Interpolation is automatically applied where needed.

Creating a Display with a Formula
Using a formula as the data when creating a display is just like using any other data. You select the formula entry in the Field Selector window, and
the list of applicable displays will be shown and you create the display.

When you create a display, McIDAS-V needs to know what actual data should be bound to the operands within your formula. A Field Selector
window will appear that allows you to select the actual data for each operand. You can select parameters from more than one data source for use in
a single formula, for example, you can pick the same parameter from data sources of different times to compute a time difference in the parameter.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_NativeFormulas__FILE
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Image 2: Field Selector Window

Open the data source to see the names of parameters available. Click on the parameter needed for each variable. Then click . The result of
the formula is computed for every data point in the source, and the result shown in the Main Display window.

Creating/Removing library files

Calling procedures from formulas

Create a formula from my procedure

FAQ

Q. What is Jython?

A. Jython is a Java implementation of the Python language. It is used within McIDAS-V for data analysis. Complex routines can be written in
the McIDAS-V Jython editor and called from the McIDAS-V Formulas.

Q. How do I learn to write Jython?

A. There are a number of books available on the language as well as a number of web sites:

http://www.python.org
http://www.jython.org

Q. How does Jython work with my data in McIDAS-V?

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Jython__faq1_cat1_4
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Jython__faq1_cat1_5
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Jython__faq1_cat1_6
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Formulas__FILE
http://www.amazon.com/s/ref=nb_ss_gw/002-3107995-7532045?url=search-alias%3Daps&field-keywords=jython&x=0&y=0
http://www.python.org/
http://www.jython.org/
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A. McIDAS-V uses the VisAD package as as an underlying data model. There is a VisAD/Jython Tutorial available.

Q. Creating/Removing library files

A. To create a new file use the File->New Jython Library... menu. To remove the currently displayed library file use the File->Remove
Library menu.

Q. Calling procedures from formulas

A. When creating a formula with the Formula Editor you can call any routines you have defined in the Jython Library. Simply enter the
procedure name in the formula with appropriate arguments, if any. For example a formula might be "convertCToF(atemp)". When evaluating the
formula for display, this will call the routine that you define in the Jython Library.

Q. Create a formula from my procedure

A. Right click on a procedure definition within the McIDAS-V editor window and choose Make formula for .... This is a convenience that
brings up the Formula creation dialog with a call to that procedure.

As another convenience you can also right-click on the Formula: field of the Formula Editor to show the Insert Procedure Call menu. This
lists all of the currently defined procedures in the other Jython libraries.

http://www.ssec.wisc.edu/~billh/visad.html
http://www.ssec.wisc.edu/~tomw/visadtutor/
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Formulas__FILE
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Jython Shell
The Jython Shell is an interactive command line interface to the McIDAS-V Jython interpreter that allows the user to type in arbitrary Jython to
evaluate. This feature is brought up with the Tools->Formulas->Jython Shell menu item in the Main Display window.

The User Interface

Image 1: Jython Shell Window

The Jython shell consists of an output window on the top and an input field on the bottom. The user enters Jython into the input field. When Enter
or  is pressed the Jython is evaluated and any output is shown in the output window. Note that Enter will only evaluate the field if the
field has not been expanded. If your are using multi-line input for your commands, you can evaluate the commands with Shift+Enter.

The icons shown with every Jython entry in the output window allow you to select the particular Jython or re-evaluate it.

The entry window can be expanded with the  to the right of the command line. When the entry field is expanded, you can enter more than one line
of code to be processed at once. When the entry field isn't expanded, you are limited to evaluating one line of code at a time. As an alternative to the

 button, you can use Ctrl+/ to change between single and multi-line command line structure.

Pressing the "Up" arrow and "Down" arrow in the entry field goes up and down through the history of commands when you are in single-line input.
If you are using multi-line input, use Ctrl+P, Ctrl+N to cycle through previously-executed commands.

After you have entered a and evaluated command, the command will be listed above the Evaluate field. To the right of the command, there are two
buttons. The  button enters the formula back into the Evaluate field without evaluating it. The  button reevaluates the previously entered
command without having to manually reenter it.

Right-clicking in the entry field brings up a menu that allows you to:

Add an entry from the history.

Insert the identifier for a display control type when creating a display.

Insert the text of a procedure call from any of the McIDAS-V Jython Library modules. Note: The shell utilities module has a number of
useful Jython shell related commands.

Insert any of the defined McIDAS-V actions (e.g., Edit color table, Show window, etc.)

Menus
All of the menu items in this tool are unique to the Jython Shell.

The File menu has these unique items:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_JythonLib__FILE
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Save Commands to Jython Library - Saves any entered commands (up to 100 by default) to the User's local Jython Library as a Procedure
or as a block of commands if no Procedure name is provided.

List Saved History - Lists out previously entered commands.

List Current Variables - Lists all global Jython Variables currently in use.

The Edit menu has these unique items:

Reset Jython Shell - Removes any saved variables and commands, as well as clears the output window.

Clear Output Buffer - Removes any text in the output window, but does not remove any variables or commands from the history.

Auto-select Operands - Causes the Jython shell to analyze every command entered to see if there are references to variables that have not
been set. It will bring up the Data Selection dialog to allow you to choose the fields to use.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_JythonLib__FILE
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Jython Library

Module: grid
This is the doc for the grid module

applyToRange(function, data):
Apply the function name to each timestep of the data

applyToRangeValues(function, data):
Apply the function name to each value in each timestep of the data

averageOverTime(field, makeTimes):
Average the values in each time step If makeTimes is true (1) then we return a field mapping all of the times to the average. Else we just return
the average

combineFields():
combine several fields together

extractLatitudeFromNWPGrid(fieldimpl):
Get the latitude coordinate from a grid. Return a grid of the latitudes at each point.

extractPressureFromNWPGrid(fieldimpl):
Get the pressure coordinate from a time series grid and return a grid of the pressure at all points. Input grid must have pressure or height (which
is converted to pressure in the standard atmosphere). User must be sure input is a suitable FlatField.

getAltitude(z):
Change units from geopotential meters to meters

getNthTimeGrid(fieldimpl, Nth):
Get the Nth grid in time series of grids; User must be sure input is a suitable data field. returns a single time. Nth is an integer, >=0, <= max
index of grid time series.

getSliceAtAltitude(fieldimpl, alt, unit):
Extract a 2D horizontal slice from a 3D grid at the given altitude; level is a real number; if unit is supplied, it must be compatible with meters (ft,
fathoms, etc) param fieldimpl is a grid which may have one or more time steps.

getSliceAtLevel(fieldimpl, level):
Extract a 2D horizontal slice from a 3D grid at "Level." level is a real number; must be appropriate for the grid. param fieldimpl is a grid which
may have one or more time steps.

horizontalAdvection(param, u, v):
horizontal advection

horizontalDivergence(param, u, v):
horizontal flux divergence

layerAverage(grid, top, bottom):
Wrapper for calculating layer average

layerDiff(grid, top, bottom):
Wrapper for calculating layer difference

make2D(slice):
Make a 2D slice from a 3D slice at a single level

makeFlowField(a, b, c):
Make a vector from 3 components
makeVector(a,b) = [a,b,c]

makeTimeSequence(g):
Merge a set of single time grids/images into a time sequence

makeTrueVector(u, v):
true wind vectors

makeVector(a, b):
Make a vector from 2 components
makeVector(a,b) = [a,b]



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 356 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

newName(field, varname, copy):
create a new field with a new parameter name

newUnit(field, varname, unitname):
set the name and unit on a grid

resampleGrid(oldGrid, gridwithNewDomain):
display gridded data on a new domain

windShear(u, v, z, top, bottom):
calculate the wind shear between discrete layers
shear = sqrt((u(top)-u(bottom))^2 + (v(top)-v(bottom))^2)/zdiff

windShearVector(u, v, top, bottom):
calculate the u and v layer difference and return as vector

writeGridToXls(grid, filename):
Write out the grid data to an excel spreadsheet

Module: griddiag
This is the doc for the Grid Diagnostics module. These functions are based on the grid diagnostics from the GEneral Meteorological PAcKage
(GEMPAK). Note that the names are case sensitive and some are named slightly different from GEMPAK functions to avoid conflicts with Jython
built-ins (e.g. str).

In the following operators, scalar operands are named Si and vector operands are named Vi. Lowercase u and v refer to the grid relative components
of a vector.

GRAVITY():
Gravity constant

add(S1, S2):
Addition

ADD (S1, S2) = S1 + S2
adv(S, V):

Horizontal Advection, negative by convention
ADV ( S, V ) = - ( u * DDX (S) + v * DDY (S) )
age(obs, geo):

Ageostrophic wind
AGE ( S ) = [ u (OBS) - u (GEO(S)), v (OBS) - v (GEO(S)) ]
atn2(S1, S2):

Wrapper for atan2 built-in
ATN2 (S1, S2) = ATAN ( S1 / S2 )
avg(S1, S2):

Average of 2 scalars
AVG (S1, S2) = ( S1 + S2 ) / 2
avor(V):

Absolute Vorticity
AVOR ( V ) = VOR ( V ) + CORL(V)
corl(S):

Coriolis Parameter for all points in a grid
CORL = TWO_OMEGA*sin(latr)
cros(V1, V2):

Vector cross product magnitude
CROS ( V1, V2 ) = u1 * v2 - u2 * v1
ddx(S):

Take the derivative with respect to the domain's X coordinate
ddy(S):

Take the derivative with respect to the domain's Y coordinate
defr(V):
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Total deformation
DEF ( V ) = ( STRD (V) ** 2 + SHR (V) ** 2 ) ** .5
div(V):

Horizontal Divergence
DIV ( V ) = DDX ( u ) + DDY ( v )
dot(V1, V2):

Vector dot product
DOT ( V1, V2 ) = u1 * u2 + v1 * v2
dvdx(V):

Partial x derivative of a vector
DVDX ( V ) = [ DDX (u), DDX (v) ]
dvdy(V):

Partial x derivative of a vector
DVDY ( V ) = [ DDY (u), DDY (v) ]
frnt(S, V):

Frontogenesis function from theta and the wind
FRNT ( THTA, V ) = 1/2 * MAG ( GRAD (THTA) ) * ( DEF * COS (2 * BETA) - DIV ) Where: BETA = ASIN ( (-DDX (THTA) * COS (PSI) -
DDY (THTA) * SIN (PSI))/ MAG ( GRAD (THTA) ) ) PSI = 1/2 ATAN2 ( SHR / STR )
geo(z):

geostrophic wind from height
GEO ( S ) = [ - DDY (S) * const / CORL, DDX (S) * const / CORL ]
grad(S):

Gradient of a scalar
GRAD ( S ) = [ DDX ( S ), DDY ( S ) ]
inad(V1, V2):

Inertial advective wind
INAD ( V1, V2 ) = [ DOT ( V1, GRAD (u2) ), DOT ( V1, GRAD (v2) ) ]
jcbn(S1, S2):

Jacobian Determinant
JCBN ( S1, S2 ) = DDX (S1) * DDY (S2) - DDY (S1) * DDX (S2)
lap(S):

Laplacian operator
LAP ( S ) = DIV ( GRAD (S) )
latr(S):

Latitudue all points in a grid
lav(S, level1, level2):

Layer Average
LAV ( S ) = ( S (level1) + S (level2) ) / 2.
ldf(S, level1, level2):

Layer Average
LDF ( S ) = S (level1) - S (level2)
mag():

Magnitude of a vector
mixr(temp, rh):

Mixing Ratio from Temperature, RH (requires pressure domain)
mul(S1, S2):

Multiply
MUL (S1, S2) = S1 * S2
quo(S1, S2):

Divide
QUO (S1, S2) = S1 / S2
qvec(S, V):

Q-vector at a level ( K / m / s )
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QVEC ( S, V ) = [ - ( DOT ( DVDX (V), GRAD (S) ) ), - ( DOT ( DVDY (V), GRAD (S) ) ) ] where S can be any thermal parameter, usually
THTA.
sdiv(S, V):

Horizontal Flux Divergence
SDIV ( S, V ) = S * DIV ( V ) + DOT ( V, GRAD ( S ) )
shr(V):

Shear Deformation
SHR ( V ) = DDX ( v ) + DDY ( u )
strd(V):

Stretching Deformation
STRD ( V ) = DDX ( u ) - DDY ( v )
sub(S1, S2):

Subtract
SUB (S1, S2) = S1 - S2
thrm(S, level1, level2):

Thermal wind
THRM ( S ) = [ u (GEO(S)) (level1) - u (GEO(S)) (level2), v (GEO(S)) (level1) - v (GEO(S)) (level2) ]
thta(temp):

Potential Temperature from Temperature (requires pressure domain)
thte(temp, rh):

Equivalent Potential Temperature from Temperature and Relative humidity (requires pressure domain)
un(V):

North relative u component
ur(V):

Grid relative u component
vadd(V1, V2):

add the components of 2 vectors
VADD (V1, V2) = [ u1+u2, v1+v2 ]
vecr(S1, S2):

Make a vector from two components
VECR ( S1, S2 ) = [ S1, S2 ]
vlav(V, level1, level2):

calculate the vector layer average
VLDF(V) = [(u(level1) - u(level2))/2, (v(level1) - v(level2))/2]
vldf(V, level1, level2):

calculate the vector layer difference
VLDF(V) = [u(level1) - u(level2), v(level1) - v(level2)]
vmul(V1, V2):

Multiply the components of 2 vectors
VMUL (V1, V2) = [ u1*u2, v1*v2 ]
vn(V):

North relative v component
vor(V):

Relative Vorticity
VOR ( V ) = DDX ( v ) - DDY ( u )
vquo(V1, V2):

Divide the components of 2 vectors
VQUO (V1, V2) = [ u1/u2, v1/v2 ]
vr(V):

Grid relative v component
vsub(V1, V2):

subtract the components of 2 vectors
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VSUB (V1, V2) = [ u1-u2, v1-v2 ]
wshr(V, Z, top, bottom):

Magnitude of the vertical wind shear in a layer
WSHR ( V ) = MAG [ VLDF (V) ] / LDF (Z)

Module: image

combineRGB(red, green, blue):
combine 3 images as an RGB image

makeNavigatedImage(d, ulLat, ulLon, lrLat, lrLon):
This takes a image data object and a lat/lon bounding box and adds a lat/lon domain to the data. Use it in conjunction with a formula:

Module: maps

averageFromMap(field, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that area

averageRangeFromMap(range, timeStep, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that area

filterMaps(mapSets, propName, operator, value):
Return a new set of maps whose property propName satisfies the given operator/value. The operators can be ==,!=, <,>,<=,>=, match, !match

getMapProperty(polygon, propName):
Get the named property from the given mapData

getMapsWithProperty(mapSets, propName, value):
Return a new set of maps that have the given property value

make3DMap(map, topo):
Make a 3d map. map - map line data - topo - topography dataset

makeFieldFromMapBounds(mapSets, length1, length2, fill, unit):
Make a field whose lat/lon area is the bounds of the given mapSet. It has length1 points in the x and length2 in the y. Fill it with the fill value
and the given unit

subsetFromMap(field, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse is
1 then it fills the areas that are enclosed

subsetRangeFromMap(range, timeStep, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse is
1 then it fills the areas that are enclosed

subsetRangeWithProperty(range, mapSets):
test code

subsetWithProperty(field, mapSets):
test code

Module: shell
A set of utilities for selecting data and creating displays. For use from the Jython shell.

clear():
Clear the shell

createDisplay(displayType, data, dataName):
create a display of type displayType. Right click in input field to select particular displayType. The data is can be a data object, a datachoice or a
list of data or datachoices The dataName is used to name the data, i.e., its the parameter name

findDataSource(name):
Find the data source object with the given name. If no name is given then this will return the first (non-formula) data source
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getData(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data for the data choice. If no data
source or data choice is found then return null

getDataChoice(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data choice If no data source or
data choice is found then return null

listVars():
List all of the variables defined in the shell's interpreter

makeDataSource(path, type):
Create a datasource from the given file name or url. The optional type parameter is used to specify the type of data

printType(data):
Print out the math type of the given data

selectData(name1, name2, name3, name4, name5):
Select up to 5 data fields. This returns a List of the actual Data objects

selectDataChoice(name1, name2, name3, name4, name5):
Select up to 5 data choices. This returns a List of the data choices, not the actual Data To get the data do:

dataList.get(0).getData(None)
setDataChoices(dataSource):

The given dataSource can be an actual data source or the name of a data source. This procedure will define a set of jython variables that
correspond to the data choices held by the given data source.

setDataSources():
This procedure will define a set of jython variables, 'dataSource0, dataSource1, ...' that correspond to loaded data sources.

showLib():
Bring up the jython library dialog

Module: misc
A set of miscellaneous utilities.

idveval(formula):
evaluate a formula

makeFloatArray(rows, cols, value):
A utility to make a 2 dimensional float array filled with the given value
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Display Settings
The Display Settings facility allows you to select a set of properties from a display control (e.g., color table, contouring info, isosurface value, label
template, etc.) and apply them to other display controls and/or save them as preferences to be used when creating new display controls.

The Display Settings dialog can be opened with the Edit->Display Settings... menu in the Layer Controls tab of the Data Explorer.

 
Image 1: Display Settings Dialog

The left panel in this window is titled Source and includes two tabs, Displays and Saved Settings. The Displays tab includes all of the display
types currently loaded into McIDAS-V. This tab is useful to make display settings changes within a session. If you wish, you can save these settings
to be used in future sessions by using the File->Save Selected Properties menu item. The Saved Settings tab includes a list of any saved display
settings you have made in previous sessions. You can store several different saved settings at once by grouping them into different categories.

The center panel of the window is titled Properties. These are the properties of the currently selected display control, which is shown highlighted in
blue in the Source panel. On the right is also a list of target display controls.

The purpose of this is that you can select properties in the Properties panel that you want to apply to the selected target display controls (via the
checkboxes) on the right. Many of the properties can be changed by clicking on the  buttons.

The View menu is useful for selecting different groups of target display controls. For example, you can select All Displays, displays of certain
types, displays that have the same data sources, etc.

Display Settings Examples
If you have two different data sources loaded with several displays created from each, normally the legend will list all of the displays based on some
display category (e.g., Plan Views). However, you can change their display category so that each group of displays that are from one data source
have the same category (e.g., "Data source 1", "Data source 2"). You can do this by changing the "Display Category" property under "Labels" to
"Data Source 1".
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Image 2: Enter New Value for Legend Label Dialog

Then, you could manually select the displays you want to change, or use the Select menu and choose "Displays with data source: ...":

Image 3: Select Menu of the Display Settings Dialog

This selects the displays with the data source of the currently selected display.

Once selected, you then hit , and the "Display Category" will be set on the selected display controls.

To do the next set of displays, select a new Source display control in the list on the left. This will select this display and reset the properties list in
the middle. Then, when you click Select->Displays with data source, the displays that share the data source from this new display will be selected.

Saving Display Settings
You can save the set of selected settings with the File->Save Selected Properties option. The Save Display Settings dialog will be shown:

 
Image 4: Save Display Settings Dialog

You can enter a category and a name. The saved settings will be shown under the Saved Settings tab. When selected they will be applied to the list
of properties on the left. If you select the checkbox for Applicable only to displays of type, only the display listed will be an option in the Displays
panel of the Field Selector.

Using Display Settings in the Field Selector
The set of saved display settings are also shown in the Field Selector:
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Image 5: Display Settings in the Field Selector

You can select any number of these, and when a new display control is created, these settings will be applied to the new display. The Show All
checkbox allows you to list all of the settings, regardless if they were saved for a particular type of display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.

The File menu has this unique option:

Save Selected Properties - Saves any settings you create. These saved properties can be found under the Saved Settings tab in the Source
panel.

The Select menu has these unique options:

This display - Modifies only the selected display in the Displays tab of Source.

All displays - Modifies all of the displays listed in the Displays tab of Source.

Displays of the type: - Modifies all of the displays of a specific Display type as chosen in the Field Selector tab of the Data Explorer (Ex.
Contour Plan View).

Displays with the category: - Modifies all of the displays of a specific Display as chosen in the Field Selector tab of the Data Explorer (Ex.
Plan Views).

Displays with data source: - Modifies all of the displays that come from the same Data Source.

Displays with the field: - Modifies all of the displays that display the same field (Ex. Pressure_reduced_to_MSL).

Displays with any data - Modifies all of the displays that contain data.

Displays in view - Modifies all of the displays that are in the specific tab that you are looking at in the Main Display window.

Special displays - Modifies the displays that were in each tab of the Main Display window before anything else was added in (Ex. Default
Background Maps).

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LayerControls__menus
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Plugin Creator
The Plugin Creator, accessed through the Tools->Plugins->Create... menu item in the Main Display window, allows you to create new plugins.
The Plugin Creator is broken up into three tabs: Resources, Excludes, and Properties.

A plugin is a Java JAR file that contains a set of resource files. These resource files can include things like the color tables you have created,
projections, station models, formulas, etc. The plugin manager supports both adding in a whole file (e.g., all of the color tables you have created) as
well as adding in individual resource objects (e.g., a specific color table you have created).

Adding Resources
Resources List
Excludes
Properties
Writing the Plugin
Menus

Adding Resources
To add in a file, use the File->Add File menu item. The file dialog will come up listing the contents of your local McIDAS-V directory. This is
where all of the various resources that are created are stored. For example, if to include all of the color tables, add the colortables.xml file. Use the
File->Add Preferences menu item to add your User Preferences to a resource, such as a bundle you are creating or editing. Individual resources
can be added through the File->Add Resource menu item. Resources can also be added through the various resource editors (e.g., Jython Editor,
Parameter Defaults, Parameter Aliases). Typically this facility is available through the editor's File menu.

Resources List
Each file, preference, and resource that is added into the Plugin Creator is listed under the Resources tab:

 
Image 1: Resources Tab of the Plugin Creator

Resources can be deleted by clicking the  button or by pressing the delete key when a resource is selected.

Excludes
The Excludes tab allows for the exclusion of system default resources. For example, in the below image, Color tables and Map projections are

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__adding_resources
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excluded. When the plugin that is defined here is loaded into McIDAS-V, the excludes will result in only the Color tables and Map projections that
are defined in this plugin to be used.

 
Image 2: Excludes Tab of the Plugin Creator

Properties
The Properties tab allows the user to overwrite different properties McIDAS-V uses. This listing is broken up into three categories: User
Interface, Data, and Miscellaneous.
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Image 3: Properties Tab of the Plugin Creator

The User Interface category primarily affects the aesthetic appearance and basic usability in McIDAS-V. These options allow you to decide if you
want to do the following:

Display icons in the Field Selector.

Display formulas in the Field Selector.

Display the menu bar.

Display the splash icon.

Show the Data Explorer on startup.

Use the full screen view.

Change the height and width of the Main Display window.

The Data category affects what sources of data you will have available when selecting data in the Data Sources tab of the Data Explorer. These
options allow you to decide the following:

Which Image Descriptors will be listed when selecting data in the Data Sources tab.

Which ADDE Point Datasets will be available to choose from.

Which Level III Datasets will be available.

Which different Servers will be available in the Data Sources tab.

Which Catalogs will be included in the General->Catalogs chooser.

Which Level II Remote Radar Catalogs will be included.

Whether to merge Catalogs and Servers together.

The Miscellaneous category affects many features of McIDAS-V. While these options affect many things that go on 'under the hood' of McIDAS-
V, there is a great deal that can be changed with these options. These options allow you to decide the following:
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If you are going to use 3D or not in your displays.

How globe and map projections are plotted in the Main Display window.

What distance units you want to use.

Many aspects of the JNLP code.

Many aspects of the User Preferences.

If and how information will be shown as quicklinks.

The vertical range for Globe, Map, and Transect displays.

Writing the Plugin
To write the plugin, click the  button. If you have not specified a plugin file name, (i.e., a .jar file) you will be prompted. If you
also want to install the plugin to your local McIDAS-V plugins area, select the Install checkbox. You can choose a specific location to save the
plugin to by selecting the  button, or by typing the file path into the field. Note: You will need to restart McIDAS-V for any installed
plugins to take effect.

Menus
Many of the menu items seen utilizing the Plugin Creator tool are unique to this menu item.

The File menu has these unique options:

Add File - Allows you to add a local file to the list under the Resources tab of the Plugin Creator window.

Add Preferences - Adds in the main.xml file for your user to the list under the Resources tab. This includes all of your User Preferences.

Add Resource - Allows you to add favorites, bundles from disk, individual color tables, station models, projections, formulas, and parameter
defaults to the list under the Resources tab of the Plugin Creator window.

Import Plugin - Allows you to import an existing plugin. All of the Resources in the plugin you import will be added to your list under the
Resources tab in the plugin you are making.

Close - Closes the Plugin Creator window.
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Plugin Manager
McIDAS-V plugins are a way to add to or modify the functionality of McIDAS-V. Plugins can range from adding new resources (e.g., color tables,
layout models, maps) to changing the entire application. Plugins are typically Java JAR archive files that can contain a set of McIDAS-V resources
and Java code. They are kept in a special directory on disk and are loaded at run time.

Plugin Command Line Arguments
You can load a plugin (one time only) with the:

-plugin <plugin file or URL>

command line argument.

You can install a plugin with the:

-installplugin <plugin file or URL>

command line argument.

You can start McIDAS-V without any plugins with the:

-noplugins

command line argument.

Plugin Manager
The Plugin Manager, accessed through the Tools->Plugins->Manage... menu item in the Main Display window, allows you to list, install, and
manage plugins.

 
Image 1: Plugin Manager

A list of the installed plugins is shown at the top of the Plugin Manager, and a list of available plugins is shown below that. Click on an icon to
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perform an action in the Plugin Manager:

 Install Plugin - Installs the selected plugin in the Available Plugins section. You can install plugins that are not in this list through the
File->Install Plugin from File and File->Install Plugin from URL menu items in the Plugin Manager window. When you install a plugin
you will need to restart McIDAS-V for the plugin to take effect.

 Delete Plugin - Deletes the selected plugin. When you delete a plugin you will need to exit McIDAS-V for the plugin to be removed.
Once McIDAS-V is restarted, the plugin will still be listed in the Available Plugins list and can be reinstalled at any time.

 Send to Plugin Creator - Directs you to the Plugin Creator, where modifications to the plugin can be made.

 View Contents - Opens the Plugin List dialog, which allows you to list the files that the plugin contains. You can view the contents of a
file and/or export a file through this dialog.

 
Image 2: Plugin List Dialog

Menus
There are a few menu items that are unique to this tool.

The File menu has these unique options:

Install Plugin from File - Opens a window that allows you to load a local *.jar plugin into McIDAS-V.

Install Plugin from URL - Opens a window that allows you to enter a URL that points to a plugin that will be brought into McIDAS-V.

The Help menu has this unique option:

Plugin Manager - Opens the Plugin Manager help page in the User's Guide.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PluginCreator__FILE
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Miscellaneous
Bundles
Scripting
Sharing
Site Configuration
Plugin Jar Files
Configuring Image Defaults
Adding in New GRIB Tables
McIDAS-V Special Data Formats
Actions
Command Line Arguments
Data Source Types
Performance Tuning
Building McIDAS-V from Source
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Bundles
Bundles let you save a quick "snapshot" of McIDAS-V, including data sources, maps, and data displays. Bundles are small information files that
specify the state of McIDAS-V. They are a kind of configuration file. They include information about what data sources are in use, and which
parameters from the data sources are displayed, and how they are displayed.

The purpose of bundles is for you to save a particular McIDAS-V setup and display. A bundle can be used for your own reference at a later time, or
others using McIDAS-V can use bundles you made to see data the same way you did.

Saving a Bundle
To make a new bundle file, select the File->Save Bundle menu item in the Main Display window. A pop-up window will let you set a new file
location and name:

 
Image 1: Save Bundle Dialog

The customary McIDAS-V bundle filename extension is .mcv; if you do not enter a file extension, .mcv will be appended. When saving a .mcv file,
no data is saved with the bundle, only references to the remote or local Data Sources are saved.

McIDAS-V does support a zipped data bundle format: .mcvz. This is a zip file that contains a regular bundle (.mcv) and a set of data files. When
the user does a "Save Bundle" or "Save Favorite " and specifies a .mcvz file extension, McIDAS-V prompts the user to select the data sources that
should be written into the zip file. When opening a .mcvz file, McIDAS-V needs to unzip the data files, so it prompts the user as to where to place
the files - a temporary directory or a user selected directory (this is a preference as well).

Note: In order for bundle files to work, the data must be available in exactly the same way you made connection to it when you made
the bundle file. Others who use your bundles must have access to the same file system or to the same remote or local data servers you
use, so that file paths or URLs to the data are exactly the same.

The file dialog has a set of buttons to define how parts of your bundle is saved.

The Jython menu allows you to save the Jython code you may have in your library in different ways. For example, you may have written
some custom Jython code that implements a Formula. You have a display that uses the results of that computation. To include your local
Jython code just select All Jython or Selected Jython. When loading in a bundle that has had Jython code saved with it, the user will be
prompted for what to do with the Jython.
 One can save a bundle with data paths that are relative to where the bundle is loaded from by checking the Save with relative paths
checkbox. McIDAS-V will change the file based data sources to point to the directory where the bundle is loaded from. For example, you can
use this to save a bundle that references model files on disk. Copy the bundle and the model files over to a thumb drive or CD. Then when
you load the bundle the files are relative to the bundle path.

Saving a Bundle as a Favorite
Favorite bundles are just normal bundles that are categorized and saved off in a particular location on disk and serve as a convenience to the user.
This allows the user to organize their favorites by category and readily load them in. Favorite bundles are easily available through the Bundles
menu and can also be displayed on the toolbar of the Main Display window.
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A favorite bundle can be created through the File->Save Favorite... menu item in the Main Display window:

 
Image 2: Save As Favorite Dialog

Define your favorite bundle by specifying a category in the Category field and a name in the Name field. Categories can be hierarchical; by using a
">" as a separator (e.g. Toolbar>sounding) the categories will appear as a tree structure in the Local Favorites Bundles Manager. The "Toolbar"
category is a special category in the Favorite Bundles Manager. The bundles in the Toolbar category will also appear as links in the toolbar of your
Main Display window.

The Local Favorite Bundles Manager, accessed through the Bundles->Manage... menu item in the Main Display window, allows you to reorganize
the categories and favorites by drag-and-drop, or right click on a favorite or a category to delete it, export it, etc.:

 
Image 3: Local Favorite Bundles Manager

Once a bundle has been saved as a favorite, it can be set as your default bundle that will load automatically when you start McIDAS-V. You can set
a default bundle in the Advanced tab of the User Preferences window. Note that after saving a favorite bundle, you must restart McIDAS-V before
the bundle will be visible in the User Preferences window.

Opening a Bundle
Use the File->Open File menu item in the Main Display window to open a bundle. When loading in a new bundle you will be prompted whether
the current displays and data should be removed. You can also start up McIDAS-V with a bundle file or URL in the command line.

Copying Data Locally

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__defaultbundle
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For most remote data types, data can be copied from the server to the local disk using the "Make Remote Data Local" facility. The following ADDE
types are supported: satellite, radar, point, sounding and forecast fronts. There is also preliminary support for grids on remote servers* (see below).

This is used in two ways. First, the user can right-click on a data source in the Field Selector and select "Make Data Local" for remote data sources.
McIDAS-V prompts for a file directory and a file prefix (the default is to use the name of the data source) and the remote data is copied over. For
multiple files the format used is: <directory><prefix><file count>.<suffix>. The data source object within McIDAS-V is then changed to point to
the new file paths.

The second way this is used is when a .mcvz file is saved. The user is prompted for both the local data sources to be saved off as well as for the
remote data sources. For the remote ones, McIDAS-V automatically copies the files over and zips them.
*Grids: There is preliminary support for grids. This support relies on some extra service information in the catalogs which, right at this moment, is
not included in the regular IDV gridded data catalog but is included for model data under the "File_Access" dataset in the main thredds catalog:
http://www.unidata.ucar.edu/georesources/threddsRtModels.xml When saving gridded data the user is prompted for the fields to save and the geo-
spatial subset is used to subset the grids. As of right now, there is not yet support for sub-setting on times and grid stride/decimation.

IDV Bundles
McIDAS-V has the ability to load and save IDV bundles (.xidv and .zidv), but all of the features between the two software packages may not be
compatible, and therefore the bundles may not load properly in the other software package.
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Scripting
McIDAS-V can be scripted to create and manipulate images and movies. The scripting is accomplished using Jython. Jython is an implementation
of the Python language in Java and follows Python syntax.

McIDAS-V scripting can be done from the Jython shell, or a Jython script can be invoked as a command line argument.

In Unix, from the McIDAS-V-System directory:

runMcV -script /home/user/example.py

In Windows, from the McIDAS-V System directory (if running under a Windows machine, it is necessary to use "\\" instead of "\" in scripts when
specifying directory paths to avoid Windows interpreting it as an escape sequence.):

runMcV.bat -script C:\\home\\user\\example.py

When invoked as a command line argument, the user interface will not be shown. However, McIDAS-V still needs to be run with an active window
system (e.g., X, MS Windows) for it to run. If running under a Linux/Unix machine with no X server running, McIDAS-V must be run under the X
virtual frame buffer, xvfb.

McIDAS-V supports a number of functions and methods to load and display data, manipulate the display, and to save images. Download the
example script to see how to use each one (example.py). This page contains a list of funtions that are supported in McIDAS-V. You can find more
information about each function, including parameters, keywords, and example commands, by clicking on a function or a function category.

Create an Object:

buildWindow
openBundle
makeLocalADDEEntry
getLocalADDEEntry
getADDEImage
listADDEImages
listADDEImageTimes
createLayer

Modify the Display Object:

annotate
setCenter
setProjection
setWireframe

Modify the Layer Object:

setColorScale
setEnhancement
setLayerLabel
setLayerVisible

Save the Display:

captureImage
writeMovie

Environment:

getJythonShellMaxHistoryLength
setJythonShellMaxHistoryLength
collectGarbage
removeAllLayers
removeAllData
expandpath
editFile
getLogLevel
setLogLevel
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For users looking for more functionality from McIDAS-V scripting, additional functions can be found in the Java docs for visAD, netCDF, IDV,
and McIDAS-V. Please send any questions or requests for functionality to the McIDAS-V Support Forum on scripting.

http://www.ssec.wisc.edu/visad-docs/javadoc/index.html
http://www.unidata.ucar.edu/software/netcdf-java/v4.2/javadocAll/index.html
http://www.unidata.ucar.edu/software/idv/docs/javadoc/index.html
http://www.ssec.wisc.edu/mcidas/software/v/javadoc/current/
http://dcdbs.ssec.wisc.edu/mcidasv/forums/viewforum.php?f=31
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Create an Object
buildWindow - Creates a window and returns an array of panels (single panel currently supported)

Usage: panel=buildWindow(keywords)
Keywords:

height= height of the window
width= width of the window
panelTypes= type of display to create

MAP (default)
GLOBE

Example:
panel=buildWindow(height=600,width=800,panelTypes=GLOBE)
panel=buildWindow(height=600,width=800,panelTypes=MAP)

openBundle - Creates a new window and displays contents of a bundle
Usage: openBundle(bundle file, keywords)

bundle file - file name of bundle (required)
Keywords:

height= height of display; default= height of the display window when the bundle was saved
width= width of display; default= width of the display window when the bundle was saved
dataDirectory= a dictionary where the keys are datasource names, and the values are either a string or list of strings representing

the full path name/names of the data that will be used in place of the data in the bundle
mode= specifies the method that will be used to open the bundle

REPLACE - Removes any previously-loaded layers and data sources and replaces the current session with the
bundle's data (default)
NEWWINDOW - Loads the bundle's data and displays into a new window, without removing any previously-
loaded layers and data sources
MERGE - Loads the bundle's data and displays into the current tab of the active display window without
removing any previously-loaded layers and data sources
NEWTAB - Loads the bundle's data and displays into a new tab of the active display window without removing
any previously-loaded layers and data sources

Example:
openBundle('C:\\Users\\myuser\\bundle.mcv',mode='NEWTAB')

makeLocalADDEEntry - Creates a local ADDE entry in the server table
Usage: localDataset= makeLocalADDEEntry(keywords)

Keywords:
dataset= name of the dataset - limit of 8 characters
imageType= image type name for local server entry. (default=format_dataset)
save= True - saves entry into the server table; False - entry is removed after McIDAS-V session is ended (default)
mask= directory containing the files used by the created dataset
format= data format of files within the dataset. Either Full Name or Short Name can be used as valid options:

Full Name Short Name
"AMSR-E L1b" "AMSR"
"LRIT GOES-9" "FSDX_G9"
"LRIT GOES-10" "FSDX_G10"
"LRIT GOES-11" "FSDX_G11"

"LRIT GOES-12" "FSDX_G12"
"LRIT MET-5" "FSDX_M5"
"LRIT MET-7" "FSDX_M7"
"LRIT MTSAT-1R" "FSDX_MT"
"McIDAS Area" "AREA"
"Meteosat OpenMTP" "OMTP"
"Metop AVHRR L 1b" "LV1B_METOP"
"MODIS MOD 02 - Level 1B Calibrated Geolocated
Radiances" "MODS"

"MODIS MOD 04 - Aerosol Product" "MOD4"
"MODIS MOD 06 - Cloud Product" "MODX_06"
"MODIS MOD 07 - Atmospheric Profiles" "MODX_07"
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"MODIS MOD 28 - Sea Surface Temperature" "MOD8"
"MODIS MOD 35 - Cloud Mask" "MODX_35"
"MODIS MOD R - Corrected Reflectance" "MODR"
"MSG HRIT FD" "MSGT_FD"
"MSG HRIT HRV" "MSGT_HRV"
"MTSAT HRIT" "MTST"
"NOAA AVHRR L 1b" "LV1B_NOAA"
"SSMI" "SMIN"
"TRMM" "TMIN"
"GINI" "GINI"

Example:
dataPath = 'C:\\Users\\myuser\\Data\\AREA'
makeLocalADDEEntry(dataset='AREA', imageType='Area files', save=True, mask=dataPath, format='McIDAS Area')

getLocalADDEEntry - Gets the descriptor for a local ADDE entry
Usage: localDescriptor= getLocalADDEEntry(keywords)

Keywords:
dataset= local ADDE entry dataset name
imageType= image type of local ADDE entry

Example:
desc = getLocalADDEEntry(dataset='AREA',imageType='Area files')

getADDEImage - Requests data from an ADDE Image server - returns both data and metadata objects
Usage: myMetaData,myData= getADDEImage(keywords)

Keywords:
localEntry= local dataset defined by makeLocalADDEEntry
server= ADDE server
dataset= ADDE dataset group name
descriptor= ADDE dataset descriptor
day= single day ('date 1') or as a day range ('begin date','end date')
time= ('begin time','end time')

coordinateSystem= coordinate system to use for retrieving data 
AREA = AREA file coordinates - zero based
LATLON = latitude and longitude coordinates
IMAGE = image coordinates - one based

location= (x,y)
x = AREA line, latitude, or IMAGE line
y = AREA element, longitude, or IMAGE element

place= CENTER places specified location (x,y) at center of panel
ULEFT places specified location (x,y) at upper-left coordinate of panel

band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in
image

unit= calibration unit to request; default = 'BRIT'
position= time relative (negative values) or absolute (positive values) position in the dataset; default=0 (most recent

image)
size= number of lines and elements to request; default=(480,640)
mag= magnification of data (line,element), negative number used for sampling data; default=(1,1)
accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default =

('idv','0')
debug= send debug information to file; default=False

Example:
metadata,data = getADDEImage(debug=True,localEntry=desc, size='ALL', mag=(1,1), unit='BRIT')

listADDEImages - Lists data from an ADDE Image server that matches the keywords in the request - returns metadata objects which can be passed
into getADDEImage

Usage: directoryList = listADDEImages(keywords)
Keywords:

localEntry= local dataset defined by makeLocalADDEEntry
server= ADDE server
dataset=
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ADDE dataset group name
descriptor= ADDE dataset descriptor
day= single day ('date 1') or as a day range ('begin date','end date')
time= ('begin time','end time')
coordinateSystem= coordinate system to use for retrieving data 

AREA = AREA file coordinates - zero based
LATLON = latitude and longitude coordinates
IMAGE = image coordinates - one based

location= (x,y)
x = AREA line, latitude, or IMAGE line
y = AREA element, longitude, or IMAGE element

place= CENTER places specified location (x,y) at center of panel
ULEFT places specified location (x,y) at upper-left coordinate of panel

band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in
image

unit= calibration unit to request; default = 'BRIT'

position= time relative (negative values) or absolute (positive values) position in the dataset; default=0 (most recent
image)

size= number of lines and elements to request; default=(480,640)
mag= magnification of data (line,element), negative number used for sampling data; default=(1,1)
accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default =

('idv','0')
debug= send debug information to file; default=False

Example:
directoryList = listADDEImages(localEntry=desc, band=4, unit='TEMP')

listADDEImageTimes - Returns a list of available dates and times of data that match the keywords in the request
Usage: directoryList = listADDEImageTimes(keywords)

Keywords:
localEntry= local dataset defined by makeLocalADDEEntry
server= ADDE server
dataset= ADDE dataset group name
descriptor= ADDE dataset descriptor
day= single day ('date 1') or as a day range ('begin date','end date')
time= ('begin time','end time')
coordinateSystem= coordinate system to use for retrieving data 

AREA = AREA file coordinates - zero based
LATLON = latitude and longitude coordinates
IMAGE = image coordinates - one based

location= (x,y)
x = AREA line, latitude, or IMAGE line
y = AREA element, longitude, or IMAGE element

place= CENTER places specified location (x,y) at center of panel
ULEFT places specified location (x,y) at upper-left coordinate of panel

band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in
image

unit= calibration unit to request; default = 'BRIT'
position= time relative (negative values) or absolute (positive values) position in the dataset; default=0 (most recent

image)
size= number of lines and elements to request; default=(480,640)
mag= magnification of data (line,element), negative number used for sampling data; default=(1,1)
accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default =

('idv','0')
debug= send debug information to file; default=False

Example:
print listADDEImageTimes(localEntry=desc, band=4, unit='TEMP')

createLayer - Creates a new data layer in a panel
Usage: myDataLayer = panel[0].createLayer(display type, myData)

display type - display type for layer; valid options shown in Field Selector (e.g. 'Image Display', 'Image Sequence Display')
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myData - data object to display (from getADDEImage)
Example:

layer=panel[0].createLayer('Image Display', data)
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Modify the Display Object
annotate - Writes text to a panel

Usage: panel[0].annotate(text,keywords)
text - annotation string
Keywords:

lat=, lon= center text string at specified latitude and longitude (must be used together)
line=, element= center text string at specified panel line and element (must be used together)
font= name of font; default is system dependent, this uses the default defined in User Preferences
size= size of font; default = size of font defined in user preferences
color= 'color name'; default = 'red'

-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0 to 1)

Example:
panel[0].annotate('EQUATOR',size=20, font='SansSerif.bold', lat=0, lon=-90, color='Green')

setCenter -  Centers the display on a specified latitude/longitude and sets a scaling factor
Usage: panel[0].setCenter(lat,lon,keywords)

lat - centers the display at the specified latitude (no default, required parameter)
lon - centers the display at the specified longitude (no default, required parameter)
Keywords:

scale=scale factor for map; default = current scale factor
Remarks:

Scale factors between 0 and 1 zoom out centered on the specified latitude/longitude and scale factors greater than 1 zoom in.
Example:

panel[0].setCenter(45, -75, scale=20)

setProjection - Sets the projection of a panel
Usage: panel[0].setProjection(projection)

projection - string specifying the projection; e.g., 'US>Southeastern U.S.' or the name of the layer returned by createLayer, which uses
the default projection of that data

Example:
panel[0].setProjection('US>States>N-Z>Pennsylvania')

setWireframe - Turns wire frame box on or off
Usage: panel[0].setWireframe(visible)

visible - True displays wire frame box, False turns off wire frame box
Example:

panel[0].setWireframe(False)
panel[0].setWireframe(True)
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Modify the Layer Object
setColorScale - Displays color scale on a panel and specifies its attributes

Usage: myDataLayer.setColorScale(keywords)
Keywords:

visible= True - displays color scale (default)
placement= location of color scale 

'Top' (default)
'Bottom'
'Left'
'Right'

font= name of font; default = font defined in User Preferences
style= font style; default=font defined in user preferences

'BOLD' - bolded font
'ITALIC' - italicized font
'NONE'

size= size of font; default = size of font defined in User Preferences
color= 'color name'; default = color defined in User Preferences

-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0 to 1)

showUnit= toggles the visibility of the display unit on the color scale (default = False)
Example:

layer.setColorScale(placement='Left',font='SansSerif',size=18.0,color='green',showUnit=True)

setEnhancement - Applies a color table and defines data range of data in a layer
Usage: myDataLayer.setEnhancement(color table,keywords)

color table - color table name e.g., 'Longwave Infrared Deep Convection'
Keywords:

range= (min,max) enhancement range; default = (min,max) of data
Example:

layer.setEnhancement('Longwave Infrared Deep Convection',range=(20,250))

setLayerLabel - Toggles a layer label on/off and defines its attributes
Usage: myDataLayer.setLayerLabel(label,keywords)

label - layer label string. this can include macros
Keywords:

visible= True - displays layer label(default)
font= name of font; default = font defined in User Preferences.
style= font style; default = font defined in user preferences

'BOLD' - bolded font
'ITALIC' - italicized font
'NONE'

size= size of font; default = size of font defined in User Preferences
color= 'color name'; default = color defined in User Preferences

-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0 to 1)

Example:
layer.setLayerLabel('%displayname% %timestamp%', size=15, color='blue', style='BOLD')

setLayerVisible - Toggles layer visibility on/off
Usage: myDataLayer.setLayerVisible(visible)

visible - True displays layer
  False turns off layer

Example:
layer.setLayerVisible(False)
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Save the Display
captureImage - Writes panel display to a file

Usage: panel[0].captureImage(file, keywords)
file - name of file, file format determine by file extension; valid options: .jpg, .gif, .png
Keywords:

height= height of image (default - see Remarks)
width= width of image (default - see Remarks)
quality= quality of jpg file (0.0 to 1.0); default=1.0; not used with other formats

Remarks:
If captureImage is used to save a panel that was created with openBundle, the sizes default to size of the display window when the
bundle was saved. If data was loaded using createLayer, the sizes default to those defined in buildWindow.

Example:
panel[0].captureImage('C:\\Users\\myuser\\Image.png')

writeMovie - Writes an image sequence to a movie file (ISL function) 
Usage: writeMovie(file,keywords)

file - name of file, file format determine by file extension; valid options: .gif, .mov
Keywords:

resize width= height= size of image (default = height of window)
Example:

writeMovie('C:\\Users\\myuser\\movie.gif',params='resize width=600 height=800')
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Environment
getJythonShellMaxHistoryLength( ) - Returns the current number of commands that are saved.

Usage: print getJythonShellMaxHistoryLength()

setJythonShellMaxHistoryLength( ) - Sets the number of commands that will be saved.
Usage: setJythonShellMaxHistoryLength(number)
Remarks:

This is the number of commands that will be listed out with the File>List Saved History menu item in the Jython Shell, as well as the
number that will be added to the Local Jython Library from the File>Save Commands to Jython Library menu item. The default
number of commands saved to the history is 100.

Example:
setJythonShellMaxHistoryLength(25)

collectGarbage( ) - Performs a garbage collection to free up memory.
Usage: collectGarbage()

removeAllData( ) - Removes all data sources added during the current session, without removing any displays.
Usage: removeAllData()

removeAllLayers( ) - Removes all layers that have been displayed.
Usage: removeAllLayers()

expandpath( ) - Expands the path entered.
Usage: expandpath(path)
Remarks:

Understands environmental variables such as "~" and "..".
Example:

print expandpath('$HOMEPATH')

editFile( ) - Pastes the content of a text file into the text input field of the Jython Shell.
Usage: editFile(path)
path - Directory path to the file to be added to the Jython Shell.
Remarks:

Pastes the text of an existing file into the text input field of the Jython Shell. This makes it easy to evaluate and edit scripts.
Example:

editFile('C:\\Users\\myuser\\myscript.py')

getLogLevel( ) - Sets the logging level to be used by McIDAS-V.
Usage: print getLogLevel()
Remarks:

Returns the current logging level being used by McIDAS-V. This is composed of two items, level and effectiveLevel.
level- The logging level of the directory path used in the command. If a directory path is not specified, this is the logging

level for the session as a whole.
effectiveLevel- The logging level for the specific module specified in the command

Example:
print getLogLevel( )

This returns the logging level for everything as long as a logging level for another directory hasn't already been set.

setLogLevel( ) - Sets the logging level to be used by McIDAS-V.
Usage: setLogLevel(level,keywords)
level- Logging level to be used. This can be set to TRACE, DEBUG, INFO, WARN, ERROR, or OFF. Information about each of these logging
levels can be found in the Advanced Preferences page.
Keywords:

temporary= determines if the logging level will be saved from session to session (default = True)
Remarks:

This command can be used to set the logging level for the session as a whole, and it can also be used to set logging levels for specific
directories to control what type of logging output goes to mcidasv.log.

Examples:
setLogLevel('TRACE')

Sets the logging level for everything to Trace as long as a logging level for another directory hasn't already been set.
print getLogLevel()

Returns the global logging level in McIDAS-V.  Both level and effectiveLevel are set to TRACE.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__loglevel
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Sharing
Sharing is a mechanism to share control operations between two or more displays. For example, you can have one animation control control
animation in two windows at once.

For sharing animation in two windows, such as in the main McIDAS-V view window and a vertical cross section control, open the animation
properties dialog in each animation control by clicking on the  icon. Toggle on the Shared box and click on Ok. Then using either animation
control will effect animation in both windows.

You can share other kinds of layer controls, such as sharing one selector line in vertical cross sections. This is toggled on by clicking on the Share
checkbox under the View menu in the control window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Animation__FILE


10/3/13 12:29 PMMcIDAS-V User's Guide

Page 385 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Site Configuration
You can customize McIDAS-V for yourself and your site in a variety of ways. McIDAS-V is configured through a set of resource files. These are
typically eXtensible Markup Language (XML) files that define things such as:

Color tables
The data chooser user interface
The derived quantities and formulas
Jython libraries
Display defaults for parameters
Parameter aliases
Help tips
Projections
Available data sources
Available displays
Where the favorite bundles are
Maps
Station models

Most of these files (with the exception of the chooser UI, help tips, data sources, displays and favorite bundle locations) are created through
facilities provided by McIDAS-V (e.g., color table editor, formula editor, etc.)

By default McIDAS-V looks in three places for the resources it uses to configure itself:

User path. This is the ~user/McIDAS-V directory that gets created for each user.
Site path. This is the file directory or URL directory that can be defined as a command line argument, -sitepath, or through the user
preferences dialog.
System path. This is a directory, /ucar/unidata/idv/resources, in the system Java jar files.

When McIDAS-V first starts up it reads the system properties file: mcv.properties. This defines some basic information (e.g., title, splash icon,
ADDE servers, etc.) as well as defining where to find other properties files. By default it looks for idv.properties files under the site path and the
user path:

idv.properties = %SITEPATH%/idv.properties;%USERPATH%/idv.properties;

You can also specify one or more properties files as command line arguments:

-properties your_properties_file

McIDAS-V processes these properties files in order, with properties defined in later files overriding those defined previously.

Once the properties have been processed McIDAS-V initializes its resources by reading in one or more resource definition files. These are called
"RBI" files - (Resource Bundle for the IDV). These are XML files, the locations of which are defined by the idv.resourcefiles property:

idv.resourcefiles=%USERPATH%/idv.rbi;%SITEPATH%/idv.rbi;%IDVPATH%/idv.rbi

When you first run McIDAS-V, the application writes out an example RBI file into your local McIDAS-V directory. This example file has
documentation that describes how to add in new resources.

These RBI files define the location of different collections of resources. For example, from the system RBI file, idv.rbi, we have the entry that
defines where McIDAS-V can find the XML files that define the color tables:

<resources name="TARGET_SiteConfiguration__idv.resource.colortables"> <resource
location="%USERPATH%/colortables.xml"/> <resource location="%SITEPATH%/colortables.xml"/>
<resource location="%IDVPATH%/colortables.xml"/> </resources>

This says to look for colortables in the user path, sitepath and McIDAS-V system path. McIDAS-V uses the first entry in this list as the file path to
write out color tables that are created using the color table editor.

Note: As a further, convenience, if there is a property defined in the properties file which is the resource name then McIDAS-V just uses the value
of the property (it treats it as a semi-colon delimited list of paths) as the resources and ignores the resources in the RBI file. So, for example, if you
had a property:

idv.resource.colortables=%USERPATH%/colortables.xml;http://yourwebsite.edu/specialtables.xml

then McIDAS-V would only load in these colortables.
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To use the RBI file, you need to configure your site to use a set of special color tables that you have created. The first thing to do is bring up
McIDAS-V and create the color tables. These color tables get saved in your local McIDAS-V/<Application name> directory in the file
colortables.xml (as defined by the resource paths defined in the default RBI). You could copy that file to an area on your web site or on a shared file
system that is pointed to by the McIDAS-V sitepath. Now, your users simply need to define the sitepath and they will naturally pick up the color
tables you have created.

Most site configuration can be accomplished through the default user/site/system resource locations. However, you can modify the RBI file to
include other resources. For example, you could add in an entry:

<resource location="http://yourwebsite.edu/specialcolortables.xml"/>

to make available some special color tables at a particular URL.

Resource
Here is the list of the resource identifiers, description and file pattern (for use with plugins) of the different resources McIDAS-V uses.

Resource Identifier Description File Pattern
idv.resource.colortables Color tables used in the application colortables.xml$
idv.resource.projections Map projections projections.xml$
idv.resource.transects Map transects transects.xml$
idv.resource.messages Message catalog messages.properties$
idv.resource.grib1lookuptables Grib 1 Lookup tables grib1lookuptable.lst$
idv.resource.grib2lookuptables Grib 2 Lookup tables grib2lookuptable.lst$
idv.resource.jython Jython libraries .py$
idv.resource.stationmodels Station models stationmodels.xml$
idv.resource.imagedefaults ADDE Image Defaults imagedefaults.xml$
idv.resource.backgroundwms Background WMS images backgroundwms.xml$
idv.resource.imagesets Image Sets imagesets.xml$
idv.resource.autodisplays Automatic display creation autodisplays.xml$
idv.resource.skin UI Skin skin.xml$
idv.resource.toolbar Tool bar toolbar.xml$

idv.resource.actions Actions actions.xml$
idv.resource.stationsymbols Station model symbols stationsymbols.xml$
idv.resource.colorpairs Color pairs no pattern
idv.resource.bundlexml Bundle xml no pattern
idv.resource.aliases Data aliases aliases.xml$
idv.resource.datasource Specification of the data sources datasource.xml$
idv.resource.derived Derived quantities derived.xml$
idv.resource.choosers The definition of the user interface for data choosers choosers.xml$
idv.resource.bundles Default bundles that are evaluated at start up no pattern
idv.resource.controls Display controls controls.xml$
idv.resource.helptips Help tips shown in the help tips dialog helptips.xml$
idv.resource.locations Fixed station locations locations.xml$
idv.resource.maps Maps for the displays maps.xml$
idv.resource.menubar Commands in the menu bar (defaultmenu.xml$|menubar.xml$)
idv.resource.paramdefaults Display defaults for data paramdefaults.xml$
idv.resource.paramgroups Parameter groups paramgroups.xml$
idv.resource.userchooser End user constructed data choosers no pattern
idv.resource.preferences User preferences no pattern
idv.resource.plugins Plugins no pattern
idv.resource.prototypes Prototypes no pattern
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Plugin Jar Files
Note: This page is intended for someone who wants to create a McIDAS-V plugin. A description of installing and managing plugins is here.

McIDAS-V supports a plugin architecture that allows for the easy extension and addition of functionality. A plugin is most commonly a Java Jar
file that contains a set of resource files (e.g., color tables) and/or Java class files. The plugins are stored on a local directory or could be loaded form
a web site. McIDAS-V processes the plugin Jar file at run time loading in the contained resources and code.

Basic Plugin
Lets suppose you have created a set of color tables and some Jython code that you want to make a plugin with. As described in the Site
Configuration docs McIDAS-V stores these user created files in <user home>/.metappps/DefaultIdv as colortables.xml and default.py.

To make these into a plugin, e.g., myplugin.jar, simply jar the the files (you need to get a Java SDK for this):

jar -cvf myplugin.jar colortables.xml default.py

Now this plugin can be distributed to others and loaded into their McIDAS-V environment.

So, you might ask how does McIDAS-V recognize these files in the plugin and treat them appropriately? McIDAS-V loads in a set of resources
(e.g., color tables, Python libraries). Each resource type is identified by a regular expression as shown in the resource list. In our example above the
file name colortables.xml matches the pattern for color table xml resources.

Now, what happens if you have some file whose name does not match a pattern? Say, you have a color table xml file called myspecialtables.xml
that you want to include in a bundle. In that case you can add a .rbi file, as described here, that defines this file as a resource:

<?xml version="1.0" encoding="ISO-8859-1"?> <resourcebundle> <resources
name="TARGET_PluginJarFiles__idv.resource.colortables"> <resource
location="/myspecialtables.xml"/> </resources> </resourcebundle>

This acts as a table of contents for the plugin. Make sure that the location is not relative. Note: Jar files can contain directory trees. e.g.,
/tables/myspecialtables.xml. In this case just have the location point to:

... <resource location="/tables/myspecialtables.xml"/> ...

Including Code
You can also include code that implements certain functionality by just including the Java .class files in the Jar. When you do this you need to
include them like a normal class containing Jar file, i.e., the package structure of your code (e.g., edu.ucar.app.Test) needs to be reflected in the
directory structure of the Plugin Jar file:

/edu/ucar/app/Test.class

For a single class file this is not necessarily required but if there are multiple class files that have interdependency among themselves then you will
get into trouble if you don't follow this structure.

Now, what this code does can be anything and is best left up to the developer's guide.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Plugins__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_SiteConfiguration__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_SiteConfiguration__resources
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_SiteConfiguration__FILE
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Configuring Image Defaults
The defaults for the advanced settings of the Image Chooser is set for particular images through a configuration file. You can override the system
defaults by creating your own configuration file and placing it in the user directory or sitepath See the section on Site Configuration for more
information on the location of these directories. The configuration file (imagedefaults.xml) has the following format:

<?xml version="1.0" encoding="ISO-8859-1"?> <imagedefaults> <default pattern="" key="" place=""
loc="" unit="" user="" band="" proj=""/> </imagedefaults>

The attributes that can be overridden are:
pattern dataset identifier (format: host:group/desc)
key type of location (LINELE or LATLON)
place placement (ULEFT or CENTER)
loc location of placement (line ele or lat lon)
size resulting image size (lines eles)
mag magnification factor (lmag emag)
unit default calibration unit
band band number
proj project number
user user id (case sensitive)
debug (true to print lots of debug information)
Except for pattern, key and debug, McIDAS-V uses the same keywords/syntax as McIDAS (longitudes are entered as degrees east, however). The
entries are hierarchical, so if you specify some defaults for the server, they apply to all datasets on that server unless overridden for specific
datasets.

Here are a few examples:

<imagedefaults> <default pattern="*" debug="true"/> <default pattern="adde.ucar.edu:RTIMAGES/GE-
IR" key="LATLON" place="CENTER" loc="40 -90" unit="BRIT" user="foo" proj="9999"/> <default
pattern="EUM_AD/M8" loc="46 10" band="9" unit="TEMP" size="512 512"/> <default pattern="CIMSS/CTP"
key="LATLON" loc="35 -100" mag="1 1" unit="CTOP"/> <default pattern="GINICOMP/GSN8KVIS"
key="LINELE" place="CENTER" loc="504 768" size="504 768" mag="-2 -2"/> <default
pattern="CCS039/G81KVIS" key="LINELE" place="ULEFT" loc="0 0" size="ALL"/> </imagedefaults>

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_SiteConfiguration__FILE
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Adding in New GRIB Tables
McIDAS-V can read Gridded Binary (GRIB) files in both GRIB-1 and GRIB-2 formats. Decoding GRIB files requires a set of lookup tables for
parameters, issuing centers, etc. McIDAS-V comes pre-configured to support commonly used tables, but regional models and modeling centers may
use tables that are not in the distribution.

You can add in specialized tables for both GRIB-1 and GRIB-2 using the steps below. Documentation on the format of the files can be found here.

GRIB-1 tables
GRIB-2 tables

GRIB-1 tables
To add in new GRIB 1 tables, you will need to create a file listing the special tables and the special table files themselves.

To add in a new parameter file, McIDAS-V would need to have access to a file called grib1lookuptable.lst which would list the parameter table
(e.g.: gwctab_2.tab) and the parameter table itself.

The format of grib1lookuptable.lst is:

<center>:<subcenter>:<version>: <table location>

so it would look like:

57: 1: 2: gwctab_2.tab

gwctab_2.tab can be a relative or absolute path. The tables are in ncep format:

-1:57:-1:2 0:var0:undefined 1:PRES:Pressure [Pa] 2:PRMSL:Pressure reduced to MSL [Pa]
3:PTEND:Pressure tendency [Pa/s] 4:PVORT:Pot. vorticity [km^2/kg/s] 5:ICAHT:ICAO Standard
Atmosphere Reference Height [m] :GP:Geopotential [m^2/s^2] ...

(You can read more information about the format of this file and the parameter table here)

Once you've created this file, you would access it by putting the grib1lookuptable.lst in your <home>/McIDAS-V directory and put the
corresponding table files where they are pointed to in the file. This can be a relative path or a web server. Alternatively, you could place the
grib1lookuptable.lst and associated parameter tables on a local web server and use McIDAS-V's sitepath parameter (startup option or user
preference) to point to the location where the files are.

GRIB-2 tables
To add in new GRIB 2 parameter, you would create a file named grib2lookuptable.lst which lists the parameters.

The format of grib2lookuptable.lst is:

<Discipline> <Category> <Parm #> <Name> <Units> <Desc>

Parameters are listed by row, fields are separated by tabs, so it would look like:

#Dis Cat Parm # Name Units Desc 0 0 0 Temperature K Temperature

(This is a sample table, the lines starting with # are not include in table.) (You can read more information about the format of this file and the
parameter table here)

Once you've created this file, you would access it by putting the grib2lookuptable.lst in your <home>/McIDAS-V directory. Alternatively, you
could place the grib2lookuptable.lst on a local web server and use McIDAS-V's sitepath parameter (startup option or user preference) to point to the
location of the file.

http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GribTables__grib1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GribTables__grib2
http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt
http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt
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McIDAS-V Special Data Formats
Text (ASCII) Point Data Format
Location XML Files
Image XML Files
Image Movie Files
XGRF Symbols

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TextPointData__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocationXml__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageXml__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ImageMovie__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Xgrf__FILE
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Text (ASCII) Point Data Format
If your point (in situ) data is not available in one of the file formats that McIDAS-V can handle, but you can output it into a column-oriented ASCII
text file, you may still be able to use the McIDAS-V displays. McIDAS-V supports reading in point observation data in a text comma separated
value (CSV) file format.

You need to specify the metadata of this point data. This can be done in two ways. First, the file can have two extra header lines that defines for
McIDAS-V the fields that are within the file and the types of the fields. The only other requirement is that there must be a latitude, longitude and
time field in the data. See below.

Secondly, if there are no metadata header lines defined, the Text Point Data Source will show the Metadata GUI described below.

More information about the format of Time and Lat/Lon symbols can be found in the User Preferences' Formats and Data Preferences page.

Examples:

Comma separated numeric values

In the simplest form, each line line is an observation at one time and one location:

(index) -> (Time,Latitude,Longitude,Altitude,PSL,GUS,SPD,DIR,TD,T) Time[fmt="yyyy-MM-dd
HH:mm:ss"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],PSL[unit="hPa"],GUS[unit="m.s-1"],SPD[unit="m/s"],DIR[unit="deg"],
TD[unit="celsius"],T[unit="celsius"] 2007-01-07
16:00:00Z,32.9,117.1,145.0,1026.1,NaN,0.0,0.0,-2.8,12.8 2007-01-07
16:00:00Z,48.3,92.5,341.0,1003.7,NaN,1.5,170.0,-2.0,-0.99 2007-01-07
16:00:00Z,36.8,98.7,449.0,1024.0,12.4,9.8,330.0,-3.0,3.0 2007-01-07
16:00:00Z,44.3,121.2,938.0,1030.1,NaN,2.1,110.0,-3.3,-1.7

Note also that the first line's structure is quite rigid -- you must have a variable (e.g., index, recNum) that is the domain parameter; this should map
to the range values. The second line defines the formatting and units of the parameters. Unit names should be standard international unit
specifications (udunits compatible). A list of valid names can be found here. (A complete description of this format is contained in the VisAD
README.text file.)

Also note that you need to set the name of the variable for time as "Time", as well as the locations as "Latitude", "Longitude" and "Altitude" (if
needed).

Text fields

If you have text fields (i.e., non-numeric data) in your observation, just do this:

(index) -> (Time,Latitude,Longitude,Altitude,ST(Text),T) Time[fmt="yyyy-MM-dd HH:mm:ss
z"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],ST(Text),T[unit="celsius"] 2007-02-16 11:00:00 MST,32.9,117.1,145.0,CA
,20.6

Here we have a ST field (State from metars). Its field name is defined as "ST(Text)" and its entry in the second line is the same.

Time in multiple columns

If you have time fields that span multiple columns, you can use the colspan keyword:

(index) -> (IDN, Latitude, Longitude, Time, WDIR, WSPD, GST) IDN, Latitude[unit="deg"],
Longitude[unit="deg"], Time[fmt="yyyy MM dd HH mm" colspan="5"], WDIR[unit="deg" miss="MM"],
WSPD[unit="m/s" miss="MM"], GST[unit="m/s" miss="MM"] 41001 34.68 -72.66 2007 07 17 20 50 210 4.0
6.0 41004 32.5 -79.09 2007 07 17 20 50 210 6.0 MM 41008 31.4 -80.87 2007 07 17 21 50 170 7.0 8.0

Skipping columns

You can use the "skip" parameter if you want to ignore (not read) values in your text file that you don't want to use:

(recNum)->(Latitude, Longitude, Altitude, type(Text), time, turb_intensity) time[fmt=yyyyMMddHH],
obtime, skip, type(Text), skip, skip, Latitude, Longitude[scale=-1], Altitude[unit=ft],

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TextPointData__metadatagui
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FormatPreferences__dateformat
http://www.unidata.ucar.edu/software/udunits/udunits-1/udunits.txt
http://www.ssec.wisc.edu/~billh/README.text
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Altitude2[unit=ft], turb_intensity, skip 2004050100 0005 34 C210 1 T 38.82 92.22 7000 7000 0 -9
2004050100 0004 35 PA32 0 T 35.40 98.62 4000 4000 0 -9 2004050100 0008 58 A36 0 T 29.18 81.05 5000
5000 2 -9

Fixed values for several observations

If you have values (like time or location) that are fixed for several observations, you may use this construct:

(index) -> (Longitude,Latitude,Time,ST(Text),SPD,DIR,TD,T) Longitude[unit="degrees
west"],Latitude[unit="deg"],Time[fmt="yyyy-MM-dd HH:mm:ss
z"],ST(Text),SPD[unit="m/s"],DIR[unit="deg"],TD[unit="celsius"],T[unit="celsius"] Longitude=-117.1
Latitude=32.9 ST=MSN 2007-02-20 11:00:00 ST ,0.0,0.0,8.9,13.3 2007-02-20 12:00:00 ST
,0.0,0.0,11.9,15.0 Longitude=-89.4 Latitude=43.1 ST=DEN 2007-02-20 11:00:00 ST
,1.5,160.0,-7.0,-2.0 2007-02-20 12:00:00 ST ,1.5,160.0,-7.0,-2.0 Longitude=-121.2 Latitude=44.3
ST=ORD 2007-02-20 11:00:00 ST ,10.8,230.0,-1.1,6.7

Loading into McIDAS-V
Finally, after you have created your file, you will want to tailor your McIDAS-V display in two ways:

1. Create a station model for those variables using the McIDAS-V's "Tools->Station Model Template" menu

Then, when you run McIDAS-V to read your data:

1. Use Data Source Type as "Text Point Data files"
2. Use the "Point Data Plot" for the Display
3. Select your newly created station model

Using the Text Point Metadata Gui
If your text data does not have the metadata header lines the Text Point Data Source will show the following dialog which allows you to specify the
metadata.
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Image 1: Point Data Dialog Window

Delimiter

This field specifies how the different data values are separated within the text file. The options are Comma, Semicolon, Tab, and Space. Selecting
this option allows McIDAS-V to separate out different text fields to allow you to define them at the bottom of this Point Data window.

Skipping lines

At the top, a number of the initial lines from the text data are shown. The arrow keys allow you to specify the start line. For example, if you had
some other header information, you can skip over those lines.

Specifying metadata 
For each column of text data there is a row shown in the bottom of the dialog. This shows the sampled value and allows you to enter a name, unit,
date format, missing value and extra information. There are some names that McIDAS-V treats special: "Latitude", "Longitude", "Altitude", and
"Time". You must have at least Latitude, Longitude and Time specified.

The Unit/Date Format field allows you to specify the Unit for data fields and the date format. For text fields choose Misc->Text as the unit.

The Extra fields must be of the form:

name="value"

Don't forget the quotes!

Skipping columns 
You can skip over certain columns by entering the Name: "skip"

Saving this as a preference 
To keep from having to enter in this data again next time you load a new text point data of the same form, simply press the "Preferences" button and
select Save Current. This allows you to save these metadata settings and reapply them later using the "Preferences" button.
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Location XML Files
McIDAS-V supports a variety of location text file formats. All of these formats can be loaded through the File Chooser. Select the "Location" data
type.

Locations XML
CSV Format
GeoRSS Format
KML/KMZ Format

Locations XML
The main one format McIDAS-V uses is a custom locations xml format. This format still has some nomenclature from when it was atmospheric
science related (e.g. "stations"). A simple example:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example"> <station name="TARGET_LocationXml__station 1"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station name="TARGET_LocationXml__station 2"
lat="40.3" lon="-107.5" elev="10"/> ... </stationtable>

The lat and lon attributes can be of the form:

+/- ddd:mm, ddd:mm:, ddd:mm:ss, ddd::ss, ddd.fffff ===> [+/-] ddd.fffff +/- ddd, ddd:, ddd:: ===>
[+/-] ddd +/- :mm, :mm:, :mm:ss, ::ss, .fffff ===> [+/-] .fffff +/- :, :: ===> 0.0 Any of the
above with N,S,E,W appended

The elev attribute is optional. By default it is in meters. You can override this default with an elevunit in the stationtable tag. e.g.:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example" elevunit="feet"> <station
name="TARGET_LocationXml__station 1" lat="65:02:06" lon="-147:30:06" elev="5340"/> ...

The station tags can have an id attribute as well:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" lat="65:02:06"
lon="-147:30:06" elev="790"/>

The station tags can also have any other attributes:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" st="AK" co="US"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station id="FTG"
name="TARGET_LocationXml__Denver/Boulder" st="CO" co="US" lat="39:47:12" lon="-104:32:45"
elev="1675"/>

These can be displayed by the station model used in the Location Display Control.

If you want to create a permanent list of station that shows up in the Display->Locations menu in the Main Display window, you can create a file
called userstations.xml in the McIDAS-V directory under your user's home directory. The format would look like:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtables> <stationtable name="SubsetA"
category="My Custom Stations"> (list of stations for SubsetA) </stationtable>
<stationtable name="SubsetB" category="My Custom Stations"> (list of stations for SubsetB)
</stationtable> </stationtables>

This will show up in the Display->Locations menu as a top menu called My Custom Stations and sub menus SubsetA and SubsetB. After adding
this XML file in through the Files/Directories chooser, you must first restart McIDAS-V before the stations will be listed.

CSV Format
Location data can be defined in a CSV (Comma Separated Value) format. The first line is a comma separated list of column names. There must be
columns that are latitude and longitude. These are denoted with (case insensitive):

latitude lat longitude lon long

Altitude is given by the column names:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocationXml__xml
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocationXml__csv
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocationXml__georss
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_LocationXml__kmlkmz
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationLocationControl__FILE
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alt altitude

The altitude value, if defined, is by default in meters. You can optionally specify a unit with the suffix: "[unit name]" (see example).

The first column that is found that is not one of the location columns is taken to be the name of the location.

Example:

Name,Latitude,Longitude,Altitude,State Boulder,40,-107,5430[feet],CO Miami,30,-95,0[feet],FL ...

GeoRSS Format
McIDAS-V can also read GeoRSS formats. This is a geocoded RSS feed.

KML/KMZ Format
McIDAS-V can also read KML/KMZ formats. This type of file can be read in through the General>Files/Directories Chooser of the Data Sources
tab of the Data Explorer with the Google Earth Files KML/KMZ Data Type.  An example file from the USGS can be found here:

http://comcat.cr.usgs.gov/earthquakes/eventpage/usb000ije3.kml

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
http://comcat.cr.usgs.gov/earthquakes/eventpage/usb000ije3.kml
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Image XML Files
The Image Xml file format (.ximg) allows one to define collections of geolocated images (and also shapefiles). The simplest file can define one
geolocated image:

<image url="sboulder.jpeg" name="South Boulder-aerial photo" ullat="39.98890"
ullon="-105.22782" lrlat="39.98755" lrlon="-105.22548"/>

The url attribute can be an absolute or relative url or file path. The ullat, ullon, lrlat and lrlon attributes are the upper left and lower right lat/lon of
the image. It is assumed that the image is in a geographic (i.e., rectilinear, lat/lon) projection.

Collections
You can also define a collection of images:

<collection name="TARGET_ImageXml__Boulder Images"> <image url="sboulder.jpeg" name="South
Boulder-aerial photo" ullat="39.98890" ullon="-105.22782" lrlat="39.98755"
lrlon="-105.22548"/> <image url="bouldertopo.jpeg" ullat="40.06654" ullon="-105.34710"
lrlat="39.98040" lrlon="-105.19676" name="Boulder topo"/> <image url="bigtopo.jpeg"
ullat="40.22807" ullon="-106.66437" lrlat="39.54718" lrlon="-105.45623" name="Mountains
topo"/> </collection>

Collections can contain other collections:

<collection name="TARGET_ImageXml__My Images"> <collection name="TARGET_ImageXml__Madison
Images"> <image url="madison_aerial.jpeg" ullat="43.09444" ullon="-89.52626"
lrlat="43.01143" lrlon="-89.36579" name="Madison aerial"/> <image url="madison_topo.jpeg"
ullat="43.09444" ullon="-89.52626" lrlat="43.01143" lrlon="-89.36579" name="Madison
topo"/> </collection> <collection name="TARGET_ImageXml__Boulder Images"> <image
url="sboulder.jpeg" name="South Boulder-aerial photo" ullat="39.98890" ullon="-105.22782"
lrlat="39.98755" lrlon="-105.22548"/> </collection> </collection>

There is also a shape tag for defining shape files:

<collection name="TARGET_ImageXml__Shapes"> <shape url="boulder_roads.zip"
name="TARGET_ImageXml__Boulder roads"/> <shape url="boulder_rivers.zip"
name="TARGET_ImageXml__Boulder rivers"/> </collection>

Grouping
The group tag allows you to group a set of images in time or space:

<group name="TARGET_ImageXml__group of images" format="yyyyMMddhhmm" ullat="39.991856"
ullon="-105.226944" lrlat="39.989426" lrlon="-105.222656"> <image date="200610011000"
url="sketch.jpg"/> <image url="map.jpg" date="200610011100"/> </group>

The format attribute defines the date/time format of the date attributes. The location attributes (ullat,ullon, etc.) can be defined both in the group tag
as well as in each individual image tag.

If there are no date attributes then the group of images are aggregated together, each potentially covering a different area.

Images in 3D Space
One is not limited to just specifying the positions of the upper left and lower right corners of the image. There is support for defining the latitude
and longitude for any of the four corners of the image:

<image url="image.jpeg" name="Image" ullat="40" ullon="-100" lllat="30" lllon="-100"
urlat="50" urlon="-90" lrlat="30" lrlon="-90" />

One can also specify the altitude of any of the points. The unit specification is not required and will default to meters.

<image url="image.jpeg" name="Image" ullat="40" ullon="-100" ulalt="20000[feet]"
lllat="30" lllon="-100" llalt="0[feet]" urlat="50" urlon="-90" uralt="5000[feet]"
lrlat="30" lrlon="-90" lralt="0[feet]" />

McIDAS-V will try to fill in defaults. So, for example, if you wanted to have an image be a vertical cross section you could do:



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 397 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

<image url="topo.jpg" name="Image" ullat="40" ullon="-100" urlat="50" urlon="-90"
ulalt="20000[feet]" llalt="0[feet]"/>

Here, we define the lat/lon of the upper left and upper right of the image. We define the altitude of the upper left and lower left corners of the
image. The altitude of the upper right corner defaults to that of the upper left and the altitude of the lower right defaults to the lower left altitude.
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Image Movie Files
McIDAS-V can display a sequence of time-stamped images as an animation.

One can write their own xml file and display the images within McIDAS-V using this xml format.

There are really two xml formats used. The first defines a set of imagesets:

<imagesets base="http://www.unidata.ucar.edu/georesources/webcams/images"
name="TARGET_ImageMovie__McIDAS-V Webcams"> <group name="TARGET_ImageMovie__Rockies">
<imageset name="TARGET_ImageMovie__Boulder, CO" index="boulder_co/index.xml" lat="40.0"
lon="-105.27"/> <imageset name="TARGET_ImageMovie__Denver, CO" index="denver_co/index.xml"
lat="39.75" lon="-105"/> </group> <group name="TARGET_ImageMovie__National Parks">
<imageset name="TARGET_ImageMovie__Theodore Roosevelt National Park, ND"
index="theodorerooseveltnationalpark_nd/index.xml" lat="46.94889" lon="-103.43306"/>
<imageset name="TARGET_ImageMovie__Big Bend National Park,TX"
index="bigbendnationalpark_tx/index.xml" lat="29.25" lon="-103.25"/> <imageset
name="TARGET_ImageMovie__Olympic National Park" index="olympicnationalpark/index.xml"
lat="48.26667" lon="-124.675"/> </group> ... </imagesets>

This is a "table of contents". The base attribute, if defined, is used as a url base to prepend to the urls defined by the index attributes. The lat and lon
attributes are optional and are used to locate the source of the movie on a map for the user to select.

Each of the index attributes refers to an images xml file of the form:

<images base="http://www.unidata.ucar.edu/georesources/webcams/images/boulder_co"
name="Boulder, CO" group="Rockies" format="yyyyMMddHHmmz" desc="From: http://9news.com">
<image time="200607251446GMT" file="image_200607251446GMT.jpeg"/> <image
time="200607251430GMT" file="image_200607251430GMT.jpeg"/> <image time="200607251414GMT"
file="image_200607251414GMT.jpeg"/> <image time="200607251357GMT"
file="image_200607251357GMT.jpeg"/> <image time="200607251344GMT"
file="image_200607251344GMT.jpeg"/> ... </images>

The images tag defines a base attribute (optional, used to prepend to any image urls), a name, a (optional) group and a date format and a description
(desc). Each image tag has a time in the format specified in the images tag and a file attribute which refers to some image. This may be an absolute
or relative url or file path.
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XGRF Symbols
The drawing control can export and import its drawings in an xgrf format. In this format you can specify a symbol type. The symbol tag in the xgrf
has a symbol attribute, the value of which can be any of the below symbols.

General Symbols
PIN - Pin
PLUS - Plus
MINUS - Minus
CROSS - Cross
SQUARE - Square
FILLED_SQUARE - Filled Square
TRIANGLE - Triangle
FILLED_TRIANGLE - Filled Triangle
CIRCLE - Circle
FILLED_CIRCLE - Filled Circle
DIAMOND - Diamond
FILLED_DIAMOND - Filled Diamond
STAR - Star
FILLED_STAR - Filled Star
HORLINE - Hor. Line
VERTLINE - Vert. Line
LEFTARROW - Left Arrow
RIGHTARROW - Right Arrow
UPARROW - Up Arrow
DOWNARROW - Down Arrow
CUBE - Cube
DOWNLINE - Down Line
PYRAMID_4FACE - 4 Face Pyramid
PYRAMID_5FACE - 5 Face Pyramid
FILLED_SPHERE - Sphere
AIRPLANE - 2-D Airplane
AIRPLANE3D - 3-D Airplane
NONE - None

Present Weather
WX_PRESENTWX_0 - Cloud development not observed or not observable
WX_PRESENTWX_1 - Clouds generally dissolving or becoming less developed
WX_PRESENTWX_2 - State of sky on the whole unchanged
WX_PRESENTWX_3 - Clouds generally forming or developing
WX_PRESENTWX_4 - Visibility reduced by smoke
WX_PRESENTWX_5 - Haze
WX_PRESENTWX_6 - Widespread dust in suspension in the air, not raised by wind
WX_PRESENTWX_7 - Dust or sand (or spray) raised by wind
WX_PRESENTWX_8 - Well developed dust or sand whirl(s)
WX_PRESENTWX_9 - Duststorm or sandstorm within sight or during preceding hour
WX_PRESENTWX_10 - Mist
WX_PRESENTWX_11 - Patches of shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_12 - Continuous shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_13 - Lightning visible, no thunder heard
WX_PRESENTWX_14 - Precipitation in sight, not reaching the ground
WX_PRESENTWX_15 - Precipitation in sight, reaching the ground, more than 5km away
WX_PRESENTWX_16 - Precipitation in sight, reaching the ground nearby
WX_PRESENTWX_17 - Thunderstorm, but no precipitation at time of observation
WX_PRESENTWX_18 - Squalls within sight during the preceding hour
WX_PRESENTWX_19 - Funnel cloud(s) within sight during the preceding hour
WX_PRESENTWX_20 - Recent drizzle or snow grains
WX_PRESENTWX_21 - Recent rain
WX_PRESENTWX_22 - Recent snow
WX_PRESENTWX_23 - Recent rain and snow or ice pellets
WX_PRESENTWX_24 - Recent freezing drizzle or freezing rain
WX_PRESENTWX_25 - Recent rain showers
WX_PRESENTWX_26 - Recent showers of snow, or of rain and snow
WX_PRESENTWX_27 - Recent showers of hail, or of rain and hail
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WX_PRESENTWX_28 - Recent fog
WX_PRESENTWX_29 - Recent thunderstorm
WX_PRESENTWX_30 - Slight or moderate duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_31 - Slight or moderate duststorm or sandstorm, no change in last hour
WX_PRESENTWX_32 - Slight or moderate duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_33 - Severe duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_34 - Severe duststorm or sandstorm, no change in last hour
WX_PRESENTWX_35 - Severe duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_36 - Slight or moderate drifting snow (below eye level)
WX_PRESENTWX_37 - Heavy drifting snow (below eye level)
WX_PRESENTWX_38 - Slight or moderate blowing snow (above eye level)
WX_PRESENTWX_39 - Heavy blowing snow (above eye level)
WX_PRESENTWX_40 - Fog extending above observer in distance
WX_PRESENTWX_41 - Fog in patches
WX_PRESENTWX_42 - Fog has become thinner in last hour, sky visible
WX_PRESENTWX_43 - Fog has become thinner in last hour, sky invisible
WX_PRESENTWX_44 - Fog, no change in last hour, sky visible
WX_PRESENTWX_45 - Fog, no change in last hour, sky invisible
WX_PRESENTWX_46 - Fog has become thicker in last hour, sky visible
WX_PRESENTWX_47 - Fog has become thicker in last hour, sky invisible
WX_PRESENTWX_48 - Fog depositing rime, sky visible
WX_PRESENTWX_49 - Fog depositing rime, sky invisible
WX_PRESENTWX_50 - Slight intermittent drizzle
WX_PRESENTWX_51 - Slight continuous drizzle
WX_PRESENTWX_52 - Moderate intermittent drizzle
WX_PRESENTWX_53 - Moderate continuous drizzle
WX_PRESENTWX_54 - Heavy intermittent drizzle
WX_PRESENTWX_55 - Heavy continuous drizzle
WX_PRESENTWX_56 - Slight freezing drizzle
WX_PRESENTWX_57 - Moderate or heavy freezing drizzle
WX_PRESENTWX_58 - Slight rain and drizzle
WX_PRESENTWX_59 - Moderate or heavy rain and drizzle
WX_PRESENTWX_60 - Slight intermittent rain
WX_PRESENTWX_61 - Slight continuous rain
WX_PRESENTWX_62 - Moderate intermittent rain
WX_PRESENTWX_63 - Moderate continuous rain
WX_PRESENTWX_64 - Heavy intermittent rain
WX_PRESENTWX_65 - Heavy continuous rain
WX_PRESENTWX_66 - Slight freezing rain
WX_PRESENTWX_67 - Moderate or heavy freezing rain
WX_PRESENTWX_68 - Slight rain or drizzle and snow
WX_PRESENTWX_69 - Moderate or heavy rain or drizzle and snow
WX_PRESENTWX_70 - Slight intermittent fall of snow flakes
WX_PRESENTWX_71 - Slight continuous fall of snow flakes
WX_PRESENTWX_72 - Moderate intermittent fall of snow flakes
WX_PRESENTWX_73 - Moderate continuous fall of snow flakes
WX_PRESENTWX_74 - Heavy intermittent fall of snow flakes
WX_PRESENTWX_75 - Heavy continuous fall of snow flakes
WX_PRESENTWX_76 - Ice prisms
WX_PRESENTWX_77 - Snow grains
WX_PRESENTWX_78 - Isolated starlike snow crystals
WX_PRESENTWX_79 - Ice pellets
WX_PRESENTWX_80 - Slight rain showers
WX_PRESENTWX_81 - Moderate or heavy rain showers
WX_PRESENTWX_82 - Violent rain showers
WX_PRESENTWX_83 - Slight showers of rain and snow mixed
WX_PRESENTWX_84 - Moderate or heavy showers of rain and snow mixed
WX_PRESENTWX_85 - Slight snow showers
WX_PRESENTWX_86 - Moderate or heavy snow showers
WX_PRESENTWX_87 - Slight showers of ice or snow pellets
WX_PRESENTWX_88 - Moderate or heavy showers of ice or snow pellets
WX_PRESENTWX_89 - Slight hail showers
WX_PRESENTWX_90 - Moderate or heavy hail showers
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WX_PRESENTWX_91 - Slight rain, thunderstorm in last hour
WX_PRESENTWX_92 - Moderate or heavy rain, thunderstorm in last hour
WX_PRESENTWX_93 - Slight rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_94 - Moderate or heavy rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_95 - Slight or moderate thunderstorm with rain and/or snow
WX_PRESENTWX_96 - Slight or moderate thunderstorm with hail
WX_PRESENTWX_97 - Heavy thunderstorm with rain and/or snow
WX_PRESENTWX_98 - Thunderstorm combined with duststorm or sandstorm
WX_PRESENTWX_99 - Heavy thunderstorm with hail

Low Cloud
WX_LOCLD_1 - Cu of fair weather, little vertical development, seemingly flattened
WX_LOCLD_2 - Cu of considerable development, generally towering, with or without other Cu or Sc bases all at same level
WX_LOCLD_3 - Cb with tops lacking clear cut outlines, but distinctly no cirriform or anvil-shaped; with or without Cu, Sc, or St
WX_LOCLD_4 - Sc formed by spreading out of Cu; Cu often present also
WX_LOCLD_5 - Sc not formed by spreading out of Cu
WX_LOCLD_6 - St or Fs or both, but no Fs of bad weather
WX_LOCLD_7 - Fs and/or Fc of bad weather (scud)
WX_LOCLD_8 - Cu and Sc (not formed by spreading out of Cu) with bases at different levels
WX_LOCLD_9 - Cb having a clearly fibrous (cirriform) top, often anvil-shaped, with or without Cu, Sc, St, or scud

Cloud Coverage
WX_SKY_0 - No clouds
WX_SKY_1 - Less than one-tenth or one-tenth
WX_SKY_2 - two-tenths or three-tenths
WX_SKY_3 - four-tenths
WX_SKY_4 - five-tenths
WX_SKY_5 - six-tenths
WX_SKY_6 - seven-tenths or eight-tenths
WX_SKY_7 - nine-tenths or overcast with openings
WX_SKY_8 - completely overcast
WX_SKY_9 - sky obscured
WX_SKY_10 - missing

Mid Clouds
WX_MIDCLD_1 - Thin As (most of cloud layer semi-transparent)
WX_MIDCLD_2 - Thick As, greater part sufficiently dense to hide sun (or moon), or Ns
WX_MIDCLD_3 - Thin Ac, mostly semi-transparent; cloud elements not changing much and at a single level
WX_MIDCLD_4 - Thin Ac in patches; cloud elements continually changing and/or occurring at more than one level
WX_MIDCLD_5 - Thin Ac in bands or in a layer gradually spreading over sky and usually thickening as a whole
WX_MIDCLD_6 - Ac formed by spreading out of Cu
WX_MIDCLD_7 - Double-layered Ac, or a thick layer of Ac, not increasing; or Ac with As and/or Ns
WX_MIDCLD_8 - Ac in the form of Cu-shaped tufts or Ac with turrets
WX_MIDCLD_9 - Ac of a chaotic sky, usually at different levels; patches of dense Ci are usually present also

High Clouds
WX_HICLD_1 - Filaments of Ci, or "mares tails", scattered and not increasing
WX_HICLD_2 - Dense Ci in patches or twisted sheaves, usually not increasing, sometimes like remains of Cb; or towers or tufts
WX_HICLD_3 - Dense Ci, often anvil shaped derived from or associated with Cb
WX_HICLD_4 - Ci, often hook shaped, spreading over the sky and usually thickening as a whole
WX_HICLD_5 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous layer
not reaching 45 degrees altitude
WX_HICLD_6 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous layer
exceeding 45 degrees altitude
WX_HICLD_7 - Veil of Cs covering the entire sky
WX_HICLD_8 - Cs not increasing and not covering the entire sky
WX_HICLD_9 - Cc alone or Cc with some Ci or Cs, but the Cc being the main cirriform cloud

Pressure Tendency
WX_TNDCY_0 - rising then falling
WX_TNDCY_1 - rising then steady; or rising, then rising more slowly
WX_TNDCY_2 - rising steadily or unsteadily
WX_TNDCY_3 - falling or steady, then rising; or rising, then rising more quickly
WX_TNDCY_4 - steady, same as 3 hours ago
WX_TNDCY_5 - falling then rising, same or lower than 3 hours ago
WX_TNDCY_6 - falling then steady; or falling, then falling more slowly
WX_TNDCY_7 - falling steadily, or unsteadily
WX_TNDCY_8 - steady or rising, then falling; or falling, then falling more quickly



10/3/13 12:29 PMMcIDAS-V User's Guide

Page 402 of 472http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php

Icing
WX_ICING_0 - No icing
WX_ICING_1 - Trace icing
WX_ICING_2 - Trace to light icing
WX_ICING_3 - Light icing
WX_ICING_4 - Light to moderate icing
WX_ICING_5 - Moderate icing
WX_ICING_6 - Moderate to heavy icing
WX_ICING_7 - Heavy or moderate to severe icing
WX_ICING_8 - Severe icing
WX_ICING_9 - Light superstructure icing
WX_ICING_10 - Heavy superstructure icing

Turbulence
WX_TURBULENCE_0 - No turbulence
WX_TURBULENCE_1 - Light turbulence
WX_TURBULENCE_2 - Light turbulence
WX_TURBULENCE_3 - Light to moderate turbulence
WX_TURBULENCE_4 - Moderate turbulence
WX_TURBULENCE_5 - Moderate to severe turbulence
WX_TURBULENCE_6 - Severe turbulence
WX_TURBULENCE_7 - Extreme turbulence
WX_TURBULENCE_8 - Extreme turbulence

Miscellaneous
WX_MISC_0 - Square (outline)
WX_MISC_1 - Square (filled)
WX_MISC_2 - Circle (outline)
WX_MISC_3 - Circle (filled)
WX_MISC_4 - Triangle (outline)
WX_MISC_5 - Triangle (filled)
WX_MISC_6 - Diamond (outline)
WX_MISC_7 - Diamond (filled)
WX_MISC_8 - Star (outline)
WX_MISC_9 - Star (filled)
WX_MISC_10 - High Pressure (outline)
WX_MISC_11 - Low Pressure (outline)
WX_MISC_12 - High Pressure (filled)
WX_MISC_13 - Low Pressure (filled)
WX_MISC_14 - Plus sign
WX_MISC_15 - Minus sign
WX_MISC_16 - Tropical Storm (NH)
WX_MISC_17 - Hurricane (NH)
WX_MISC_18 - Tropical Storm (SH)
WX_MISC_19 - Hurricane (SH)
WX_MISC_20 - Triangle with antenna
WX_MISC_21 - Mountain obscuration
WX_MISC_22 - Slash
WX_MISC_23 - Storm Center
WX_MISC_24 - Tropical Depression
WX_MISC_25 - Tropical Cyclone
WX_MISC_26 - Flame
WX_MISC_27 - X Cross
WX_MISC_28 - Low pressure with X (outline)
WX_MISC_29 - Low pressure with X (filled)
WX_MISC_30 - Tropical Storm (NH)
WX_MISC_31 - Tropical Storm (SH)
WX_MISC_32 - Volcanic activity
WX_MISC_33 - Blowing spray
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Actions
Below is a list of the actions that can be used in menubars, skins and in the html or qhtml pages.

To use these in an html or qhtml file simply specify a link with the href:

action:the_action_id

e.g.:

action:bundle.open

new.datachooser 
Show data sources window

show.dataselector 
Show field selector window

show.dashboard 
Show Data Explorer

ui.closewindow 
Close Window

new.displaywindow 
New view window

bundle.open 
Open a bundle

bundle.save 
Save bundle

bundle.default.save 
Save as default

bundle.default.open 
Reload default bundle

bundle.default.remove 
Delete default bundle

bundle.favorite.save 
Save as favorite bundle

bundle.favorite.manage 
Manage favorites

plugins.install.file 
Install a plugin from a file

plugins.install.url 
Install a plugin from a url

plugins.manage 
List plugins

plugins.create 
Create plugin

edit.preferences 
Edit user preferences
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edit.formula.create 
Create formula

edit.formula.import 
Import formula

edit.formula.export 
Export formula

edit.jython 
Edit Jython library

edit.colortables 
Edit color tables

edit.stationmodels 
Edit station models

edit.paramaliases 
Edit parameter aliases

edit.projections 
Edit projections

edit.paramdefaults 
Edit parameter defaults

edit.paramgroups 
Edit parameter groups

edit.autodisplays 
Auto-create displays

edit.views.delete 
Delete Saved Views

edit.removedisplays 
Remove all displays

edit.removedisplaysanddata 
Remove all displays and data

view.reloadalldata 
Reload all data sources

edit.removedata 
Remove all data sources

exit 
Exit

idv.stopload 
Stop current loads

capture.all 
Capture All Images

collab.showcapture 
Event Capture

collab.showwindow 
Show Window
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collab.shareall 
Share All State

help.introduction 
Show help

help.showconsole 
Show Console

help.showhelptips 
Show Help Tips

help.showsupportform 
Submit support request

help.showabout 
About...

display.curvedrawer 
Create Drawing Control

display.locationindicator 
Create Location Indicator

display.backgroundimage 
Create Background Image

display.rangeandbearing 
Create Range and Bearing

display.imagemovie 
Create Image Movie Display
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Command Line Arguments
There are a number of command line arguments for McIDAS-V. To view them provide the argument: -help:
mcv -help

-help (prints this message)
-properties <property file>
-installplugin <plugin jar file to install>
-plugin <plugin jar file, directory, url for this run>
-noplugins (do not load any plugins)
-cleardefault (clear the default bundle)
-nodefault (do not read in the default bundle file)
-default <.xidv file>
-bundle <bundle file or url>
-oneinstanceport <port number>
  (check if another version of McIDAS-V is running, and if so, pass command line arguments to it and shut down)
-nopref (do not read in the user preferences)
-userpath <user directory to use>
-sitepath <url path to find site resources>
-nogui (do not show the main window GUI)
-data <data source> (load the data source)
-display <parameter> <display>
-islinteractive (run the ISL file in interactive mode)
-script <Jython script file name> (run the McIDAS-V script in the background)
-image <image file name> (create a jpeg image and then exit)
-movie <movie file name> (create a quicktime movie and then exit)
-imageserver <port number or .properties file> 
  (run McIDAS-V in image generation server mode, and support http requests on the given port)
-Dpropertyname=value (define the property value)
-catalog <url to a chooser catalog>
-connect <collaboration hostname to connect to>
-server (run in collaboration server mode)
-port <port number collaboration server should listen on>
-chooser (show the data chooser on start up)
-printjnlp (print out any embedded bundles from jnlp files)
-setfiles <datasource pattern> <semi-colon delimited list of files> 
  (use the list of files for the bundled datasource)
-currenttime <dttm> (override current time for ISL processing)
-listresources (list out the resource types)
-debug (turn on debug printing)
-debugmessages (turn on language pack debug)
-recordmessages <language pack file to write missing entries>
-trace (print out trace messages)
-traceonly <trace pattern> (print out trace messages that match the pattern)

Specifying data source type
If you load in a data source from the command line using the -data argument, McIDAS-V tries to figure out what type of data it is by looking for
patterns in the file or url you specify. If it cannot determine the type, McIDAS-V will prompt the user for the type.

You can add in a "type:" prefix to the argument that will specify the type with:

mcv -data type:somedatatype:the_file_or_url_to_the_data

For the different values for the "somedatatype", see Data Source Types.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSourceTypes__FILE
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Data Source Types
dods.grid Grids from an OPeNDAP server
opendap.grid Grids from an OPeNDAP server
dods Data from an OPeNDAP server
opendap Data from an OPeNDAP server
adde.image Images from an ADDE server
raob
adde.point Point data from an ADDE server
adde.profiler Wind Profiler Data
file.track Track files
opendap.track Track files
opendap.trajectory Track files
db.point Point data database
db.trajectory Trajectory database
eol.trackdb Eol Track Database
file.sonde Upsonde/Dropsonde files
netcdf.point netCDF Point Data files
netcdf.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
httpserver.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
file.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
aggregated.netcdf.grid Aggregate Grids by Time
file.netcdf netCDF files
file.radar NEXRAD Radar files
opendap.radial OPeNDAP Radar files
file.doraderadar DORADE Radar files
wms WMS image data
kml Google Earth Files KML/KMZ
iser IDV Serialized Data
file.vis5d Vis5D files
file.areafile McIDAS AREA files
file.shapefile Map files
file.mapfile Map files
file.image Image files (gif, jpg, png)
file.dem DEM files
product.adde Weather Text Products (from server)
product.gempak Weather Text Products (from NWX files)
storm.atcf ATCF Tropical Storm Data
file.text Text or HTML files
file.pointtext Text Point Data files
file.pointtracktext Text Point and Trajectory Data files
file.location Locations
file.imagemovie Image Movie Index

file.drawing Drawing files
file.imagexml Image XML files
movie Movies
file.tiff TIFF files
cached Cached data source
file.audio Audio File
file.chatlog Chat Log file
file.addetext Adde Text
text.front Front Bulletins
netcdf.sweep netCDF Radar Sweep files
netcdf.metar netCDF METAR/Synoptic files
file.profiler EOL netCDF Profiler files
file.any I'm Still Feeling Lucky
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Performance Tuning
If you are running into issues with memory consumption or slow response of McIDAS-V, there are several things you can do.

The amount of memory used by McIDAS-V will depend on the size of the datasets you use and the types of displays. Datasets rendered as 2D
depictions (plan views - contours or color shaded displays) use much less memory than 3D displays (isosurfaces, cross sections). Large datasets
(images, dense grids) will use much more memory.

There are several features in McIDAS-V that allow you to more efficiently view large datasets:

Temporal/Spatial Subset of Data
Subsetting the data before display reduces the memory and display time
Memory Allocation
Changing the amount of memory allocated to McIDAS-V
Data Caching
Caching of data uses more memory
Maximum Grid/Image Size
Reducing the maximum size of a display can reduce the memory used
Fast Rendering
Fast Rendering reduces memory and time at the expense of accuracy
Parallel Rendering and Data Reading
Parallel Rendering and Data Reading can reduce data reading and rendering time

Temporal/Spatial Subset of Data
Some data sources allow you to subset the data temporally and spatially. You can set these properties for all fields in a dataset through the
Properties menu of the data source (double click on the Data Source in the Field Selector) or you can set these for individual field using the tabs in
the lower right corner of the Field Selector. For more information, see Data Sources.

Memory Allocation
By default, McIDAS-V allocates 512 megabytes of maximum memory for Java. This is usually the optimum amount for a Windows system with 1
gigabyte of physical memory (RAM). Windows takes up half of that anyway and once Windows has to start swapping, performance severely
degrades. On a Linux system, you can probably get away with 700m for 1 GB of memory as it does a much better job of swapping. All this also
depends on what else you are running on the machine and how much memory those applications use.

If your system has more than 1 GB of memory, increasing the amount available to McIDAS-V can improve performance for displaying large
datasets. You change the amount of memory used by McIDAS-V by editing the Maximum Heap Size in the Advanced tab of the User Preferences
by selected Edit->Preferences from the Main Display window. The new amount of memory will be saved and used in subsequent sessions. Do not
use the maximum amount of memory on your machine as some is needed for the operating system itself. If the system has to use swap memory,
performance will degrade as well. For 32 bit operating systems, it is recommended to set this to no more than 1250 MB (i.e. -Xmx1250m). The
maximum value for 32 bit operating systems is 1536 MB, while 64 bit operating systems can use all of the RAM available. For more information
see Running McIDAS-V.

Data Caching
By default, McIDAS-V caches the data used for a display in memory. If a field is used more than once for several displays, caching the data
prevents an additional reading from of the data from disk or a remote server. If you are only displaying/using a field (i.e. not using it for multiple
displays or calculations), you can keep McIDAS-V from caching it in memory. You can turn off data caching by unchecking the Cache Data in
Memory checkbox on the Formats & Data tab of the User Preferences window (accessible from the Edit->Preferences menu).

Maximum Grid/Image Size
You can also set the maximum size of a grid or image that will be displayed. This will allow you to download a large image or grid, but it will be
re-sampled before displaying if it is larger than the maximum size you have asked for. You can set the maximum image/grid size under the
Formats & Data tab of the User Preferences window (accessible from the Edit->Preferences menu).

Fast Rendering
By default, McIDAS-V will try to adjust the data layer (images, contours, etc.) renderings to account for projection seams. This is computationally
intensive in some cases and slows down the display of data. If you change your User Preferences setting to Use fast rendering, McIDAS-V will
not try to account for the projection seams. If you are displaying a layer of data in its native projection, this will result in faster rendering of the data
depiction. However, if you have several layers of data, each from a different data source and on a different projection, you may see anomalies in
one or more layers (spurious lines, portions of images). If that occurs, you can turn off fast rendering for the layer(s) by unchecking the Use Fast
Rendering checkbox in its Properties dialog, or set your system preference back to not use fast rendering.

A separate fast rendering option for map layers is available in the Map Controls. Some maps display better when fast rendering is turned on, others
display better when it's turned off. If a map displays poorly (e.g., has missing line segments), try switching its fast rendering settings to see if it fixes

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__subset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__heap
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__cache
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__maxsize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__fastrender
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PerformanceTuning__parallelrender
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataSource__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Starting__run
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FormatPreferences__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FormatPreferences__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GeneralPreferences__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PropertiesDialog__properties
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_MapDisplayControl__FILE
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the problem.

Parallel Rendering and Data Reading
If you are running McIDAS-V on a multi-core machine you can configure it to render individual time steps in parallel. You can also do remote data
reads in parallel. This typically results in a 50% reduction in overall data reading and rendering time.

There are 2 preferences in the User Preference's Advanced tab. One is the number of threads used for rendering. This defaults to the number of
processors on your machine. The second is the number of threads used for data reading. This defaults to 4.

For rendering McIDAS-V will render each time step in parallel. Note: Since the rendering processes can allocate temporary memory, it is possible
to exhaust the available memory if too many threads are running concurrently. Linear speedup with the number of cores available for rendering
(probably due to memory contention issues) is not seen, however a 40%-50% performance improvement is seen for complex rendering tasks (e.g.,
contouring).

The second preference is used when reading individual time steps of data from remote ADDE and OpenDAP servers. This parallelization takes
advantage of the multiple cores available on the remote server and somewhat the available bandwidth on the network. A linear speed up in
accessing remote data based on the number of cores on the remote server (ADDE or OpenDAP) has been seen. However, if you load the server too
much your performance

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AdvancedPreferences__FILE
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Building McIDAS-V from Source
Developers can download the source files for McIDAS-V and build it from scratch.

Before building McIDAS-V you need to first install Java and Java 3D on your system. You need to use the Java SDK, because the Java RunTime
Environment (JRE) does not contain the Java compiler (javac). You need to use a version of Java 1.6 or above. You can use either the Java 3D SDK
or JRE, version 1.3.x.

You will also need to install Ant 1.7 (http://ant.apache.org/) on your machine. Ant is similar to make - instead of a Makefile, Ant uses a
build.xml file. Be sure to follow the instructions for installing Ant, especially those for setting up environment variables.

Build steps:

1. Download the compressed source files from the McIDAS-V Download Page.
2. Uncompress the .zip file. This will create a new directory containing the McIDAS-V source and Unidata IDV .jar files.

The resulting directory structure will be:

mc-v/ mc-v/build.xml mc-v/... <-- McIDAS-V source directories idv/ idv/lib <-- Unidata IDV
.jar files

The Ant build script "mc-v/build.xml" is be used to build and run McIDAS-V.
3. Change to the mc-v directory and run:

"ant jar" to create the McIDAS-V .jar files in mc-v/dist.
"ant run" to run McIDAS-V with a small java heap size for testing.

http://ant.apache.org/
http://www.ssec.wisc.edu/mcidas/software/v/download.html
http://www.unidata.ucar.edu/software/idv
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Message Console
Clicking on the main menu bar choice Help->Show Console in the Main Display window shows a Console window which has error messages and
other text output from McIDAS-V. Error messages created before you open the console are shown, as well as later ones.

Image 1: Message Console Window

Properties

 - Clears the Console of all messages.

 - Allows you to save your Console messages in the Log files (*.log) format.

The console is useful if you encounter an error as you can save the console message to a file and include it in email to McIDAS-V Support at SSEC
or attach it in the Support Request Form.
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Support Request Form
Clicking on the main menu bar choice Help->Show Support Request Form in the Main Display window opens a Request McIDAS-V Support
window to post a support request to the McIDAS Help Desk. This form can also be brought up from the Support Form button of an Error dialog.

Image 1: Support Request Form

Properties

Name - Represents your name.

Your Email - Represents your email.

Confirm Email - Confirms your email address was entered correctly the first time

Organization - Represents your organization.

Subject - Represents the subject of the problem or request.

Description - Represents a thorough description of the problem or request. Please provide a thorough description of the problem you
encountered, as well as the steps you took to produce the problem.

Attachment - Allows for any attachments to be sent along with the request. Hit  to find your file.

Include current state as a bundle - Includes a bundle of your current session along with your support request to the McIDAS-V Support
Team. This helps to determine what the problem may be.

Send copy of support request to me - Sends a copy of the email you are sending to McIDAS-V Support to the email address provided under
Your Email.

 - Opens the McIDAS-V User's Guide to this page.

 - Cancels the request and closes the Request McIDAS-V Support window without sending a request.

 - Sends your request to the McIDAS-V Support Team.
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Appendices
Examples of Display Types
FAQ - Frequently Asked Questions
McIDAS-X Commands in McIDAS-V

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_examples__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Faq__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_xequivalent__FILE
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Examples of Display Types
Plan Views
3D Surface
Cross Sections
Probes
Hovmoller Display
Imagery
Radar - Level II WSR-88D Data Displays
Soundings
Profiler Winds
Flow Displays
Observations
Miscellaneous Display Types

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_3DSurface__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CrossSections__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Probes__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hovmoller__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Imagery__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Soundings__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Observations__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__FILE
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Plan Views
A plan view is a flat, horizontal display of 2D data, or a horizontal cross section of 3D data. More simply, a plan view is a view from the top. These
plan views are represented by contour lines used to display a parameter overlaying a base map. McIDAS-V offers the ability to shade or fill the
spaces between the contour lines of the plan view display for further customization.

Contour Plan View
Color-Filled Contour Plan View
Color-Shaded Contour Plan View
Value Plots
Contour Plan View for Ensembles

Contour Plan View

Image 1: Contour Plan View Display

Color-Filled Contour Plan View

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__contourplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__colorfilledplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__colorshadedplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__valueplots
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViews__ensemble
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Image 2: Color-Filled Contour Plan View Display

Color-Shaded Contour Plan View

Image 3: Color-Shaded Contour Plan View Display Overlaid with a Contour Plan View Display

Value Plots
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Image 4: Value Plots Display

Contour Plan View for Ensembles

Image 5: Contour Plan View Display for Ensembles

Plan views can be displayed in several ways:

with solid or dashed contour lines
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with contour lines colored by value

with color-filled contours

with "color-shaded" images (all data grid cells colored by value, which may be smoothed)

with value plots

Colors help distinguish values and subtle features, and if used carefully can be an intuitive indication of value and trend, such as using "hot" colors
for higher or important values.

All of these displays display in the Main Display window, with their controls in the Layer Controls tab of the Data Explorer. For more information
about the controls for the Plan Views, see Plan View Controls. For more information about the Value Plot display, see Value Plot Controls. For
more information about the Ensemble Contour Plan View display, see Ensemble Grid Controls.

A McIDAS-V 3D Plan View can be set to any of the data levels in the data source, or between data levels, in which case interpolation is used to
estimate the data values in the plan view. A colored square selector point in the left corner of the 3D plan view can be moved up and down by
dragging the mouse button to re-position the level. You can make several 3D plan views at the same time for one or more parameters in 3D data. To
learn how to make a display, see Displaying Gridded Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_PlanViewControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ValuePlotControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_EnsembleGridControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__FILE
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3D Surface
Isosurface
Topography
2D Data Draped Over Topography

Isosurface
An isosurface is a surface of a single value in a 3D parameter field. Isosurfaces are the 3D analog of a single-valued contour line in a 2D plot. The
intersection of an isosurface and a plane is a contour line of the same value. Isosurfaces may form closed surfaces enclosing regions of higher or
lower value, but not always.

 
Image 1: 3D Surface Isosurface Display

McIDAS-V also supports isosurface displays that are colored from another parameter, not the parameter used to make the shape of the surface. The
example here shows an isosurface of 89% relative humidity over North America colored by air temperature. A useful plot is to color isosurfaces by
height (geopotential height) to show height of features by color.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_3DSurface__isosurface
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_3DSurface__topography
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_3DSurface__2dtopo
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Image 2: 3D Surface Isosurface Display Colored by Another Parameter.

All Isosurface displays display in the Main Display window, and their controls are in the Layer Controls tab of the Data Explorer. For more
information about isosurface controls, see 3D Surface Controls.

Topography
For data sources that include topography or terrain data, such as the "terrain" parameter in NAM and RUC model output or DEM data, McIDAS-V
can display a 3D relief map. Select "Topography" for the display type.

Image 3: 3D Topography Display of DEM Data

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ThreeDSurfaceControl__FILE
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Image 4: 3D Topography Display of GFS Model Terrain Data

Image 5: 3D Surface Contours Over Topography Display
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Image 6: 3D Surface Color-Filled Contours Over Topography Display

Image 7: 3D Surface Color-Shaded Contours Over Topography Display
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Image 8: 3D Surface Color-Shaded Parameter As Topography Display

Image 9: 3D Surface Contoured Parameter as Topography Display
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Image 10: 3D Surface Color-Filled Contoured Parameter as Topography Display

2D Data Draped Over Topography
Two dimensional grid data can be draped over a topography field to provide a terrain following representation of the data.

 
Image 11: Color-Filled Contours Over Topography Display Overlaid with the Contours Over Topography Display

All topography displays display in the Main Display window, and their controls are in the Layer Controls tab of the Data Explorer. For more
information about the the controls for these displays see 3D Surface Controls and Topography Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ThreeDSurfaceControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TopographyControl__FILE
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For more information see Displaying Gridded Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Grids__FILE
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Cross Sections
A cross section is a horizontal or vertical slice through a 3D space. This type of display can be useful to determine the vertical profile of a parameter
over a specific region, or the profile of a parameter at a constant elevation level throughout the entire area. The Cross Sections display is available
for 3D fields. The 3D derived parameter 'Relative Humidity (from Temperature & mixingratio)' was used to create the below examples.

Contour Cross Section
Color-Filled Contour Cross Section
Color-Shaded Contour Cross Section

Contour Cross Section

Image 1: Contour Cross Section Display

Color-Filled Contour Cross Section

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CrossSections__contourcross
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CrossSections__colorfilledcross
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CrossSections__colorshadedcross
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Image 2: Color-Filled Contour Cross Section Display

Color-Shaded Contour Cross Section

Image 3: Color-Shaded Cross Section Display

You can adjust the end points of the cross section by left-clicking and dragging them in the Main Display window. A duplicate of the displays made
in the Main Display window will be drawn in the Layer Controls tab of the Data Explorer, where you can also modify different characteristics of
the display. For more information about cross section controls, see Vertical Cross Section Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_CrossSectionControl__FILE
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Probes
Vertical Profile Display
Data Probe/Time Series Display
Time/Height Display

Vertical Profile Display
The Vertical Profile display is an available display type for 3D model data that plots the value of any number of fields versus altitude. For more
information on this display type, see Vertical Profile Controls.

Image 1: Vertical Profile Display

Data Probe/Time Series Display
The Data Probe/Time Series display plots in the Layer Controls tab of the Data Explorer, and plots a line that represents the numerical value of the
parameter (Y-axis) at a given time (X-axis). You can change the location of the probe in the Main Display window by left-clicking and dragging it.
See Data Probe/Time Series for more information on this display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Probes__verticalprofile
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Probes__dataprobe
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Probes__timeheight
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfileControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProbeControl__FILE
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Image 2: Data Probe/Time Series Display

Time/Height Display
A Time/Height display plots a field's value in the vertical through the progression of time, with altitude on the Y-axis, and time along the X-axis.
This can be a Contour or Color-Shaded display. For more information on this display type, see Time/Height Controls.

Image 3: Time/Height Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_TimeHeightControl__FILE
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Hovmoller Display
The Hovmoller display plots grid and gridded point data in a diagram with the Latitude/Longitude component on the X-axis, and the time
component on the Y-axis. You can display the data with respect to either Latitude or Longitude, and as a Color Shaded or Contour view.

Color Shaded Display
Contour Display

Color Shaded Display

Image 1: Color Shaded Display

Contour Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hovmoller__shaded
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Hovmoller__contour
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Image 2: Contour Display

For more information about the Hovmoller Display, see Hovmoller Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_HovmollerControl__FILE
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Imagery
Satellite Imagery Display
Level III Radar Display

Satellite Imagery Display

 
Image 1: Image Display of a GOES Visible Satellite Image

Extensive satellite image data are available from both local files and remote ADDE servers. For more information see Displaying Satellite Imagery.

Level III Radar Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Imagery__image1
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Imagery__image2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Satellite__FILE
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Image 2: Image Display of a Level III Base Reflectivity Radar Image

For more information see Displaying Level III Radar Imagery.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelIII__FILE
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Radar - Level II WSR-88D Data Displays
McIDAS-V can read and use WSR-88D Level II data, including reflectivity, radial velocity, and spectrum width, and display it in several ways.

Radar Sweep View
RHI
Radar Cross Section
CAPPI
Volume Scan
Radar Isosurface

Radar Sweep View

Image 1: Radar Sweep View in 2D Display

The Radar Sweep View in 2D display appears in the Main Display window. The display depicts radar data at a variety of different elevation angles.
For more information, see Radar Sweep View Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__sweep
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__rhi
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__crosssection
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__cappi
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__volume
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Radar__isosurface
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarSweepControl__FILE
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Image 2: Radar Sweep View in 3D Display

The Radar Sweep View in 3D display appears in the Main Display window. The display depicts 3D radar data at a variety of different elevation
angles. For more information, see Radar Sweep View Controls.

RHI

Image 3: RHI Display in the Main Display window

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarSweepControl__FILE
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Image 4: RHI Display in the Layer Controls Tab

The RHI (Range-Height Indicator) display appears in the Main Display window and as a 2D plot in the Layer Controls tab. The display is a cross
section of radar data, with one end point at the location of the radar and the other set by the user. In the chart, distance along transect is on the X-
axis, and altitude is on the Y-axis. For more information, see Radar RHI Display Controls.

Radar Cross Section

Image 5: Radar Cross Section Display in the Main Display Window

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarRhiDisplayControls__FILE
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Image 6: Radar Cross Section Display in the Layer Controls Tab

The Radar Cross Section display appears in the Main Display window and as a 2D plot in the Layer Controls tab. The display is a cross section of
radar data, with distance along transect on the X-axis, and altitude in the Y-axis. For this display, you have the ability to change the position both
end points of the transect line. For more information, see Radar Cross Section Controls.

CAPPI

Image 7: CAPPI Display

The CAPPI (Constant Altitude Plan Position Indicator) display appears in the Main Display window. The display depicts radar data at a constant
altitude around the Radar site. For more information, see Radar CAPPI Display Controls.

Volume Scan

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarCrossSectionControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarCappiDisplayControls__FILE
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Image 8: Volume Scan Display

The Volume Scan Display appears in the Main Display window. This display depicts various elevation angles at once. For more information, see
Radar Volume Scan Controls.

Radar Isosurface

Image 9: Radar Isosurface Display

The Radar Isosurface display displays radar data at the user-specified reflectivity value. For more information, please see Radar Isosurface
Controls.

For more information see Displaying Level II Radar Imagery.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarVolumeControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarIsosurfaceControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_RadarLevelII__FILE
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Soundings
The meteorological sounding display is available with a choice of thermodynamic diagrams (Skew-T, Stuve and Emagram), with a table of related
aerological parameters.

Skew-T
Stuve
Emagram

Skew-T

Image 1: Skew-T Display

Stuve

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Soundings__skewt
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Soundings__stuve
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Soundings__emagram
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Image 2: Stuve Display

Emagram
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Image 3: Emagram Display

A sounding diagram can be made for any point inside a data grid of numerical weather prediction model output with temperature and humidity (the
dew-point temperature is computed by Unidata code from temperature and relative humidity grids), or from balloon soundings (RAOBs). The
sounding display and its table and controls appear in a separate window. To learn more about the aerological displays see Sounding Display
Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_AerologicalSoundingControl__FILE
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Profiler Winds
McIDAS-V Profiler Time/Height plot shows wind data from any of the NOAA National Profiler Network stations. You can choose hourly, 30
minute, 12 minute, or 6 minute data.

Time/Height Display
Profiler Station Plot
3D View

Time/Height Display

 
Image 1: Time/Height Display

The Time/Height display displays in the Layer Controls tab of the Data Explorer. For more information on the controls for this display, see
Profiler Time/Height Controls.

Profiler Station Plot

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__timeheight
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__profiler
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Profiler__3dview
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerTimeHeightControl__FILE
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Image 2: Profiler Station Plot Display

The Profiler Station Plot display displays in the Main Display window, and its controls are in the Layer Controls tab of the Data Explorer. For
more information about the controls for this display, see Profiler Station Plot Controls.

3D View

Image 3: 3D View Display

The 3D View display displays in the Main Display window, and its controls are in the Layer Controls tab of the Data Explorer. For more
information about the controls for this display, see Profiler 3D Multi-Station Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerStationPlotControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_ProfilerMultiStationControl3D__FILE
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Flow Displays
For parameters with a vector nature such as wind, vector and streamline displays of flow are available.

Vector Plan View
Streamline Plan View
Wind Barb Plan View
Vector Cross Section
Wind Barb Cross Section

Vector Plan View

Image 1: Vector Plan View Display

Streamline Plan View

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__vectorplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__streamlineplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__windbarbplan
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__vectorcrosssection
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowDisplays__windbarbcrosssection
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Image 2: Streamline Plan View Display

Wind Barb Plan View

 
Image 3: Wind Barb Plan View Display

Vector Cross Section
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Image 4: Vector Cross Section Display in the Main Display Window

Image 5: Vector Cross Section Display in the Layer Controls Tab

Wind Barb Cross Section
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Image 6: Wind Barb Cross Section Display in the Main Display Window

Image 7: Wind Barb Cross Section Display in the Layer Controls Tab

For more information see Flow Display Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FlowPlanViewControl__FILE
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Observations
Point Data Displays
Track Displays
Front Positions

Point Data Displays
You can make plots of point data such as meteorological surface (METAR) and synoptic surface weather station observations.

Image 1: Point Data Plot

For more information see Displaying Surface and Upper Air Point Data . You can change the plot layout with the Station Model Editor.

You can plot non-meteorological point data as well. The image below depicts the locations of earthquakes, sized by magnitude and colored by
depth. Earthquake data can be obtained from the U.S. Geological Survey (USGS) in Google Earth (KMZ) format and can be loaded into McIDAS-
V in the General->Files/Directories Chooser with the Data Type of "Google Earth Files KML/KMZ". Using the Station Model Editor, you can
specify how your data will be displayed in the Main Display window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Observations__obs
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Observations__track
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Observations__frontpositions
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Point__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_StationModelEditor__FILE
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Image 2: Locations Display

Track Displays
Aircraft and drifting buoy tracks can be plotted to show the path of the sensor. You can also plot the track data as observations along the track. The
track path is brought into McIDAS-V through the General->Files/Directories Chooser with the Data Type of "Text Point and Trajectory Data files".
The Flythrough feature is invoked in the Main Display Window through the View->Flythrough menu item. You can set the Flythrough to follow
the track path by creating and importing an XML file with location (latitude, longitude, and altitude) data via File->Import in the Flythrough
window.

 
Image 3: Track Colored by Parameter Display with a Flythrough

Front Positions
Via ADDE, McIDAS-V has the ability to plot a frontal analysis or a forecast of frontal positions. You can create these displays by selecting Front
Positions in the Data Sources tab of the Data Explorer. For more information about this feature, see Displaying Fronts and Front Controls.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FileChooser__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DisplayMenus__flythrough
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Fronts__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_FrontControl__FILE
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Image 4: Front Positions
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Miscellaneous Display Types
Globe Display
Multi-Panel Display
Data Transect Display
Grid Table Display
Omni Display

Globe Display

 
Image 1: The Globe Display

The illustration shows a McIDAS-V globe display of the earth, with AVN numerical weather prediction model output of mean sea level pressure
(as color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet streams. The upper vertical scale is set to 32,000.

For more about this display and how to make it, see Using the Globe Display.

Multi-Panel Display
You can create multi-panel map and globe displays through the File->New Display Tab (Window)->Map (Globe) Display-># panel(s) menu.
Below is an example of a four panel display of storms over Mississippi and the Gulf of Mexico. The first panel is radar reflectivity from central and
southern Mississippi. Panel two is a Goes East visible satellite image. Panel three contains point data metars over the Gulf coast region. Panel four
is a Goes East IR satellite image, with an enhancement for temperature.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__globedisplay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__multipanel
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__transect
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__gridtable
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Miscellaneous__omnidisplay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_Globe__FILE
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Image 2: Four Panel Map Display

Data Transect Display
The Data Transect display plots in the Layer Controls tab of the Data Explorer, and plots a line of data at a constant height. The X-axis of the plot
represents distance, and the Y-axis represents the numerical value of the parameter you are plotting. In the Main Display window, you can drag the
end points of the transect line, to move the transect to your desired location. See Data Transect Controls for more information on this display.

Image 3: Data Transect Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_DataTransectControl__FILE
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Grid Table Display
The Grid Table display plots in the Layer Controls tab of the Data Explorer, and plots a chart of the numerical value of the field you are displaying
at individual latitudes, longitudes, and altitudes (if available). See Grid Table Controls for more information on this display.

Image 4: Grid Table Display

Omni Display
The Omni display is a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to create a
display where you have complete control over which coordinates are the axes, how it is colored, and so on. See more in the Omni Control.

For use of the Spread Sheet, see the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

Image 5: Omni Control Display

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GridTable__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_OmniControl__FILE
http://www.ssec.wisc.edu/~curtis/ss.html
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FAQ - Frequently Asked Questions
This section contains a list of questions commonly asked by users. The questions are organized by categories. You can find the answer to each
question by clicking on the question, or the category that the question is in.

General
What is McIDAS-V?

Is McIDAS-V still under development?

Using McIDAS-V
What do I do if McIDAS-V will not work on my computer?

Where are the McIDAS-V files stored on my computer?

How can I tell if McIDAS-V is busy doing something?

How can I save a display?

How can I change the start-up settings?

How can I change the amount of memory available to McIDAS-V?

How can I reset the map projections?

How can I set the default projection?

How can I change the color table range of a displayed parameter?

When I set a color table transparent, why doesn't it show up that way?

When I load an image, why is it displayed with fewer colors than I expect?

When I load an image, why does it appear pixelated (blocky)?

Data
What is Fast Rendering and when should I use it?

What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

Why do I get an error when I try to load radar data that I downloaded from NCDC?

When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

How are grids resampled in McIDAS-V?

Why can't I create a time series from single time grids?

How do I create a time series from individual grid files with different time steps?

What are the wind speed thresholds for different wind barbs?

Video Cards
Do I need a special video card to run McIDAS-V?

Why does the display go gray or get corrupted when I resize my McIDAS-V display?

If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

Common Installation Errors

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GeneralFaq__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GeneralFaq__whatis
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_GeneralFaq__mcvfuture
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__basicchecks
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__filelocations
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__busy
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__savedisplay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__changestart
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__memory
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__projections
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/1.4/combine_all.php#TARGET_UsingMcVFaq__defaultprojection
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How do I get around a security error when installing McIDAS-V on my 10.8 OSX machine?

What do I do if I am told to upgrade JDK when installing McIDAS-V?

How do I solve write permissions errors on OSX?

How do I solve shortcut permissions errors on OSX?

Why am I am seeing a "Canvas3D: Non-recoverable graphics configuration error" when installing on my Windows 7 64-bit machine?

Common Run-Time Errors
What do I do if I get a 'Could not create a graphics configuration' error?

What do I do if I get 'JAVA 3D Error: GLX extension is not supported' and 'Could not create a graphics configuration' errors?

What do I do if I see 'Connection refused' or 'No public datasets found' errors when connecting to the listed data servers?

Why am I having drawing problems on Monitor2 of a two-monitor system?

Why is there no map drawn in the McIDAS-V Main Display window?

How do I fix the spurious map lines in my Main Display window?

Why do my images display blank (black or white) when there should be valid data?

Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V under
Linux?

Reporting Problems
What kind of support is provided for McIDAS-V?

How do I report problems?

How do I open the Error Logs Console?

What do I do if McIDAS-V is locked up and not responding?
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General FAQ
Q. What is McIDAS-V?

A. McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in the Space Science and
Engineering Center's (SSEC) 40 year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including
hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful
mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables
McIDAS-X users to run their commands and tasks in the McIDAS-V environment, and an integrated version of SSEC's HYDRA software
package.

Q. Is McIDAS-V still under development?

A. Development of McIDAS-V is ongoing at SSEC and as it progresses new features will be added and any problems/bugs will be fixed. The
development will be driven by the needs of the community of users. Suggestions, comments and collaboration are welcomed and encouraged.
The goal is to provide new and innovative ways of displaying and analyzing data, as well as provide the common displays that many users have
come to expect.

http://www.ssec.wisc.edu/
http://www.ssec.wisc.edu/hydra/
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Using McIDAS-V FAQ
Q. What do I do if McIDAS-V will not work on my computer?

A. Listed below is a basic checklist of steps to follow if your McIDAS-V is not working properly. Once you successfully complete each step in
the process, restart McIDAS-V and try again. If the problem still exists, proceed to the next step, and so on.

1. Make sure that your drivers are up to date. Please see the Graphics Cards and Drivers section of the System Requirements page for
more information.

2. Try downloading this Java3D example to see if you can view it. Please see the Java Versions section of the System Requirements page
for more information. If this example does not work, then your system does not support Java3D.
Note: If your system does not support Java3D version 1.3.1+ McIDAS-V will not work for you.

3. Set a small heap size by setting the Memory option to 512 megabytes in the User Preferences window's Advanced tab. If this resolves the
issue, you can start increasing the memory until the problem appears again. Stay below the memory value that produces the problem.

4. Disable Java Access to Image Data by Reference by unchecking Enable access to image data by reference option in the User Preferences
window's Advanced tab.

5. If you are on a Windows computer, use Direct3D by checking the Enable Direct3D option in the User Preferences window's Advanced
tab.

6. Rename your McIDAS-V document directory to start with a clean set of options. This will undo the changes made in steps 3-5 listed
above, but it will eliminate any corrupt startup bundles or settings.

7. Repeat steps 3-5 with a clean slate.

Q. Where are the McIDAS-V files stored on my computer?

A. McIDAS-V files are divided into two categories: "system files" (supplied files that should not be edited) and "user files" (new user-created
files and supplied ones that contain user settings and preferences). By default, the system files are stored in a directory named McIDAS-V-
System, and the user files are stored in a directory named McIDAS-V. The system file directory can be changed during installation and its
location defaults to the OS application directory (e.g., C:\Program Files on Windows, /Applications on OS X). The user file directory is
created in the user's document directory (e.g., C:\Documents and Settings\user\ on Windows, /Users/user/Documents on OS X, /home/user
on Linux).

Q. How can I tell if McIDAS-V is busy doing something?

A. The lower right corner of the Main Display window shows a box with progress bars if McIDAS-V is busy making a display or doing
anything. In the status bar at the bottom, messages will appear when McIDAS-V is reading data from a server or disk. Also, while the displays
are being created, there is usually a "please wait" notice in the lower left corner of the main display. When McIDAS-V is in the middle of a
process in the Data Explorer window, the cursor will change to a spinning, blue ring.

Q. How can I save a display?

A. McIDAS-V supports JPEG, PNG, and GIF image formats. McIDAS-V can also write out an image and the corresponding Google Earth KML
or KMZ files. Animations can be captured as QuickTime movies or animated GIFs. See Image Captures for more information. You can save a
particular McIDAS-V state with all displays, data sources, maps, etc. by saving the data as a bundle. You can also save a bundle as a favorite.

Q. How can I change the start-up settings?

A. You can customize many of the McIDAS-V properties through the User Preferences window, accessed through the Edit->Preferences menu
item in the Main Display window. This allows you to configure the many features of McIDAS-V.

You can set a bundle to open by default when you start McIDAS-V. To do this, save a bundle as a favorite and set it as your default bundle in
the Defaults panel of the Advanced tab of the User Preferences window.

You can also set the locations of the Main Display window and the Data Explorer window, as well as the number of tabs and panels. To do this,
save a default layout via the File->Default Layout menu item in the Main Display window.

Q. How can I change the amount of memory available to McIDAS-V?

A. You can change the amount of memory used by McIDAS-V by editing the Memory in the Advanced tab of the User Preferences window by
selecting Edit->Preferences... from the Main Display window. See Running McIDAS-V for more information.

Q. How can I reset the map projections?
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A. This can be controlled with the Projections->Auto-set Projection menu check-box. You can switch an existing display to its native data set
projection using the display control's View->Use Data Projection menu.

Q. How can I set the default projection?

A. The default projection is set with the Default Projection field in the Display Window tab of the User Preferences window. This window is
accessed via the Edit->Preferences menu item in the Main Display. If you do not want to use any of the native projections of McIDAS-V, you
can create your own projections with the Projection Manager which is accessed from the Projections->New/Edit menu item in the Main
Display window. The default projection is overridden by the projection saved in the default bundle, or by displaying new data, if the
Projections->Auto-Set Projection menu checkbox is checked on. As a result, you may never see the default map projection unless your default
bundle has the default projection, and you have the checkbox checked off. Choosing a default map projection is not necessary to use of
McIDAS-V, it is just a feature to allow for further user-customization of their sessions.

Q. How can I change the color table range of a displayed parameter?

A. You can change the range for a display parameter in the Color Table Editor. This can be accessed in the Layer Controls tab of the Data
Explorer by clicking the button next to Color Table, or by right-clicking on the color bar in the Legend of the Main Display window and
selecting Edit Color Table. The range of the color table can be changed next to the Range button in the Color Table Editor. Alternatively, you
can change the range outside of the Color Table Editor by right clicking on the color bar in the Legend of the Main Display window and
selecting Change Range..., which opens a Change Range window where you can enter new values. If you always want to use a specific data
range for a parameter, you can create a user parameter default so the range you desire will always be used when displaying the parameter. This
can be done through the Tools->Parameters->Defaults menu item in the Main Display window to get to the Parameter Defaults Editor.

Q. When I set a color table transparent, why doesn't it show up that way?

A. Using transparency in a color display may give unexpected results. In general, only the last thing added can be fully transparent. If you have a
display that is transparent, then add in a new display, you may not see it. You can use the display control's View->Bring to Front menu to
remove and re-add the display that you want to be transparent so it is last.

Q. When I load an image, why is it displayed with fewer colors than I expect?

A. First, check that your display configuration is set to the maximum number of colors (e.g., 32 bit) so that McIDAS-V is able to display
imagery and color tables using a full range of colors. If that is set correctly, it's possible that the range of values defined for the color table is less
than the range of values in the displayed image. You can view or modify the range of values defined for the color table by right-clicking on the
color bar in the Legend of the Main Display window and selecting either Change Range... or Edit Color Table. Right-clicking also displays
other options that let you apply a different color table or edit the current one. If you created a contour display, you may also need to lower the
Contour Interval in the Contour Properties Editor.

Q. When I load an image, why does it appear pixelated (blocky)?

A. A displayed image can appear pixelated (blocky) due to one or more factors, including the resolution of the displayed image, the
magnification and pixel sampling factors at which it was displayed, and the zoom factor.

For example, if you display an 8 km resolution image while zoomed in to a small geographic region such that each display pixel represents a
higher resolution value (e.g., 1 km2 of the earth surface) the image pixels need to be duplicated to fill the display and thus the image will appear
pixelated. The same effect will occur with any image if you zoom in (using the Zoom/Pan Toolbar buttons or other zooming actions) to where
the display resolution is higher than the image resolution.

If you believe that the displayed image is more pixelated than it should be for its given resolution, check the settings of the Magnification sliders
in the Field Selector's Advanced tab and the Pixel Sampling slider in the Layer Controls tab. In order to display the image at the highest
possible resolution (its native resolution), the line and element magnifications must be set to 1 (sliders all the way to the right) and the pixel
sampling set to 0 (slider all the way to the left).
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Data FAQ
Q. What is Fast Rendering and when should I use it?

A. By default, McIDAS-V will try to adjust the data layer (images, contours, etc.) renderings to account for projection seams. This is
computationally intensive in some cases and slows down the display of data. If you change your User Preferences setting to Use fast rendering,
McIDAS-V will not try to account for the projection seams. You can turn on/off Fast Rendering for individual displays in their Properties
dialogs.

Q. What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

A. McIDAS-V displays pressure surfaces by converting the pressure to a height in some reference system. There are two reference systems that
come standard with McIDAS-V - the U.S. Standard Atmosphere and Vis5D. The U.S. Standard Atmosphere only computes has conversions for
pressures up to about 80 km. The Vis5D coordinate system uses a logarithmic conversion:

P = 1012.5 * e^( H / -7.2 ) (^ denotes exponentiation) H = -7.2 * Ln( P / 1012.5 ) (Ln denotes
natural log)

so it can be used for heights above 80 km.

Q. Why do I get an error when I try to load radar data that I downloaded from NCDC?

A. There are few common problems that can cause this:

1. The files are in a compressed tar file - Typically, when you download Level II data from NCDC, the files are in a compressed TAR file
which holds the individual volume scans. You need to extract the volumes from the TAR file with utilities like tar, gunzip, WinZip into a
directory.

2. You are using the Files chooser - You should load the radar data using the Radar->Level II->Local file chooser in the Data Sources
tab of the Data Explorer, not the General->Files chooser. In some cases, the files do not have any location information in them. The Level
II data chooser allows you to associate a station location with the data file, using the directory name as a first guess.

3. You are trying to load Level III raster products - McIDAS-V only handles the Level III data that is stored in radial format (Base
Reflectivity, Storm Relative Velocity, Base Velocity, 1 and 3 hour precipitation, Echo Tops).

Q. When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

A. For McIDAS-V to read in GRIB data, it needs access to lookup tables for decoding the information in the data. McIDAS-V comes pre-
configured with most of the commonly used tables from NCEP, FNMOC, etc, but some GRIB data from regional centers may use tables other
than the defaults. If McIDAS-V does not have the necessary table, you will get the NotSupportedException. You can add in new tables by
following the instructions in the User's Guide section on Adding in new GRIB tables.

Q. How are grids resampled in McIDAS-V?

A. McIDAS-V uses two methods for resampling data - weighted average and nearest neighbor. These are the default sampling modes for
VisAD, which McIDAS-V is based on. For any grid, the samples are organized in a topology, which may be triangles (Irregular2D), squares
(Gridded2D), tetrahedra (Irregular3D) or cubes (Gridded3D). For target points the system finds which topology element contains the target. For
nearest neighbor, it gets the values at the vertex of that containing topology element closest to the target point. For weighted average, it
computes a weighted average of all vertices of that containing topology element, where the weights are bilinear in 2D and trilinear in 3D.
(source: Bill Hibbard, SSEC)

Q. Why can't I create a time series from single time grid files?

A. If you receive an error message similar to the following:

An error has occurred: Creating display: Color-Shaded Plan View org.python.core.PyException
visad.UnitException: visad.UnitException: Set: units dimension 1 does not match Domain dimension
2

the files may not have a "time" dimension defined in them. It is recommended that you use the NetCDF Markup Language (NcML) to aggregate
the files. See http://www.unidata.ucar.edu/software/netcdf/ncml/v2.2/Aggregation.html for more information on aggregating files.
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Q. How do I create a time series from individual grid files with different time steps?

A. If you have individual files of gridded data for multiple time steps that you want to display as a single layer to utilize the Time Animation
Widget, there are two methods of doing this. First, in the Data Sources tab of the Data Explorer, navigate to the Gridded Data->Local or the
General Files/Directories chooser. Select the Aggregate Grids by Time Data Type, navigate to the directory where your files are stored, and
use Shift+click to select the files you wish to include in your layer. In the Field Selector, you will see that all of the times you selected for the
data are grouped together. You can select your display type, create the display, and all of the data times will be loaded in as one layer and you
can animate through them.

Alternatively, you can add all of the files individually through the Gridded Data->Local or General->Files/Directories chooser (without
the Aggregate Grids by Time Data Type) and use the Make a time sequence from single time grids/images formula. This is a native formula of
McIDAS-V that can be found under the Miscellaneous tree of formulas in the Field Selector. Using this formula, you can select all of the
individual files, and McIDAS-V will add all of them to the Main Display window as a single layer you can animate through time.

Q. What are the wind speed thresholds for different wind barbs?

A. Below is a table that shows different wind speed thresholds when it comes to plotting wind barbs of gridded or point data.  In this table, 'x'
represents wind speed in knots.
Wind Barb Knots Wind Barb Knots

x = 0 52.6 ≤ x ≤ 57.5
0 < x ≤ 2.5 57.6 ≤ x ≤ 62.5
2.6 ≤ x ≤ 7.5 62.6 ≤ x ≤ 67.5
7.6 ≤ x ≤ 12.5 67.6 ≤ x ≤ 72.5
12.6 ≤ x ≤ 17.5 72.6 ≤ x ≤ 77.5
17.6 ≤ x ≤ 22.5 77.6 ≤ x ≤ 82.5
22.6 ≤ x ≤ 27.5 82.6 ≤ x ≤ 87.5
27.6 ≤ x ≤ 32.5 87.6 ≤ x ≤ 92.5
32.6 ≤ x ≤ 37.5 92.6 ≤ x ≤ 97.5
37.6 ≤ x ≤ 42.5 97.6 ≤ x ≤ 102.5
42.6 ≤ x ≤ 47.5 102.6 ≤ x ≤ 107.5
47.6 ≤ x ≤ 52.5 107.6 ≤ x ≤ 112.5
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Video Cards FAQ
Q. Do I need a special video card to run McIDAS-V?

A. Your graphics system must support 3D; make sure you have the latest video driver for your graphics card. This is included in the Windows
operating system. On Linux the driver must support GLX, an X windows system extension to OpenGL programs. See Operating System
Requirements for more information.

Q. Why does the display go gray or get corrupted when I resize my McIDAS-V display?

A. ATI cards do not always work correctly with the OpenGL version of Java 3D under Windows. If you experience problems with corrupted
displays (sets of triangles, spurious lines, weird looking displays) and have an ATI card and are running Windows, try the following:

Right click on the Windows Desktop and select Properties from the pop-up menu.
From the Settings tab, make sure the color quality is 16 bit.
Click the Advanced button and select the OpenGL tab. Depending on your card, either click the button for Force 16 bit buffer (or
something like that) or click on the Compatibility settings button and click the "Force 16 bit" radio button.
Click the OK buttons to exit the Display Properties dialog.
Try McIDAS-V again and see if it works better.
If not, try using the Direct-X installer instead of the OpenGL installer.

Q. If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

A. If you are using the version of Java 3D distributed with McIDAS-V (1.3.2), you can switch between the OpenGL and Direct-X versions of
Java 3D with a command line switch. If you are using runMcV.bat to start McIDAS-V, edit that file and uncomment the appropriate line. If you
have your own script for starting McIDAS-V, add in the -Dj3d.rend=d3d option to your start line (before -jar or class name).
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Common Installation Errors FAQ
Q. How do I get around a security error when installing McIDAS-V on my 10.8 OSX machine?

A. After double-clicking on the *.dmg installer file, you may see the following error:

"McIDAS-V Installer" can't be opened because it is from an unidentified developer.

Your security preferences allow installation of only apps from the Mac App Store and
identified developers.

To get around this, you could turn off the security checks or follow the next steps which will work around the security for the McIDAS-V
installation. To do this, right-click on the installer icon to get a dropdown menu, and choose Open. After choosing Open, you should see the
following message:

"McIDAS-V Installer" is from an unidentified developer. Are you sure you want to open
it?

Opening "McIDAS-V Installer" will always allow it to run on this Mac.

Once you click Open in this window, you will be prompted to enter a login/password for the administrator account. After entering this
information, click OK and the installation should proceed without error.

Q. What do I do if I am told to upgrade JDK when installing McIDAS-V?

A. A user reported --- The first time I ran the script, it told me I needed to upgrade my JDK. So I installed jdk1.6.0_03 and Java3D 1.3.1. Then
McIDAS-V installed without any problem.

Q. How do I solve write permissions errors on OSX?

A. Browse for a writable directory (e.g. /Users/mcuser). Under "Select Additional Tasks", uncheck "Create Launcher and Configuration
shortcuts in Applications folder"

Q. How do I solve shortcut permissions errors on OSX?

A. At Extracting files: McIDAS-V Configuration.app/Contents/Info.plist/Applications/McIDAS-V Configuration.app/Contents/Info.plist I can
not create this file. To solve this, click "Cancel" and restart the installer. Follow instructions under Error #2 above.

Q. Why am I am seeing a "Canvas3D: Non-recoverable graphics configuration error" when installing on my Windows 7 64-bit
machine?
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Common Run-Time Errors FAQ
Q. What do I do if I get a 'Could not create a graphics configuration' error?

A. First, check for the most updated video card driver. If the problem still remains, the 32bit Linux installer comes with an option to install
Java3D 1.3. Rerun the installer and select to install Java3D 1.3.

Q. What do I do if I get 'JAVA 3D Error: GLX extension is not supported' and 'Could not create a graphics configuration' errors?

A. GLX is an extension that must be supported by the graphics card.  This error is most likely occurring because the graphics drivers for
RHEL are not properly configured.

Assuming that the latest graphics drivers are installed, they must be configured in the window system configuration file. Since RHEL uses
Xorg, look in the file

/etc/X11/xorg.conf

and see if there are any references to "GLX" or "glx" (and possibly "dri").  If there are, try uncommenting them and rebooting.

Q. What do I do if I see 'Connection refused' and 'No public datasets found' errors when connecting to the listed data servers?

A. If you have a firewall and are trying to get data from the remote servers (image, radar, point, upper air and profiler data), error messages
such as "Error opening connection ... Operation timed out" or "No Data Available" are normal.  For these servers to send data, your firewall
software must allow connections on ports 112 (ADDE) and 8080 (THREDDS Data Server).

Q. Why am I having drawing problems on Monitor2 of a two-monitor system?

A. Some graphics card/driver combinations don't allow McIDAS-V window functions to work correctly in Monitor2 of two-monitor systems.
For example, if your system has this problem and you move the McIDAS-V windows to Monitor2, the Image Chooser's Advanced tab in the
Field Selector may not be visible, or adding a new tab in the Main Display may result in most of the window going blank ("graying out"). 
You may also receive the error (or see it in the mcidasv.log file), '...adding a container to a container on a different GraphicsDevice'.

For now, the only working solution for this problem is to move the McIDAS-V windows to Monitor1. After doing this, the windows should
display correctly and you should be able to successfully add new tabs and run bundles.

If you are running Red Hat with a NVIDIA graphics card using TwinView and are having problems, go to the preferences, click on the
primary display, and make sure the "Make this the primary display..." checkbox is checked.

Q. Why is there no map drawn in the McIDAS-V Main Display window?

A. Try changing your memory to use 1 GB or lower and restart McIDAS-V. You can change the amount of memory used by McIDAS-V by
editing the Maximum Heap Size in the Advanced tab of the Preferences by selected Edit->Preferences... from the Main Display window.

Q. How do I fix the spurious map lines in my Main Display window?

A. If you run into this problem, you should first try changing your Enable access to geometry by reference VisAD setting in the Advanced
tab of the User Preferences window. You can get to the User Preferences window through the Edit->Preferences menu item in the Main
Display window. This option is turned on by default, but turning this option off can help to remove random/extraneous map lines that
sometimes appear in the display. This is a problem that may occur more frequently on systems with ATI graphics cards. After changing this
preference, click OK and restart McIDAS-V (any changes to the Advanced Preference require a restart to take affect).

If this did not solve the map line problem, look in the Layer Controls tab of the Data Explorer for the Default Background Maps. Determine
which map is causing the spurious lines by toggling the visibility of the maps on and off. Once you determine which map is causing the lines,
change the Fast Rendering option for this map.

Q. Why do my images display blank (black or white) when there should be valid data?

A. The first thing to do is to make sure that your graphics drivers are up to date. If this does not solve the problem, another option is to
change the amount of memory allocated to McIDAS-V. From the Main Display window's menu bar, select Edit->Preferences. This opens a
User Preferences window, where you want to select the Advanced tab. At the top of the window there are two options for selecting memory.
Click the radio button that allows you to specify the numerical value of memory allocated to McIDAS-V. Enter in a value of 512 megabytes
and click OK to save the change. Then exit and restart McIDAS-V (changes in the Advanced User Preferences require a restart of McIDAS-
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V to take effect). If this resolves the issue of white images, you can start increasing the memory until the problem appears again. Stay below
the memory value that produces the problem.

We have also received reports of this problem (blank images in the Main Display window) occurring on computers with the Mobile Intel 4
Series Express Family of graphics cards. If you have a computer with that configuration and are seeing the problem, try setting the card's
"Vertex Processing" configuration setting to "Enable Software Processing". That setting is recommended because it will likely work with a
typical amount of memory allocated to McIDAS-V (e.g., 80% of available). If the "Vertex Processing" option is set to a different value (e.g.,
"Application Settings" and "Default settings"), you may have to select a memory value of 800 MB or less in order to avoid the problem.

Q. Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V
under Linux?

A. If the error message also includes a line that is looking for a Library with "dri" in it's name (e.g.:
Library=/usr/X11R6/lib/modules/dri/i915_dri.so), it means that you are trying to load the DRI library in your X server which is not
compatible with Java 3D. You need to comment out the line:

Load "dri"

in your X server configuration file (xorg.conf or XF86Config).
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Reporting Problems FAQ
Q. What kind of support is provided for McIDAS-V?

A. For information about obtaining help and support for McIDAS-V, check out the Documentation and Support page in the McIDAS-V
User's Guide.

Q. How do I report problems?

A. First, check this FAQ and the McIDAS-V Support Forums to make sure this is a problem that has not yet been reported.

If you experience unexpected problems that are not reported in those locations, please let us know. See the Documentation and Support
section of the manual for the procedures on how to do this.

Q. How do I open the Error Logs Console?

A. Open a console to show error logs with the Help->Show Console menu.

Q. What do I do if McIDAS-V is locked up and not responding?

A. First, you need to retrieve a stack track of the program so we can find out why this is happening. McIDAS-V provides a web-based service
that produces a stack trace. Just view the URL:

http://127.0.0.1:8788/

and send the McIDAS-V Support Team on the Contact Us page. Note: This service is only available from browsers running on the machine
McIDAS-V is running on.

You can also use this service to shutdown McIDAS-V.
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McIDAS-X Commands in McIDAS-V
Listed Below are several common McIDAS-X commands, followed by a brief description of the corresponding method used in McIDAS-V.

ADDE Datasets

DATALOC ADD - Enter server and dataset information in the chooser, or use the ADD ADDE Servers... button in the ADDE Servers
tab of the User Preferences window.

DATALOC LIST - Select server in chooser and use Dataset pull down menu to view available datasets.

DSINFO - Select the chooser with the data you want to view (Image, Point, etc.), connect to the server and view "Data" type list to see
available descriptors.

DSSERVE ADD - Open the Local ADDE Data Manager and select File -> New Local Dataset.

DSSERVE DEL - Open the Local ADDE Data Manager and select which dataset to delete by clicking on the dataset and then selecting
Edit -> Remove Selection.

DSSERVE LIST - Open the Local ADDE Data Manager, which lists all of the remote datasets.

Frame Control

A, B, L - Use the Time Animation Widget above the 3D display to control the looping.

D - Use the middle mouse button click option to probe the data in the Main Display window.

E - Move the mouse anywhere over the image, and the lat/lon readout will be displayed at the bottom of the Main Display window.

K, W - Use the Layer Visibility checkboxes in the Legend to control the visibility status of images, maps, and other layers in the Main
Display window.

O - Use Layer checkboxes in the Legend to control visibility, or right-click on the item in the Legend, and use the View->Bring View to
Front option to reorganize layers.

Gridded Data

GRDDISP - Use the Gridded Data Chooser to select a Catalog and Data Source.

GRDIMG - Once the gridded data is loaded in the Field Selector, select which field to display, and select Color-Shaded Plan View in the
Displays panel.

Image Data

IMGDISP - Use the Satellite Imagery chooser to select dataset, add the data, and load the image(s).

IMGFILT - Once the data is loaded in the Field Selector, select Formulas->Image Filters.

IMGLIST - After the Image Type is chosen, select the Absolute Times tab to view the list of available times of the data.

IMGOPER - Many formulas are built into McIDAS-V, which can be accessed in the Field Selector tab of the Data Explorer. You can
also create and edit formulas and Jython methods.

IMGPLOT - Use the Transect/Probe displays.

IMGPROBE - Click the middle mouse button over the image or use Data Probe/Time Series display.

IMGREMAP - Use the Projections menu to create or change projections.

Image Enhancements

COMBINE - Once the data source is loaded into the Field Selector, select Formulas->Imagery->RGB in the Data Sources panel.
When you click Create Display, a second Field Selector window will pop-up for selecting the red, green, and blue fields. After the fields
are selected, the image will be displayed.

EB - Change the range of the data being display by interactively modifying the color bar, or click the Change button next to Contour in
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the Layer Controls tab to open the Contour Properties Editor.

EU LIST - Right-click on the color table in the Legend or Layer Controls to get a list of available color tables.

EU MAKE - Use the Tools->Color Table Editor menu item.

EU REST - Right-click on the color table in the Legend or Layer Controls and select a new enhancement.

EU SAVE - Use the Tools->Color Table Editor menu item. Here, you can create/modify an existing color bar. To save, click File ->
Save As.

Surface Data

PTDISP - Use the Point Observations->Plot/Contour chooser to select data, and display Point Data as a Point Data Plot and choose
your station model for how to plot your point data. Use the Tools->Station Model Editor menu item to create/edit a new station model.

PTCON - Use the Point Observations->Plot/Contour chooser to select data. In the Field Selector, select a parameter under Gridded
Fields, and select which Display and Level to use.

SFCCON - Use the Point Observations->Plot/Contour chooser to select surface data. Select a parameter under Gridded Fields, and
choose Contour Plan View.

SFCLIST - Use the Point Observations->Plot/Contour chooser to select surface data. Select Point Data as your field. Display the Point
Data as a Point Data List. The chart of surface data will be listed in the Layer Controls tab of the Data Explorer.

SFCPLOT - Use the Point Observations->Plot/Contour chooser to select surface data. Display Point Data as a Point Data Plot, and
choose station model for how to plot the point data. Use the Tools->Station Model Editor menu item to create/edit a new station model.

SFCRPT - Weather Text Products Display (Tools->Text Data->Weather Text Products (from server)). Select Observed Data-
>Sounding Data, and the station in the Locations tab.

Upper Air Data

HODO - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab. Once the
Skew-T is created in the Layer Controls tab, select the Hodograph tab above the image.

PTDISP - Use the Point Observations->Plot/Contour chooser to select data, and display Point Data as a Point Data Plot and choose
your station model for how to plot your point data. Use the Tools->Station Model Editor menu item to create/edit a new station model.

PTCON - Use the Point Observations->Plot/Contour chooser to select data. In the Field Selector, select a parameter under Gridded
Fields, and select which Display and Level to use.

RAOBCON - Use the Point Observations->Soundings chooser to select upper air data. Use the Gridded Fields to display contours in
the Plan View Display.

RAOBPLOT - Use the Point Observations->Soundings chooser to select upper air data. Display Point Data as a Point Data Plot, and
choose station model for how to plot the point data. Use the Tools->Station Model Editor to create/edit a new station model.

RAOBPRT - Weather Text Products Display (Tools->Text Data->Weather Text Products (from server)). Select Observed Data-
>Sounding Data, and the station in the Locations tab).

UAEDIT - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab of the
Data Explorer. Once the Skew-T is displayed, it can be interactively modified by clicking and dragging on the temperature and dew point
temperature profiles.

UALIST - Use the Point Observations->Plot/Contour chooser, and select upper air data from the Server/Dataset chosen. In the Field
Selector, select Point Data as the Field, Point Data List as the display, and the Level for the data to be displayed.

UAPLOT - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab of the
Data Explorer.

Other

EG - Click the Remove all layers button  in the Main Display window, select Edit->Remove->All Layers in the Main Display

window, or click the trash can icon  next to the item in the Legend.

HELP - Click the Help menu in the Main Display window and select User's Guide or Getting Started. Also, you can click on the question
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mark icon in the bottom right corner of the Data Explorer to open the User's Guide to the section appropriate to what is being viewed.

Scheduler (SKED, SKE, SKL, SKU) - Set up polling options in data sources (right-click on the Data Source in the Field Selector and
select Properties), or run background scripts through cron. Active polling can be used to automatically reload data at a set interval.

WWDISP - Shape files from the General->Catalogs chooser, or use the McIDAS-X Bridge.

ZA - Text option in the Drawing Controls (Display->Draw Freely).

ZLM, CW - Shape options in the Drawing Controls (Display->Draw Freely).
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